#ovirt: oVirt Weekly Sync

Meeting started by bkp at 14:02:03 UTC (full logs).

Meeting summary

  1. Agenda and Roll Call (bkp, 14:02:19)
    1. infra updates (bkp, 14:02:42)
    2. 3.4.z updates (bkp, 14:02:42)
    3. 3.5 planning (bkp, 14:02:42)
    4. conferences and workshops (bkp, 14:02:42)
    5. other topics (bkp, 14:02:42)

  2. infra updates (bkp, 14:03:01)
    1. infra os1 issues solved, will add new slaves in the following days (bkp, 14:06:28)

  3. 3.4.z updates (bkp, 14:08:05)
    1. 3.4.z updates 3.4.2: RC scheduled for 2014-05-27 (bkp, 14:11:53)
    2. 3.4.z updates SvenKieske sent a list of proposed blockers to be reviewed: http://lists.ovirt.org/pipermail/users/2014-May/024518.html (bkp, 14:11:53)
    3. 3.4.z updates Bug 1037663 status: ovirt-log-collector: conflicts with file from package sos >= 3.0, sbonazzo working with sos maintainer for coordinating oVirt 3.4.2 release. Not a blocker. (bkp, 14:11:53)
    4. 3.4.z updates Discussion is ongoing on mailing list for other bugs (bkp, 14:11:54)

  4. 3.5 planning (bkp, 14:12:20)
    1. 3.5 planning UX Phase one of patternfly is in, and the sorting infra (bkp, 14:14:53)
    2. 3.5 planning UX Issues fixed as they are reported. (bkp, 14:14:53)
    3. 3.5 planning SLA All planned 3.5 features will be ready on time, fingers crossed :) (bkp, 14:18:22)
    4. 3.5 planning SLA NUMA feature: APIs (GUI and RESTful) still missing. (bkp, 14:18:22)
    5. 3.5 planning SLA optaplanner: in advanced development state. (bkp, 14:18:22)
    6. 3.5 planning SLA Limits (blkio and cpu, incluiding disk and cpu profile, including refactoring current network qos and vnic profile to suit new sla/profiles infra): we are working on them nowadays (no real issues there) (bkp, 14:18:22)
    7. 3.5 planning SLA Scheduling RESTful API: developed now - patch this evening (bkp, 14:18:22)
    8. http://www.ovirt.org/Features/Self_Hosted_Engine_iSCSI_Support all patches have been pushed and under review (sbonazzo, 14:20:07)
    9. http://www.ovirt.org/Features/oVirt_Windows_Guest_Tools (sbonazzo, 14:20:55)
    10. 3.5 planning integration ovirt 3.5.0 alpha released yesterday (bkp, 14:22:47)
    11. 3.5 planning integration ovirt live iso uploaded this afternoon (bkp, 14:22:47)
    12. 3.5 planning integration ovirt node iso will follow (bkp, 14:22:47)
    13. 3.5 planning integration 3.5.0 Second Alpha scheduled for May 30 for Feature Freeze (bkp, 14:22:47)
    14. 3.5 planning integration http://www.ovirt.org/Features/Self_Hosted_Engine_iSCSI_Support all patches have been pushed and under review (bkp, 14:22:47)
    15. 3.5 planning integration There's an issue on additional host setup, but should be fixed easily. Patch pushed an under review. (bkp, 14:22:49)
    16. 3.5 planning integration F20 support started for ovirt-engine, hopefully ready for alpha 2 (bkp, 14:22:52)
    17. 3.5 planning virt Unfinished features are closer to completition... but nothing got in yet. (bkp, 14:29:06)
    18. 3.5 planning virt Last week spent fixing major bugs. (bkp, 14:29:06)
    19. 3.5 planning Gluster Volume capacity - vdsm dependency on libgfapi-python needs to be added (bkp, 14:34:31)
    20. 3.5 planning Gluster Volume profile - review comments on patches incorporated and submitted, need final review and approval (bkp, 14:34:31)
    21. 3.5 planning Gluster REST API in progress (bkp, 14:34:31)
    22. 3.5 planning node All features are in progress. (bkp, 14:37:59)
    23. 3.5 planning node Two features up for review (generic registration and hosted engine plugin) (bkp, 14:37:59)
    24. 3.5 planning node Appliances can also be built, now all needs to be reviewed and tested. (bkp, 14:37:59)
    25. 3.5 planning node ETA for a node with the bits in place by early next week. (bkp, 14:37:59)
    26. 3.5 planning network All Neutron appliance oVirt code is merged. Feature now depends on some OpenStack repository processes that are async with oVirt releases. oVirt side completed. (bkp, 14:42:17)
    27. 3.5 planning network The two MAC pool features are in a tough review, so they're in danger even for the new deadline of end of May. (bkp, 14:42:17)
    28. 3.5 planning network Progress with the RHEL bug on which bridge_opts depends upon is unknown. danken adds that it is not a blocker for 3.5 (bkp, 14:42:17)
    29. 3.5 planning network [UPDATE] Progress with the RHEL bug on which bridge_opts depends upon done (with an asterisk). (bkp, 14:43:34)
    30. 3.5 planning storage Store OVF on any domains - merged (bkp, 14:49:12)
    31. 3.5 planning storage Disk alias recycling in web-admin portal - merged (bkp, 14:49:13)
    32. 3.5 planning storage [RFE] Snapshot overview in webadmin portal - merged (bkp, 14:49:13)
    33. 3.5 planning storage import existing data domain - phase one was revised yesterday, should be reviewed today and tommorow, and hopefully be merged by end of week (bkp, 14:49:13)
    34. 3.5 planning storage Sanlock fencing seems this will slip 3.5.0 after (infra required a late redesign) (bkp, 14:49:13)
    35. 3.5 planning storage live merge (delete snapshot) - in progress. Three patches upstream (engine side), one is going to be merged soon (today hopefully), the other two under review. (bkp, 14:49:14)
    36. 3.5 infra Working hard on 3.5 features, and hope everything will make it on time. (bkp, 14:49:53)
    37. 3.5 infra The current status is in the planning wiki. (bkp, 14:49:53)
    38. 3.5 infra If infra-related questions pop up then just email them, and ovedo will answer them this evening/tomorrow. (bkp, 14:49:53)

  5. conferences and workshops (bkp, 14:50:22)
    1. Conferences OpenStack Israel is still on for June 2. (bkp, 14:51:50)
    2. Conferences FrOSCON CfP closes May 23 (bkp, 14:51:50)
    3. Conferences OSCON Open Cloud Day CfP closes May 27 (bkp, 14:51:50)
    4. ACTION: More conference participation is needed for 2014. See bkp for help planning/submitting presentations. (bkp, 14:51:50)

  6. other topics (bkp, 14:53:04)


Meeting ended at 14:56:14 UTC (full logs).

Action items

  1. More conference participation is needed for 2014. See bkp for help planning/submitting presentations.


Action items, by person

  1. bkp
    1. More conference participation is needed for 2014. See bkp for help planning/submitting presentations.


People present (lines said)

  1. bkp (115)
  2. sbonazzo (32)
  3. lvernia (14)
  4. gchaplik (12)
  5. nsoffer (11)
  6. fabiand (9)
  7. mskrivanek (8)
  8. danken (5)
  9. awels (4)
  10. dcaro (3)
  11. sahina (3)
  12. ovirtbot (3)
  13. jb_badpenny (1)
  14. SvenKieske (1)
  15. fsimonce (1)
  16. mburns (1)


Generated by MeetBot 0.1.4.