14:02:03 <bkp> #startmeeting oVirt Weekly Sync
14:02:04 <ovirtbot> Meeting started Wed May 21 14:02:03 2014 UTC.  The chair is bkp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:04 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:19 <bkp> #topic Agenda and Roll Call
14:02:33 <bkp> doron is out for this one this week, so I'll be managing the sync meeting this week. Here's the agenda:
14:02:42 <bkp> #info infra updates
14:02:42 <bkp> #info 3.4.z updates
14:02:42 <bkp> #info 3.5 planning
14:02:42 <bkp> #info conferences and workshops
14:02:42 <bkp> #info other topics
14:03:01 <bkp> #topic infra updates
14:03:42 <bkp> dcaro, anything to report?
14:04:28 <dcaro> we finally (a couple hours ago) got os1 issues solved, will add new slaves in the following days
14:04:44 <bkp> Excellent!
14:05:23 <jb_badpenny> waves at @mburns
14:05:27 <dcaro> that's mostly all the news for this week
14:05:50 * mburns waves back at jb_badpenny
14:06:05 <bkp> dcaro, is there anything from this that could be written up for other projects/teams using os1 could learn from?
14:06:28 <bkp> #info infra os1 issues solved, will add new slaves in the following days
14:06:30 * gchaplik for sla
14:06:55 * lvernia is here as well.
14:07:02 <dcaro> not really,they had a majorr issue with nfs storage that forced us to delete the slaves
14:07:17 * sbonazzo for integration
14:07:20 <bkp> Ugh. Okay.
14:07:34 <bkp> Hey all, who are checking in!
14:07:49 * awels is here for UX
14:07:58 <bkp> Thanks, dcaro. Moving on...
14:08:05 <bkp> #topic 3.4.z updates
14:08:19 <sbonazzo> 3.4.2: RC scheduled for 2014-05-2
14:08:24 <sbonazzo> 27
14:08:34 <sbonazzo> sent status to mailing list this morning http://lists.ovirt.org/pipermail/users/2014-May/024516.html
14:08:34 <sbonazzo> SvenKieske sent a list of proposed blockers to be reviewed: http://lists.ovirt.org/pipermail/users/2014-May/024518.html
14:08:47 <sbonazzo> About Bug 1037663 - ovirt-log-collector: conflicts with file from package sos >= 3.0
14:08:47 <sbonazzo> I'm working with sos maintainer for coordinating oVirt 3.4.2 release with sos 3.1.1 release fixing the issue
14:08:55 <sbonazzo> by moving all oVirt sos plugins to upstream sos fixing conflicts once for all.
14:08:55 <sbonazzo> Since a workaround exists (yum downgrade sos to 2.2-31.fc19 still available in F19) I don't think it should be a blocker.
14:09:32 <sbonazzo> discussion is ongoing on mailing list for other bugs
14:10:25 <SvenKieske> I agree with the current status of the discussion regarding blockers..
14:10:43 <sbonazzo> SvenKieske: thanks :-)
14:10:58 <sbonazzo> bkp: taht's should be all for 3.4.z
14:11:06 <sbonazzo> from integration side
14:11:38 <bkp> Okay, thanks, sbonazzo
14:11:53 <bkp> #info 3.4.z updates 3.4.2: RC scheduled for 2014-05-27
14:11:53 <bkp> #info 3.4.z updates SvenKieske sent a list of proposed blockers to be reviewed: http://lists.ovirt.org/pipermail/users/2014-May/024518.html
14:11:53 <bkp> #info 3.4.z updates Bug 1037663 status: ovirt-log-collector: conflicts with file from package sos >= 3.0, sbonazzo working with sos maintainer for coordinating oVirt 3.4.2 release. Not a blocker.
14:11:54 <bkp> #info 3.4.z updates Discussion is ongoing on mailing list for other bugs
14:12:17 <bkp> On to the big one...
14:12:20 <bkp> #topic 3.5 planning
14:12:33 <bkp> Since UX was last last week, let's have them go first. awels, anything to report for 3.5?
14:13:17 <awels> bkp: Same as last week, phase one of patternfly is in, and the sorting infra
14:13:36 <awels> bkp: fixing issues as they are reported
14:14:20 <bkp> awels Cool, anything else?
14:14:28 <awels> bkp: Nope thats it
14:14:53 <bkp> #info 3.5 planning UX Phase one of patternfly is in, and the sorting infra
14:14:53 <bkp> #info 3.5 planning UX Issues fixed as they are reported.
14:15:04 <bkp> Rolling on down the line to SLA. gchaplik?
14:15:22 <gchaplik> hi bkp :-)
14:15:36 <bkp> Hey.
14:15:41 <gchaplik> bkp, No serious updates from last week, all planned 3.5 features will be ready on time, fingers crossed :)
14:15:48 <gchaplik> details:
14:15:54 <gchaplik> NUMA feature: APIs (GUI and RESTful) are still missing.
14:15:55 <gchaplik> optaplanner: in advanced development state.
14:15:55 <gchaplik> Limits (blkio and cpu, incluiding disk and cpu profile, including refactoring current network qos and vnic profile to suit new sla/profiles infra): we are working on them nowadays (no real issues there)
14:16:10 <gchaplik> bkp, any questions?
14:16:21 <gchaplik> bkp, if not, I'm done
14:16:43 <bkp> gchaplik: I don't think so.
14:16:56 <gchaplik> bkp, 10x
14:17:41 <gchaplik> bkp, missed sth
14:17:45 <gchaplik> bkp, Scheduling RESTful API: is developed now - patch at evening time :)
14:18:16 <bkp> Noted
14:18:22 <bkp> #info 3.5 planning SLA All planned 3.5 features will be ready on time, fingers crossed :)
14:18:22 <bkp> #info 3.5 planning SLA NUMA feature: APIs (GUI and RESTful) still missing.
14:18:22 <bkp> #info 3.5 planning SLA optaplanner: in advanced development state.
14:18:22 <bkp> #info 3.5 planning SLA Limits (blkio and cpu, incluiding disk and cpu profile, including refactoring current network qos and vnic profile to suit new sla/profiles infra): we are working on them nowadays (no real issues there)
14:18:22 <bkp> #info 3.5 planning SLA Scheduling RESTful API: developed now - patch this evening
14:18:40 <bkp> Moving on to integration for 3.5. sbonazzo?
14:18:55 <sbonazzo> ovirt 3.5.0 alpha released yesterday
14:19:08 <sbonazzo> ovirt live iso uploaded this afternoon
14:19:17 <sbonazzo> ovirt node iso will follow
14:19:31 <sbonazzo> 3.5.0 Second Alpha scheduled for May 30 for Feature Freeze
14:19:31 <sbonazzo> sent status to mailing list this morning http://lists.ovirt.org/pipermail/users/2014-May/024519.html
14:19:53 <sbonazzo> about features
14:20:07 <sbonazzo> http://www.ovirt.org/Features/Self_Hosted_Engine_iSCSI_Support all patches have been pushed and under review
14:20:26 <sbonazzo> we've an issue on additional host setup, but should be fixed easily
14:20:38 <sbonazzo> Services on separate hosts
14:20:38 <sbonazzo> http://www.ovirt.org/Features/WebSocketProxy_on_a_separate_host
14:20:38 <sbonazzo> http://www.ovirt.org/Features/Separate-DWH-Host
14:20:38 <sbonazzo> http://www.ovirt.org/Features/Separate-Reports-Host
14:20:38 <sbonazzo> Patches have been pushed and verified but it has been asked to complete engine setup splitting
14:20:39 <sbonazzo> and complete fixes to partial cleanup before merging them. A patch has been already pushed and currently under review.
14:20:55 <sbonazzo> http://www.ovirt.org/Features/oVirt_Windows_Guest_Tools
14:20:56 <sbonazzo> No much progress on that this week since Lev has been away most of the week.
14:21:07 <sbonazzo> Started working on F20 support for ovirt-engine
14:21:23 <sbonazzo> so hopefully we'll have engine running on it by alpha 2
14:22:18 <sbonazzo> if there aren't questions, that's all on integration side
14:22:45 <bkp> Very well.
14:22:47 <bkp> #info 3.5 planning integration ovirt 3.5.0 alpha released yesterday
14:22:47 <bkp> #info 3.5 planning integration ovirt live iso uploaded this afternoon
14:22:47 <bkp> #info 3.5 planning integration ovirt node iso will follow
14:22:47 <bkp> #info 3.5 planning integration 3.5.0 Second Alpha scheduled for May 30 for Feature Freeze
14:22:47 <bkp> #info 3.5 planning integration http://www.ovirt.org/Features/Self_Hosted_Engine_iSCSI_Support all patches have been pushed and under review
14:22:49 <bkp> #info 3.5 planning integration There's an issue on additional host setup, but should be fixed easily. Patch pushed an under review.
14:22:52 <bkp> #info 3.5 planning integration F20 support started for ovirt-engine, hopefully ready for alpha 2
14:23:21 <bkp> Checking in now with virt. mskrivanek?
14:24:36 <bkp> Oh, he's away. Anyone from the virt team?
14:25:30 * mskrivanek here
14:25:47 <bkp> Hey, sir! Got anything to report on virt?
14:25:48 * fabiand is also here - tentative
14:25:51 <mskrivanek> not much changed since last week...
14:26:13 <mskrivanek> the unfinished features are just a little bit closer to completition...but nothing got in
14:26:16 <mskrivanek> yet
14:26:19 <mskrivanek> but it will!
14:26:21 <mskrivanek> :-)
14:26:46 <bkp> Should we have you pledge beer to that?
14:27:01 <bkp> :)
14:27:13 <mskrivanek> i need to bribe reviewers....
14:27:37 <bkp> Again, beer.
14:27:56 <bkp> Okay, is that it for virt?
14:28:21 <mskrivanek> well, i guess. we had some major bugs during the last week and that kept us busy...
14:28:55 <bkp> Acknowledged.
14:29:06 <bkp> #info 3.5 planning virt Unfinished features are closer to completition... but nothing got in yet.
14:29:06 <bkp> #info 3.5 planning virt Last week spent fixing major bugs.
14:29:27 <bkp> Moving on... fabiand, since you are "tentative," what is the status for node?
14:31:47 <bkp> Apparently he was serious. I will circle back.
14:31:49 <bkp> Let's talk about Gluster. sahina?
14:32:20 <sahina> bkp, hi
14:32:26 <bkp> Howdy!
14:32:46 <sahina> bkp, for the 2 features in progress, here's the updat. Volume capacity - vdsm dependency on libgfapi-python needs to be added, Gluster volume profile - review comments on patches incorporated and submitted, need final review and approval. REST API in progress
14:34:04 <bkp> sahina Noted. Anything else?
14:34:10 <fabiand> bkp, sorry, back now
14:34:16 <sahina> bkp, nope..that's it from me
14:34:23 <bkp> K, fabiand. Two secs
14:34:31 <bkp> #info 3.5 planning Gluster Volume capacity - vdsm dependency on libgfapi-python needs to be added
14:34:31 <bkp> #info 3.5 planning Gluster Volume profile - review comments on patches incorporated and submitted, need final review and approval
14:34:31 <bkp> #info 3.5 planning Gluster REST API in progress
14:34:35 <fabiand> sure
14:34:51 <bkp> Okay, fabiand, you are go for node...
14:35:06 <fabiand> thanks
14:35:09 <fabiand> all of the features are in progress. Two up for review (generic registration and hosted engine plugin)
14:35:15 <fabiand> Appliances can also be built
14:35:20 <fabiand> Now all needs to be reviewed and tested.
14:35:37 <fabiand> I hope to have a node with the bits in place by ... early next week.
14:36:53 <bkp> fabiand, noted. Anything else?
14:37:18 <fabiand> It's warm and a bit cloudy. Nothing else.
14:37:50 <bkp> Heh.
14:37:59 <bkp> #info 3.5 planning node All features are in progress.
14:37:59 <bkp> #info 3.5 planning node Two features up for review (generic registration and hosted engine plugin)
14:37:59 <bkp> #info 3.5 planning node Appliances can also be built, now all needs to be reviewed and tested.
14:37:59 <bkp> #info 3.5 planning node  ETA for a node with the bits in place by early next week.
14:38:13 <bkp> Onwards. Network, what be the word for 3.5? lvernia?
14:38:20 <lvernia> bkp: Hi!
14:38:24 <lvernia> bkp: So...
14:39:03 <lvernia> All Neutron appliance oVirt code is merged - now things depend on some OpenStack repository processes that are async with oVirt releases.
14:39:21 <lvernia> But it's as done as it can be as far as oVirt code is concerned.
14:40:09 <lvernia> There hasn't been any significant process with the two MAC pool features (tough review process), so they're in danger even for the new deadline of end of May.
14:40:49 <lvernia> And I don't know of any progress with the RHEL bug on which bridge_opts depends upon, danken might know more.
14:41:21 <danken> lvernia: no news there, but it does not block 3.5
14:41:34 <lvernia> Yep, so there you have it.
14:41:38 <lvernia> That's it for us.
14:41:56 <bkp> lvernia, thanks
14:42:02 <danken> lvernia: the feature would simply fail for certain bridge opts for certain initscripts versions
14:42:17 <bkp> #info 3.5 planning network All Neutron appliance oVirt code is merged. Feature now depends on some OpenStack repository processes that are async with oVirt releases. oVirt side completed.
14:42:17 <bkp> #info 3.5 planning network The two MAC pool features are in a tough review, so they're in danger even for the new deadline of end of May.
14:42:17 <bkp> #info 3.5 planning network Progress with the RHEL bug on which bridge_opts depends upon is unknown. danken adds that it is not a blocker for 3.5
14:42:18 <lvernia> danken: So should I mark the feature as done?
14:42:20 <danken> but that's an initscript bug for el6.
14:42:37 <lvernia> Done with an asterisk? :)
14:42:40 <danken> lvernia: yes, please
14:43:06 <danken> lvernia: done, with a limited known bug
14:43:34 <bkp> #info 3.5 planning network [UPDATE] Progress with the RHEL bug on which bridge_opts depends upon done (with an asterisk).
14:43:46 <lvernia> Done, dan.
14:43:51 <bkp> Moving on to storage.
14:44:15 <bkp> I don't see amureini. Anyone else here to report on storage in 3.5?
14:44:20 <nsoffer> bkp, /me replaces Allon today
14:44:41 <bkp> nsoffer Go ahead!
14:44:45 <nsoffer> bkp, we have some features merged
14:44:55 * lvernia has got to go, apologies!
14:44:56 <nsoffer> * Store OVF on any domains - merged
14:45:03 <nsoffer> * Disk alias recycling in web-admin portal - merged
14:45:11 <nsoffer> * [RFE] Snapshot overview in webadmin portal - merged
14:45:12 <bkp> Bye lvernia
14:45:23 <lvernia> See ya next week :)
14:45:26 <nsoffer> * import existing data domain - phase one was revised yesterday, should be reviewed today and tommorow, and hopefully be merged by end of week
14:45:43 <nsoffer> * Sanlock fencing seems this will slip 3.5.0 after (infra required a late redesign)
14:46:31 <nsoffer> * live merge (delete snapshot) - in progress
14:46:41 <nsoffer> fsimonce, can you update us on live merge status?
14:47:16 <nsoffer> fsimonce, and on progress of Get rid of storage pool metadata on master storage domain
14:47:57 <fsimonce> 3 patches upstream (engine side), one is going to be merged soon (today hopefully), the other 2 are under review
14:48:41 <nsoffer> bkp, thats all from me
14:49:03 <bkp> nsoffer, acknowledged!
14:49:12 <bkp> #info 3.5 planning storage Store OVF on any domains - merged
14:49:13 <bkp> #info 3.5 planning storage Disk alias recycling in web-admin portal - merged
14:49:13 <bkp> #info 3.5 planning storage [RFE] Snapshot overview in webadmin portal - merged
14:49:13 <bkp> #info 3.5 planning storage import existing data domain - phase one was revised yesterday, should be reviewed today and tommorow, and hopefully be merged by end of week
14:49:13 <bkp> #info 3.5 planning storage Sanlock fencing seems this will slip 3.5.0 after (infra required a late redesign)
14:49:14 <bkp> #info 3.5 planning storage live merge (delete snapshot) - in progress. Three patches upstream (engine side), one is going to be merged soon (today hopefully), the other two under review.
14:49:41 <bkp> It's infra's turn now, but I have been informed that they could not make it today.
14:49:45 <bkp> So...
14:49:53 <bkp> #info 3.5 infra Working hard on 3.5 features, and hope everything will make it on time.
14:49:53 <bkp> #info 3.5 infra The current status is in the planning wiki.
14:49:53 <bkp> #info 3.5 infra If infra-related questions pop up then just email them, and ovedo will answer them this evening/tomorrow.
14:50:20 <bkp> Moving on to the next topic...
14:50:22 <bkp> #topic conferences and workshops
14:50:36 <bkp> OpenStack Israel is still on for June 2.
14:50:44 <bkp> FrOSCON still has its call for presentations open until Friday, May 23. http://www.froscon.de/en/cfp/#c161
14:50:52 <bkp> OSCON Open Cloud Day CfP deadline is May 27 http://www.oscon.com/oscon2014/public/cfp/337
14:51:05 <bkp> In general, we would like to see more participation in conferences and events, so expect more CfP notices on the mailing lists. If you need any help with creating a presentation, contact me. That's what I am here for.
14:51:29 <bkp> Also, DV_ will be speaking on oVirt tomorrow at LinuxCon Japan
14:51:50 <bkp> #info Conferences OpenStack Israel is still on for June 2.
14:51:50 <bkp> #info Conferences FrOSCON CfP closes May 23
14:51:50 <bkp> #info Conferences OSCON Open Cloud Day CfP closes May 27
14:51:50 <bkp> #action More conference participation is needed for 2014. See bkp for help planning/submitting presentations.
14:52:10 <bkp> Unless there's anything else...
14:52:33 <bkp> ...moving on to the final item on the agenda.
14:52:33 <ovirtbot> bkp: Error: "..moving" is not a valid command.
14:53:00 <bkp> Okay, thanks, obot.
14:53:04 <bkp> #topic other topics
14:53:19 <bkp> From what I hear, Google Summer of Code projects seem to be rolling along very nicely.
14:53:49 <bkp> Does anyone have any additional items to add/discuss?
14:54:19 <bkp> Going once...
14:55:21 <bkp> Going twice...
14:56:10 <bkp> Okay, then may the road rise up to meet you! See you on the wires!
14:56:14 <bkp> #endmeeting