#ovirt: oVirt Weekly Sync

Meeting started by bkp at 14:02:00 UTC (full logs).

Meeting summary

  1. Agenda and Roll Call (bkp, 14:02:15)
    1. infra updates (bkp, 14:02:27)
    2. 3.4.z updates (bkp, 14:02:27)
    3. 3.5 planning (bkp, 14:02:27)
    4. conferences and workshops (bkp, 14:02:27)
    5. other topics (bkp, 14:02:27)

  2. infra updates (bkp, 14:03:43)
    1. Infra Started the week with minidells and os1 slaves down, then one rackspace server fails and one of the vms there got frozen (bkp, 14:09:27)
    2. Infra os1 issues are still there, we can't create new slaves (bkp, 14:09:27)
    3. Infra found an issue with the job throttling jenkins plugin, that was fixed (bkp, 14:09:27)
    4. Infra OSAS team is trying to start an internal community to curate/manage os1, FYI (bkp, 14:09:27)

  3. 3.4.z updates (bkp, 14:10:04)
    1. 3.4.z updated status can be found at http://lists.ovirt.org/pipermail/users/2014-May/024320.html (bkp, 14:12:37)
    2. 3.4.z no blockers found, 70 bugs still open, RC scheduled for 2014-05-27 (bkp, 14:12:37)

  4. 3.5 planning (bkp, 14:12:57)
    1. 3.5 integration Status for alpha release posted to list this morning: http://lists.ovirt.org/pipermail/users/2014-May/024301.html (bkp, 14:19:55)
    2. 3.5 integration Alpha scheduled for May 16, 2014 (bkp, 14:19:55)
    3. 3.5 integration features are still not merged, but feature freeze postponed to end of may so we can still try to make it (bkp, 14:19:55)
    4. 3.5 integration dwh, reports, adn websocket are pending on a refactoring of the setup package (bkp, 14:19:55)
    5. 3.5 integration iscsi support for hosted engine is pending on an issue about logical volume disconnected on vdsm restart (bkp, 14:19:56)
    6. 3.5 integration we got progress in wgt but nothing ready to test yet (bkp, 14:19:59)
    7. 3.5 integration ovirt-release34-1.0.1 enable automatically mirror list (bkp, 14:20:01)
    8. ACTION: 3.5 integration Maintainers, please start filling release notes for 3.4.2 rc and 3.5.0 alpha (bkp, 14:20:03)
    9. 3.5 virt Things going well, sheet up to date. fromani is making at least some progress with SPICE+VNC vdsm-side (bkp, 14:28:40)
    10. 3.5 virt "Edit Running Vm" and "virtio-rng support" mskrivanek expects to get in by the end of the week (bkp, 14:28:40)
    11. 3.5 virt "disable spice file transfer & copy and paste" feature depends on the fate of fromani's patch...danken should pay attention on the patchset (bkp, 14:28:40)
    12. 3.5 virt New "feature" since the last time: Debian guest agent finished, so the remaining part to properly support it in UI is so small that we wanted to get it in completely (bkp, 14:28:40)
    13. 3.5 infra People update the sheet with the latest status (bkp, 14:34:41)
    14. 3.5 infra some wiki pages were also improved in the last week (bkp, 14:34:41)
    15. 3.5 network Two features (related to MAC address pool management), once postponed, may make it yet due to feature freeze postponment. (bkp, 14:44:50)
    16. 3.5 network REST patches have been merged, so ethtool_opts is done and bridge_opts is still blocked on the init_scripts bug that was discussed last week. (bkp, 14:44:50)
    17. 3.5 network Neutron appliance feature that was removed last week might make it as well. Marked as "async?" because it's not a core component. It may possibly be moved back to tracked items, but further discussion is warranted. (bkp, 14:44:50)
    18. 3.5 node Problem discovered in hosted-engine plugin. node relies on networkmanager, which doesn't play well with hosted-engine-setup (and the rest of vdsm). Solution found, testing of the plugin is pending. (bkp, 14:49:55)
    19. 3.5 node Generic registration stuff is also in the works, testing is also pending (bkp, 14:49:55)
    20. 3.5 node Virtual appliance image is a bit troublesome to build, but there was some progress on it. (bkp, 14:49:55)
    21. 3.5 storage [RFE] Snapshot overview in webadmin portal was merged. The UI can still be improved a bit, but basically in. (bkp, 14:57:38)
    22. 3.5 storage Import existing data domain - phase1 under final review, *may* make the alpha, *will* make the feature freeze (bkp, 14:57:38)
    23. 3.5 storage Live merge - we have several blocker issues with libvirt. Talk scheduled with the relevant stake holders later on May 14, will update when new info is present (bkp, 14:57:38)
    24. 3.5 storage Get rid of storage pool metadata on master storage domain - will be merged by the alpha (bkp, 14:57:38)
    25. 3.5 storage Sanlock fencing - discussion held the infra stakeholders and resolved the concerns they had. Working with sanlock stakeholders on it; at risk, though. (bkp, 14:57:40)
    26. ACTION: For storage - AI: code and review like bats out of h*ll (bkp, 14:57:43)
    27. 3.5 SLA All planned features are going to make it for 3.5 (bkp, 15:02:48)
    28. 3.5 SLA Opta-Planner integration: initial version uploaded - jboss7 or jetty backed, no rules atm. ETA 2 weeks. (bkp, 15:02:48)
    29. 3.5 SLA NUMA-support: Engine & agent merged, some minor complimentary patches are missing, and we're having some birth labor, as for every massive feature. API is under review and very close to be merged. UI patches should be sent today/tomorrow. (bkp, 15:02:48)
    30. 3.5 SLA blkio-limits: server patches are started to get reviewed now. UI and agent patches should be sent next week. (bkp, 15:02:48)
    31. 3.5 SLA cpu-limits: patches sent for agent side. Engine in progess (should be ready in next couple of working days). (bkp, 15:02:51)
    32. 3.5 SLA Hosted Engine on SAN: everything is ready but blocked by vdsm bug (1094657). (bkp, 15:02:56)
    33. 3.5 SLA scheduling RESTful API: designed reviewed off-line by maintainer. patches and design should be uploaded by Monday. (bkp, 15:02:58)
    34. 3.5 UX Nothing new for UX, one feature is merged, fixing issues as they are reported. (bkp, 15:05:56)
    35. 3.5 UX Sorting infrastructure is added, too. (The crowd goes wild.) (bkp, 15:05:56)
    36. 3.5 Gluster No reps this week. (bkp, 15:07:09)

  5. conferences and workshops (bkp, 15:07:25)
    1. Conferences DockerConf in UK show is a non-event. (bkp, 15:11:09)
    2. Conferences Local OpenStack Israel point person, please coordinate with bkp if things need doing by him. (bkp, 15:11:09)
    3. Conferences oVirt will have booth presence at OSCON. LinuxCon NA status TBD. (bkp, 15:11:09)

  6. other topics (bkp, 15:11:19)
    1. http://lists.ovirt.org/pipermail/users/2014-May/024237.html (SvenKieske, 15:11:46)
    2. Other the recommended and minimum system requirements for ovirt-engine seem not to be accurate. (re: http://lists.ovirt.org/pipermail/users/2014-May/024237.html) SvenKieske (with orc_orc) asked to take point, to provide history of running instances. (bkp, 15:16:31)
    3. bkp will be in TLV from May 26-June 2. Would like to meet with teams again. (bkp, 15:17:03)
    4. 3.5 Gluster vdsm patch for volume monitoring has an issue which is being worked on. (bkp, 15:21:30)
    5. Other Mirroring of http://resources.ovirt.org/pub continues. Mirror file being created to auto-divert users to nearest/fastest mirrors. Testing in progress. (bkp, 15:21:47)


Meeting ended at 15:23:34 UTC (full logs).

Action items

  1. 3.5 integration Maintainers, please start filling release notes for 3.4.2 rc and 3.5.0 alpha
  2. For storage - AI: code and review like bats out of h*ll


People present (lines said)

  1. bkp (161)
  2. sbonazzo (26)
  3. lvernia (17)
  4. mskrivanek (17)
  5. SvenKieske (16)
  6. gchaplik (16)
  7. amureini_ (12)
  8. ovedo (9)
  9. fabiand (9)
  10. ewoud (8)
  11. dcaro (7)
  12. awels (4)
  13. ecohen (4)
  14. dr_gogeta86 (3)
  15. sahina (3)
  16. danken (2)
  17. itamar (2)
  18. ovirtbot (2)
  19. fromani (1)
  20. RobertM (1)


Generated by MeetBot 0.1.4.