#ovirt: oVirt Node Weekly Meeting

Meeting started by mburns at 14:00:21 UTC (full logs).

Meeting summary

  1. agenda (mburns, 14:00:42)
    1. bug review (mburns, 14:00:46)
    2. release status (mburns, 14:00:53)
    3. patch process update (mburns, 14:01:02)

  2. 3.0 bug review (mburns, 14:04:56)
    1. https://bugzilla.redhat.com/showdependencytree.cgi?id=947475&hide_resolved=1 (mburns, 14:05:05)
    2. password changes not working correctly (mburns, 14:07:01)
    3. workaround/fix should be available later today (mburns, 14:07:09)
    4. https://bugzilla.redhat.com/show_bug.cgi?id=922593 (mburns, 14:07:25)
    5. issue is blocked by changes in dracut between el6 and f18 (mburns, 14:08:51)
    6. solution should be posted today (mburns, 14:08:57)

  3. patch review (mburns, 14:10:28)
    1. http://gerrit.ovirt.org/#/q/status:open+project:ovirt-node,n,z (mburns, 14:10:36)
    2. 16 patches pending (mburns, 14:10:55)
    3. 1 is a duplicate that needs to be dropped (http://gerrit.ovirt.org/#/c/15015/) (mburns, 14:11:19)
    4. http://gerrit.ovirt.org/#/c/14737/ (mburns, 14:12:15)
    5. ACTION: mburns to follow up on concerns with approach of this patch (mburns, 14:17:40)
    6. overall -- not a blocker, but a nice to have (mburns, 14:17:55)
    7. http://gerrit.ovirt.org/#/c/15045/ (mburns, 14:18:03)
    8. fileConfig for logging (mburns, 14:18:09)
    9. blocker for 3.0 release (mburns, 14:18:16)
    10. code review +1 (mburns, 14:18:22)
    11. http://gerrit.ovirt.org/#/c/15082/ (mburns, 14:20:22)
    12. log rotate for ovirt node logs (mburns, 14:20:33)
    13. blocker for 3.0 (mburns, 14:20:39)
    14. needs review (mburns, 14:20:48)
    15. ACTION: rbarry to review logging patches (mburns, 14:21:31)
    16. http://gerrit.ovirt.org/#/c/14962/ (mburns, 14:21:40)
    17. tuned configuration (mburns, 14:21:46)
    18. not a blocker, but nice to have (mburns, 14:21:50)
    19. mburns has followup work to do (mburns, 14:21:56)
    20. ACTION: mburns to update patch 14962 (mburns, 14:22:07)
    21. http://gerrit.ovirt.org/#/c/14491/ (mburns, 14:22:29)
    22. reboot task running async (mburns, 14:22:37)
    23. code review -1 (mburns, 14:22:43)
    24. ACTION: jboggs to followup and update patch (mburns, 14:22:53)
    25. http://gerrit.ovirt.org/#/c/14958/ (mburns, 14:23:30)
    26. catch upgrade exceptions (mburns, 14:23:42)
    27. code-review -1 (mburns, 14:23:44)
    28. ACTION: jboggs to followup and update (mburns, 14:23:50)
    29. http://gerrit.ovirt.org/#/c/15079/ (mburns, 14:24:13)
    30. Draft patch (mburns, 14:24:19)
    31. related to 966354, blocker for 3.0 (mburns, 14:25:01)
    32. update expected today (mburns, 14:25:08)
    33. http://gerrit.ovirt.org/#/c/15015/ <-- duplicate of 14737 (mburns, 14:25:28)
    34. http://gerrit.ovirt.org/#/c/14600/ (mburns, 14:25:39)
    35. code review -1 (mburns, 14:25:43)
    36. needs to be abandoned -- obsoleted by new patch (mburns, 14:25:55)
    37. ACTION: jboggs to abandon 14600 (mburns, 14:26:18)
    38. http://gerrit.ovirt.org/#/c/13089/ (mburns, 14:26:23)
    39. awaiting feedback from submitter (mburns, 14:26:30)
    40. not a blocker (mburns, 14:26:34)
    41. http://gerrit.ovirt.org/#/c/14664/ (mburns, 14:26:53)
    42. puppet plugin (mburns, 14:26:57)
    43. rbarry close to making it work with automake (mburns, 14:28:28)
    44. should be updated today (mburns, 14:28:37)
    45. http://gerrit.ovirt.org/#/c/14956/ (mburns, 14:28:49)
    46. upgrade log file name (mburns, 14:28:55)
    47. awaiting feedback from mburns (mburns, 14:29:01)
    48. ACTION: mburns to give feedback on 14956 (mburns, 14:29:16)
    49. http://gerrit.ovirt.org/#/c/14970/ (mburns, 14:29:31)
    50. fix edit-node file name when nvr isn't correct (mburns, 14:29:50)
    51. currently +1 in code review (mburns, 14:30:00)
    52. ACTION: jboggs to review and ack/nack 14970 (mburns, 14:30:28)
    53. http://gerrit.ovirt.org/#/c/15018/ (mburns, 14:30:30)
    54. log dir sync with iso on boot (mburns, 14:30:42)
    55. needs testing/review/update from mburns (mburns, 14:30:54)
    56. not a blocker (mburns, 14:31:03)
    57. ACTION: mburns to update 15018 (mburns, 14:31:19)
    58. http://gerrit.ovirt.org/#/c/14960/ (mburns, 14:31:32)
    59. upgrade lock file (mburns, 14:31:40)
    60. needs review (mburns, 14:31:47)
    61. ACTION: jboggs to update the patch (mburns, 14:32:19)
    62. blocker for 3.0 (mburns, 14:32:39)
    63. http://gerrit.ovirt.org/#/c/13625/ (mburns, 14:32:47)
    64. old patch for partition table removal during re-install (mburns, 14:33:02)
    65. not a blocker, but should be reviewed/updated/abandoned (mburns, 14:33:14)
    66. currently code-review -1 (mburns, 14:33:24)
    67. ACTION: fabiand to look at 13625 (mburns, 14:33:44)

  4. release status (mburns, 14:34:20)
    1. going to slip out beyond 31-May (mburns, 14:34:35)
    2. IDEA: (mburns, 14:36:13)
    3. IDEA: get all blocker bugs and patches resolved by EOD thursday (mburns, 14:36:32)
    4. IDEA: build new beta/RC on Friday (mburns, 14:36:46)
    5. IDEA: target release for late next week (mburns, 14:36:57)
    6. AGREED: resolve issues by thursday eod, build friday, release next week (mburns, 14:37:43)
    7. ACTION: fabiand to update dates on release management (mburns, 14:38:02)

  5. patch process update (mburns, 14:38:23)
    1. there is logic in gerrit for marking patches post/modified when they go through certain stages (mburns, 14:39:03)
    2. based on Bug-Url in the commit message (mburns, 14:39:14)
    3. http://lists.ovirt.org/pipermail/infra/2013-May/003154.html (mburns, 14:39:29)
    4. AGREED: -- add Bug-url to all new patches (mburns, 14:41:12)

  6. Other Topics (mburns, 14:42:31)
  7. urwid support in el6 (mburns, 14:42:51)
    1. el6 and derivatives (centos, scientific linux, etc) have an old version of python-urwid (mburns, 14:43:24)
    2. which is incompatible with some aspects of the new tui codebase (mburns, 14:43:40)
    3. it's an uphill battle to get urwid updated in el6 and derivatives (and probably at least 6 months for derivatives) (mburns, 14:44:21)
    4. ACTION: jboggs to file bug (mburns, 14:51:58)
    5. ACTION: fabiand to investigate whether we can work around these issues (mburns, 14:52:09)

  8. Other Topics (mburns, 14:53:06)


Meeting ended at 14:54:50 UTC (full logs).

Action items

  1. mburns to follow up on concerns with approach of this patch
  2. rbarry to review logging patches
  3. mburns to update patch 14962
  4. jboggs to followup and update patch
  5. jboggs to followup and update
  6. jboggs to abandon 14600
  7. mburns to give feedback on 14956
  8. jboggs to review and ack/nack 14970
  9. mburns to update 15018
  10. jboggs to update the patch
  11. fabiand to look at 13625
  12. fabiand to update dates on release management
  13. jboggs to file bug
  14. fabiand to investigate whether we can work around these issues


Action items, by person

  1. fabiand
    1. fabiand to look at 13625
    2. fabiand to update dates on release management
    3. fabiand to investigate whether we can work around these issues
  2. jboggs
    1. jboggs to followup and update patch
    2. jboggs to followup and update
    3. jboggs to abandon 14600
    4. jboggs to review and ack/nack 14970
    5. jboggs to update the patch
    6. jboggs to file bug
  3. mburns
    1. mburns to follow up on concerns with approach of this patch
    2. mburns to update patch 14962
    3. mburns to give feedback on 14956
    4. mburns to update 15018
  4. rbarry
    1. rbarry to review logging patches


People present (lines said)

  1. mburns (165)
  2. fabiand (37)
  3. Yamaksi_ (14)
  4. jboggs (14)
  5. jvandewege (8)
  6. rbarry (6)
  7. ovirtbot (5)
  8. RobertM (1)
  9. fabiand_afk (1)


Generated by MeetBot 0.1.4.