14:00:21 <mburns> #startmeeting oVirt Node Weekly Meeting
14:00:21 <ovirtbot> Meeting started Tue May 28 14:00:21 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:32 <mburns> #chair rbarry jboggs fabiand
14:00:32 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
14:00:42 <mburns> #topic agenda
14:00:46 <mburns> #info bug review
14:00:53 <mburns> #info release status
14:01:02 <mburns> #info patch process update
14:03:04 <mburns> are people here?
14:03:23 * rbarry is here
14:03:43 * jboggs here
14:03:44 * RobertM here
14:04:23 * fabiand_afk here
14:04:51 <mburns> excellent
14:04:56 <mburns> #topic 3.0 bug review
14:05:05 <mburns> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=947475&hide_resolved=1
14:05:36 <mburns> let's start from the bottom --
14:05:49 <mburns> rbarry: any updates on 966354 ?
14:06:46 <rbarry> I'm reading fabiand's comments right now. I'll have a workaround today.
14:07:01 <mburns> #info password changes not working correctly
14:07:09 <mburns> #info workaround/fix should be available later today
14:07:25 <mburns> #info https://bugzilla.redhat.com/show_bug.cgi?id=922593
14:07:32 <mburns> jboggs: any update on ^^
14:08:05 <jboggs> just need to finish up the dracut work, hopefully today
14:08:51 <mburns> #info issue is blocked by changes in dracut between el6 and f18
14:08:57 <mburns> #info solution should be posted today
14:09:13 <mburns> anyone have other bugs that we should block 3.0 release on?
14:09:44 <fabiand> mburns, nope
14:10:24 <mburns> ok, then moving on
14:10:28 <mburns> #topic patch review
14:10:36 <mburns> #link http://gerrit.ovirt.org/#/q/status:open+project:ovirt-node,n,z
14:10:55 <mburns> #info 16 patches pending
14:11:19 <mburns> #info 1 is a duplicate that needs to be dropped (http://gerrit.ovirt.org/#/c/15015/)
14:11:55 <mburns> let's run through them from the top to see what needs to get in for 3.0
14:12:15 <mburns> #info http://gerrit.ovirt.org/#/c/14737/
14:12:25 <mburns> not a blocker in my opinion, but would be a nice to have
14:13:26 <mburns> i think we're still working through issues with the submitter, right?
14:13:33 <jboggs> right
14:13:40 <mburns> ok, so not a blocker
14:13:42 <jboggs> there was an update last night
14:14:04 <mburns> yes
14:14:15 <mburns> ok, next
14:14:18 <fabiand> erm
14:14:23 <fabiand> just a comment  on the patch above
14:14:27 <mburns> ok
14:15:00 <fabiand> From my py perspective I really don't feel well if a function is using int's to represent different return values. This doesn't really match pythons idea of handling different failures
14:15:07 <fabiand> Exceptions are the keyword here ...
14:15:52 <fabiand> I'd like to see a clean py version so it can later also be used in other py contexts. This is ground work to get a good exception handling in the future (i mean on the high level, e.g. installation failures)
14:15:55 <fabiand> just my 2ct
14:16:25 <mburns> fabiand: i haven't looked recently, but we were trying to handle that i thought
14:16:37 <mburns> have a good python function that has the right exceptions
14:16:59 <mburns> and a wrapper that translates the exceptions into int values for use with bash scripts
14:17:10 <fabiand> mburns, I expressed my concerns, but there was no reply to this concerns
14:17:13 <Yamaksi_> mburns: ok thanks!
14:17:19 <fabiand> mburns, yep
14:17:20 <Yamaksi_> jvandewege: hehe, doing what ?
14:17:23 <mburns> fabiand: ok, i'll follow up on the patch as well
14:17:40 <mburns> #action mburns to follow up on concerns with approach of this patch
14:17:55 <mburns> #info overall -- not a blocker, but a nice to have
14:18:01 <mburns> next patch
14:18:03 <mburns> #info http://gerrit.ovirt.org/#/c/15045/
14:18:09 <mburns> #info fileConfig for logging
14:18:16 <mburns> #info blocker for 3.0 release
14:18:22 <mburns> #info code review +1
14:18:27 <Yamaksi_> mburns: that livecd-iso-to-pxeboot is only for FC yet ?
14:18:27 <jvandewege> Yamaksi_: adding a server to be used as an ovirt host in a xen environment ;-)
14:18:41 <Yamaksi_> jvandewege: huh ? how stupid is that ?
14:18:44 <fabiand> mburns, log rotation patch is also a must, imho
14:18:46 <Yamaksi_> jvandewege: which DC ?
14:19:07 <mburns> fabiand: that's the next patch, i think
14:19:28 <mburns> we do need to get a verified and another code review on this patch
14:19:50 <jvandewege> Yamaksi_: I'm not going to explain, historical mess that needs to be cleaned up without downtime, DC in Ede
14:20:09 <fabiand> mburns, yep
14:20:22 <mburns> #info http://gerrit.ovirt.org/#/c/15082/
14:20:33 <mburns> #info log rotate for ovirt node logs
14:20:39 <mburns> #info blocker for 3.0
14:20:48 <mburns> #info needs review
14:20:58 <mburns> rbarry: can you test these patches?
14:21:18 <Yamaksi_> jvandewege: ah nice BIT
14:21:19 <rbarry> mburns: Certainlyh
14:21:31 <mburns> #action rbarry to review logging patches
14:21:32 <Yamaksi_> jvandewege: hehe, would like to have some replication for the engine
14:21:40 <mburns> #info http://gerrit.ovirt.org/#/c/14962/
14:21:46 <mburns> #info tuned configuration
14:21:50 <mburns> #info not a blocker, but nice to have
14:21:56 <mburns> #info mburns has followup work to do
14:22:07 <mburns> #action mburns to update patch 14962
14:22:25 <jvandewege> Yamaksi_: saw your request, should be coming, could run engine with virtmanager and replicate image
14:22:29 <mburns> #info http://gerrit.ovirt.org/#/c/14491/
14:22:37 <mburns> #info reboot task running async
14:22:43 <mburns> #info code review -1
14:22:53 <mburns> #action jboggs to followup and update patch
14:23:02 <Yamaksi_> jvandewege: yeah, let's hope... a Vm import would be nice too
14:23:21 <Yamaksi_> jvandewege: btw... how much amps are you pulling on the rack(s)
14:23:30 <mburns> #info http://gerrit.ovirt.org/#/c/14958/
14:23:31 <jvandewege> Yamaksi_: just as pxe boot of node :-)
14:23:42 <mburns> #info catch upgrade exceptions
14:23:44 <mburns> #info code-review -1
14:23:50 <mburns> #action jboggs to followup and update
14:23:57 <jvandewege> Yamaksi_: don;'t know, need to look that up......
14:24:13 <mburns> #info http://gerrit.ovirt.org/#/c/15079/
14:24:14 <Yamaksi_> jvandewege: pulling 14AMPS on 1 rack atm
14:24:19 <mburns> #info Draft patch
14:24:35 <mburns> fabiand: this is related to the password setting bug metioned above?
14:24:40 <fabiand> mburns, yep
14:24:43 <mburns> ok
14:24:53 <fabiand> I see two ways to solve the bug, the patch contains one of the two solutions
14:25:01 <mburns> #info related to 966354, blocker for 3.0
14:25:08 <mburns> #info update expected today
14:25:28 <mburns> #info http://gerrit.ovirt.org/#/c/15015/ <-- duplicate of 14737
14:25:39 <mburns> #info http://gerrit.ovirt.org/#/c/14600/
14:25:43 <mburns> #info code review -1
14:25:55 <mburns> #info needs to be abandoned -- obsoleted by new patch
14:26:18 <mburns> #action jboggs to abandon 14600
14:26:23 <mburns> #info http://gerrit.ovirt.org/#/c/13089/
14:26:30 <mburns> #info awaiting feedback from submitter
14:26:34 <mburns> #info not a blocker
14:26:53 <mburns> #info http://gerrit.ovirt.org/#/c/14664/
14:26:57 <mburns> #info puppet plugin
14:27:15 <mburns> i would very much like to see this in 3.0
14:27:22 <mburns> but i'm hesitant to say it's a blocker
14:27:26 <jvandewege> Yamaksi_: got a couple of racks but none more than 5Amps and average ~3
14:27:43 <Yamaksi_> jvandewege: what ? are you running 3 servers in it ?
14:28:06 <rbarry> Makefile integration to build as a subproject done today (almost working at the end of Friday)
14:28:28 <mburns> #info rbarry close to making it work with automake
14:28:37 <mburns> #info should be updated today
14:28:49 <mburns> #info http://gerrit.ovirt.org/#/c/14956/
14:28:55 <mburns> #info upgrade log file name
14:29:01 <mburns> #info awaiting feedback from mburns
14:29:16 <mburns> #action mburns to give feedback on 14956
14:29:31 <mburns> #info http://gerrit.ovirt.org/#/c/14970/
14:29:38 <jvandewege> Yamaksi_: no, couple of equallogics, couple of vmhosts and a set of switches and couple of mail and backupservers
14:29:50 <mburns> #info fix edit-node file name when nvr isn't correct
14:30:00 <mburns> #info currently +1 in code review
14:30:07 <mburns> jboggs: can you review and ack/nack?
14:30:15 <jboggs> yes
14:30:22 <Yamaksi_> jvandewege: 5amps ? Impossible
14:30:28 <mburns> #action jboggs to review and ack/nack 14970
14:30:30 <mburns> #info http://gerrit.ovirt.org/#/c/15018/
14:30:42 <mburns> #info log dir sync with iso on boot
14:30:54 <mburns> #info needs testing/review/update from mburns
14:31:03 <mburns> #info not a blocker
14:31:19 <mburns> #action mburns to update 15018
14:31:32 <mburns> #info http://gerrit.ovirt.org/#/c/14960/
14:31:40 <mburns> #info upgrade lock file
14:31:47 <mburns> #info needs review
14:32:09 <mburns> jboggs: there is a comment from alonbl on that patch, can you address that?
14:32:13 <jboggs> yeah will update it
14:32:19 <mburns> #action jboggs to update the patch
14:32:39 <mburns> #info blocker for 3.0
14:32:47 <mburns> #info http://gerrit.ovirt.org/#/c/13625/
14:33:02 <mburns> #info old patch for partition table removal during re-install
14:33:14 <mburns> #info not a blocker, but should be reviewed/updated/abandoned
14:33:24 <mburns> #info currently code-review -1
14:33:32 <fabiand> mburns, I'll take a look at it ..
14:33:44 <mburns> #action fabiand to look at 13625
14:33:57 <mburns> that's the end of the patch list
14:34:13 <mburns> #info release status
14:34:17 <mburns> #undo
14:34:17 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0xa4678ec>
14:34:20 <mburns> #topic release status
14:34:35 <mburns> #info going to slip out beyond 31-May
14:34:57 <mburns> how about targeting a build for EOW
14:35:02 <mburns> and a release next week
14:35:31 <fabiand> mburns, sounds good ... if the patches are in shape
14:35:50 <mburns> fabiand: right, so target getting all bugs and blocker patches reviewed and merged by EOW
14:36:01 <mburns> actually, but EOD Thursday
14:36:05 <mburns> and build friday
14:36:13 <mburns> #idea
14:36:26 <fabiand> yep
14:36:28 <fabiand> sounds good
14:36:32 <mburns> #idea get all blocker bugs and patches resolved by EOD thursday
14:36:39 <fabiand> otherwise IÄd slip to monday
14:36:46 <mburns> #idea build new beta/RC on Friday
14:36:54 <Yamaksi_> jvandewege: my airco and espressomachine are even using more
14:36:57 <mburns> #idea target release for late next week
14:37:13 <mburns> jboggs: rbarry:  ack?
14:37:18 <jboggs> ack
14:37:31 <rbarry> ack
14:37:43 <mburns> #agreed resolve issues by thursday eod, build friday, release next week
14:37:52 <mburns> fabiand: can you update the release management page?
14:37:56 <fabiand> mburns, yep
14:38:02 <mburns> #action fabiand to update dates on release management
14:38:23 <mburns> #topic patch process update
14:38:32 <mburns> fabiand: raised a good suggestion earlier
14:38:49 <fabiand> If it's about Bug-Url - http://lists.ovirt.org/pipermail/infra/2013-May/003154.html
14:39:03 <mburns> #info there is logic in gerrit for marking patches post/modified when they go through certain stages
14:39:14 <mburns> #info based on Bug-Url in the commit message
14:39:23 <mburns> #link http://lists.ovirt.org/pipermail/infra/2013-May/003154.html\
14:39:27 <mburns> #undo
14:39:27 <ovirtbot> Removing item from minutes: <MeetBot.items.Link object at 0xa47642c>
14:39:29 <mburns> #link http://lists.ovirt.org/pipermail/infra/2013-May/003154.html
14:39:56 <mburns> i agree with adding this to our process for patches that fix specific bugs
14:40:16 <mburns> any objections to adding this entry to patches?
14:40:24 <mburns> it can be instead of rhbz#
14:40:25 * fabiand strongly favors this!
14:40:27 <fabiand> :)
14:40:42 <jboggs> same here
14:41:12 <mburns> #agreed -- add Bug-url to all new patches
14:41:35 <rbarry> I also loke this idea
14:41:42 <mburns> i'd say there is no need to add it to existing patches unless you already have to update the patch
14:42:12 <mburns> but all new patches should have this reference
14:42:23 <fabiand> ack
14:42:31 <mburns> #topic Other Topics
14:42:39 <mburns> oh
14:42:42 <mburns> wait...
14:42:51 <mburns> #topic urwid support in el6
14:42:55 <fabiand> ah ..
14:43:24 <mburns> #info el6 and derivatives (centos, scientific linux, etc) have an old version of python-urwid
14:43:40 <mburns> #info which is incompatible with some aspects of the new tui codebase
14:44:21 <mburns> #info it's an uphill battle to get urwid updated in el6 and derivatives (and probably at least 6 months for derivatives)
14:44:32 <mburns> fabiand: any thoughts on working around this issue?
14:44:50 <fabiand> mburns, depends on the issues ...
14:45:01 <fabiand> is there a list of the issues seen?
14:45:24 <jvandewege> Yamaksi_: then you must be using a lot of servers or just very old power hungry ones ;-)
14:45:37 <jboggs> watch_loop function was missing, thats the only one I saw so far
14:45:38 <mburns> jboggs: identified the first one
14:46:03 <fabiand> okay ..
14:46:24 <mburns> we may hit others, though
14:46:41 <fabiand> okay ..
14:46:49 <fabiand> we can probably work around some ..
14:46:58 <fabiand> or just keep the old tui until an updated urwid lands ..
14:47:45 <mburns> fabiand: no guarantee we could get an updated urwid into el6 or derivatives
14:47:48 <fabiand> what version is in el6?
14:48:01 <jboggs> we can probably workaround at least the one issue I found, it was a small change
14:48:02 <fabiand> 0.9.9 or so iirc?
14:48:14 <mburns> yes, 0.9.9 something...
14:48:21 * mburns gets the exact version
14:48:29 <jboggs> 9.9-1.4
14:48:37 <jboggs> 0.9.9-1.4
14:48:46 <mburns> jboggs: is quicker than mburns
14:48:59 <fabiand> okay ..
14:49:09 <fabiand> I suppose that we can atleast workaround the watch pipe issue
14:49:29 <fabiand> yes, quite sure - without promisses :)
14:49:39 <mburns> fabiand: great
14:49:55 <fabiand> is there a bug for this issue?
14:50:19 <mburns> jboggs: did you file anything?
14:50:21 * mburns hasn't
14:50:34 <jboggs> not yet, rbarry was looking at it friday, i can though
14:50:51 <mburns> yes, let's get a bug filed against the oVirt project
14:50:56 <fabiand> jboggs, it will be easier to track ..
14:50:58 <mburns> and add it to the tracker
14:51:18 <jboggs> adding it now
14:51:58 <mburns> #action jboggs to file bug
14:52:09 <mburns> #action fabiand to investigate whether we can work around these issues
14:53:01 <Yamaksi_> jvandewege: powerhungry for sure, but 5 amps is really impossible if you ask me... it should be one server without any disks running on arm ;)
14:53:06 <mburns> #topic Other Topics
14:53:13 <mburns> anything else?
14:54:47 <mburns> ok, then i'll close the meeting
14:54:50 <mburns> #endmeeting