14:02:19 <bkp> #startmeeting oVirt Weekly Sync (Open Format)
14:02:19 <ovirtbot> Meeting started Wed Apr 22 14:02:19 2015 UTC.  The chair is bkp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:19 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:42 <bkp> Good day all, welcome to the open session weekly meeting.
14:03:09 * sbonazzo here for the open session
14:03:29 <bkp> This is going to be more free form than meetings past, as we transition from the status-report type meetings to something more discussion oriented.
14:04:08 <bkp> #topic Agenda
14:04:33 <bkp> #info 3.5 news
14:04:45 <bkp> #info 3.6 news/discussion
14:04:55 <bkp> #info Open Discussion
14:05:26 * awels here
14:06:01 <bkp> ^^^ If this works. We still haven't set a schedule/structure for "Office Hours" so I don't want to ignore release status completely at this time.
14:06:15 <sbonazzo> bkp +1
14:06:35 <bkp> #topic 3.5 news/discussion
14:07:06 <bkp> Is there anything needed to report about the 3.5 branch?
14:07:33 <sbonazzo> bkp I sent a general status email to mailing list a couple of hours ago: http://lists.ovirt.org/pipermail/devel/2015-April/010315.html
14:07:53 <sbonazzo> for 3.5.2 we looks good to go with GA on april 28
14:07:59 <sbonazzo> only one bug still on QA
14:08:49 <sbonazzo> I'd like to ask if maintainers reviewed the package list I sent on RC4 release
14:09:08 <sbonazzo> to be sure that listed packages correspond to the ones maintainers want to release
14:11:09 <bkp> Noted? Any other items to discuss on 3.5 status?
14:11:53 <bkp> Okay...
14:11:56 <sbonazzo> I think that's all. I've not seen new bugs opened against 3.5.2 RC4 but also didn't get positive feedback
14:12:10 <bkp> maintainers reviewed the         asadpanda  package list I sent on RC4 release                  Asmadeus
14:12:18 <sbonazzo> so I just assume that for example ovirt-live is working great :-)
14:12:34 <bkp> maintainers reviewed the         asadpanda  package list I sent on RC4 release                  Asmadeus
14:12:37 <bkp> 10:09   sbonazzo: to be sure that listed packages correspond to the   aterribl~ ones maintainers want to release
14:12:44 <bkp> Hm
14:12:47 <sbonazzo> :-)
14:12:58 <bkp> #info 3.5 general status email: http://lists.ovirt.org/pipermail/devel/2015-April/010315.html
14:13:01 <bkp> #info 3.5.2 looks good for April 28
14:13:03 <bkp> #info 3.5.2, only one bug in QA
14:13:04 <bkp> Ah, there we go.
14:13:07 <bkp> #info sbonazzo needs maintainers to review the package list he sent on RC4 release, to be sure that listed packages correspond to the ones maintainers want to release
14:13:12 <bkp> Keymap not working right
14:13:29 <bkp> #topic 3.6 news/discussion
14:13:30 <sbonazzo> bkp, for reference the package list is here: http://lists.ovirt.org/pipermail/devel/2015-April/010259.html
14:13:49 <bkp> sbonazzo: Noted.
14:14:15 <sbonazzo> bkp sent a brief general status for 3.6 here: http://lists.ovirt.org/pipermail/devel/2015-April/010310.html
14:14:19 <bkp> News or discussion matters for 3.6 development? Feature freeze is today, correct?
14:14:45 <sbonazzo> we currently have el6 repository broken by the removal of vdsm from it
14:15:14 <sbonazzo> we need to address it in the next couple of days
14:15:23 <sbonazzo> today is feature submission deadline
14:15:40 <sbonazzo> so we should start reviewing the submitted features
14:16:18 <bkp> Who needs to address the broken repo?
14:16:26 <sbonazzo> we have a planned alpha release for may 6
14:17:01 <sbonazzo> bkp: for ovirt-host-deploy a ticket as been opened on infra for fixing the build job excluding 36 master from the build matrix
14:17:13 <sbonazzo> bkp for vdsm-node fabiand?
14:17:37 <mr_chris> These are the instructions for converting centos into a host, right? http://www.ovirt.org/Quick_Start_Guide#Install_Fedora_or_CentOS_Host
14:18:16 <bkp> mr_chris: That should work. Holding a meeting now, sorry.
14:18:39 <bkp> sbonazzo: Anything else?
14:18:49 <mr_chris> bkp, It doesn't. All it says to do is install the repo and configure iptables and disable network manager.
14:19:06 <mr_chris> It doesn't say what to install for vdsm.
14:19:19 <sbonazzo> bkp let me check
14:19:24 <bkp> mr_chris: Noted. Please stand by.
14:19:30 <mr_chris> bkp, Thanks. Standing by.
14:20:02 <sbonazzo> I'd like to ask dev infra if there are news about jdk 1.8 / wildfly support
14:20:14 <sbonazzo> any progress on it?
14:21:24 <sbonazzo> on my side, I tried to rebuild jdk 1.7 from f20 on f22 and it didn't work very well as contingency plan
14:21:40 <sbonazzo> too many broken deps by the downgrade
14:21:51 <sbonazzo> and 1.7 can't be installed side by side with 1.8
14:21:51 <bkp> Any one here form infra?
14:21:52 <fabiand> bkp, hey - all green from the Node side.
14:22:03 <fabiand> bkp, Node is building nicely and we are cleaning up and preparing for 3.6
14:22:06 <bkp> fabiand: Noted, thanks.
14:22:17 <sbonazzo> fabiand: there's a small issue in vdsm deps on el6
14:22:28 <fabiand> Indeed
14:22:36 <sbonazzo> fabiand: http://lists.ovirt.org/pipermail/devel/2015-April/010312.html
14:22:39 <fabiand> Currently we are blocked by a dep issue, but that is hopefully just transient
14:22:55 <sbonazzo> fabiand: issue is that vdsm is not built anyymore on el6 for master
14:23:29 <sbonazzo> fabiand: so node on el6 can be dropped
14:23:36 <sbonazzo> for master
14:23:40 <fabiand> indeed, for master
14:23:41 <fabiand> yes
14:23:47 <fabiand> I thought that we've already done that
14:24:55 <sbonazzo> fabiand: loosk like some related job is still building rpms for el6
14:24:58 <sbonazzo> lloks
14:25:00 <sbonazzo> looks
14:26:08 <sbonazzo> bkp no more news on my side for 3.6
14:26:26 <bkp> Okay, and no one from infra to answer the jdk question?
14:27:30 <sbonazzo> bkp:naybe mperina? masayag?
14:28:11 <sbonazzo> bkp ok, looks nobody around
14:28:17 <bkp> Noted.
14:28:29 <bkp> #info Brief general status for 3.6 here: http://lists.ovirt.org/pipermail/devel/2015-April/010310.html
14:28:32 <bkp> #info el6 repo broken by the removal of vdsm, infra and node (fabiand) must address in the next couple of days
14:28:35 <bkp> #info Node needs to be dropped on el6, which, according to sbonazzo some related job is still building RPMs for el6
14:28:38 <bkp> #info Today (22.4.15) is feature submission deadline for 3.6
14:28:40 <bkp> #info Submitted features need to be reviewed.
14:28:43 <bkp> #info An alpha release of 3.6 is scheduled for May 6
14:28:44 <bkp> #topic Open Discussion
14:28:46 <bkp> #info Inquiry about jdk 1.8 / wildfly support for dev infra, no initial response. Using jdk 1.7 as a fallback is not optimal, sbonazzo reports
14:28:49 <bkp> #info Node is building nicely and the team is cleaning up and preparing for 3.6, fabiand reports
14:29:13 <bkp> For this, I open the virtual floor for any remainin dav/community issues.
14:29:24 <bkp> *dev
14:29:56 <bkp> One thing to resolve: if we move to office hours instead of this weekly meeting, how many would we like to hold?
14:30:00 <sbonazzo> bkp last week there was a report about a security issue with ovirt servers dcaro|lunch looks away, maybe he can update offline on hardening status
14:30:16 <bkp> sbonazzo: Got it.
14:30:28 <dcaro> sbonazzo: I'm here
14:30:39 <sbonazzo> dcaro: hope you enjoyed the lunch :-)
14:31:15 <bkp> dcaro: Any updates on locking things down?
14:31:30 <dcaro> sbonazzo: we are  waiting for the sec team to finish the checks and give more feedback on best practices
14:31:57 <sbonazzo> dcaro: can you drop the directory listing template in the meanwhile? it's not working anymore
14:32:02 <dcaro> sbonazzo: but the immediate issue is solved
14:32:15 <dcaro> sbonazzo: what?
14:32:39 <sbonazzo> dcaro: http://resources.ovirt.org/pub/
14:32:46 <sbonazzo> dcaro: it says it's empty
14:32:59 <sbonazzo> dcaro: while http://plain.resources.ovirt.org/pub/ shows content
14:33:04 <dcaro> sbonazzo: I see it ok
14:33:15 <dcaro> both
14:34:00 <sbonazzo> dcaro: weird, just refreshed clearing browser cache and now it works
14:34:04 <sbonazzo> dcaro: nevermind
14:35:18 <dcaro> sbonazzo: happened before, I think it's apache related, have to investigate but does not seem too problematic
14:35:32 <dcaro> so low prio
14:35:35 <sbonazzo> dcaro: ok
14:35:37 <bkp> Okay, thanks, dcaro
14:35:52 <sbonazzo> bkp about your topic
14:35:58 <bkp> Re: office hours: I was thinking three times a week? Two?
14:35:58 <sbonazzo> "if we move to office hours instead of this weekly meeting, how many would we like to hold?"
14:36:39 * dcaro 
14:36:45 <bkp> I'd like an early-morning one that will catch the EU/west Asia community members
14:36:46 <dcaro> I would
14:36:50 <sbonazzo> bkp I guess 2 may be enough, wed and fri ? middle week and end of week?
14:37:25 <dcaro> fri would not catch the guis in israel
14:37:33 <dcaro> *guys
14:37:41 <sbonazzo> dcaro: tue and thu?
14:37:45 <bkp> Then maybe one that would be more conveient for Pacific region
14:37:55 <bkp> Tue and Thurs seem good
14:37:57 <dcaro> sbonazzo: ok for me
14:38:54 <bkp> I was also thinking these would be moderated (lightly) and the moderators could be just people who signed up and would rotate.
14:40:08 <sbonazzo> let's start without moderation and see if it's needed
14:40:17 <bkp> So, the storage team already has a community gardener person who rotates. I would suggest that this could be a standing thing for them.
14:40:33 <sbonazzo> we have 200 quiet users here :-)
14:40:43 <bkp> sbonazzo: How would that work?
14:41:32 <bkp> I'm thinking there needs to be a scheduled time that people would absolutely know someone was available to answer questions/host discussions.
14:42:44 <misc> +1
14:42:54 <bkp> Questions would still be answered at any time of the day, but knowing there was an open/planned meeting time would be useful, too
14:43:15 <sbonazzo> bkp and we can commit to be there I mean, ok for the days, ok for the hours, ok for rotating, not sure that a moderator is needed during the 1/2 hour or full hour of presence
14:43:19 <bkp> sbonazzo: ^^^ That's all I mean by moderation.
14:43:30 <sbonazzo> bkp: oh
14:43:32 <sbonazzo> bkp ok
14:44:01 <bkp> They could come on, say "I'm here," "Is there anything we need to go over?"
14:44:25 <sbonazzo> bkp +1
14:44:41 <bkp> If yes, off they go to help. If no, then "I'll be here until ___, so feel free to ask"
14:45:06 <bkp> Then they would have to make sure they keep an eye on the channel during the office hour period.
14:45:36 <bkp> But if it's quiet, there's nothing that says the moderator can't just keep working on whatever.
14:47:01 <bkp> Does that seem reasonable?
14:47:51 <bkp> Also, how long do we think will be useful? 30 minutes? 60? Something else?
14:49:08 <sbonazzo> bkp looks ok to me. I'd start with 30 minutes and see if more if needed
14:49:36 <dcaro> bkp: maybe better ask on the list so the team leads can say how much will they allow
14:49:55 <bkp> dcaro sbonazzo +1 (x2)
14:50:57 <bkp> Okay, any other issues outstanding?
14:52:09 <bkp> Going once...
14:53:32 <bkp> Twice...
14:53:45 <bkp> #info On the issue of server hardening, dcaro reports that we are waiting for the sec team to finish the checks and give more feedback on best practices
14:53:48 <bkp> #info bkp suggests that office hours be held for set half-hour periods, moderated by a rotation of community members. Format should be open, answering all questions and discussing any cross-team/community-wide issues as needed. Twice a week, Tuesdays and Thursdays.
14:53:52 <bkp> #action bkp will ask on community mailing lists to finalize discussion on office hour format
14:54:05 <bkp> Then we are done for today! Thanks!
14:54:10 <bkp> #endmeeting