15:00:02 <fabiand> #startmeeting oVirt Node Weekly Meeting
15:00:02 <ovirtbot> Meeting started Mon Feb 16 15:00:02 2015 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:02 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:07 <fabiand> #chairs rbarry tlitovsk dougsland
15:00:10 <fabiand> #topic Agenda
15:00:14 <fabiand> #info oVirt 3.5
15:00:27 <fabiand> #info oVirt 3.6 planning
15:00:32 <fabiand> #info Other Items
15:00:40 <fabiand> #topic oVirt 3.5
15:01:55 * rbarry here
15:02:48 <fabiand> nice
15:02:54 <fabiand> dougsland, attending?
15:03:04 <fabiand> rbarry, hey
15:03:48 <fabiand> Well, let's get started slowly.
15:03:57 <fabiand> #info oVirt 3.5 is there
15:04:04 <fabiand> #info Official ISO builds are pending
15:04:13 <fabiand> #info Idea: Only provide stable Jenkins builds.
15:04:23 <fabiand> #info Limit releases to tarballs
15:04:34 <fabiand> #info Build rpms and iso in jenkins
15:05:57 <fabiand> I know that tlitovsk has been thinking about this
15:06:13 <fabiand> Let's put that on the list for now:
15:06:24 <fabiand> #action tlitovsk to review existnig jobs and clean them up
15:06:32 <fabiand> #action tlitovsk to create job pulling in stable packages
15:06:45 <fabiand> That is basically it what I wanted to clarify about 3.5
15:06:49 <fabiand> Moving on
15:06:54 <fabiand> #topic oVirt 3.6 planning
15:07:09 <fabiand> So, we had some pretty interesting weeks and got some news
15:07:55 <fabiand> The (core) Node team had a meetup
15:08:08 <fabiand> And we investigated new approaches so that we are able to cope with the future
15:08:23 <fabiand> This basically means that we investigated dropping large parts of our custom code.
15:08:34 <fabiand> Including the setup TUI and installer TUI
15:08:59 <fabiand> As an replacement we are looking at anaconda (for installation) and cockpit (for administration)
15:09:12 <fabiand> Missing parts which are not covered are solved upstream, so in eitehr anaconda or cockpit ..
15:09:23 <fabiand> rlhey, ncie to see yuo :)
15:09:40 <fabiand> tlitovsk, nice to see you
15:09:51 <tlitovsk> fabiand, :-)
15:10:00 <fabiand> #info Node team decided to drop the custom installer and custom setup TUI
15:10:17 <tlitovsk> :-D
15:10:20 <fabiand> #info Replacements will be anaconda (for installation) and cockpit (for administration)
15:10:51 <fabiand> Another big point is the simplification of the build process
15:11:01 <fabiand> We need to get away from the complex kickstarts we currently maintain
15:11:20 <fabiand> #info Moving to a minimal kickstart approach
15:11:32 <fabiand> Distro specific dependencies are kept in packages (as Requriements)
15:12:38 <fabiand> Furthermore we will solve the image based fashion of Node differently
15:12:52 <fabiand> And these topics will probably the big pieces of the cake for 3.6
15:13:18 <fabiand> There are already a couple of bugs related to these items, and we also need to cleanup older bugs in the light of this new changes
15:14:11 <fabiand> rbarry, tlitovsk we need to create a feature page for these features
15:14:18 <fabiand> rbarry, tlitovsk at least for the cockpit feature for now
15:14:55 <tlitovsk> tlitovsk, I will be happy to , but I dont have permissions (can be good oportunity to get those)
15:15:13 <tlitovsk> fabiand, ^^
15:15:20 <fabiand> tlitovsk, you need to register in the ovirt wiki, then you should be able to create pages
15:15:44 <tlitovsk> fabiand, I will try.
15:15:58 <fabiand> tlitovsk, perfect, there is a template for features:
15:16:01 <bkp> tlitovsk: I will keep an eye out today and approve your account fast
15:16:13 <fabiand> tlitovsk, http://www.ovirt.org/Template:Feature
15:16:21 <fabiand> bkp++
15:16:35 <fabiand> #action tlitovsk to open a feature page for the Cockpit feature
15:16:54 <fabiand> Right
15:16:55 <fabiand> Moving on ..
15:17:03 <fabiand> Or questions so far?
15:17:42 <fabiand> #topic Other Items
15:17:52 <fabiand> dougsland, rbarry tlitovsk anything else you want to bring up?
15:19:10 <fabiand> Right
15:19:12 <fabiand> I think then we are good
15:19:13 <bkp> fabiand: No, but that info above looks like a mighty fine blog topic.
15:19:14 <fabiand> going once
15:19:20 <bkp> :)
15:19:23 <fabiand> bkp, :)
15:19:35 <fabiand> twice
15:19:49 <fabiand> bkp, indeed
15:19:52 <fabiand> and a third time
15:19:54 <fabiand> #endmeeting