15:07:47 <bkp> #startmeeting oVirt Weekly Sync
15:07:47 <ovirtbot> Meeting started Wed Feb 11 15:07:47 2015 UTC.  The chair is bkp. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:07:47 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:07:47 <bkp> #topic Agenda and Roll Call
15:07:47 <bkp> #info infra update
15:07:47 <bkp> #info 3.4.z updates
15:07:47 <bkp> #info 3.5 status
15:07:49 <bkp> #info conferences and workshops
15:07:52 <bkp> #info other topics
15:08:04 <bkp> Call out, who's here?
15:08:08 * lvernia is here.
15:08:12 * amureini here
15:08:43 * sbonazzo here
15:09:16 <bkp> I am thinking we should poke people a bit more...
15:09:23 <bkp> Okay, let's go.
15:09:25 <bkp> #topic infra update
15:09:42 <bkp> dcaro: You got news?
15:10:31 <lvernia> Well, I've noticed Jenkins jobs have been succeeding today.
15:10:37 <lvernia> Or at least, failing on actual failures.
15:10:40 <lvernia> So something has improved :)
15:10:57 <bkp> lvernia: Something.
15:11:02 * rgolan here
15:11:11 <eedri> lvernia, yea, we did a major cleanup, no production jobs are failing at the moment w/o a real reason
15:11:12 <bkp> Is anyone here for infra? eedri?
15:11:16 <eedri> dcaro, ^
15:11:47 <eedri> bkp, basically we have one job (upgrade 3.4->3.5) failing on bug 1161012
15:12:09 <eedri> bkp, vdsm error codes mismatch, new bug opened 1191514
15:12:23 <eedri> bkp, and there 2 vdsm unit tests jobs failing also due to known issues
15:13:25 <bkp> Got it. Anything else?
15:14:03 <eedri> bkp, basically we're nearing the point of no real errors on ci and i'd like to ask everyone to start looking at failures on gerrit again
15:14:19 <eedri> bkp, and not ignore them. and report any false positive error to the infra list so we can investigate and fix
15:14:38 <eedri> bkp, there has been major stabilization work done recently, specifially with the move to the new phx lab
15:16:08 <bkp> Noted.
15:16:54 <bkp> #info infra Major Jenkins cleanup done, no production jobs are failing at the moment w/o a real reason
15:16:57 <bkp> #info infra One job (upgrade 3.4->3.6) failing on bug 1161012
15:17:00 <bkp> #info infra vdsm error codes mismatch, new bug opened 1191514
15:17:02 <bkp> #info infra Two vdsm unit tests jobs failing also due to known issues
15:17:05 <bkp> #action infra We're nearing the point of no real errors on CI and eedri asks everyone to start looking at failures on gerrit again and not ignore them. Report any false positive error to the infra list so we can investigate and fix.
15:17:09 <bkp> #info infra There has been major stabilization work done recently, specifially with the move to the new phx lab
15:17:12 <bkp> Is that all from infra?
15:17:42 <eedri> bkp, dcaro will send an email tomorrow summarizing the details on last week
15:18:20 <bkp> #info infra dcaro will send an email tomorrow summarizing the details on last week
15:18:23 <bkp> Moving on...
15:18:32 <bkp> #topic 3.5.z updates
15:18:42 <bkp> sbonazzo: What be the word?
15:19:12 <sbonazzo> bkp: I sent the status this morning  http://lists.ovirt.org/pipermail/users/2015-February/031258.html
15:19:26 <sbonazzo> bkp no much progress since last week, first blocker appeared
15:19:49 <sbonazzo> https://bugzilla.redhat.com/show_bug.cgi?id=1161012
15:20:28 <dcaro> bkp: sorry, did not see the ping
15:20:48 <bkp> dcaro: No worries.
15:21:31 <sbonazzo> bkp nothing else for 3.5.z on my side
15:22:08 <bkp> Okay, thanks.
15:22:17 <bkp> #info 3.5.z updates Full status here: http://lists.ovirt.org/pipermail/users/2015-February/031258.html
15:22:20 <bkp> #info 3.5.z updates First blocker for 3.5.2 appeared last week. (https://bugzilla.redhat.com/show_bug.cgi?id=1161012)
15:22:45 <bkp> Let's roll on...
15:22:54 <bkp> #topic 3.6 status
15:23:10 <bkp> sbonazzo, want to continue for integration?
15:23:21 <sbonazzo> bkp: sure
15:23:43 <sbonazzo> bkp sent status this morning here http://lists.ovirt.org/pipermail/users/2015-February/031260.html
15:23:59 <sbonazzo> bkp most important news on our side is ovirt-live rebased on EL7
15:24:49 <sbonazzo> bkp other features for 3.6 are still in porgress, Fc support for HE will be probably completed next week
15:25:10 <bkp> And may I offically add that our response time on this impressed the socks off the RDO crew.
15:25:23 <sbonazzo> bkp :-D
15:26:00 <bkp> sbonazzo: Is that it from integration?
15:26:20 <sbonazzo> mmm I guess virt sig can be discussed in other topics
15:26:28 <sbonazzo> so for now that's it
15:26:28 <bkp> Noted.
15:26:37 <bkp> #info 3.6 status integration Full status here: http://lists.ovirt.org/pipermail/users/2015-February/031260.html
15:26:40 <bkp> #info 3.6 status integration ovirt-live rebased on EL7!
15:26:42 <bkp> #info 3.6 status integration Other features for 3.6 are still in progress, FiberChannel support for HE will be probably completed next week
15:27:02 <bkp> Let's check in with virt. sbonazzo, what's up with the Virt CentOS SIG?
15:27:31 <sbonazzo> bkp: virt sig meeting logs are here: http://www.centos.org/minutes/2015/february/centos-devel.2015-02-10-14.03.log.html
15:27:49 <sbonazzo> bkp news from our side are that we built qemu-kvm-rhev in centos koji server
15:28:05 <sbonazzo> bkp but sadly it has been rejected due to the -rhev suffix
15:28:22 <sbonazzo> bkp so we'll have more work to do on it
15:28:52 <sbonazzo> bkp we also discussed about rpm packaging for centos, and it seems that the same guidelines requested by fedora are in place
15:29:12 <sbonazzo> bkp so it will take lot of time before ovirt will be available in centos repos
15:29:42 <sbonazzo> bkp plan for now is to resolve the qemu-kvm naming and have vdsm in centos repo
15:29:58 <sbonazzo> the engine will follow slowly
15:30:21 <sbonazzo> bkp that's all on virt sig side
15:31:54 <bkp> Okay, anything from virt in general?
15:32:42 <bkp> I don't see michal... anyone here for virt?
15:33:37 <bkp> Okay, moving on.
15:33:48 <bkp> #info 3.6 status virt SIG meeting logs are here: http://www.centos.org/minutes/2015/february/centos-devel.2015-02-10-14.03.log.html
15:33:51 <bkp> #info 3.6 status virt qemu-kvm-rhev has been built in centos koji server but has been rejected due to the -rhev suffix. More work will need to be done on it
15:33:54 <bkp> #info 3.6 status virt SIG also discussed rpm packaging for centos, and it seems that the same guidelines requested by fedora are in place. This means it will take lot of time before ovirt will be available in centos repos
15:33:58 <bkp> #info 3.6 status virt Plan for now is to resolve the qemu-kvm naming and have vdsm in centos repo; the engine will follow slowly
15:34:08 <bkp> Storage? 3.6 updates?
15:34:12 <bkp> amureini ^^^
15:34:14 <amureini> bkp, yup.
15:35:21 <amureini> bkp, cinder/ceph integration coming along nicely, working on a tesk-centric poc for removing spm, lsm between storage types coming along nicely although we identified some gaps in libvirt (was escalated to them)
15:35:39 <amureini> bkp, other smaller rfes progressing, closed a bunch already, and working on some more.
15:35:46 <amureini> bkp, that's it for me
15:36:53 <bkp> Thanks, amureini
15:37:02 <bkp> #info 3.6 status storage Cinder/Ceph integration coming along nicely, working on a tesk-centric poc for removing spm
15:37:05 <bkp> #info 3.6 status storage lsm between storage types coming along nicely although we identified some gaps in libvirt (was escalated to them)
15:37:08 <bkp> #info 3.6 status storage Other smaller RFEs progressing, closed a bunch already, and working on some more.
15:37:15 <bkp> infra 3.6 status?
15:37:26 <bkp> pkliczew ^^^
15:38:00 <bkp> emesika ^^^
15:38:45 <pkliczew> bkp, how can I help?
15:39:07 <bkp> pkliczew: Are there any updated from your team regarding 3.6?
15:39:12 <bkp> *updates
15:39:46 <pkliczew> bkp, I am not aware of any
15:40:04 <bkp> That's one option. :)
15:40:30 <bkp> Thanks pkliczew
15:40:35 <bkp> #info 3.6 status infra No updates at this time.
15:40:50 <bkp> Network, 3.6 updates? lvernia?
15:40:58 <lvernia> bkp: Indeed, we have some.
15:41:13 <lvernia> bkp: Two more features have been merged, management network as a role and cumulative network usage statistics.
15:41:14 <bkp> Fire away, sir
15:41:36 <lvernia> bkp: The latter has starred on the mailing list in the past...
15:41:43 <lvernia> bkp: So hopefully should help out some people.
15:42:05 <lvernia> bkp: Other features are moving along, not much to update.
15:42:26 <bkp> Noted.
15:42:39 <bkp> #info 3.6 status network Two more features have been merged, management network as a role and cumulative network usage statistics (highlighted recently on mailing list).
15:42:42 <bkp> #info 3.6 status network Other features are moving along, not much to update.
15:42:45 <bkp> Thank you lvernia
15:42:45 <lvernia> I'll update the spread sheet as well...
15:42:50 <lvernia> bkp: Sure.
15:43:13 <bkp> SLA, who's here to give 3.6 status update?
15:43:25 <rgolan> bkp: hello
15:43:45 <bkp> Hey, rgolan What do you have for us?
15:44:13 <rgolan> bkp: Not much on going on 3.6. work on quota REST api has started
15:45:19 <rgolan> bkp: besides that nothing concrete
15:45:39 <bkp> Okay, thanks, rgolan
15:45:49 <bkp> #info 3.6 status sla Not much on going on 3.6. Work on quota REST api has started
15:46:02 <bkp> VDSM, 3.6 updates? danken?
15:47:40 <lvernia> bkp: He's been sick today.
15:47:44 <lvernia> bkp: Not sure he's actually there.
15:48:07 <bkp> lvernia: Thanks. Is anyone here for vdsm this week?
15:48:53 <bkp> Okay...
15:49:13 <bkp> #info 3.6 status vdsm No updates this week.
15:49:36 <bkp> UX, 3.6 updates?
15:49:59 <bkp> ecohen? gshereme? ^^^
15:50:12 <ecohen> bkp, no 3.6 updates - all same as last week.
15:50:47 <bkp> ecohen: Thanks, noted!
15:50:55 <bkp> #info 3.6 status ux No updates this week.
15:51:08 <bkp> Okay, that should do it for 3.6...
15:51:20 <bkp> #topic Conferences and Workshops
15:51:38 <bkp> Just going to roll these out...
15:52:14 <bkp> #info Conferences and Workshops Linux Collab Summit is next week in Santa Rosa, CA. bkp will be presenting an oVirt Status Update to the Open Virtualization Alliance, as well as a talk on Containers v. VMs.
15:52:18 <bkp> #info Conferences and Workshops jbrooks will be speaking about smart scheduling at SCALE next weekend in LA, and bkp will be talking about the differences between scale up and out, as well as delivering the Containers/VMs presentation again at the SCALE:Infrastructure.Next miniconf.
15:52:23 <bkp> #info Conferences and Workshops mlipchuk has his talk on Disaster Recovery in oVirt accepted for the FOSSAsia conference, so it looks like he will be joining bkp in Singapore in mid-March.
15:52:27 <bkp> #info Conferences and Workshops gshereme will be speaking on "Using Bootstrap with Google Web Toolkit" as POSSCON in South Carolina on April 14-15.
15:52:36 <bkp> That's a lot... is there any other conference news to add?
15:53:27 <bkp> I'll take that as a no...
15:53:45 <bkp> #topic Other Topics
15:54:24 <bkp> Almost done, but the big news this week from me is we are eliglible to enter the 2015 Google Summer of Code!
15:54:41 <bkp> #info Other Topics bkp very pleased to report that oVirt *can* partcipate in the 2015 Google Summer of Code. Information is here (http://lists.ovirt.org/pipermail/users/2015-February/031225.html).
15:54:54 <bkp> #info Other Topics bkp very pleased to report that oVirt *can* partcipate in the 2015 Google Summer of Code. Information is here (http://lists.ovirt.org/pipermail/users/2015-February/031225.html).
15:55:09 <bkp> Whoops
15:55:12 <bkp> #action Other Topics The deadline for GSoC project/mentor submission is 1900 UTC on Feb. 20, 2015. So please get your ideas in to our Ideas page (http://www.ovirt.org/Summer_of_Code) *and* the GSoC 2015 site by then. Once they give us a number of projects slots, we can determine which projects will get the go ahead.
15:55:30 <bkp> #action Other Topics Also, if you register as a mentor with a project, send bkp your GSoC username so bkp can link you to the oVirt organization on the GSoC site.
15:55:43 <bkp> #action Other Topics  One more thing: bkp needs someone to act as a backup administrator for the oVirt organization, which is essentially someone to get a hold of students and mentors about deadlines and such if he can't do it. If interested, contact bkp as soon as possible. Admins *cannot* be mentors, too, so think carefully.
15:56:00 <bkp> And in non-GSoC news...
15:56:20 <bkp> #info Other Topics bkp is hearing good things about our current round within the GNOME Outreach Program for Women. We *are* planning to enter the next round, details to follow.
15:56:37 <bkp> #info Other Topics Speaking of OPW, voting will close for officially making moVirt an incubator subproject within oVirt today. Announcement to follow.
15:56:56 <bkp> #info Other Topics The design team and the documentation team are still hashing out the details of revamping our site. It is clear that we will use markdown as the base format for content that is *not* documentation. The format for documentation will need to be something more robust, so downstream providers will have metadata with which they can create their products' docs.
15:57:17 <bkp> And, finally...
15:57:19 <bkp> #action Other Topics A general reminder: blog entries are (always) needed. tl,dr: MOAR BLOGS!!
15:57:37 <bkp> Anyone have another topic/issue to add?
15:58:11 <bkp> It's the post-FOSDEM hangover blues time of year...
15:58:19 <amureini> bkp, question: should slides from past conferences be uploaded to oVirt.org? I see we have /some/ there, but it definitely isn't comprehensive
15:58:54 <bkp> amureini: They should. If you don't want to do it, send them to me and I will happily take care of it.
15:59:39 <amureini> bkp, i don't mind doing it, was just curious about the guideline. the decision which ones go up there and which ones don't seemed arbitrary to me
16:00:25 <bkp> amureini: It's basically who remembers to do it/I remember to follow up.
16:01:22 <amureini> bkp fair enough :-)
16:01:22 <bkp> #info Other Topics  Slides from past conferences should be uploaded to oVirt.org. If you do not want to do it, send slide file to bkp and he will handle it.
16:01:48 <bkp> Good question, anything else?
16:02:33 <bkp> Going once...
16:02:55 <bkp> ..twice...
16:02:55 <ovirtbot> bkp: Error: ".twice..." is not a valid command.
16:03:01 <lvernia> Haha.
16:03:04 * bkp headthumps
16:03:12 <bkp> Twice....
16:03:54 <bkp> Okay. we're done. See you next week!
16:04:06 * bkp takes wrench to ovirtbot...
16:04:11 <lvernia> :)
16:04:14 <bkp> #endmeeting