15:01:35 <ydary_> #startmeeting oVirt Weekly Sync
15:01:35 <ovirtbot> Meeting started Wed Jan 21 15:01:35 2015 UTC.  The chair is ydary_. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:35 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:41 * amureini here
15:01:46 * lvernia is here.
15:01:58 <ydary_> hi guys, let's start the meeting.
15:02:08 * awels here
15:02:11 * doron here
15:02:17 <lvernia> Hello hello.
15:02:23 * ydary_ will lead the meeting today
15:02:32 <doron> hi lvernia
15:02:57 <doron> I'm happy to announce that ydary will lead today's meeting
15:03:06 <doron> #chair ydary
15:03:27 * bkp here
15:03:32 <doron> #help
15:03:56 <ydary_> #topic Agenda and roll Call
15:04:15 <ydary_> #info infra update
15:04:16 <ydary_> #info 3.5.z updates
15:04:16 <ydary_> #info 3.6.0 status
15:04:16 <ydary_> #info conferences and workshops
15:04:16 <ydary_> #info other topics
15:04:29 <ydary_> let's start with infra updates
15:04:40 <ydary_> #topic infra update
15:04:45 <ydary_> dcaro|pto|away: ?
15:05:24 <ydary_> anyone can help with infra update?
15:05:39 * sbonazzo here
15:05:53 <doron> hi sbonazzo
15:06:28 <doron> sbonazzo: do you know how things are going with infra?
15:06:32 <sbonazzo> ydary_: maybe bkorren ewoud ?
15:06:55 <ydary_> bkorren: any updates on infra for this week?
15:07:00 <sbonazzo> doron: not much, on my side just added a couple of jobs we missed in the transition from 3.4 to 3.5 on engine
15:07:33 <doron> sbonazzo: thanks. let's see if anyone else can cover for dcaro|pto|away.
15:07:48 <sbonazzo> doron: oh, also investigated on a couple of bugs
15:07:50 <bkp> eedri?
15:08:00 <ydary_> moving on..
15:08:02 <sbonazzo> doron: affecting f21 builds
15:08:07 <ydary_> #topic 3.5.z updates
15:08:16 <sbonazzo> doron: solved updating kernel on jenkins slaves
15:08:17 <ydary_> sbonazzo: can you update?
15:08:18 <doron> sbonazzo: let's cover it in the relevant version.
15:08:37 <sbonazzo> doron: it's infra specific
15:08:40 <eedri> bkp, not too much to update, but few things are important
15:08:54 <sbonazzo> doron: there was an infinite loop on gettimeofday when called within a vm
15:09:06 <sbonazzo> doron: solved in latest kernel in f21
15:09:07 <eedri> bkp, dcaro|pto|away sent email yesterday about current status and future plans for automation and standartization of build process
15:09:13 <bkp> eedri: Hang on, we moved on.
15:09:17 <eedri> bkp, i think it's important that maintainers will review it
15:09:22 * eedri ducks..
15:09:28 <eedri> opss, sorry guys
15:09:38 <doron> eedri: nm. please go on.
15:10:11 <eedri> doron, ok
15:10:31 <eedri> next, is the jdk 1.8 issue which we need to start addressing, both in infra and all the teams
15:10:38 <eedri> as 1.7 is eol in april
15:11:03 <doron> eedri: can you provide a link to dcaro|pto|away's mail?
15:11:17 <eedri> doron, looking, do you have the link to piper?
15:11:22 <eedri> doron, where i can search it?
15:11:30 <doron> eedri: which list is it?
15:11:38 <eedri> doron, infra and devel
15:12:42 <doron> eedri: http://lists.ovirt.org/pipermail/infra/2015-January/thread.html
15:12:47 <doron> but we need the specific list.
15:13:12 <doron> #info sbonazzo resolved kernel based issues in some of the jobs.
15:14:33 <eedri> doron, http://lists.ovirt.org/pipermail/infra/2015-January/009014.html
15:14:45 <ydary_> #info the teams need to start working\testing JDK 8, since JDK 7 EOL is in April 2015
15:14:59 <sbonazzo> doron another issue was on slaves running out of entropy, solved by installing haveged
15:15:03 <eedri> doron, also, new gwt params and updates were added to pom files by vszocs
15:15:16 <eedri> we can now build engine for 3.6 without memory errors
15:15:46 * doron reminds everyone ydary_ is chair today ;)
15:16:09 <lvernia> eedri: So snapshot builds now pass?...
15:16:21 <ydary_> #info some jenkins slaves had issues on running out of entropy, solved by installing haveged
15:16:41 <eedri> a meeting was held with phx lab it team to discuss phase ii of deployment, which will include moving to private network, expanding ip range and other important features
15:16:47 <eedri> we'll update once we have a fix plan
15:16:51 <eedri> lvernia, yea, should be
15:17:23 <lvernia> eedri: But the patch was merged on Thursday/Friday.
15:17:38 <lvernia> eedri: And this week it seemed like the snapshot build didn't include new-ish patches.
15:17:38 <ydary_> #info 3.6 memory errors in gwt resolved by vszocs
15:17:50 <eedri> lvernia, let's take it offline, no point in delaying the meeting
15:17:58 <eedri> lvernia, might be specific issue
15:18:02 <lvernia> eedri: It's quite relevant to the meeting.
15:18:16 <lvernia> eedri: The master snapshot actually being built on a nightly basis.
15:18:26 <eedri> lvernia, dcaro|pto|away isn't here today and he's mostly maintaining it, so i'm afraid i won't have too much updated into to give you
15:18:41 <lvernia> eedri: Okay.
15:18:47 <ydary_> #info progress in moving oVirt resources to phx lab
15:18:49 <eedri> lvernia, but as i said the main problem was resovled
15:18:55 <ydary_> eedri: anything else?
15:18:58 <eedri> lvernia, there might be other issues still need to be looked at
15:19:02 <lvernia> ydary_: I suspect nightly builds still aren't functioning properly.
15:19:19 <eedri> ydary_, nothing major to update from my side
15:19:23 <ydary_> lvernia: is it a infra issue?
15:19:30 <lvernia> ydary_: I've asked mburman to join the channel.
15:19:33 <lvernia> ydary_: Definitely.
15:19:56 <ydary_> lvernia: Let's take it offline and report back next week
15:19:57 <eedri> ydary_, what i know is f21 build weren't working, due to bugs, so it might be worth to remove it from the builds
15:20:07 <lvernia> ydary_: Patches merged two weeks ago still didn't take effect in his snapshot installation this week.
15:20:16 <lvernia> ydary_: Specifically, 3.6 clusters can't be created.
15:20:28 <ydary_> #action eedri to follow up on nightly issues with lvernia
15:20:46 <lvernia> Cool.
15:20:53 <doron> guys, we'd like to proceed. let's move on
15:21:07 <ydary_> moving on to 3.5.z topics
15:21:15 <ydary_> sbonazzo: any updates?
15:21:23 <sbonazzo> ydary_: 3.5.z. sent an update this morning http://lists.ovirt.org/pipermail/devel/2015-January/009710.html
15:21:36 <sbonazzo> ydary_: finished collecting rpms, composing final repo as we speak
15:22:07 <sbonazzo> ydary_: will announce 3.5.1 later today
15:22:17 <doron> sbonazzo: you mea RC, right?
15:22:27 <sbonazzo> doron: no, I mean GA
15:22:37 <doron> sbonazzo: thanks for clarifying.
15:22:42 <ydary_> #info 3.5.1 to be released today.
15:23:07 <ydary_> #action lease fill release notes, the page has been created here http://www.ovirt.org/OVirt_3.5.1_Release_Notes
15:23:19 <ydary_> #action please fill release notes, the page has been created here http://www.ovirt.org/OVirt_3.5.1_Release_Notes
15:23:35 <ydary_> sbonazzo: anything else on 3.5.z or 3.5.1?
15:24:23 <sbonazzo> ydary_: well, nothing special, just a reminder that bug targeted to 3.5.1 will be re-targeted to a later release
15:24:51 <doron> sbonazzo: thanks for the kind reminder.
15:25:12 <ydary_> #info all open bugs on 3.5.1 will be re-targeted to 3.5.2 post the GA release
15:25:26 <ydary_> moving on to 3.6
15:25:35 <ydary_> #topic 3.6 status
15:25:41 <ydary_> sbonazzo: any updates?
15:25:57 <sbonazzo> ydary_: sent status this morning http://lists.ovirt.org/pipermail/devel/2015-January/009711.html no great updates, just updated bug counting
15:26:37 <sbonazzo> ydary_: on integration side, glusterfs support on hosted engine (for existing replica 3 gluster storage) has been merged
15:26:55 <ydary_> #info 3.6.0 currently shows no blockers. There are 502 bugs targeted to 3.6.0.
15:27:43 <ydary_> #info integration update on 3.6.0: added glusterfs support on hosted engine (for existing replica 3 gluster storage)
15:27:58 <ydary_> sbonazzo: anything else on integration?
15:28:39 <sbonazzo> ydary_: about f21 support, received report this morning that jboss-as 7.1 doesn't work at all with jdk 1.8 so for supporting it we need to move to wildfly
15:29:24 <sbonazzo> ydary_: that's all on integration side
15:29:26 <ydary_> sbonazzo: is infra team aware? oved ^^^
15:29:56 <sbonazzo> ydary_: yep
15:30:33 <sbonazzo> ydary_: also jdk 1.7 is going eol in april so it's time to look at 1.8 anyway
15:30:36 <ydary_> #info integration update on 3.6.0: jboss-as 7.1 doesn't work at all with jdk 1.8 so for supporting fc21 we need to move to wildfly
15:30:53 <doron> oved: here?
15:31:15 <ydary_> who is covering for infra today?
15:32:42 <ydary_> #action oved to report next week on JDK 1.8 and wildfly status
15:32:54 <ydary_> moving on to network
15:33:00 <ydary_> lvernia: any updates?
15:33:16 <lvernia> ydary_: What resolution are you looking for?
15:33:30 <ydary_> lvernia: current RFEs status for 3.6
15:33:31 <lvernia> ydary_: We haven't covered feature progress in previous weeks.
15:33:46 <lvernia> ydary_: Okay, so as I had mentioned in the past, a couple already merged and ready for testing.
15:33:47 <doron> lvernia: indeed and time to start looking int oit.
15:33:56 <doron> lvernia: for now it';s current status mostly.
15:33:59 <lvernia> ydary_: Host Network QoS and MAC pool per DC, specifically.
15:34:24 <lvernia> ydary_: As soon as 3.6 clusters can be created on master, they'll be available for users of the nightly snapshots.
15:34:36 <lvernia> ydary_: As for other features, good progress is being made.
15:34:53 <lvernia> ydary_: Nothing specific in risk, and I can update whenever further ones are merged.
15:35:38 <ydary_> #info Host Network QoS and MAC pool per DC are in. Once 3.6 clusters can be created, it will be available.
15:36:23 <ydary_> #info network 3.6 updates: currently nothing at risk.
15:36:35 <ydary_> lvernia: thanks
15:36:45 <lvernia> ydary_: No problem.
15:36:47 <ydary_> amureini: can you update on storage status for 3.6?
15:36:59 <amureini> ydary_, sure.
15:37:26 <amureini> ceph-cinder integ have good progress - wip patches already posted
15:37:52 <amureini> some minor rfes also moving forward, nothing too dramatic.
15:37:55 <amureini> ydary_, ^^^
15:38:34 <ydary_> #info ceph-cinder integration have WIP patches.
15:39:05 <ydary_> #info storage 3.6 updates: minor RFEs also making progress
15:39:25 <ydary_> amureini: thanks!
15:39:37 <ydary_> fabiand: can you update for node on 3.6 status?
15:41:42 <ydary_> #info node 3.6 updates: currently no updates
15:41:57 <ydary_> awels: can you update on UX status for 3.6?
15:42:17 <awels> ydary_: Nothing new since last time, REST api making progress, tooltips making progress.
15:42:53 <ydary_> awels: can you add more details on the tooltips?
15:42:56 <fabiand> ydary_, sorry was afk, but yes, no updates so far
15:43:13 <awels> ydary_: We are moving the tool tip infrastructure to be patternfly based.
15:44:20 <awels> ydary_: Once the infrastructure is in we can convert all existing tooltips to use it.
15:44:44 <ydary_> #info UX 3.6 updates: UI over REST api and tool tip infrastructure over patternfly making progress
15:44:58 <ydary_> awels: anything else?
15:45:03 <awels> ydary_: Nope that is it
15:45:09 <ydary_> awels: thanks!
15:45:20 <ydary_> doron: can you update on 3.6 status for SLA?
15:45:28 <doron> ydary_: SLA still planning, no further updates.
15:45:46 <ydary_> #info SLA 3.6 updates: SLA still in planning, no further updates.
15:46:05 <ydary_> anyone here for virt?
15:47:18 <ydary_> #info virt 3.6 updates: no one for virt team to update
15:47:35 <ydary_> moving on to conferences and workshops
15:47:43 <ydary_> #topic conferences and workshops
15:47:54 <ydary_> bkp: can you update?
15:48:01 <bkp> Yup
15:48:19 <bkp> FOSDEM is a go. Booth schedules and talks are here at http://etherpad.ovirt.org/p/ovirt-fosdem-15
15:48:39 <bkp> Social media is mostly scheduled for talks before and during the show.
15:48:52 <bkp> After taking a quick poll, the FOSDEM oVirt social meetup will be Sat., Jan. 31, at 2030 in the Au Bon Vieux Temps,
15:48:55 <bkp> Impasse Saint-Nicolas 4, 1000 Bruxelles. All oVirt community members are invited for excellent beer and socializing! https://plus.google.com/103481186631922352759/about?gl=us&hl=en
15:48:59 <doron> bkp: we may need some volunteers for fosdem. will update later this week.
15:49:16 <bkp> doron: For?Devroom or booth?
15:49:27 <doron> bkp: dev room.
15:49:33 <bkp> doron: Noted
15:49:37 <doron> mostly video guys,
15:49:46 <doron> TBD.
15:49:55 <bkp> Okay.
15:50:03 <bkp> In other conference news...
15:50:31 <bkp> The half-day workshop for FOSSAsia in Singapore is getting planned. The Korea user group has responded with interest now, so we could be getting a good run of speakers
15:50:33 <ydary_> #info conferences and workshops FOSDEM is a go. Booth schedules and talks are here at http://etherpad.ovirt.org/p/ovirt-fosdem-15
15:50:33 <ydary_> #info conferences and workshops After taking a quick poll, the FOSDEM social meetup will be Sat., Jan. 31, at 2030 in the Au Bon Vieux Temps,
15:50:33 <ydary_> Impasse Saint-Nicolas 4, 1000 Bruxelles. All oVirt community members are invited for excellent beer and socializing! https://plus.google.com/103481186631922352759/about?gl=us&hl=en
15:50:44 <bkp> Reminder: amureini will be giving a talk at DevConfCZ in Feb, after FOSDEM
15:51:11 <bkp> oVirt will have a very strong presense at SCALE 13X in LA this year.
15:51:27 <bkp> sbonazzo and tirsboschi_ may be at 11th Intl. Conf. on Open Source Systems http://www.oss2015.org
15:51:39 <bkp> Finally, as a general reminder: if you *ever* need slides for an oVirt presentation, there are many to choose from here: http://www.ovirt.org/OVirt_Slide_Decks They are all under CC license.
15:51:58 <bkp> That's all from me on conferences, ydary_
15:52:08 <ydary_> #info conferences and workshops The half-day workshop for FOSSAsia in Singapore is getting planned. The Korea user group has responded with interest now.
15:52:08 <ydary_> #info conferences and workshops amureini will be giving a talk at DevConfCZ in Feb, after FOSDEM
15:52:08 <ydary_> #info conferences and workshops oVCirt will have a very strong presense at SCALE 13X in LA this year.
15:52:08 <ydary_> #info conferences and workshops sbonazzo and tirsboschi_ may be at 11th Intl. Conf. on Open Source Systems http://www.oss2015.org
15:52:09 <ydary_> #info conferences and workshops As a general reminder: if you *ever* need slides for an oVirt presentation, there are many to choose from here: http://www.ovirt.org/OVirt_Slide_Decks They are all under CC license.
15:52:17 <ydary_> bkp: thanks
15:52:32 <ydary_> moving on to other topics
15:52:36 <ydary_> #topic other topics
15:52:42 <ydary_> Does anyone want to raise an issue? discuss something?
15:52:44 <bkp> I got some things...
15:52:56 <bkp> mskrivanek and tjelinek have approached me to start the process for launching moVirt as an incubator project within oVirt. This will be a mobile app that will enable users to manage oVirt on the go.
15:53:08 <bkp> This will likely supercede the Nomad project, which has not moved forward in years. We may need to retire the Nomad incubator.
15:53:18 <bkp> I am looking into setting up an oVirt account in the Google Play store now, as well as checking trademarks, if any, for moVirt.
15:53:26 <bkp> Look for official announcements and votes, based on our incubator governance policy, for moVirt soon.
15:53:44 <bkp> I will be meeting with designers at FOSDEM to discuss the revamp of ovirt.org for 2015. Finally, there shall be a schedule!!!
15:54:26 <bkp> And finally from me, in 2015, there will be a stronger focus on what it takes to get new users to oVirt to the final production stage. I will be holding meetings with other FOSS project community leads to build a map for this process.
15:54:55 <doron> cool
15:55:27 <ydary_> bkp: anything else?
15:55:30 <eedri> bkp, what about focus to attract new developers also ? :)
15:55:43 <bkp> ydary_: Not from me.
15:56:10 <sbonazzo> eedri: ++
15:56:10 <bkp> eedri: That will be part of it, but out broader strategy for oVirt has been, bring more users, devs should follow
15:56:23 <ydary_> #info mskrivanek and tjelinek have approached me to start the process for launching moVirt as an incubator project within oVirt. This will be a mobile app that will enable users to manage oVirt on the go. This will likely supercede the Nomad project, which has not moved forward in years. We may need to retire the Nomad incubator.
15:56:53 <bkp> eedri: But some of this will be about creating a dev "pipeline" into the oVirt community, too.
15:56:58 <ydary_> #action bkp to looking into setting up an oVirt account in the Google Play store now, as well as checking trademarks, if any, for moVirt.
15:57:48 <ydary_> #info bkp will have  meeting with designers at FOSDEM to discuss the revamp of ovirt.org for 2015.
15:58:18 <ydary_> #info bkp updates that in 2015, there will be a stronger focus on what it takes to get new users to oVirt to the final production stage. I will be holding meetings with other FOSS project community leads to build a map for this process.
15:58:47 <ydary_> #info bkp updates that in 2015, there will be a stronger focus on what it takes to get new users to oVirt to the final production stage. he will be holding meetings with other FOSS project community leads to build a map for this process.
15:59:09 <ydary_> Does anyone want to raise an issue? discuss something?
15:59:27 <ydary_> 3...
15:59:35 <ydary_> 2...
15:59:45 <ydary_> 1...
16:00:13 <ydary_> thanks to everyone for joining, talk to you next week!
16:00:14 <ydary_> #endmeeting