13:12:53 <dcaro> #startmeeting
13:12:53 <ovirtbot> Meeting started Mon Oct 20 13:12:53 2014 UTC.  The chair is dcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:12:53 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:13:10 <dcaro> #chair eedri obasan bkorren bkp YamakasY pdangur
13:13:10 <ovirtbot> Current chairs: YamakasY bkorren bkp dcaro eedri obasan pdangur
13:13:26 <dcaro> #topic Hosting
13:13:31 * YamakasY has a chair! great, I hate standing
13:14:33 <dcaro> #info PHX lab has been working with fc20, fc21 and el6 slaves for a week now, looking good
13:14:46 <dcaro> #info created base el7 and fc19 templates
13:15:02 <dcaro> #action create jenkins slave templates and vms for el7 and fc19
13:15:26 <dcaro> right now they have some issues with puppet and the packages they install, have to look into it
13:15:46 <dcaro> hopefully this week we can stop using rackspace
13:16:09 <dcaro> (only fc19 is still used from there)
13:16:22 <bkorren> dcaro, awesome
13:16:30 <YamakasY> is rackspace bad ?
13:16:38 <dcaro> is more money :)
13:16:56 <YamakasY> yeah you better can buy beer for a GA party with it :)
13:17:30 <dcaro> We have been having issues with the wiki again this week
13:17:53 <YamakasY> I think the wiki needs some cleanup
13:17:56 <dcaro> for some reason mysql stops working and there's no useful logs
13:18:08 <YamakasY> dcaro: which version ?
13:18:18 <dcaro> YamakasY: mysql?
13:18:22 <YamakasY> yap
13:18:36 <YamakasY> running on Ubuntu ??? ;)
13:18:51 * dcaro looking
13:19:21 * YamakasY eyes
13:19:21 <bkorren> dcaro, is that running on OpenShift?
13:19:30 <dcaro> bkorren: yep
13:19:38 <dcaro> we wanted to migrate to phx lab once it's stable
13:19:49 <dcaro> maybe we can push it a bit
13:19:50 <bkorren> dcaro, so that's the MySQL cartridge?
13:19:58 <dcaro> bkorren: yep
13:20:16 <YamakasY> mhh, why is that so complex ? just some vm or dedi would do the job
13:20:20 <dcaro> YamakasY: mysql 5.1
13:20:35 <bkorren> dcaro, hmm... they are supposed to take care of it for us no?
13:20:35 <dcaro> dedi?
13:21:58 <dcaro> bkorren: yes, but as far as I know there's no SLA or anything, we are also running low on space (due to having one big innodb file, requires redumping the db to fix)
13:22:30 <bkorren> dcaro, oh,, yeah... that is trouble....
13:22:41 <dcaro> bkorren: s migrating to a vm on phx we can fix both easily
13:23:36 <bkorren> dcaro, yeah but I kinda like to have them doing updates/firewallig/etc. for us....
13:24:48 <bkorren> dcaro, which wiki is it?
13:25:29 <dcaro> bkorren: you mean the wiki engine?
13:25:35 <bkorren> dcaro, yeah
13:25:54 <dcaro> bkorren: mediawiki I think (php), let me check
13:26:03 <dcaro> bkorren: yep
13:27:10 <bkorren> dcaro, scary... I'd really not like to run that on my own... too many bugs to worry about... but I might be in minority opinion about this
13:28:20 <YamakasY> dcaro: that is kinda old, can you upgrade ?
13:28:24 <dcaro> bkorren: I've administered a mediawiki before, did not have too many problems with it (did not do any fancy things either), misc is the one doing the maintenance for this one though, he know better
13:28:28 <YamakasY> dcaro: dedicated box
13:29:07 <dcaro> YamakasY: what do you mean dedicated box? You mean using a bare metal to host it?
13:29:22 <YamakasY> dcaro: and put all vm's and stuff on it
13:29:30 <YamakasY> using esxi ?
13:29:32 <YamakasY> :D
13:30:03 <dcaro> YamakasY: I'm not sure what you are talking about xd, can you elaborate?
13:30:20 <YamakasY> dcaro: it;t now a VM @ rackspace ?
13:30:24 <YamakasY> or dedi ?
13:30:37 <bkorren> dcaro, maybe we can give it some love? create a new grear with mysql 5.5, upload the DB and push the code up?
13:30:42 <dcaro> YamakasY: right now it's a container (or whatever they use underneath) at openshift
13:31:43 <YamakasY> dcaro: ok, so why not host it all on a ovirt all in one dedi ?
13:31:46 <dcaro> bkorren: I don't have access to the admin panel, but afaik, misc wanted to go away from openshift
13:32:22 <dcaro> YamakasY: we were planning on moving it to phoenix lab, that is an vm on an ovirt instance in a set of 8 dedicated servers
13:32:32 <bkorren> dcaro, I'm really afraid of the possibility that a php bug in the wiki will allow someone to gain access to the phx CI machines
13:32:35 <dcaro> (actually 10 including the storage)
13:33:11 <bkorren> dcaro, I think at the very least it should be in some kind of a dedicated DMZ
13:33:34 * eedri here
13:33:42 <YamakasY> dcaro: hosted @ rhel ?
13:33:48 <dcaro> bkorren: we are still talking with the network team in phx to get some internal network and such, we can try to get that in too
13:34:01 <YamakasY> eedri: did you bring the cookies ? tea is kinda cold tho
13:34:29 <dcaro> YamakasY: they run CentoOS and Fedora, but yes, it's infrastructure in redhat datacenter
13:34:46 <YamakasY> dcaro: ah ok, I might have some dedi's left maybe
13:38:01 <bkorren> dcaro, are we actually paying for OpenShift, or do we get it for free becasue RedHat?
13:38:19 <dcaro> bkorren: I'm not sure, maybe bkp knows?
13:38:43 <YamakasY> I thought it was free...
13:38:54 <YamakasY> I understood once from bkp
13:38:56 <bkp> dcaro bkorren Not sure either, but I seriously doubt we are paying anything.
13:38:59 <bkorren> YamakasY, it is up to 3 small gears
13:39:14 <YamakasY> bkorren: ?
13:39:29 <dcaro> bkorren: I don't think we have 'enterprise' gears if that's what you mean
13:39:39 <bkp> bkorren: Yeah, that's the free account, but oVirt's infra is donated by OpenShift
13:39:45 <bkorren> YamakasY, gear is a VM in openshify terms
13:39:58 * YamakasY wonder if CentOS 7 is really "stable" at the moment
13:40:06 <YamakasY> bkorren: aha!
13:41:27 <bkorren> dcaro, bkp seems to me like it should be enough for a wiki, maybe we can add som CDN service in front of it to improve uptime/performance
13:42:09 <bkp> We just had the gear updated to large by the OpenShift folks two weeks ago
13:42:21 <dcaro> bkorren: we still have the disk space issue and the mysql service down, that is not solved by CDN
13:43:18 <bkorren> dcaro, if its a mostly static wiki, a caching CDN can help, I'm trying to remember the name of the free one...
13:43:26 <ybronhei> fabiand: doron_afk: what flag do you put for node\rhevh bugzilla?
13:43:45 <dcaro> bkorren: speed is not the issue right now
13:44:15 <dcaro> bkorren: cloudflare maybe?
13:44:21 <bkorren> yeah :)
13:45:27 <Yossarianuk> Hi -  are there ubuntu packages for the latest stable Ovirt?
13:46:17 <fabiand> ybronhei, got a new one for us? :)
13:46:43 <dcaro> #action: look into getting cloudflare or any other free CDN for ovirt.org
13:47:22 <bkorren> dcaro, well, I like OpenShift, but maybe my liking is unjustified in this case, do we have some record of what problems we had and what was tried to solve them?
13:48:20 <dcaro> bkorren: it should be aroung the mailing lists for sure, but the current issues are mysql getting stopped without notice and disk space
13:50:42 <dcaro> bkorren: the way to solve the disk space issue is regenerating the inode file, hopefully spliting it on a per-table basis so it's easier to do in the future
13:50:46 <bkorren> dcaro, too bad misc isn't here, I'd really like to hear his say about this, but it seems to me that we can at lease try to rebuild the DB, and mayb some tuning
13:51:05 <dcaro> bkorren: the mysql issue has no known solution yet, we don't even know the cause
13:52:01 <bkorren> dcaro, well, why don't we add a ticket to look into it, and maybe another one to upgrade to 5.5
13:52:02 <dcaro> bkorren: you can send an email to infra
13:52:16 <dcaro> bkorren: so we can discuss it
13:52:29 <bkorren> dcaro, ok. will do.
13:54:26 <SvenKieske> yamakasy: what's your problem with el7?
13:54:49 <YamakasY> SvenKieske: as host ? it cannot find a disk to boot from
13:54:54 <eedri> YamakasY, there was a cake but it's finished
13:55:07 <YamakasY> eedri: it's in 'space' ?
13:55:35 <dcaro> We are almost out of time, any other issues?
13:55:35 <YamakasY> SvenKieske: you use el7 hosts ?
13:55:40 <SvenKieske> yamakasy: I guess you mean a host in ovirt to start vms? well maybe a little bleeding edge, it works fine as a desktop though
13:55:59 <SvenKieske> yamakasy: I'm still on el 6.5
13:56:08 <YamakasY> SvenKieske: yes, I have a vdsm host with el7
13:56:17 <dcaro> SvenKieske: YamakasY eedri we are still in the middle f a meeting, can that wait 5 min?
13:56:21 <SvenKieske> yamakasy: did you open a bz?
13:56:23 <YamakasY> dcaro: yes
13:56:29 <SvenKieske> dcaro, oh sorry, of course
13:56:32 <YamakasY> dcaro: we are at the end ;)
13:56:33 <YamakasY> :P
13:56:51 <YamakasY> but guys about the wiki, can we clean it up ?
13:57:05 <YamakasY> there are lots of references not really wrong but incomplete
13:57:33 <dcaro> YamakasY: we agreed to start a discussion on the mailing list to discuss if we can keep it on openshift or it¡s better to move it to our hosting
13:57:45 <dcaro> YamakasY: you mean about the contents?
13:58:35 <YamakasY> dcaro: yes let's say you even google for "ovirt install vdsm host" you mostly, and also using the index, come on a page where it says... oh yeah you can install it, or rpm... not the "steps"
13:58:40 <YamakasY> it's with more
13:59:04 <YamakasY> most pages are "introduction" which need more links to the actualy howot's
13:59:06 <dcaro> YamakasY: that might be more fit in the global ovirt meeting or the users list, bkp?
14:00:00 <YamakasY> userslist is not ideal for it
14:00:09 <YamakasY> better meeting an let some people do it
14:00:42 <bkp> YamakasY: This *is* something I am working on, pulling documentation together and improving it.
14:02:43 <YamakasY> bkp: kewl!
14:02:56 <dcaro> okok, we are out of time
14:03:12 <dcaro> anyone wants to rise any other issue before closing?
14:03:33 <YamakasY> dcaro: yes, next time bring cookies!
14:03:35 <bkorren> dcaro, no me
14:03:47 <dcaro> YamakasY: xd
14:04:20 <dcaro> closing in 3
14:04:26 <dcaro> 2
14:04:32 <dcaro> 1
14:04:35 <dcaro> #endmeeting