14:04:43 <doron> #startmeeting oVirt Weekly Sync
14:04:43 <ovirtbot> Meeting started Wed Oct  1 14:04:43 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:43 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:44 <doron> #topic Agenda and roll Call
14:04:46 <doron> #info infra update
14:04:47 <doron> #info 3.4.z updates
14:04:49 <doron> #info 3.5 status
14:04:50 <doron> #info conferences and workshops
14:04:52 <doron> #info other topics
14:04:53 <doron> hi amureini
14:04:55 <doron> long time ;)
14:05:19 <doron> let's start with infra
14:05:25 <doron> #topic infra update
14:05:32 <doron> dcaro: here?
14:05:44 <dcaro> doron: yep
14:05:53 <doron> dcaro: how's infra doing?
14:06:12 <dcaro> we will start creating all the slaves that will replace the rackspace ones in phx
14:06:54 <dcaro> we also started creating the vm and the disk that will hold the repositories (still not in place) to replace or at least leverage linode01
14:07:04 <doron> #info infra update: soon to start creation of all the slaves that will replace the rackspace ones in phx
14:07:53 <dcaro> and, thanks to sbonazzo we got vdsm rpms built entirely on mock, and replaced the old jobs
14:07:58 <doron> #info infra update: soon to start creation of  the vm and the disk that will hold the repositories (still not in place) to replace or at least leverage linode01
14:08:18 * lvernia is here.
14:08:23 <doron> #info thanks to sbonazzo we have vdsm rpms built entirely on mock, and replaced the old jobs
14:08:30 <doron> dcaro: thanks!
14:08:44 <doron> #topic 3.4.z updates
14:08:51 <doron> sbonazzo: how are we doing with 3.4.z?
14:09:02 <sbonazzo> hi doron, 3.4.4 has been released
14:09:14 <doron> sbonazzo: last week?
14:09:19 <sbonazzo> this should have been the last 3.4.z release, yes last week
14:09:50 <doron> #info 3.4.4 released last week. No additional 3.4.z expected.
14:09:53 <sbonazzo> but there have been questions about the optoin of releasing a newer ovirt-engine and vdsm
14:09:58 <sbonazzo> with additional fixes
14:10:37 <sbonazzo> maybe danken, oved__ may follow up on this
14:10:42 <doron> sbonazzo: if we'll have 3.5 in the next week or so we may not have the capacity for another 3.4.z
14:11:10 <doron> danken: oved__ is there something specific which requires 3.4.5 while 3.5.09 GAs?
14:12:35 <sbonazzo> doron: if I remember correctly it's memoryleak related for vdsm
14:12:43 <sbonazzo> doron: and ppc for engine
14:13:15 <doron> sbonazzo: let's take it offline in the list.
14:13:20 <sbonazzo> doron: ok
14:13:33 <doron> #topic 3.5 status
14:13:50 <doron> sbonazzo: where are we now?
14:14:20 <sbonazzo> doron: this morning we had 2 more blockers, but looking at bugzilla right now seems they've been fixed
14:14:33 <sbonazzo> doron: i think that if nothing shows up in the night, we can go RC4 tomorrow
14:14:44 <doron> sbonazzo: very well.
14:15:13 <oved__> doron, sorry for the late response. if there will be additional 3.4 release then we'll push something.
14:15:19 <oved__> doron, wouldn't build only for that.
14:15:21 <sbonazzo> doron: and GA on monady or tuesday if no other blockers will show up
14:15:23 <doron> #info 3.5.0 status: currently no blockers. RC4 expected tomorrow.
14:15:46 <doron> #info 3.5.0 status: If no blockers in RC4 GA should be expected on Monday.
14:16:13 <doron> oved__: no plans for additional 3.4.z if we ga 3.5.0 next week.
14:16:33 <oved__> doron, okay. I'll update the bug accordingly.
14:16:34 <doron> oved__: unless there's something which requires a special 3.4.z build
14:16:40 <oved__> doron, nope.
14:16:50 <doron> ok
14:17:11 <doron> sbonazzo: how many bugs do we have on 3,5.0?
14:17:53 <sbonazzo> doron: checking
14:18:31 <sbonazzo> doron: http://red.ht/1q7SqNL shows 54 bugs
14:19:02 <sbonazzo> doron: 9 on node, 14 on docs
14:19:13 <doron> sbonazzo: 13 bugs in post? basically we should have it all move to 3.5.1 unless blockers
14:19:25 <sbonazzo> doron: I agree
14:19:49 <sbonazzo> doron: the only one left on integration is the release tracker
14:19:53 <doron> sbonazzo: danken do we have 3.5.1 branch?
14:20:15 <sbonazzo> doron: no, we can branch 3.5.0 from 3.5 and use it for last step
14:20:24 <sbonazzo> and continue 3.5.1 on 3.5 branch
14:20:54 <doron> sbonazzo: very well. danken should probably create one as well.
14:21:06 <sbonazzo> doron: ok I'll create it for engine
14:21:31 <doron> #action sbonazzo danken create 3.5.1 branch
14:22:11 <sp34t> evilissimo ping
14:22:23 <evilissimo> sp34t: pong
14:22:34 <doron> #action lvernia amureini doron mskrivanek awels fabiand sahina oved__ push all current 3.5.0 bugz to 3.5.1 or later
14:22:46 <doron> unless blockers...
14:22:49 <sp34t> evillissimo: still have an unnoticed gerrit change request http://gerrit.ovirt.org/#/c/33369/
14:22:52 <sbonazzo> doron: 3.5.0 stabilization branch created for engine, will push version bump to 3.5.1 on 3.5
14:23:02 <doron> k
14:23:03 <sp34t> I noticed I wasn't subscribed to ovirt-patches, hence it never got there
14:23:09 <lvernia> Ack.
14:23:17 <doron> moving on
14:23:19 <doron> #topic conferences and workshops
14:23:23 <doron> bkp: here?
14:23:28 <bkp> sp34t: Can you hang on a bit? In a meeting now.
14:23:34 * bkp is here
14:23:40 <sp33t> bkp: sure
14:23:44 <doron> bkp: welcome back with the amazing admin guide!
14:24:03 <evilissimo> sp33t: I have seen it
14:24:07 <bkp> Thanks! ECS in Brisbane gets a big thanks from me, too!
14:24:23 <bkp> Lot's of event news...
14:24:30 <sp33t> evilissimo: looks acceptible to you?
14:24:33 <bkp> We have gotten all the passes we are going to get for the KVM Forum. Double-check with bazulay, but from this point forward, registration fees will need to be paid.
14:24:35 <doron> #info kudus to ECS in Brisbane for the admin guide!
14:24:53 <evilissimo> sp33t: Actually not, I did not want to jump immediately on it and give it a -2 :S
14:24:56 <bkp> Unless something blows up, oVirt Workshop schedule is a go. http://www.ovirt.org/KVM_Forum_Workshop_Oct_2014 We have three confirmed user/organizations to come in and detail their stories.
14:25:04 <doron> #info: kvm forum passes: from now on all should be paied for.
14:25:17 <bkp> As a reminder, if you are attending the oVirt Workshop, you need to register (it's free) for the oVirt Workshop separately at https://www.regonline.com/Register/Checkin.aspx?EventID=1625495. *Even if you are signed up for the KVM Forum.*
14:25:18 <evilissimo> sp33t: It seems to be a nice intermediate solution on the first thought, however this should be actually controlled from the engine
14:25:27 <evilissimo> sp33t: it's a workaround, not a solution
14:25:29 <sp33t> evilissimo: I agree
14:25:42 <evilissimo> sp33t: I am currently working on a solution for that
14:25:51 <bkp> Following the event-fest in Düsseldorf, I will be speaking about oVirt at All Things Open in Raleigh on Oct. 21. I am also speaking about oVirt at OpenWorldForum in Paris on Oct. 31. (Which is Halloween, so I am missing candy for you people!)
14:25:54 <doron> #info ovirt workshop (free) registration: https://www.regonline.com/Register/Checkin.aspx?EventID=1625495
14:26:09 <evilissimo> sp33t: however that'll need changes in engine front- and backend and vdsm
14:26:15 <sp33t> evilissimo: still looks like it's cross platform, and very simple
14:26:18 <bkp> alitke will be making an oVirt presentation to the Central PA Open Source event in Pennsylvania on Nov. 1.
14:26:31 <evilissimo> sp33t: well but it's a hassle for an admin
14:26:41 <bkp> LISA 14 will be from Nov. 9-14 in Seattle. CentOS is hosting a dojo on Nov. 10, which I may be attending on behalf of oVirt (they are still deciding). We will definitely have a booth presence, probably with the CentOS team, which is optimal because we can talk up oVirt on the enterprise.
14:26:46 <doron> #info following Düsseldorf events bkp will be speaking about oVirt at All Things Open in Raleigh on Oct. 21 and OpenWorldForum in Paris on Oct. 31.
14:26:57 <sp33t> evilissimo: not if the env is well managed, or if it uses templates
14:26:59 <evilissimo> sp33t: he has to log on to each machine he wants this behaviour and change it once updated
14:27:03 <doron> #info alitke will be making an oVirt presentation to the Central PA Open Source event in Pennsylvania on Nov. 1.
14:27:11 <sbonazzo> dcaro can you copy merge/review rights from 3.5 branch to 3.5.0 branch for ovirt-engine?
14:27:12 <sp33t> evilissimo: no.
14:27:13 <bkp> FOSDEM'15 is Jan 31-Feb 1. I have applied for a Main Track talk and a stand-alone booth for oVirt. Developer rooms should be announced today, and the deadline for the Main Track talks are today as well.
14:27:14 <evilissimo> sp33t: that only works for new templates
14:27:23 <doron> #info  LISA 14 will be from Nov. 9-14 in Seattle. CentOS is hosting a dojo on Nov. 10, which bkp may attend
14:27:29 <sp33t> or with puppet :-)
14:27:36 <evilissimo> sp33t: of course there can be something like puppet yeah
14:27:51 <evilissimo> sp33t: still I don't really like to have this kind of things in there :/
14:27:57 <doron> #info FOSDEM'15 is Jan 31-Feb 1 bkp applied for a Main Track talk and a stand-alone booth for oVirt. Developer rooms should be announced today, and the deadline for the Main Track talks are today as well.
14:28:06 <doron> bkp: cool :)
14:28:14 <evilissimo> sp33t: and if, it needs the modification in the default.ini as well
14:28:23 <bkp> doron: That's it for events.
14:28:25 <sp33t> which I added
14:28:28 <doron> bkp: thanks
14:28:32 <doron> let's move on
14:28:35 <evilissimo> sp33t: nope, only default.conf
14:28:39 <doron> #topic other topics
14:28:51 <doron> Does anyone want to raise an issue? discuss something?
14:28:56 <bkp> A few things...
14:29:03 <doron> bkp: shoot
14:29:05 <bkp> As doron mentioned, there's a new Administrator's Guide on the site (http://www.ovirt.org/OVirt_Administration_Guide). It is a bootstrapped revision of the RHEV 3.4 Admin Guide, so we need two things: a complete check on converting rhev/rhevm mentions to oVirt (I got most, but not all) and an update as soon as possible to oVirt 3.5.
14:29:25 <bkp> I can work on the screenshots for 3.5, but if people can go in and ID/fix the rhev parts and start sending me features new to 3.5, we can start working on it.
14:29:31 <doron> #info There's a new Administrator's Guide on the site (http://www.ovirt.org/OVirt_Administration_Guide). It is a bootstrapped revision of the RHEV 3.4 Admin Guide, so we need two things: a complete check on converting rhev/rhevm mentions to oVirt (I got most, but not all) and an update as soon as possible to oVirt 3.5.
14:29:33 <dcaro> sbonazzo: done
14:29:49 <bkp> It's too long for here, but expect a blog highlighting some postive directions for documenation that may be coming soon.
14:29:50 <sbonazzo> dcaro thanks
14:29:53 <doron> #info bkp can work on the screenshots for 3.5, but if people can go in and ID/fix the rhev parts and start sending me features new to 3.5, we can start working on it.
14:30:07 <doron> bkp: anything else?
14:30:16 <bkp> Finally, in the middle of the all that travel at the end of October, I am going to visit the Ra'anana office (Oct. 26-30) for a work week of touching base/catching up. Y'all have been warned.
14:30:26 <bkp> That's it from me!
14:31:01 <doron> #info bkp expected in the Ra'anana office (Oct. 26-30) for a work week of touching base/catching up.
14:31:04 <doron> yei!
14:31:08 <doron> bkp: thanks
14:31:14 <doron> anythin / anyone else?
14:31:26 <doron> Going once?
14:32:04 <doron> Going twice...
14:32:10 <karimb> is there any plan to make an appliance for the engine
14:32:12 <karimb> ?
14:32:43 <doron> Gone. Thanks all for joining. Drive safely and be good!
14:32:45 <doron> #endmeeting