13:00:05 <fabiand> #startmeeting oVirt Node Weekly Meeting
13:00:05 <ovirtbot> Meeting started Tue Sep 23 13:00:05 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:05 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:15 <fabiand> #chairs dougsland rbarry
13:00:19 <fabiand> #topic Agemda
13:00:21 <fabiand> #undo
13:00:21 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0xb5b363cc>
13:00:24 <fabiand> #topic Agenda
13:00:36 <fabiand> #info Action Item Review
13:00:40 <fabiand> #info oVirt 3.5
13:00:48 <fabiand> #info Jenkins
13:00:55 <fabiand> #info Next-Gen Node
13:00:59 <fabiand> #info Other Items
13:04:58 <fabiand> Okay, seems like there ain't much about Node today ...
13:05:21 * rbarry here
13:06:33 * bkp here
13:06:42 <fabiand> morning rbarry and bkp
13:07:57 <rbarry> Morning fabiand :)
13:08:21 <fabiand> Okay
13:08:25 <fabiand> let's get started
13:08:30 <fabiand> Ui think there ain't to much ..
13:08:40 <fabiand> #link http://lists.ovirt.org/pipermail/devel/2014-September/008779.html
13:08:46 <fabiand> #undo
13:08:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Link object at 0xb5b36e6c>
13:08:51 <fabiand> #topic Action Item Review
13:08:52 <fabiand> #link http://lists.ovirt.org/pipermail/devel/2014-September/008779.html
13:09:03 <fabiand> #info fabiand to generate rpms for 3.5rc2 iso
13:09:20 <fabiand> I didn't do that, but I'll respin Node anyway. New rpms will get published ..
13:09:27 <fabiand> #info fabiand to ask dcaro to publish iso
13:09:34 <fabiand> The iso got published. Thanks dcaro
13:09:58 <fabiand> #info rbarry to create a wiki page summarizing all the compoents which need a module, also specifying if it can be done with puppet or needs something else
13:10:06 <fabiand> rbarry, not sure - did you create a page?
13:10:25 <rbarry> I got busy with the ovirt test day and other issues last week -- I'll get this up today
13:10:31 <fabiand> Ack
13:10:41 <fabiand> #info Page is not yet up there
13:11:00 <fabiand> Going fwd
13:11:05 <fabiand> #topic oVirt 3.5
13:11:20 <fabiand> Looking not to bad on el6 and el7
13:11:30 <fabiand> some last minute bugs on el7 found
13:12:41 <fabiand> As there is no official release yet, I still need to wait when the iso can be spun.
13:13:07 <fabiand> #info fabiand to build Node once 3.5 is out
13:13:18 <fabiand> going fwd
13:13:25 <fabiand> oh
13:13:26 <fabiand> wait
13:13:42 <fabiand> #info Appliance build issues which were - sadly - only discovered on the test day are finally solved
13:13:54 <dougsland> fabiand, here, sorry
13:14:05 <fabiand> A side effect of using a to new netinst Fedora iso, with an older Fedora version (21 vs 19)
13:14:07 <fabiand> morning dougsland
13:14:11 <fabiand> :)
13:14:18 <dougsland> morning :)
13:14:25 <fabiand> #info Appliance to be built once 3.5 is done
13:14:43 <fabiand> #action fabiand to build ovirt appliance once 3.5 is released
13:14:51 <fabiand> going fwd
13:14:59 <fabiand> #topic Jenkins
13:15:15 <fabiand> I think we can skip this, as we moved the bigger changes to post-3.5
13:15:29 <fabiand> #info Changes are moved post-3.5
13:15:35 <fabiand> #topic Next-Gen Node
13:16:17 <fabiand> rbarry, had any chance to play with puppet?
13:17:15 <rbarry> Some...
13:17:47 <rbarry> It's nice to see that we don't *have* to use YAML for Hiera. There are JSON providers, which would make sharing facts with ovirt easier
13:18:00 <fabiand> indeed
13:18:11 <rbarry> I spent a little time redoing the decorator in ovirt.node.config.defaults to look at a JSON file instead, with hiera pointed there
13:18:55 <fabiand> Interesting
13:18:56 <rbarry> There's not a nice way to use arrays of configured manifests, but "include some/path/*" in manifests work, so we could potentially symlink them or copy them in from /usr/share/ovirt/... to /etc/puppet/manifests
13:19:23 <fabiand> #info rbarry had a chance to play with hiera/puppet
13:19:38 <rbarry> Putting together a "proper" proof of concept and pushing it up to gerrit is also on my to-do list this week
13:19:46 <fabiand> cool!
13:19:49 <fabiand> and yeah ...
13:20:09 <fabiand> I think - following some other OS movements - we should have some sane default manifests in /usr/lib or share
13:20:18 <fabiand> and have the actual ones, the specific ones in /etc somewhere
13:20:34 <fabiand> and using includes to bundle them seems a good idea ..
13:21:26 <fabiand> #info Pushing out a POC is on his list
13:21:31 <fabiand> Nice progress rbarry
13:21:53 <fabiand> anything else, rbarry ?
13:22:29 <ewoud> rbarry: if you mean import some/path/*, that is gone in puppet 3.6 or 3.7 IIRC or at the very least will be gone in 4.0
13:24:00 <fabiand> ewoud, thanks for that hint ..
13:24:12 <fabiand> #info ewoud notes that imports might be gone at some point.
13:24:15 <rbarry> Thanks, ewoud
13:24:17 <fabiand> A small update from my side
13:24:40 <fabiand> #info fabiand used stock F19 iso to deploy rootfs image into the necessary lvm layout
13:24:54 <fabiand> But it had some glitches here and there ..
13:25:11 <rbarry> I just looked at the docs. Their deprecation warning is phrased interestingly. It looks like "parser=future" may be able to do the same thing, and won't be deprecated, but I'll test
13:25:32 <fabiand> I used a tarball for deployment and snapshot creation after deployment did not work ..
13:25:37 <fabiand> rbarry, ack
13:27:20 <fabiand> dougsland, we also spoke about a change for Next-Gen Node ..
13:27:30 <dougsland> yes
13:27:36 <fabiand> Restructuring the ovirt-node package a bit to separate some parts ..
13:28:11 <fabiand> I'll just put it no the list so we can track it on the long run
13:28:47 <dougsland> right
13:29:05 <vidalinux> ovirt 3.5rc2 got issues VMs freezes and pause
13:29:24 <fabiand> #info dougsland to look into separating some node parts into subpackages but a more differentiated usage
13:29:49 <vidalinux> try updating to latest one on repo but got the same issues
13:30:04 <fabiand> vidalinux, are you using centos or fedora as a host?
13:30:12 <fabiand> okay, but I think that is it on next gen ..
13:30:14 <fabiand> for now
13:30:35 <vidalinux> fabiand, fedora19
13:31:11 <fabiand> going fwd
13:31:15 <fabiand> #tpoic Other Items
13:31:22 <fabiand> anything else to discuss, dougsland rbarry ?
13:31:28 <vidalinux> fabiand, i was using 3.4 without issues, update to 3.5 then freeze problems
13:31:30 <rbarry> Nothing from me
13:31:31 <fabiand> vidalinux, mh, can't tell about F19 ..
13:31:32 <dougsland> not from my side
13:31:37 <fabiand> Cool
13:31:50 <bkp> Nothing here.
13:32:17 <fabiand> Cool
13:32:19 <fabiand> Going once
13:32:58 <fabiand> Dos
13:33:12 <fabiand> Drittens
13:33:15 <fabiand> Thanks!
13:33:16 <fabiand> #endmeeting