14:39:36 <dcaro> #startmeeting
14:39:36 <ovirtbot> Meeting started Mon Sep 22 14:39:36 2014 UTC. The chair is dcaro. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:39:36 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:39:51 <dcaro> #chair obasan misc bkorren pdangur
14:39:51 <ovirtbot> Current chairs: bkorren dcaro misc obasan pdangur
14:40:12 <dcaro> #topic Hosting
14:40:55 <dcaro> Ok, the slaves have been running there for a couple weeks without any unintended outages (they went down doing the HA tests, but that's fixed)
14:41:11 <dcaro> So I think we can start using and adding vms and others
14:41:29 <dcaro> #info The reverse DNS is ready on the RedHat side
14:41:48 <dcaro> #action make sure reverse DNS it works properly on foreman-proxy
14:42:10 <dcaro> I think that we can start migrating the wiki safely to the PHX lab
14:42:26 <dcaro> anyone against?
14:42:43 <dcaro> (or with any other opinion?)
14:42:58 <bkorren> dcaro, not me :P
14:43:21 <dcaro> okok
14:43:40 <dcaro> #action dcaro misc Create vm and setup new ovirt wiki on PHX lab
14:44:54 <dcaro> The foreman automatic installation and vm templates are not yet ready, anyone wants to help there?
14:45:31 <bkorren> sure
14:45:53 <dcaro> bkorren: thanks! :)
14:45:54 <bkorren> if I knew what you mean by that :)
14:46:14 <dcaro> #action Help finishing up the foreman PXE installation and vm templates on PHX lab
14:46:43 <bkorren> n/p we'll PM later and you'll me what to do k?
14:46:49 <dcaro> bkorren: okok
14:46:56 <dcaro> that brings us to another topic
14:47:12 <dcaro> #topic New members
14:47:37 <dcaro> Last week we introduced two new candidates to infra members, and the poll was approved
14:47:49 <dcaro> so I can officialy proclaim that
14:48:07 <dcaro> #info bkorren and pdangur are now infra members (learning)
14:49:03 <dcaro> Congratulations! bkorren pdangur
14:49:10 <bkorren> thanks :)
14:49:43 <pdangur> thanks!
14:50:01 <obasan> welcome!!!!
14:50:52 <dcaro> ok, moving topic
14:50:56 <dcaro> #topic Jenkins
14:51:22 <dcaro> I've been trying to get vdsm to work on docker to see if it was possible to run functional tests there... nad succeded... more or less
14:51:37 <dcaro> the problem being that it's using the host kernel and creting the interfaces on the host xd
14:52:15 <dcaro> not usre if that's possible to get sorted out :/
14:52:34 <bkorren> yeah, I'm not sure vdsm is a good candidate for running in docker, engine might be better at it
14:52:35 <dcaro> #info starting to test encapsulation (docker) of the vdsm functional tests
14:52:42 <dcaro> yep
14:53:01 <dcaro> that's what I wanted to try next
14:53:14 <bkorren> mybe for certain simple tests like NFS storage
14:53:37 <dcaro> but vdsm is more problematic right now, because it's functional tests block a whole host and are suitable to bring it down
14:54:26 <bkorren> what do we stand to gain from using docker here?
14:54:48 <Zordrak> I wondered that..
14:55:44 <Zordrak> (i.e. would FreeIPA or Spacewalk run or want to be run in Docker?)
14:56:26 <bkorren> Zordrak, those probably would, but oVirt is more of a bare-metal kind of thing
14:58:09 <bkorren> dcaro, perhaps we can try to boot physical machines from NFS images stored in containers, that would allow us to roll back changes using docker layering mechanisms, while still running bare-metal stuff
14:58:16 <dcaro> the intended gain is to be ale to setup test envs
14:58:27 <bkorren> but may be too complex to maintain
15:01:26 <dcaro> the idea is to be able to leverage full hosts, maybe we should just wait for the new tests that use vms instead of containers/chroots
15:02:48 <dcaro> another problem I see is that right now we are using mock to build rpms, but that does not work for other packaging systems, so instead of using 2+ tools for packaging using docker would leverage the space usage and coplexity
15:03:18 <dcaro> but it's not a priority right now though
15:03:43 <dcaro> something that we might want first (and the we can start doing right away) is pipelines on jenkins jobs
15:04:06 <bkorren> well, I guess this is the point where I know too little about the environment to completely understand what you mean exactly
15:04:39 <dcaro> you mean about the pipelines? or the package creation?
15:05:19 <bkorren> the package creation I actually kind of understand, the other stuff not so much
15:06:33 <dcaro> on jenkins we have totally independent jobs, that for each of them, they build rpms/jars/whatever if needed
15:06:50 <bkorren> dcaro, ok
15:07:33 <dcaro> instead of doing that, building a pipeline means that you have one only job that it's triggered, then this jobs controls the test execution, hopefully creating firs the packages to test, and then passing those packages to the test jobs so they don't have to rebuild
15:07:44 <dcaro> and the artifact that they test is exactly the same
15:08:19 <bkorren> dcaro, I see, so not related to Docker at all.
15:09:26 <dcaro> nop, just jenkins
15:10:29 <bkorren> ok
15:10:35 <dcaro> okok, we are getting out of time xd
15:11:02 <dcaro> any other issue I skipped?
15:11:35 <bkorren> no that I know of, but that is to be expected :)
15:13:52 <dcaro> okok :)
15:13:56 <dcaro> closing the meeting then
15:14:00 <dcaro> #endmeeting