13:00:25 <fabiand> #startmeeting oVirt Node Weekly Meeting
13:00:25 <ovirtbot> Meeting started Tue Sep 16 13:00:25 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:25 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:30 <fabiand> #chairs dougsland rbarry
13:00:45 <fabiand> #topic Agenda
13:00:50 <fabiand> #topic Action Item Review
13:00:54 <fabiand> #info oVirt 3.5
13:00:58 <fabiand> #info Jenkins
13:01:16 <fabiand> #info Next-Gen Node
13:01:23 <fabiand> #info Other Items
13:01:49 * rbarry here
13:02:46 <dougsland> here
13:03:57 <fabiand> dougsland, rbarry hi
13:04:11 <fabiand> #topic oVirt 3.5
13:04:24 <fabiand> #info Testing and some smaller bug ficxing happend last Friday
13:04:30 <fabiand> Thanks a lot to dougsland and rbarry
13:04:41 <fabiand> #info rbarry created a new iso
13:04:45 <fabiand> (which I am currently uploading)
13:04:55 <[trip]> Anyone have USB redirection working using Remote Viewer and a Window's Client?
13:04:58 <fabiand> rbarry, do you know what packages you pulled in?
13:05:04 <fabiand> Was it already 3.5rc2?
13:05:16 <rbarry> It was RC2
13:05:31 <fabiand> cool
13:05:54 <fabiand> Then we can use your iso for the test day tomorrow
13:06:19 <fabiand> It's just pending to publish the relevant rpms.
13:06:44 <fabiand> #info ovirt-node-iso-3.5.0.ovirt35.20140912.el6.iso contains 3.5rc2 packages
13:06:51 <fabiand> #info ovirt-node rpms need to be published
13:07:13 <fabiand> rbarry, have you tried creating the ovirt-node-iso using th eovirt-3.5 branch of th every same repository?
13:07:37 <rbarry> I have not yet tried using the 3.5 branch of ovirt-node-iso, no
13:08:13 <fabiand> Okay ..
13:10:17 <fabiand> right
13:10:36 <fabiand> We've got a testday iso which is good
13:10:54 <fabiand> #action fabiand to generate rpms for 3.5rc2 iso
13:11:01 <Netbulae> :->
13:11:05 <fabiand> #action fabiand to ask dcaro to publish iso
13:11:22 <fabiand> #action fabiand to go over and give Netbulae the iso
13:11:24 <fabiand> #undo
13:11:24 <ovirtbot> Removing item from minutes: ACTION by fabiand at 13:11:22 : fabiand to go over and give Netbulae the iso
13:11:25 <fabiand> ;)
13:11:33 <fabiand> nice
13:11:55 <dougsland> :)
13:11:55 <fabiand> dougsland, rbarry just as a reminder - tomorrow is testday ..
13:12:35 <fabiand> So we should hang out here to see if someone is having issues with Node
13:12:41 <fabiand> The usual stuff for a testday ...
13:12:53 <fabiand> okay, now, back to the action item review
13:12:56 <fabiand> which i missed.
13:13:05 <fabiand> #topic Action Item Review
13:13:16 <fabiand> #link http://lists.ovirt.org/pipermail/devel/2014-September/008713.html
13:13:33 <fabiand> #info fabiand to fix appliance job during the next week
13:13:42 <fabiand> #link http://jenkins.ovirt.org/view/All/job/ovirt-appliance_master_merged/
13:13:46 <vidalinux> when 3.5 will be released ?
13:14:02 <fabiand> The build is fixed as in the rootfs is build, ubt the ova creator has currently some issues
13:14:17 <fabiand> I'm optimistic that we have an ova at the end of this meeting
13:14:20 <fabiand> so be patient ..
13:14:36 <fabiand> #info appliance rootfs is built, ova is currentl not created, but WIP
13:14:57 <fabiand> carrying on
13:15:00 <fabiand> #topic Jenkins
13:15:09 <fabiand> rbarry, we also spoke about it last week, and actually many times ..
13:15:15 <fabiand> consolidation of Jenkins jobs
13:15:23 <fabiand> But I believe we agreed to move that out after 3.5 ..
13:15:45 <fabiand> vidalinux, take a look here to get an idea of the schedule: http://www.ovirt.org/OVirt_3.5_release-management
13:16:01 <rbarry> After 3.5 is probably better. Hopefully we can also move to EL7 builders at the same time
13:16:56 <fabiand> Indeed
13:17:04 <fabiand> And consolidate into few streams as possible
13:17:27 <fabiand> rbarry, can we do anything to prepare the move?
13:17:32 <fabiand> Maybe already shut down jobs we do not need?
13:17:43 <fabiand> dougsland, also for you ..
13:17:50 <fabiand> We might want to merge jobs
13:18:01 * fabiand thinks about merging jobs which are relevant per release
13:18:09 <dougsland> make sense
13:18:17 <fabiand> i.e for 3.4 we should have a job (theoretically) combining base + vdsm plugin
13:18:34 <fabiand> for 3.5 we should have a job combinding base + vdsm plugin + he plugin ..
13:18:50 <fabiand> so just building the final image ..
13:19:43 <fabiand> carrying on ..
13:19:53 <fabiand> #topic Next-Gen Node
13:20:09 <fabiand> #info Stable job which builds the rootfs
13:20:17 <fabiand> #undo
13:20:17 <ovirtbot> Removing item from minutes: INFO by fabiand at 13:20:09 : Stable job which builds the rootfs
13:20:21 <fabiand> #info Stable job which builds the runtime layout
13:20:27 <fabiand> This includes Fedora 20 + imgbased
13:20:40 <fabiand> The runtime layout is an image which can be used inside qemu to test imgbased
13:20:41 <fabiand> #link http://www.ovirt.org/OVirt_3.5_release-management
13:20:53 <fabiand> #info Stable job to run functional tests on runtime layout image
13:21:43 <fabiand> The job is running some sanity tests (checking for denials, checking for mandatory binaries, checking that imgbase is working)
13:21:53 <fabiand> #link http://www.ovirt.org/OVirt_3.5_release-management
13:22:14 <fabiand> rbarry, you started looking into puppet for managing the local configuration ...
13:22:23 <fabiand> Could you summarize what you are thinking about?
13:23:28 <rbarry> At present, I'm thinking of ripping the guts out of ovirt.node.config.defaults and shipping small puppet manifests which match each bit (kdump, ntp, rsyslog, etc al)
13:23:53 <rbarry> Then assigning variables with hiera and pushing from there
13:24:01 <fabiand> rbarry, that sounds nice!
13:24:12 <fabiand> Especiall because if they are individual manifests then we can push the upstream ..
13:24:23 <rbarry> I looked at how packstack does it, but they're writing the templates on the fly and inserting variables, which isn't very pretty
13:24:33 <fabiand> okay ..
13:24:37 <rbarry> Well, the upside to this is that upstream puppet should already handle almost everything we need to configure
13:24:50 <fabiand> Indeed, and we can contribute the rest ..
13:25:38 <fabiand> rbarry, do you know if it's also possible to do the configuration of
13:25:42 <fabiand> - network
13:25:45 <rbarry> There also appears to be an etcd hiera provider, which could be very interesting (under the assumption that nodes will be configured similarly), but that's likely a task for a future release beyond next-gen
13:25:53 <fabiand> (with bonding, bridging...)
13:26:38 <rbarry> I haven't found a provider for that yet, but I haven't spent a lot of time looking
13:27:12 <rbarry> I suspect that using the Anaconda configuration bits for that may be better, since even if puppet does support networking, it's likely to be fairly basic (since most puppet configurations assume networking is already up)
13:27:34 <fabiand> right
13:28:08 <fabiand> rbarry, would you mind creating a page, summarizing all the configration topics (snmp, cim, ntp, network, ..) we need to address in a table
13:28:19 <fabiand> Where we can then also provide links to manifests
13:28:30 <fabiand> or note that the configuraiton should take place using anaconda ..
13:28:38 <fabiand> (or a different technology)
13:30:11 <rbarry> Sure, I can do that. I think that linking to puppet resource types/modules may be what you mean here rather than manifests
13:30:15 <rbarry> Ala https://github.com/razorsedge/puppet-snmp
13:30:45 <fabiand> Yeah, I think I was wrong about the terminology
13:30:47 <fabiand> thx
13:31:32 <fabiand> yeah
13:31:45 <fabiand> it's clases/modules/types i was thinking about ..
13:32:14 <fabiand> #info Idea to do configuration using puppet - early investigationsdone by rbarry
13:32:28 <fabiand> #info  ripping the guts out of ovirt.node.config.defaults and shipping small puppet manifests which match each bit (kdump, ntp, rsyslog, etc al),  assigning variables with hiera and pushing from there
13:32:48 <fabiand> #info etcd hiera provider is also interesting to configure many nodes at once
13:33:30 <fabiand> #action rbarry to create a wiki page summarizing all the compoents which need a module, also specifying if it can be done with puppet or needs something else
13:33:49 <fabiand> rbarry, sounds good in general
13:34:08 <fabiand> rbarry, if you start writing anything ..
13:34:14 <fabiand> then we can include it in the appliance build
13:34:31 <fabiand> also, think of adding tests right from the beginning, then we can add the testing to the check function job ..
13:35:09 <fabiand> Okay
13:35:12 <fabiand> carrying on ..
13:37:50 <fabiand> #topic Other Items
13:38:00 <fabiand> anything else you want to bring up rbarry dougsland ?
13:38:21 <dougsland> not really, let's have a great 3.5 release :)
13:38:30 <dougsland> Netbulae, right? =)
13:38:32 <Netbulae> +1
13:39:24 <vidalinux> btw 3.5 looks really great I'm testing the rc1 on one lab server
13:39:25 <vidalinux> :)
13:39:33 <winfr34k> ~_~
13:39:34 <dougsland> vidalinux, cool
13:39:47 <Netbulae> why still rc1?
13:40:00 <Netbulae> I like rc2 better :-)
13:40:04 <fabiand> rbarry, https://forge.puppetlabs.com/razorsedge/network
13:40:08 <fabiand> rbarry, https://forge.puppetlabs.com/adrien/network
13:40:17 <vidalinux> I think is rc2 don't remeber lol
13:40:21 <fabiand> great, then thanks dougsland and rbarry
13:40:29 <fabiand> Going once
13:40:48 <vidalinux> guys is posible to manage docker on ovirt ?
13:41:27 <fabiand> twice
13:42:28 <rbarry> That's why I'm looking, fabiand :) They exist, but I haven't had a chance to test if any of them test more exotic configurations, I suppose
13:42:38 <fabiand> yes yes
13:42:39 <fabiand> :)
13:42:48 <fabiand> I think we need to carefully look at them ..
13:43:12 <fabiand> Especially I'd take care to not bind us to much to fedora/rhel/centos, but also open node to debian based distors
13:43:14 <fabiand> distros
13:43:17 <fabiand> third time
13:43:19 <fabiand> #endmeeting