14:04:35 <doron> #startmeeting oVirt Weekly Sync
14:04:35 <ovirtbot> Meeting started Wed Aug  6 14:04:35 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:35 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:47 <awels> doron: here
14:04:48 <bkp> Sure!
14:04:49 <lvernia> Welcome back doron :)
14:04:50 <doron> #topic Agenda and roll Call
14:04:51 <doron> #info infra update
14:04:53 <doron> #info 3.4.z updates
14:04:53 * bkp here
14:04:54 <doron> #info 3.5 status
14:04:56 <doron> #info conferences and workshops
14:04:57 <doron> #info other topics
14:05:03 <doron> lvernia: thanks, good to be back :)
14:05:13 * danken is here
14:05:17 * sbonazzo here
14:05:18 * lvernia is here, evidently.
14:05:28 <doron> first of all a big THANK YOU to bkp for filling-in while I was away.
14:05:48 <doron> let's start with infra updates
14:05:54 <doron> #topic infra update
14:06:00 <doron> dcaro: eedri here?
14:06:21 <dcaro> doron: hey
14:06:30 <doron> dcaro: how is ovirt infra doing?
14:06:51 <dcaro> phx lab network is already configured, lacking small details, hosted engine is already running and 2 hosts already added to the setup
14:07:11 <dcaro> hopefully this week we can start creating vms and using them on jenkins
14:07:14 <doron> dcaro:  is there an eta for phx?
14:07:23 <eedri> dcaro, +1
14:07:42 <sbonazzo> dcaro++
14:08:04 <bkp> Yay, dcaro!
14:08:18 <eedri> doron, last week solved tickets: http://goo.gl/6o62T6
14:08:22 <doron> eedri: do we have a plan of what migrates when? ie- ehwn will jenkins move? when will gerrit? ovirt.org, etc?
14:08:28 <eedri> doron, yes
14:08:49 <eedri> doron, 1st stage (after all hypervisors are added + storage)
14:08:51 <dcaro> doron: friday we should be creating slaves
14:08:52 <doron> eedri: can we share it somewhere so fplks can prepare?
14:09:07 <doron> s/fplks/folks
14:09:11 <eedri> doron, is migrating jenkins slaves and decommisions rackspace
14:09:31 <eedri> doron, run it for some time and then when we're confident start migrating production vms
14:09:53 <eedri> doron, sure, i think it's somewhere on the wiki
14:10:02 <doron> eedri: link?
14:10:22 * eedri looking
14:11:23 <eedri> doron, i'll send it to the list
14:11:30 <doron> #info phx lab in final step. Initial Jenkins slaves expected this Friday.  More details will be published in the list.
14:11:42 <doron> eedri: dcaro thank you and well done.
14:11:58 <doron> moving on
14:12:00 <doron> #topic 3.4.z updates
14:12:04 <doron> sbonazzo: here?
14:12:07 <eedri> #info infra tickets solved last week http://goo.gl/6o62T6
14:12:13 <sbonazzo> doron: yes
14:12:30 <doron> eedri: thanks :)
14:12:34 <sbonazzo> doron sent status this morning here:  http://lists.ovirt.org/pipermail/users/2014-August/026543.html
14:12:45 <sbonazzo> doron: we're nearly the same as last week
14:12:51 <doron> sbonazzo: highlights?
14:13:03 <sbonazzo> doron: GA date postponed by one week due to lack of release engineers
14:13:28 <doron> sbonazzo: any blockers?
14:13:35 <sbonazzo> doron: 7 bugs still to be addressed
14:13:40 <sbonazzo> doron: no blockers
14:13:57 <doron> sbonazzo: very well, thanks. Let's see how it evolves.
14:14:02 <sbonazzo> doron: ok
14:14:24 <danken> sbonazzo: ready link to the 3.4.z bugs?
14:14:39 <doron> #info 3.4.z updates: GA date postponed by one week, 7 bugs still to be addressed, no current blockers. Full info available in: http://lists.ovirt.org/pipermail/users/2014-August/026543.html
14:14:45 <sbonazzo> doron: http://red.ht/1sQDLwg
14:15:25 <doron> #info relevant bugs: http://red.ht/1sQDLwg
14:15:27 <doron> sbonazzo: thanks
14:15:45 <doron> let's see how 3.5 is doing;
14:15:48 <doron> #topic 3.5 status
14:15:57 <doron> sbonazzo: how are we doing here?
14:16:11 <sbonazzo> doron: sent status this morning here: http://lists.ovirt.org/pipermail/users/2014-August/026544.html
14:16:16 <sbonazzo> we still have one blocker
14:16:25 <sbonazzo> https://bugzilla.redhat.com/show_bug.cgi?id=1124099
14:16:26 <danken> sbonazzo: I know that RC has been composed, but I think we should wait for http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:ovirt-3.5+topic:livemerge-3.5,n,z
14:16:49 <sbonazzo> danken: we need another RC anyway, we can't release with blockers
14:16:54 <danken> it's the crown jewel feature, and I'd rather have these patches in.
14:17:00 <sbonazzo> danken: I suggest an RC2 on monday
14:17:20 <alitke> danken, I am waiting for one more micro-api from Eric Blake as well
14:17:21 <danken> sbonazzo: good, I just want all live merge backports in.
14:17:34 <mlipchuk> doron: Currently https://bugzilla.redhat.com/show_bug.cgi?id=1124099 is pending on UI review
14:17:36 <danken> alitke: which blocks backport?
14:17:40 <sbonazzo> danken: add a blocker to the tracker so we can track it
14:17:43 <alitke> so I'd like to get 2 more vdsm patches into master and backport
14:17:58 <danken> alitke: ah
14:18:05 <alitke> It allows for internal volume resizing on block storage domains
14:18:06 <sbonazzo> doron: we also have issues with ovirt-optimizer dependencies on EL6
14:18:18 <danken> alitke: could you add your backport bug as a 3.5.0 blocker?
14:18:19 <sbonazzo> doron: and infra issues with building vdsm on EL7
14:18:26 <alitke> and the other patch enables us to handle an obscure negative flow
14:18:35 <alitke> danken, sure
14:19:01 <doron> sbonazzo: el6 or el7?
14:19:26 <sbonazzo> doron: ovirt-optimizer dependencies on EL6, vdsm on EL7: it's needed for hosted engine running on EL7 hosts
14:19:54 <danken> sbonazzo: what's with vdsm on el7 ?
14:20:18 <alitke> danken, I think it already was marked a blocker
14:20:24 <sbonazzo> danken: it failed one test on job 65 and then the host become unreachable
14:20:29 <danken> alitke: ah, silly me. thanks.
14:20:38 <doron> so...
14:20:39 <alitke> danken, I'll create separate bugs for the other two issues.
14:20:51 <doron> looks like rc2 is needed. when should we expect it?
14:20:55 <sbonazzo> danken: see https://fedorahosted.org/ovirt/ticket/242 - vdsm_3.5_create-rpms_merged broken on EL7 slave
14:21:11 <eedri> doron, aug 11
14:21:17 <eedri> doron, according to the schedule
14:21:22 <sbonazzo> doron: if all blockers are fixed, we can try to compose on monday so we can use it on Tue for 3rd test day
14:21:48 <doron> danken: do you think the live migration will make it for the above dates?
14:22:28 <danken> doron: live merge is there as it is
14:22:51 <danken> doron: but some cleanup work can be merged today (if ybronheim tkes it)
14:22:58 <doron> danken: I'm asking about alitke's patch set.
14:23:34 <danken> doron: yes, they'll be in
14:23:45 <doron> danken: thanks.
14:23:54 <alitke> As for the extra two things, those should be doable with a concerted review effort.
14:23:55 <danken> doron: but please add an action item on ybronheim to review and take them
14:23:57 <doron> Anyone else has reservations for RC2?
14:24:08 <alitke> We should check with gpadgett and rnori about the engine side though
14:24:25 <sbonazzo> gpadgett: the blocker still on post is assigned on you, eta? https://bugzilla.redhat.com/show_bug.cgi?id=1124099
14:24:45 <danken> apuimedo: have you seen brctl failing on el7 http://jenkins.ovirt.org/job/vdsm_3.5_create-rpms_merged/65/label=centos7/console ?
14:24:45 <danken> sbonazzo: is it reproducible?
14:24:53 <gpadgett> alitke, sbonazzo: sec, reading
14:25:00 <doron> #action ybronheim to make sure we have http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:ovirt-3.5+topic:livemerge-3.5,n,z ready for Aug 11.
14:25:34 <sbonazzo> danken: looks like infra restarted the slave somehow and now seems to work
14:25:45 <gpadgett> sbonazzo: waiting on review for that one, so as soon as it's +1'd we can merge and I can backport it.  Will ping some people about that
14:26:01 <sbonazzo> gpadgett: thanks
14:26:14 <alitke> Just added https://bugzilla.redhat.com/show_bug.cgi?id=1109920 as a release blocker
14:26:19 <danken> sbonazzo: I don't like the sound of thiss... do you know if NetworkManager is running on that host?
14:26:37 <sbonazzo> danken: no idea. please sync with eedri / dcaro
14:26:38 <alitke> gpadgett, Any other negative flows that need to be handled on engine side before 3.5 can be released?
14:26:58 <doron> sbonazzo: what is the version / blocker tracker?
14:27:12 <dcaro> doron: iirc the job did stop network manager itself right?
14:27:22 <sbonazzo> doron: bug #1073943
14:27:40 <gpadgett> alitke: you emailed me about one recently that I think needs to be handled, should be fairly easy.  I'll try to get a patch out today for it.
14:28:21 <alitke> gpadgett, Might want to formalize it with a bug that can be tracked for release purposes.  You'll need it anyway in order to merge into the 3.5 branch.
14:28:22 <doron> sbonazzo: thanks we have 4 open blockers?
14:28:31 <apuimedo> danken: probably slow to take the device down
14:28:37 <apuimedo> before brctl delbr
14:28:39 <doron> #info version tracker: https://bugzilla.redhat.com/showdependencytree.cgi?id=1073943&hide_resolved=1
14:28:44 <apuimedo> rarely it happens on my f20
14:28:49 <gpadgett> alitke: yes, agreed, will handle the bz too
14:29:27 <doron> apuimedo: danken is seems that https://bugzilla.redhat.com/show_bug.cgi?id=1041569 is blcoking us?
14:29:32 <danken> apuimedo: what is "slow to take the device down"?
14:30:04 <doron> ie- blocking live merge bz assigned to alitke
14:30:04 <sbonazzo> doron: looks like so
14:30:31 <apuimedo> danken: it might be that it takes a bit too long to down the device which may be needed for the delbr
14:30:34 <doron> alitke: do we have an eta for this issue?
14:30:37 <danken> doron: don't tell anyone, but I think we can release 3.5.0 without internal-resize-while-live-merge
14:31:13 <doron> danken: if this so then the libvirt bz should not be a blocker.
14:31:18 <alitke> danken / doron: fsimonce does not agree.
14:31:38 <alitke> we need the code to take advantage of an eventual libvirt api
14:31:47 <alitke> so this bz covers the vdsm changes, not the libvirt ones.
14:32:02 <alitke> I need to get the API from eblake so I can write the vdsm code.
14:32:07 <alitke> Should be a minor change
14:32:16 <alitke> in vdsm since the plumbing is already there
14:32:23 <doron> alitke: danken please discuss it offline. I'll re-cap next week as this is currently a blocker.
14:32:37 <alitke> ok
14:32:55 <doron> gpadgett: IIUC https://bugzilla.redhat.com/show_bug.cgi?id=1124099 should be resolved soon?
14:32:57 <apuimedo> danken: basically ifdown returns before the kernel has it down
14:33:05 <apuimedo> and immediately after we try to remove
14:33:08 <apuimedo> and it fails
14:33:11 <gpadgett> doron: yes, working on getting my reviews now
14:33:12 <sbonazzo> doron: last highlight on 3.5, we still havemore than 400 bugs open, and for an RC I think we should start re-targeting them
14:33:12 <apuimedo> cause it is not down yet
14:33:27 <danken> apuimedo: ahh, anothe initscript race?
14:33:34 <apuimedo> danken: no
14:33:42 <apuimedo> rather a kernel one
14:33:50 <apuimedo> we use ip link set dev foo down
14:33:51 <doron> sbonazzo: agreed.
14:34:08 <apuimedo> or iproute2 race, if you will
14:34:09 <danken> apuimedo: oh, the old "it's not a race, it's designed to be async" line.
14:34:15 <apuimedo> yup
14:34:37 <doron> sbonazzo: I suggest that post rc2 we should produce a report based on whiteboard group, and mail it to the list. So relevant groups can start retargetting.
14:34:44 <apuimedo> I wouldn't mind if iproute2 added a flag to wait for confirmation :P
14:34:50 <doron> gpadgett: thanks.
14:35:16 <danken> apuimedo: someone needs to sync the operations... and if it's not kernel/iproteu2/initscripts - its us.
14:35:18 <doron> alitke: https://bugzilla.redhat.com/show_bug.cgi?id=1124445 seems to be blocking us as well. is there an ETA for it?
14:35:34 <sbonazzo> doron: ok
14:35:41 <apuimedo> danken: (it's the worst place of doing it though)
14:36:30 <alitke> doron, looking
14:36:39 <doron> veery well.
14:36:55 <doron> until we finalize the blocking bz's.
14:37:10 <doron> does anyone have any other updates on 3.5.0 status?
14:37:11 <alitke> doron, That is being fixed in upstream libvirt.  It does not need to block our release
14:37:34 <doron> alitke: if so then it should not block 1115127
14:37:46 <alitke> ok, I'll update it
14:37:47 <doron> alitke: you can add it as 'see lso'.
14:37:52 <doron> (also). thanks
14:38:12 <doron> veyr well.
14:38:49 <doron> So...
14:39:26 <doron> #info  3.5.0 has ~2 real blockers, will track it next week. RC2 expected on time.
14:39:59 <doron> #info 3.5.0 post RC2 teams should start retarget 3.5.0 bugs.
14:40:14 <doron> anything else related to 3.5.0?
14:41:02 <sbonazzo> doron: the brocken dep on ovirt-optimizer
14:41:02 <doron> very well. Let's move on.
14:41:31 <doron> sbonazzo: we'll handle it early next week when it's maintainer will be back.
14:41:48 <sbonazzo> doron: ok
14:41:51 <doron> sbonazzo: unless there's something else we need to do for it?
14:42:05 <sbonazzo> doron: no, I think we can wait
14:42:10 <doron> very well.
14:42:13 <doron> Moving on.
14:42:24 <doron> #topic conferences and workshops
14:42:33 <doron> bkp: long time :)
14:42:49 <bkp> Indeed, Vacation Man! First off, welcome back doron! These folks are mad, I tell you, mad! :)
14:43:02 <doron> Thanks ;)
14:43:06 <bkp> A couple of things...
14:43:15 <bkp> LinuxCon NA has now added an Infrastructure.Next track and will now have two oVort-related talks--a general overview session from ybronhei and a discussion og mature open source communities from me. We *may* also have a talk (topic to be determined) from sherold.
14:43:22 <bkp> *oVirt
14:43:34 <bkp> KVM Forum is coming along. There are 15 Red Hat staffers who have submitted talks, though it looks like just two directly related to oVirt.
14:44:15 <bkp> That's basically it... still firming up talks for oVirt Workshop in Dusseldoerf and at Fossetcon.
14:44:34 <doron> #info LinuxCon NA added an Infrastructure.Next track; 2-3 ovirt related sesions expected.
14:45:33 <doron> #info kvm forum status:  15 Red Hat staffers who have submitted talks, only 2 directly related to ovirt.
14:45:53 <doron> bkp: iirc linux con may also host a few related talks?
14:46:15 <bkp> LinuxCon NA? Yes.
14:47:06 <doron> bkp: there's a linux con that is next to kvm forum
14:47:14 <doron> so we may see additional sessions there.
14:47:40 <bkp> LinuxCon EU, yes, but I have no insight on what talks were accepted for that yet.
14:47:50 <doron> bkp: very well, thanks!
14:48:01 <doron> #topic other topics
14:48:15 <doron> anyone wants to raise anything for discussion?
14:48:25 <bkp> I will be on PTO next week (Aug. 11-15), driving around the East Coast, looking for America. Or, y'know, visiting potential colleges with my middle daughter.
14:48:50 <doron> #info bkp will be in PTO next week
14:48:56 <doron> bkp: enjoy the sun :)
14:49:00 <bkp> Talked to Tuleap about configuring/hosting a marketplace for plugins on ovirt.org (and ManageIQ). But at 700 euro/month, it's looking more likely we will need to set something up on our own. Probably when we switch the site over from MediaWiki.
14:49:24 <bkp> No actions with this lat, just an update.
14:49:28 <bkp> *last
14:49:51 <doron> bkp: is the quote for infrastructure or something else?
14:50:08 <awels> bkp: Let me know if you are near Myrtle Beach during that time.
14:50:27 <bkp> Either they host it for us, or we host and they provide management software. Either way, price is the same.
14:51:13 <doron> bkp: we can help with hosting with the new phx coming soon.
14:51:28 <doron> but if the price is the same we'll wait for the new site layout.
14:51:29 <bkp> awels, Durham, NC is the closest on my itinerary.
14:51:44 <bkp> doron: Agreed. Kind of pricey.
14:51:48 <awels> bkp: That is like 4 hours away.. oh well
14:51:58 <doron> bkp: is there an eta for the transition?
14:52:30 <doron> bkp: if you're around VA try lurie caverns...
14:52:34 <bkp> No, garrett is still working on re-doing the gcc site, and then he will turn attention to ovirt.org
14:53:10 <bkp> Yeah, my 17-year-old daughter will love a cave. :)
14:53:22 <doron> bkp: very well. worth synciung with eedri and dcaro for the new phx lab.
14:53:33 <bkp> doron: Acknowledged
14:53:39 <doron> ok.
14:53:42 <doron> anyting else?
14:53:44 <bkp> If they will share. :)
14:53:50 <bkp> Nothing from me.
14:53:54 <doron> bkp: trust me, they will....
14:54:52 <doron> last chance to speak before next week's meeting. Going once...
14:55:32 <doron> Going twice...
14:56:20 <doron> bkp: happy tracking! thanks everyone, see you next week. Be good...
14:56:23 <doron> #endmeeting