14:05:20 <bkp> #startmeeting oVirt Weekly Sync
14:05:20 <ovirtbot> Meeting started Wed Jul 23 14:05:20 2014 UTC.  The chair is bkp. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:05:20 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:40 <bkp> Good day to all from not-so-sunny Portland, Oregon!
14:05:48 <bkp> #topic Agenda and Roll Call
14:05:59 <awels> bkp: Its going to be 100+ real feel here today
14:06:00 * amureini here for storage
14:06:01 * lvernia is here.
14:06:24 * awels here for UX
14:06:25 * sbonazzo here for integration
14:06:46 * danken is here, too
14:07:27 <bkp> Okay, let's roll!
14:07:35 <bkp> #info infra update
14:07:35 <bkp> #info 3.4.z updates
14:07:35 <bkp> #info 3.5 status
14:07:35 <bkp> #info conferences and workshops
14:07:35 <bkp> #info other topics
14:07:43 <bkp> #topic infra update
14:07:55 <bkp> dcaro, any infra news?
14:08:48 <bkp> Actually, anyone with infra updates?
14:09:26 <sbonazzo> bkp I guess dcaro is a bit busy
14:09:49 <sbonazzo> bkp: we're finalizing 3.5.0 beta2
14:10:46 <bkp> sbonazzo Noted
14:10:53 <sbonazzo> orc_orc: ?
14:11:19 <misc> for infra, we have at least cabling for the lab in phx2
14:11:28 <misc> so thing should go faster now on the migration
14:12:04 <sbonazzo> bkp massive work on 3.5 jobs, close to finishing all
14:12:09 <bkp> #info infra Cabling in place for the lab in phx2, migration should be faster
14:12:20 <sbonazzo> bkp multiple tickets closed , eedri can provide a link
14:12:37 <bkp> #info infra Multiple tickets closed.
14:12:39 <eedri> sbonazzo, http://goo.gl/Gc3jwJ
14:12:48 <eedri> sbonazzo, all tickets solved in the past month
14:12:50 <sbonazzo> bkp ^^
14:13:09 <bkp> #info infra Tickets solved in last month link: http://goo.gl/Gc3jwJ
14:13:24 <bkp> Okay, that sounds good.
14:13:34 <bkp> Moving on...
14:13:38 <bkp> #topic 3.4.z updates
14:13:53 <bkp> What I got from sbonazzo...
14:14:02 <sbonazzo> bkp: 3.4.3 released, 3.4.4 development started, sent 3.4.4 status: http://lists.ovirt.org/pipermail/users/2014-July/026245.html
14:14:08 <bkp> #info 3.4.z updates oVirt 3.4.4 in development. General availability: 2014-09-16, RC Build: 2014-09-09.
14:14:38 <dcaro> yes, sorry, went for a tea, phx lab network should be ready today
14:14:39 <bkp> #info 3.4.z updates 3.4.4 released
14:14:48 <sbonazzo> bkp looks like we have some issues in 3.4.3 vdsm, will respin soon
14:14:53 <bkp> dcaro: Tea?? :)
14:15:26 <bkp> #info 3.4.z updates Some issues with 3.4.3 vdsm, will respin
14:15:31 <dcaro> bkp: yep, ice tea goes well in summer :)
14:16:02 <danken> bkp, new vdsm build already done.
14:16:13 <bkp> danken cool.
14:16:14 <danken> dcaro: what is the state of the respin of 4.14.11.2 ?
14:17:04 <dcaro> danken: maybe sbonazzo knows better ^
14:17:11 <eedri> danken, downstream ?
14:17:24 <eedri> danken, sorry, i meant for last beta2?
14:17:59 <sbonazzo> danken: dcaro|mtg: we'll handle it right after 3.5.0 beta announce
14:18:04 <Wermwud> hey folks, anyone using 3.4 on CentOS 7 yet?
14:18:13 <sbonazzo> eedri: it's for 3.4.3 ga respin
14:18:27 <eedri> sbonazzo, ok
14:18:27 <bkp> #info 3.4.z updates AMEND Some issues with 3.4.3 vdsm, already respun
14:19:16 <bkp> Anything else for 3.4.z updates?
14:19:26 <sbonazzo> bkp not from my side
14:19:37 <danken> Wermwud: some do Bug 1121999
14:19:51 <danken> https://bugzilla.redhat.com/show_bug.cgi?id=1121999#c2
14:19:53 <bkp> Great, thank you sbonazzo dcaro danken
14:20:04 <bkp> #topic 3.5 status
14:20:29 <sbonazzo> bkp not sent status yet, we've composed the repo and it passed basic sanity on bare metal
14:20:34 <bkp> Let's stay with integration. sbonazzo, I did not see a status email, so can you update?
14:20:52 <sbonazzo> bkp we're going to release it  in a while
14:21:01 <Wermwud> thanks danken, our guys are looking to go with several CentOS boxen and I'm trying to get up to speed on things.
14:21:16 <sbonazzo> bkp test day should be postponed to next Tue
14:21:45 <bkp> Any objections?
14:22:03 <danken> Wermwud: good luck (it's much less tested then el6) but go ahead, tell me and users@ovirt.org if something breaks
14:22:54 <bkp> Not hearing any.
14:23:01 <danken> bkp: none from me
14:23:04 <bkp> #info 3.5 status integration repo composed and it passed basic sanity on bare metal, will be released soon.
14:23:04 <bkp> #info 3.5 status integration Test Day 2 should be delayed until July 29
14:23:29 <sbonazzo> bkp for GA, we stil have 2 blockers on POST
14:23:34 <bkp> #action Test Day 2 for 3.5 Beta to be delayed until 29/7/14
14:24:04 <bkp> #info 3.5 status integration Two blockers remain, both in POST status.
14:24:19 <bkp> sbonazzo: Which teams have these?
14:24:34 <sbonazzo> bkp: infra and network
14:25:02 <lvernia> bkp: :(
14:25:06 <bkp> K, will review when we get to them.
14:25:14 <bkp> DUN DUN DUNNN...
14:25:34 <sbonazzo> bkp that's all on integration side
14:25:34 <bkp> Anything else, sbonazzo?
14:25:46 <bkp> (I am too slow today.)
14:26:15 <bkp> Network: lvernia, what be the word?
14:26:56 <lvernia> Okay.
14:27:11 <lvernia> So we added 1114987 as a blocker today.
14:27:28 <lvernia> It's been open for a couple of weeks, but it wasn't clear that the problem was network-related.
14:28:08 <lvernia> The fact that it's on POST is misleading, because the patch up for review deals with a secondary logging issue, not with the principal problem.
14:28:14 <lvernia> Which we've only pinned down today.
14:28:27 <lvernia> But now that we understand it, I hope it'll be fixed in the next couple of days.
14:28:48 <lvernia> P.S. all blockers from last week(s) are fixed.
14:29:23 <bkp> #info 3.5 status network Bug 1114987 added today, since it became clear it was a network issue. POST status misleading, since primary issue not addressed in fix. Complete fix ETA: a couple of days.
14:29:23 <bkp> #info 3.5 status network All other blockers closed.
14:29:33 <bkp> lvernia, Anything else?
14:29:58 <lvernia> bkp: Don't think so, unless you're interested in further details on that specific bug.
14:30:22 <bkp> No, I think we have enough for the record.
14:30:56 <bkp> Let's check in with infra next. Who is here this week for infra?
14:32:59 <bkp> sbonazzo: What was that infra blocker? Bug # ?
14:33:15 <sbonazzo> bkp Bug 1115044 -        Host stuck in "Unassinged" state when using jsonrpc and disconnection from pool failed
14:34:35 <bkp> pkliczew: Do you have the status of this blocker?
14:35:01 <pkliczew> bkp: still not fixed
14:35:21 <bkp> pkliczew: ETA?
14:35:58 <pkliczew> bkp: hope that it will be this week
14:36:14 <bkp> #info 3.5 status infra Bug 1115044 blocker in POST. Estimated time to fix: Sometime this week.
14:36:26 <bkp> Thanks, pkliczew
14:37:16 <bkp> Moving on to virt. I don't see mskrivanek. Anyone else here from the virt team?
14:37:31 <danken> pkliczew: I'm still missing I58745450b962844211585874460574f000c441cc on 3.5
14:37:38 <danken> bkp it's a blocker too
14:37:47 <danken> no forceLink
14:37:48 <danken> https://bugzilla.redhat.com/1120721
14:37:50 <pkliczew> danken: let me check
14:39:24 <danken> pkliczew: I see it's already posted http://gerrit.ovirt.org/#/c/30545/
14:39:30 <danken> missing verification and merge
14:39:48 <danken> we must not think about beta2 before this is in.
14:40:33 <pkliczew> danken: let me talk to the author
14:41:03 <danken> pkliczew: she's on a conference, I think.
14:41:19 <bkp> pkliczew: I'm going to keep moving. Jump in when you get something.
14:41:35 <bkp> virt, Any news?
14:41:37 <pkliczew> bkp: ok
14:42:33 <bkp> #info 3.5 status virt No updates this week.
14:43:02 <bkp> Moving on to storage... amureini, anything on your end?
14:43:27 <amureini> bkp, a couple of updates
14:44:13 <amureini> bkp, gpadgett and alitke are closing gaps on live-merge (mostly active-layer handling and negative flows)
14:44:58 <amureini> amureini, other that than just the normal inflow of bugs
14:45:06 <amureini> bkp ^^^
14:45:28 <amureini> "that's all folks"  - Pig, P. (1983)
14:45:46 * bkp *Headdesk*
14:45:50 <bkp> #info 3.5 status storage gpadgett and alitke are closing gaps on live-merge (mostly active-layer handling and negative flows)
14:45:50 <bkp> #info 3.5 status storage Just dealing with the normal inflow of bugs
14:46:12 <bkp> Rolling forward to node. fabiand?
14:46:19 <fabiand> Heya!
14:46:31 <bkp> Yo fabiand
14:46:36 <fabiand> Yo!
14:46:40 * fabiand read about the "Yo" app ...
14:46:49 <fabiand> 1.3million - but that is sth else …
14:46:54 <fabiand> Well, some instabilities with the appliance builds
14:47:05 <fabiand> Some clarification needed on generic registration
14:47:11 <fabiand> We'll take care of both in the next days.
14:48:05 <bkp> Noted. Anything else, fabiand?
14:48:12 <fabiand> Not from my side for now.
14:48:19 <bkp> Coolness.
14:48:25 <bkp> #info 3.5 status node Some instabilities with the appliance builds. Estimated time to fix: Couple of days
14:48:26 <bkp> #info 3.5 status node Some clarification needed on generic registration. Estimated time to fix: Couple of days
14:48:51 <bkp> sla, now. msivak, status?
14:49:33 <msivak> bkp: not good, still the same story.. we need reviews for the engine part and I haven't been able to get any QE to verify the vdsm part till today
14:49:51 <msivak> bkp: gklein promised me at least CI testing, they are too busy to do manual job
14:51:21 <bkp> msivak: Will that be enough?
14:51:24 <msivak> bkp: so qos and numa ui are not in, hosted engine is good, optimizer is good, but pending some infrastructure tickets for jenkins
14:51:46 <msivak> danken: will CI testing be enough for you?
14:52:53 <danken> msivak: it depends what happens there
14:53:16 <bkp> msivak: How soon was that CI testing going to happen?
14:53:23 <msivak> gklein: here?
14:53:26 <danken> msivak: but generally speaking, multi-VM migration on file/block storage makes me happy, usually.
14:53:40 <gklein> msivak, yes
14:53:57 <msivak> gklein: when can we get the CI test results?
14:54:31 <msivak> gklein: we are discussing the vdsm qos patches that need pre-verification
14:54:36 <gklein> msivak, I meant dev CI, I guess as soon as we get a build running there
14:55:25 <msivak> gklein: what do I have to do to make it easy for you?
14:56:50 <gklein> msivak, I don't control dev CI.
14:57:36 <gklein> msivak, its just a matter if they can consume the private build and run the basic sanity jobs
14:57:55 <msivak> gklein: who does control that?
14:58:37 <msivak> who do I have to ask? I have been chasing people only to be sent to somebody else this whole week.. :/
15:00:19 <gklein> msivak, sorry about that, I can't shift the current QE tasks at such a short notice.
15:00:52 <gklein> msivak, for dev CI you can sync with eyal edri
15:01:16 <msivak> gklein: thanks, I will talk to him
15:01:22 <msivak> gklein: I know
15:01:35 <msivak> bkp: I will take this offline, but that is the current status
15:01:48 <bkp> eedri: Please work with msivak on getting this blocker through dev CI. Thanks!
15:02:08 <bkp> Thanks msivak, for staying on this.
15:02:17 <bkp> #info 3.5 status sla iotunes bug (1085049) we need reviews for the engine part and I haven't been able to get any QE to verify the vdsm part till today. gklein has indicated dev CI testing, as soon as a build is running there. ETA indeterminate.
15:02:17 <bkp> #info 3.5 status sla qos and numa ui are not in
15:02:17 <bkp> #info 3.5 status sla Hosted engine is good, optimizer is good, but pending some infrastructure tickets for jenkins
15:02:17 <bkp> #info 3.5 status msivak will be working to push CI testing through
15:02:18 <eedri> bkp, sure, will do my best to help
15:02:42 <bkp> vdsm is up. danken, any news?
15:04:14 <danken> I told of the sad news of 3.4.3
15:04:26 <danken> and the infra blocker for 3.5
15:04:35 <bkp> Right.
15:04:40 <danken> we found today a 3.5 regression in networking (dhcp)
15:04:47 <danken> but nothing horrible
15:04:52 <lvernia> danken: Mentioned that.
15:05:01 <lvernia> danken: Well, the related bug.
15:05:40 <bkp> #info 3.5 status vdsm A 3.5 regression has been found in networking (dhcp) (related bug already mentioned)
15:05:57 <bkp> Anything else, danken?
15:05:58 <danken> anyway not mych
15:06:03 <bkp> Coolness.
15:06:19 <bkp> UX! awels, status?
15:06:44 <awels> bkp: Hi, not much change in status since last week
15:06:56 <awels> bkp: GUI  sorting: all main tabs are in 3.5, including Volumes (gluster).  Sub-tabs sorting within 'virt' main tabs is still in progress. full  status is in: https://docs.google.com/spreadsheets/d/1S3qDYqv9OK5ruI41RpFpRAsLaojpGL-W6WYUej3629s/edit?usp=sharing
15:07:03 <danken> (msivak: eedri may itch you if you don't add Bug-Url to your 3.5 patches!)
15:07:07 <awels> bkp: Italian  translation in progress; currently still in ~30% completion, hopefully  will increase soon (a couple more translators may contribute additional  translations)
15:07:23 <eedri> msivak, not just me, gerrit will give you -1
15:07:28 <awels> bkp: I believe that is all.
15:08:05 <msivak> danken: I will add it, that is just commit message change :) I won't lose flags because of it :)
15:08:34 <bkp> #info 3.5 status ux GUI  sorting: all main tabs are in 3.5, including Volumes (gluster). Sub-tabs sorting within 'virt' main tabs is still in progress. full status is in: https://docs.google.com/spreadsheets/d/1S3qDYqv9OK5ruI41RpFpRAsLaojpGL-W6WYUej3629s/edit?usp=sharing
15:08:34 <bkp> #info 3.5 status ux Italian  translation in progress; currently still in ~30% completion, hopefully  will increase soon (a couple more translators may contribute additional translations)
15:08:40 <bkp> Thanks, awels
15:08:45 <bkp> Moving on...
15:08:46 <awels> bkp: np
15:08:52 <bkp> #topic Conferences and Workshops
15:09:00 <bkp> #info Conferences and Workshops We will be participating in a Day 0 enterprise Linux day at Fossetcon on Sept 11. oVirt will have lots of room for tutorials.
15:09:00 <bkp> #info Conferences and Workshops OSCON is going well and we are having good discussions on oVirt.
15:10:11 <bkp> #info Conferences and Workshops We need submissions for KVM Forum, and (now) oVirt Workshop. Talk to bazulay or bkp for more details.
15:10:21 <bkp> #topic Other Topics
15:11:09 <bazulay> was test day discussed ?
15:11:16 <bkp> I have nothing really, though a quick question: will oVirt 3.5 be able to run on CentOS 7? We are getting a lot of inquiries on social media?
15:11:33 <YamakasY> jvandewege: ping
15:11:35 <bkp> bazulay: It was postponed to next Tuesday
15:12:08 <bkp> Any other topics?
15:12:35 <bkp> pkliczew: Any news on that bug from the author?
15:12:40 <bazulay> CentOS 7 should be supported as a hypervisor |
15:12:55 <pkliczew> bkp: not yet, I had to send an email
15:13:07 <YamakasY> sorry I was not here, was watching the ceremony in The Netherlands
15:13:31 <bkp> pkliczew: Please follow up offline, and send status to devel list.
15:13:41 <pkliczew> bkp: sure
15:13:45 <bkp> Going once on other topics?
15:14:13 <bkp> Twice?
15:14:43 <bkp> Then like the man said, "That's all, folks!" Thank you!
15:14:50 <bkp> #endmeeting