14:04:55 <doron> #startmeeting oVirt Weekly Sync
14:04:55 <ovirtbot> Meeting started Wed Jun 25 14:04:55 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:55 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:04:56 * sbonazzo here
14:04:57 <doron> #topic Agenda and roll Call
14:04:58 <doron> #info infra update
14:05:00 <doron> #info 3.4.z updates
14:05:01 <doron> #info 3.5 status
14:05:03 <doron> #info conferences and workshops
14:05:04 <doron> #info other topics
14:05:08 * amureini here
14:05:09 <doron> hi sbonazzo bkp amureini
14:05:20 <doron> let's do a proper role call
14:05:34 <awels> doron: here
14:05:45 * amureini here for storage
14:05:45 <doron> awels: here for ux?
14:05:59 <awels> doron: yes
14:06:04 <doron> gr8
14:06:27 <doron> who's here for network? infra? gluster?
14:06:44 * sbonazzo here for integration
14:06:46 * lvernia is here.
14:07:17 <doron> k. stll missing rep's for gluster and infra
14:07:31 <doron> fabiand: here for node?
14:08:03 <doron> I'll assume yes...
14:08:19 <doron> let's get going.
14:08:22 <doron> #topic infra update
14:08:32 <doron> dcaro: infra updates?
14:08:48 <fabiand> doron, sorry  -yes I am here!
14:08:57 <doron> fabiand: hey ;)
14:09:10 <fabiand> hey - didn't expect such a quick ping :)
14:09:12 <fabiand> so
14:09:20 <dcaro> doron: from now you'll start seeing more and more jobs create from yaml files
14:09:21 <doron> fabiand: it was just a role call.
14:09:25 <fabiand> Right
14:09:27 * fabiand is here
14:09:49 <doron> dcaro: cool. updaes on phx lab?
14:09:52 <dcaro> doron: just keep in mind that changing those jobs from the ui will not persist, they will be reset the next time the confs are updated
14:10:15 <dcaro> doron: we have installed the 2 storage servers and setup drbd, it's already wynched but no HA setup yet
14:10:33 <doron> #info infra updates: more jobs being created by yaml. UI changes do not persist.
14:11:09 <doron> info: phx lab: 2 storage servers installed with drbd setup. ha tbd
14:11:15 <doron> dcaro: thanks!
14:11:22 <doron> moving on
14:11:24 <doron> #topic 3.4.z updates
14:11:32 <doron> sbonazzo: any special updates?
14:11:36 <Akegata> Is memory hot plug a planned feature for ovirt?
14:11:45 <sbonazzo> doron: sent 3.4.3 RC status to mailing lists http://lists.ovirt.org/pipermail/users/2014-June/025413.html this morning
14:11:53 <sbonazzo> doron: no blockers
14:12:12 <sbonazzo> doron: not many bugs fixed since last week, but we should be on track
14:12:19 <doron> sbonazzo: what's the next milestone for 3.4.z?
14:12:25 <sbonazzo> 3.4.3 RC
14:12:35 <doron> eta?
14:12:40 <sbonazzo> 2014-07-10
14:13:19 <doron> #info up next on 3.4.z is 3.4.3 RC planned for 2014-07-10. Currently no blockers.
14:13:23 <doron> sbonazzo: thanks
14:13:26 <doron> let's move on.
14:13:31 <doron> #topic 3.5 status
14:13:47 <sbonazzo> sent 3.5.0 beta status to mailing lists http://lists.ovirt.org/pipermail/users/2014-June/025414.html this morning
14:13:52 <doron> sbonazzo: do we have any blockers for it?
14:14:18 <sbonazzo> only 2 blockers both on integration: F20 support and external scheduler logs to be added to log-collector on EL6
14:14:51 <doron> #info current 3.5 blockers: integration: F20 support and external scheduler logs to be added to log-collector on EL6
14:14:51 <sbonazzo> tracker: http://bugzilla.redhat.com/1073943
14:15:21 <doron> #info 3.5.0 tracker: http://bugzilla.redhat.com/1073943
14:15:37 <lvernia> Akegata: I remember hearing this discussed, mskrivanek should be able to answer you after this meeting.
14:15:48 <sbonazzo> Bug 1110305 -        BSOD - CLOCK_WATCHDOG_TIMEOUT_2 - Win 7SP1 guest, need to set hv_relaxed
14:15:56 <sbonazzo> has been proposed as blocker
14:16:31 <sbonazzo> https://bugzilla.redhat.com/show_bug.cgi?id=1073943#c1
14:16:46 <mskrivanek> Akegata: it is. the support in KVM is a bit delayed....but finaly it starts to materialize so we'll be working on it in not so distant future
14:17:12 <doron> sbonazzo: since this is an integration bz, do you think it can be handled for 3.5.0?
14:17:21 <Akegata> mskrivanek: Cool! Thanks for the info.
14:17:36 <sbonazzo> above bug is on Fedora 20 VDSM
14:17:58 <doron> sbonazzo: I was referring to 1073943
14:18:25 <sbonazzo> doron: the 2 bugs in integration: the external scheduler log sure, will be fixed for 3.5.0 GA
14:18:45 <sbonazzo> the Fedora 20 support is in a good shape but more test are needed
14:19:02 <doron> mskrivanek: is https://bugzilla.redhat.com/show_bug.cgi?id=1110305 virt?
14:19:06 <doron> sbonazzo: very well.
14:19:57 <doron> mskrivanek: ?
14:20:11 <mskrivanek> doron: yes
14:20:24 <doron> mskrivanek: is this 3.5.0 blcoker?
14:20:27 <doron> (blocker)
14:20:35 <doron> as it was requested
14:21:23 <mskrivanek> it's in the plan for future release
14:21:47 <mskrivanek> and is in fact a duplicate of 1083529 as mentioned in https://bugzilla.redhat.com/show_bug.cgi?id=1110305#c16
14:22:23 <doron> mskrivanek: which means it will not be fixed for 3.5.0
14:22:38 <mskrivanek> i'm not aware of any other instances of BSOD right now...so it may be specific to the setup
14:23:23 <doron> mskrivanek: so the question if this is a blocker or not for 3.50?
14:23:36 <mskrivanek> i would at least move the bug to oVirt first
14:24:29 <doron> mskrivanek: ???
14:24:51 <doron> ie- will moving it make it less of a blocker?
14:25:38 <mskrivanek> no, but it will make it at least visible to me. i wasn't aware of that bug as it is on Fedora right now
14:25:57 <doron> mskrivanek: very well. so please update as needed and it is not a blocker.
14:26:46 <mskrivanek> i'm not saying that it's not. it may very well be a valid problem...we just haven't really investigated
14:26:48 <doron> #agreed bug 1110305 is related (if not duplicate) of 1083529. Currently not a blocker
14:26:52 <mskrivanek> i'd say the same is true for https://bugzilla.redhat.com/show_bug.cgi?id=1107835
14:27:16 <doron> ok, I'd like to follow on exceptions given last week or needed
14:27:40 <doron> actually I'd rather start with the state of master
14:27:45 <doron> oved: here?
14:28:41 <doron> anyone here from ovirt infra team?
14:29:11 <doron> engine infra probably more accurate.
14:29:18 <doron> oved: ?
14:29:27 <doron> bazulay: here?
14:29:33 <bazulay> fabianyes
14:29:45 <bazulay> doron:  yes
14:29:59 <doron> bazulay: we're looking for an update on  status on master
14:30:03 <doron> (of master)
14:30:18 <doron> seems to be broken currently and we need to decide how to handle branching
14:30:24 <oved> doron, also joined.
14:30:37 <bazulay> oved: please explain
14:30:39 <doron> oved: see my Q to bazulay.
14:30:44 <oved> doron, people still reviewing the patch.
14:30:51 <oved> doron, but seems like it is convergin.
14:31:00 <oved> doron, however, the dev jobs have some issues
14:31:08 <doron> oved: is there an estimated eta?
14:31:11 <oved> doron, and not really sure what's their nature.
14:31:19 <doron> oved: ???
14:31:27 <oved> doron, not really, as we're still examining the issues.
14:31:40 <oved> doron, we need to understand if they are related or not.
14:31:57 <oved> doron, if not, then we either need to resolve them... or just merge... if they do we need to fix them.
14:32:02 <doron> oved: so basically we need to ait with branching, beta and test day until you sort out this issue?
14:32:12 <doron> (wait)
14:32:12 <oved> doron, for now it looks like they aren't related to Yair's changes, but he is still on it.
14:33:04 <doron> oved: so, when do you expect we can resume to branching, beta and test day?
14:33:16 <oved> doron, we'll know better in the morning, about the issues. and then we should decide whether to merge it or not.
14:33:35 <doron> sbonazzo: seems that beanching may not happen tomorrow
14:33:44 <doron> we should prepare for that
14:34:16 <oved> we will need close help from integration team in case we won't be able to fix the dev jobs by ourselves.
14:34:26 <doron> oved: please make sure to update sbonazzo tomorrow so we'll decide how to continue with the curent plan
14:34:32 <danken> doron: please note that vdsm has already branched ovirt-3.5
14:34:39 <sbonazzo> doron: ok, keep me informed on the status we'll try to provide as much help as we can
14:34:44 <doron> danken: noted.
14:34:46 <oved> sbonazzo, doron sure
14:34:57 <sbonazzo> oved: thanks
14:35:08 <danken> doron: fabiand: dougsland: a minor 3.5 infra/node issue for discussion from me: ovirt-node-3.0.4 is expected to be in 3.5?
14:35:31 <fabiand> danken, we hope to get ovirt-node-3.1 into 3.5
14:35:32 <danken> if so, is there any reason not to take http://gerrit.ovirt.org/#/c/28244/ in ?
14:35:37 <fabiand> but for now 3.0.4 should be in, danken
14:35:41 <doron> #info 3.5.0 status: vdsm branched already. Engine branch delayed until infra resolves current issue. oved to update sbonazzo tomorrow.
14:36:11 <danken> fabiand: so why was it impossible/very very hard to get it into the jenkins slaves?
14:36:19 <doron> danken: any other 3.5.0 issues in vdsm?
14:36:24 <fabiand> danken, what do you mean with "get it into jenkins slaves"?
14:36:55 <danken> fabiand: well, adding that patch caused depdency tests to fail
14:37:07 <fabiand> yes. I explained that in the ticket
14:37:09 <fabiand> and on irc
14:37:17 <fabiand> ovirt-node (pkg) is not intended to be installed on a regular host
14:37:20 <fabiand> I would drop the dependency
14:37:25 <fabiand> even if it is a real dependency
14:37:32 <fabiand> I know that i snot nice, but we can not change it for now.
14:38:03 <danken> fabiand: ok, we can replace it with a "Conflicts" just to make sure the version is enforced by the image builder.
14:38:14 <fabiand> Ah, nice idea!
14:39:12 <sbonazzo> danken: not sure that conflict will ensure version and just not fail
14:40:21 <danken> sbonazzo: "Conflicts < 3.0.4" states that "we break with earlier node", which is what dougsland wants to express.
14:40:32 <sbonazzo> danken: ok, +1
14:41:00 <danken> fabiand: thanks for your response, I was not aware of the ticket.
14:41:25 <fabiand> danken, you are always welcome. excuse me if I was a bit harsh yesterday :)
14:41:54 <doron> danken: anything else fro,m vdsm perspective?
14:41:58 <danken> fabiand: harsh? on irc? I might have missed it
14:42:23 <fabiand> danken, :)
14:42:28 <doron> danken: ie- any vdsm 3.50 blcokers?
14:42:32 <fabiand> danken, maybe I just felt harsh
14:42:42 <danken> doron: branched, no blocker knowns
14:42:47 <doron> danken: thanks.
14:42:48 <danken> to me
14:43:09 <doron> #info vdsm 3.5.0: branched, no blockers.
14:43:18 <doron> now for the exceptions
14:43:55 <doron> oved: other than the master issues, you have several items in yellow. are these exceptions?
14:44:25 <oved> these items should be published by tomorrow morning by alonbl
14:44:31 <oved> alonbl, am I right about that?
14:45:09 <alonbl> oved: yes
14:45:19 <doron> very well.
14:45:31 <doron> oved: please make sure to update the doc once ready.
14:45:40 <oved> doron, sure
14:45:48 <doron> sbonazzo: you have 2 exceptions. how are we doing?
14:46:28 <sbonazzo> doron: most of the code is is pushed and currently under verification. I don't think it will be in tomorrow beta.
14:46:35 <doron> #info infra has 3 pending items for 3.5.0 which should be concluded for tomorrow.
14:46:55 <doron> sbonazzo: we still need to see we have a beta tomorrow.
14:47:02 <doron> sbonazzo: is there an eta?
14:47:53 <sbonazzo> doron: not yet but shouldn't take more than 3 or 4 days with all the possible test cases, we have 2^4 possible combinations to test
14:48:19 <doron> sbonazzo: so eta is by the end of next week?
14:48:26 <sbonazzo> doron: I think so
14:48:32 <doron> sbonazzo: very well. thanks
14:48:51 <doron> #info integration 3.5.0 updates: 2 items should be finalized by the end of next week.
14:49:11 <doron> amureini: any outstanding issues for storage?
14:49:24 <doron> within 3.5.0 that is.
14:49:54 <doron> amureini: ?
14:50:36 <doron> #info sla has 2 exceptions. should be handled next week.
14:51:02 <doron> until we hear from amureini, let's check with ux. awels how are you doing with your exceptions?
14:51:03 <amureini> doron, yup, sorry, momentary laps of concentration
14:51:20 <doron> amureini: any outstanding issues for storage?
14:51:34 <amureini> doron, outstanding exceptions - 1. live merge depend on upstream libvirt work, need to add caps checks
14:51:36 <doron> #info sla has 3 exceptions. should be handled next week.
14:51:44 <awels> doron: The column sorting patches are under review, the one that is hold us up hopefully will be reviewed and merged today, after that it is just going through and making sure they all work and merge
14:51:50 <amureini> doron, 2. import existing domain on block storage
14:51:51 <doron> amureini: thanks
14:51:59 <doron> oh there's more.
14:52:00 <amureini> doron, that's it for me/storage
14:52:08 <doron> amureini: eta?
14:52:25 <awels> doron: The look and feel packaging, we have a pending review patch as well, not sure on when that will be merged.
14:52:34 <amureini> doron, mid-next week
14:53:05 <doron> #info storage 3.5.0 updates: live merge depend on upstream libvirt work, import existing domain on block storage. Current ETA: mid-next week
14:53:08 <doron> amureini: thanks
14:53:14 <doron> awels: back to you ;)
14:53:21 <awels> doron: That was about it :)
14:54:03 <doron> awels: so with the above details, when can they be set as completed?
14:54:37 <doron> awels: and I'm missing Italian translation
14:54:57 <awels> doron: The sorting probably early next week, the packaging, not sure, probably will be looked at after the sorting is done.
14:55:27 <awels> doron: The translation is pending the translation, need at least a certain percentage done, which is slowly getting there.
14:55:41 <doron> awels: since exceptions are holding the release we'll need to know more next week.
14:56:15 <awels> doron: Okay, I am going on PTO starting tomorrow, I will inquire with ecohen about it.
14:56:47 <doron> #info ux 3.5.0 updates: sorting early next week, followed by packaging. Italian translation still in progress.
14:56:55 <doron> awels: thanks
14:57:00 <ecohen> doron, what do you mean by "exceptions are holding the release"? for me, "exception" means "a feature authorized to be worked on post feature freeze", not "blocking the release".
14:57:02 <awels> doron: But none of these should block the release I would think.
14:57:10 <doron> mskrivanek: virtio-rng updates?
14:58:10 <doron> ecohen: what's the point of tracking it if it's not targeting this release?
14:58:22 <doron> ie- you may remove it and work on anything you see fit.
14:58:52 <ecohen> doron, ok, by "release" you mean "3.5 in general" or the upcoming milestone release (tomorrow or so)?
14:59:14 <doron> ecohen: I meant 3.5.0 GA. sorry if it's unclear.
14:59:29 <doron> so it would block 3.5.0 RC or GA.
14:59:44 <mskrivanek> doron: the patch to disable on < EL 7 is not yet in
14:59:49 <ecohen> doron, sure, no problem. all ux features will be in for the RC/GA, I don't expect any issues.
14:59:53 <mskrivanek> doron: can be backported later on easily
15:00:19 <doron> mskrivanek: should we keep tracking it or do you wish to target it for 3.6.0?
15:00:28 <doron> ecohen: thanks for clarifying.
15:00:36 <mskrivanek> doron: it needs to get to 3.5 eventually
15:00:36 <ecohen> doron, np. thank you.
15:00:50 <doron> mskrivanek: so do you have an eta?
15:01:24 <mskrivanek> ~ a week
15:02:21 <doron> #info virt 3.5.0 updates: virtio-rng  planned to be resolved during the following week.
15:02:26 <doron> mskrivanek: thanks
15:02:28 <mskrivanek> doron: after quick review I'd like to consider https://bugzilla.redhat.com/show_bug.cgi?id=1110305 a blocker. We need to see if it's possible in the short time we have, but it looks important indeed.
15:02:43 <mskrivanek> doron: at least let's decide next week if it's a real blocker or not
15:02:52 <mskrivanek> I can't really tell much more right now
15:03:03 <doron> mskrivanek: very well.
15:03:30 <doron> #info https://bugzilla.redhat.com/show_bug.cgi?id=1110305  suggested as a version blocker for 3.5.0, TBD for next week.
15:04:20 <doron> mskrivanek: if you end up setting it as a blocker it should be added to the tracker.
15:04:31 <doron> sbonazzo: anything else on 3.5.0?
15:04:45 <sbonazzo> doron: not on my side
15:05:00 <doron> very well, let's move on
15:05:08 <danken> doron: I've suggested Bug 1113091 -        VDSM trying to restore saved network rollback  as a blocker
15:05:08 <doron> #topic conferences and workshops
15:05:21 <bkp> Still prepping for OSCON next month, have finalized the booth preparations.
15:05:29 <doron> bkp: sec plz
15:05:42 <bkp> Noted
15:06:16 <doron> danken: is there a workaround
15:06:18 <doron> ?
15:06:49 <lvernia> doron: Network team?
15:06:58 <doron> lvernia: indeed.
15:07:04 <lvernia> doron: Not much to talk about though.
15:07:12 <lvernia> doron: Not aware of any blockers at the moment.
15:07:23 <doron> lvernia: how about 1113091?
15:07:25 <lvernia> doron: The Neutron appliance situation is interesting though.
15:07:31 <lvernia> Hang on, let me take a look.
15:08:20 <mskrivanek> btw, danken, because of the possible blocker I mention, would you please quickly review the general approach in patch http://gerrit.ovirt.org/#/c/27619 ?
15:08:47 <lvernia> doron: Ahh, not sure yet, need to discuss with danken.
15:08:56 <lvernia> doron: It's really new.
15:09:02 <doron> lvernia: danken suggesting it as a blocker.
15:09:15 <doron> lvernia: please review and report next wek. ok?
15:09:20 <lvernia> doron: No problem.
15:09:29 <lvernia> doron: So just concerning features for a sec...
15:09:34 <danken> lvernia: it was opened earlier today
15:10:18 <lvernia> doron: Since Neutron appliance requires a patch to be merged in the OpenStack Java SDK project, then it won't be part of the beta if it's built tomorrow.
15:10:24 <lvernia> If It isn't, then it might get in, I don't know.
15:10:25 <danken> lvernia: it can affect reboot of hosts with an un-plugged nic.
15:10:52 <lvernia> Definitely wouldn't block beta on it, since it's an external dependency.
15:11:03 <lvernia> But might get in if it is postponed due to other circumstances.
15:11:03 <doron> lvernia: very well.
15:11:17 <doron> lvernia: noted.
15:11:21 <doron> anything else lvernia?
15:11:33 <danken> mskrivanek: regarding  http://gerrit.ovirt.org/#/c/27619 - I do not think I've ever heard of this API change
15:11:34 <lvernia> doron: Also, two lower priority features ended up making it into master branch, so will add to sheet and to the test day scenarios.
15:11:42 <danken> mskrivanek: is it a surprise requirement?
15:11:49 <doron> danken: we'll track ythe bz next week to see if it was a bloccker and status.
15:12:05 <doron> lvernia: can you please specify what?
15:12:30 <lvernia> doron: Yes. One is "being able to work with" arbitrarily-named VLAN-tagged networks.
15:12:56 <lvernia> e.g. if a network is tagged with VLAN 101, it doesn't have to be named xxx.101.
15:13:12 <lvernia> It only allows working with such networks if they had been defined this way on the host manually though.
15:13:22 <doron> understood.
15:13:26 <doron> and the other?
15:13:51 <lvernia> Changed inner implementation of MAC pools to allow working with bigger MAC pools without running out of memory.
15:14:07 <doron> lvernia: thanks
15:14:10 <lvernia> doron: Thank you.
15:14:38 <doron> #info network 3.5.0 updates: 2 additional features made it in. Neutron appliance may not ,make it for first beta.
15:15:15 <doron> #info Bug 1113091 -  VDSM trying to restore saved network rollback  as a blocker suggested as a blocker. TBD by next week with thre network team.
15:15:23 <doron> bkp back to you.
15:15:30 <doron> (sorry for the delay)
15:15:43 <bkp> ZZZ... oh! Right! :)
15:15:53 <bkp> Again, Still prepping for OSCON next month, have finalized the booth preparations.
15:16:09 <bkp> Plans still underway to set up oVirt workshop, OSAS working on budget now.
15:16:35 <bkp> Finally regarding events, the various community leaders will be getting together to figure out a more streamlined approach to project-specific events. This will, ideally, lead to more oVirt content in more focused conferences and workshops.
15:16:39 <doron> #info OSCON prep's making progress.
15:17:31 <doron> #info ovirt workshop planning in progress. The various community leaders will be getting together to figure out a more streamlined approach to project-specific events. This will, ideally, lead to more oVirt content in more focused conferences and workshops.
15:17:38 <doron> bkp: thanks
15:17:54 <doron> moving on
15:17:56 <doron> #topic other topics
15:18:05 <doron> any aother issues you wish to discuss?
15:18:15 <bkp> I got some....
15:18:27 <bkp> ECS is delivering an abbreviated set of oVirt documentation this week. I have a first draft of an administrator's guide now.
15:18:38 <doron> ECS?
15:18:48 <bkp> Docs team in Brisbane.
15:19:06 <doron> cool
15:19:10 <bkp> We may just post these as static PDFs for now, since converting to them to MediaWiki would be unnecessary, given that we are moving the site to a markdown-based system.
15:19:38 <doron> #info Docs team is delivering an abbreviated set of oVirt documentation this week.  bkp has a first draft of an administrator's guide now.
15:19:41 <bkp> Regarding site migration: working with OSAS design team on a timeline now that they are done with ManageIQ to schedule the shift.
15:20:03 <bkp> Mirror update: New European mirror is up, still waiting for AARNET to post their mirror in Australia.
15:20:44 <bkp> Finally, I am preparing what I believe to be are solid download metrics for oVirt software. Thanks to misc and alonbl for their assistance. Will publish as soon as I figure out best format on Google Docs.
15:20:53 <doron> #info for now docs may be published in pdf format.  site migration: bkp working with OSAS design team on a timeline.
15:21:04 <doron> #info Mirror update: New European mirror is up, still waiting for AARNET to post their mirror in Australia.
15:21:43 <doron> #info bkp preparing solid download metrics for oVirt software. Thanks to misc and alonbl for their assistance. This will publish as soon as I figure out best format on Google Docs.
15:21:47 <doron> bkp: thanks!
15:21:50 <doron> anything else?
15:21:54 <doron> anyone else?
15:21:56 <bkp> doron: NP
15:22:12 <doron> going once?
15:22:43 <doron> going twice....
15:23:27 <doron> Thanks all for joining! stay tune for updates on the coming test day!
15:23:30 <doron> #endmeeting