14:01:38 <doron> #startmeeting oVirt Weekly Sync
14:01:38 <ovirtbot> Meeting started Wed May 28 14:01:38 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:38 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:50 <doron> #topic Agenda and roll Call
14:01:51 <doron> #info infra update
14:01:53 <doron> #info 3.4.z updates
14:01:54 <doron> #info 3.5 status
14:01:56 <doron> #info conferences and workshops
14:01:57 <doron> #info other topics
14:02:00 <doron> #topic infra update
14:02:15 <doron> orc_orc: dcaro here?
14:02:34 <dcaro> doron: about to enter a meeting
14:02:44 <doron> dcaro: quick infra update?
14:03:24 <dcaro> doron: this week the most relevant issue is that some jenkins jobs give 404 when running, and after it, and jenkins has to reload config from disk to show them (ping me and I'll do it), we are still trying to find out the cause
14:03:25 * lvernia is here, hi everyone.
14:03:57 <everyone> hi lvernia!
14:04:32 <lvernia> everyone is in a good mood today :)
14:04:36 <doron> dcaro: thanks
14:04:43 * bkp wants to run around and just hover over people's shoulders as they type
14:05:08 <doron> #info some jenkins jobs are giving 404 when running. mail infra@ovirt.org or ping dcaro if you hit it.
14:05:26 <doron> let's move on
14:05:28 <doron> #topic 3.4.z updates
14:06:32 <doron> #info 3.4.2: no blockers, we should be on track. RC published yesterday
14:06:45 <doron> status posted to the list: http://lists.ovirt.org/pipermail/users/2014-May/024730.html
14:07:32 <doron> if no one has comments, we'll move next.
14:08:32 <doron> moving on.
14:08:46 <doron> #topic 3.5 status
14:09:00 <doron> So... /current plan/ is:
14:09:26 <doron> We'll compose 3.5.0 second alpha on May 30 from nightly snapshot.
14:09:27 <doron> This build will be used in first test day currently scheduled on June 5th.
14:09:32 * fabiand is here
14:09:49 <doron> I want to get feedback from the groups now on current status to see how valid current dates are;
14:10:02 <doron> sahina: here?
14:10:16 <sahina> doron, yes
14:10:20 <doron> hi sahina
14:10:28 <doron> current status for 3.5?
14:11:06 <sahina> doron, for the gluster volume capacity - vdsm patch is dependent on a libgfapi-python patch that's yet to be merged
14:11:08 <doron> hi fabiand
14:11:42 <sahina> doron, and for the gluster volume profile feature, all the patches are submitted. needs to be reviewed and merges
14:11:47 <sahina> *merged
14:12:06 <doron> sahina: how long di you think it'll take to finalize all?
14:12:11 <doron> s/di/do/
14:12:58 * lvernia_ is back, sorry.
14:13:09 <doron> lvernia_: welcome back.
14:13:37 <sahina> doron, gluster volume profile - we should have it wrapped by next week. for the volume capacity, i'm not so sure...will try to make it by end of next week
14:13:58 <doron> sahina: thanks.
14:14:25 <doron> #info gluster missing 2 features for 3.5 plan, and require additional ~2 weeks to complete.
14:14:31 <doron> moving to infra
14:14:41 <doron> oved: here?
14:14:45 <oved> yes
14:14:52 <oved> infra status was updated in the wiki page
14:14:52 <doron> oved: infra updates for 3.5?
14:14:57 <oved> AAA status is that most code is on
14:15:00 <oved> most code is in
14:15:15 <oved> but finalization and fixes will be made by mid June
14:15:19 <oved> it is a big feature
14:15:38 <oved> fence kdump and jsonrpc should be in by the end of the week
14:15:45 <oved> ioprocess by mid june
14:16:04 <oved> foreman - code will be there, but still needs a lot of stabilization, and also depends on other external projects
14:16:30 <oved> command coordination - postponed due to design changes. we will know in middle of next week what's the real status, and what are the gaps.
14:16:37 <oved> that's all on infra side.
14:16:38 <doron> oved: based on the google doc, you have 3 patches that should be concluded by tomorrow, and 4 more ending in mid June?
14:17:02 <oved> by the end of the week, not by the end of tomorrow. that's what we aim for.
14:17:52 <doron> oved: it's a day difference, but yes. so technically you require adidtional 2 weeks?
14:18:01 <doron> *additional
14:18:07 <oved> yes.
14:18:17 <doron> oved: thanks.
14:18:22 <oved> doron, thank you.
14:19:07 <doron> #info infra 3.5 missing 4 features and require additional 2 weeks to conclude (Mid June).
14:19:34 <doron> Moving next to integration
14:20:36 <doron> #info integration 3.5 updates: Websocket proxy, DWH and Reports on separate hosts will need additional 2 weeks as well to conclude.
14:20:57 <doron> moving next to network
14:21:06 <doron> lvernia: network 3.5 status?
14:21:24 <lvernia> doron: Sure. The two missing features are not gonna make it by the end of the week.
14:21:30 <lvernia> doron: I'll move them to the removed tab.
14:21:50 <lvernia> doron: Other than that, nothing to update on.
14:21:51 <doron> lvernia: how much time do you need to conclude it?
14:22:20 <lvernia> doron: Hard to say... What's the schedule for 3.5 following the feature freeze?
14:22:35 <lvernia> doron: I generally doubt it's gonna make it into 3.5.
14:23:28 <doron> lvernia: feature freeze is may 30. However, we see a general need for additional 2 weeks for many teams
14:23:43 <doron> so I'm trying to understand if that will be benefitial for you.
14:23:55 <lvernia> doron: I doubt it.
14:24:08 <doron> lvernia: very well, thanks.
14:24:20 <lvernia> doron: But in that case I'd still keep it in the planning tab, I might be wrong.
14:24:54 <doron> lvernia: well... do not remove it yet. but it would make sense to know how much time you need for completion.
14:25:46 <doron> #info network 3.5 updates: all features ready but 2.
14:25:53 <lvernia> doron: It's really hard to say, can't commit on a deadline.
14:26:14 <lvernia> doron: A lot of the code is there but there are big disagreements in the reviewing.
14:26:18 <doron> lvernia: life is hard sometimes and we do need to draw the line somewhere.
14:26:54 <doron> moving next to node
14:26:57 <lvernia> doron: Thanks.
14:27:12 <doron> lvernia: thank you. fabiand node 3.5 updates?
14:27:30 <fabiand> doron, hey
14:27:37 <fabiand> We are a bit behind ..
14:27:44 <fabiand> But All three features are looking good
14:27:55 <fabiand> Two of them are in review - generic registratipon and hosted engine plugin.
14:28:11 <fabiand> The appliance is also in a rough, but likely usable state
14:28:23 <doron> fabiand: based on the google doc, you're almost there. Do you need additional time? if so, how much time?
14:28:32 <fabiand> Yes, we'll need some more time.
14:28:52 <fabiand> I'd say we need another week and a half
14:29:03 <doron> fabiand: very well, thanks.
14:29:16 <fabiand> yuo are welcome
14:29:34 <doron> #info node 3.5 updates: 2 features mostly done, but additional 1.5 weeks will be beneficial.
14:29:53 <doron> Moving next to SLA
14:30:02 <doron> let me get the guy...
14:30:49 <doron> #info All SLA features are mostly done, but need additional time to conclude; so 2 weeks will help here as well.
14:31:06 <doron> Let's check storage;
14:31:31 <doron> who's here for storage?
14:32:34 <doron> we'll skip storage for now.
14:32:47 <doron> ux team; awels here?
14:32:52 <awels> doron: I am
14:32:58 <doron> awels: 3.5 updates?
14:33:10 <awels> doron: The usual, the one feature is in, fixing issues as we find it.
14:33:22 <doron> awels: excellent, thanks.
14:33:34 <awels> doron: We are also working as fast as possible to implement sorting in as many tabs as possible for 3.5
14:33:34 <doron> #info UX team ready for 3.5 feature freeze.
14:33:54 <doron> awels: is this a feature or something else?
14:33:55 <awels> doron: That is more of a bonus than anything else.
14:34:13 <doron> awels: very well. Thanks and well done!
14:34:22 <doron> moving on to virt
14:34:28 <doron> mskrivanek: here?
14:34:32 <awels> doron: since we implemented the infrastructure and get seem to be getting a little more time, we are trying to use it in as many places as possible.
14:34:41 * mskrivanek here
14:34:47 <doron> awels: thanks
14:34:53 <doron> mskrivanek: virt 3.5 updates?
14:34:57 <mskrivanek> not much has changed since last time
14:35:23 <mskrivanek> still waiting on maintainer's attention to virtio-rng patches and spice filetransfer&copypaste
14:35:54 <doron> mskrivanek: will additional 2 weeks help you?
14:35:55 <mskrivanek> the SPICE+VNC vdsm side is merged so actually that is a good progress. Still the whole feature as such is out (but it allows us to move on with the spice features above)
14:36:09 <mskrivanek> to converge? I'm still hoping for this week
14:36:21 <mskrivanek> don't actually need more:-)
14:36:46 <doron> mskrivanek: so for the missing featurees you can converge by the end of this wek?
14:36:49 <doron> (week)
14:37:03 <doron> including virtio-rng?
14:37:06 <mskrivanek> hopefully yes
14:37:20 <mskrivanek> (the two in yellow in the spreadsheet)
14:37:33 <doron> ok. so you'll be ready with ll features for May 30?
14:37:43 <doron> (all)
14:38:08 <doron> Including REST review for instance types?
14:38:37 <mskrivanek> i marked insttypes in yellow again as the main developer is sick
14:38:52 <mskrivanek> but that still makes 12 features green
14:38:59 <doron> mskrivanek: and the REST maintainer in pto...
14:39:04 <mskrivanek> yep
14:39:12 <doron> so at least one more week?
14:39:48 <doron> (or at most)
14:39:52 <mskrivanek> depends on the sickness:) the patches are posted, but little attention from other maintainers really...
14:39:54 <mskrivanek> at most
14:40:12 <doron> k, got it, thanks.
14:40:41 <doron> #info virt 3.5 is mostly done. 3 last features needs some more time to converge. Probably less than a week.
14:40:47 <doron> ok.
14:41:27 <doron> so based on the above it looks like we need for additional 2 weeks for many teams.
14:41:34 <doron> Any major objections?
14:42:09 <doron> We're talking about pushing the feature freeze in 2 weeks to allow most of the missing features to converge.
14:42:37 <doron> If no objections, I'll post an email to the devel list suggesting a new date.
14:43:33 <doron> #action doron to post a suggestion to push feature freeze by 2 weeks in order to allow converging the last features.
14:43:46 <doron> Let's move on
14:43:53 <doron> #topic conferences and workshops
14:43:56 <doron> bkp: here?
14:44:05 <bkp> Still here!
14:44:09 <bkp> OpenStack Israel is Monday, just down the road from the Ra'anana office.
14:44:23 <doron> bkp: cool ;)
14:44:26 <bkp> oVirt will have a presence at OSCON in mid-July.
14:44:30 <doron> any additional updates?
14:44:35 <bkp> We will also be at LinuxCon/CloudOpen in mid-August, as well as LinuxCon/CloudOpen/KVM Forum in October.
14:44:58 <bkp> oVirt will be at USENIX LISA in September, though no talks were accepted.
14:45:10 <doron> #info events & conferences: OpenStack Israel in June 2nd and oVirt will have a presence at OSCON in mid-July.
14:45:15 <bkp> I am coordinating with Fedora, CentOS communities to find local meetups that we might speak at and ideally "seed" our own meetup events.
14:45:28 <doron> #info LinuxCon/CloudOpen in mid-August, as well as LinuxCon/CloudOpen/KVM Forum in October.
14:45:47 <doron> #info oVirt will be at USENIX LISA in September, though no talks were accepted.
14:45:50 <bkp> Finally, a related item: I have brought a whole bunch of oVirt contributor shirts, power adapters, and new liveUSB sticks to Ra'anana, which can be distributed at events. See doron for requisition.
14:46:07 <bkp> That's it for conferences.
14:46:26 <doron> #info bkp is oordinating with Fedora, CentOS communities to find local meetups that we might speak at and ideally "seed" our own meetup events.
14:46:33 <doron> bkp: thanks!
14:46:42 <doron> #topic other topics
14:46:58 <doron> anyone wants to raise an issue? discuss something?
14:47:18 <bkp> I finished a new oVirt feature article that will on Linux Weekly News (lwn.net) possibly as early as today
14:47:38 <bkp> And, meetings with oVirt teams in TLV have been very productive, and I appreciate the reception I have had in Ra'anana this week.
14:47:53 <bkp> Even from gchaplik :)
14:47:57 <doron> :)
14:48:23 <doron> #info bkp finished a new oVirt feature article that will on Linux Weekly News (lwn.net) possibly as early as today
14:48:33 <doron> anything / anyone else?
14:48:39 <doron> bkp: thanks!
14:48:56 <doron> Going once?
14:49:39 <doron> Going twice...
14:50:12 <doron> #endmeeting