13:00:02 <fabiand> #startmeeting oVirt Node Weekly Meeting
13:00:02 <ovirtbot> Meeting started Tue Apr 22 13:00:02 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:02 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:08 <fabiand> #chair jboggs rbarry
13:00:08 <ovirtbot> Current chairs: fabiand jboggs rbarry
13:00:15 <knesenko> shastri: brb
13:00:17 * jboggs here
13:00:20 <fabiand> #topic Agenda
13:00:28 <fabiand> #info oVirt 3.5
13:00:32 <fabiand> #info Other Items
13:00:55 <fabiand> #topic oVirt 3.5
13:01:03 <fabiand> #undo
13:01:03 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0x8b2662c>
13:01:14 <fabiand> Well, before we start a happy post-easter :)
13:01:44 <fabiand> And I hope you had some nice days.
13:01:48 <fabiand> #topic oVirt 3.5
13:01:56 <fabiand> This is actually the hottest item.
13:02:18 <fabiand> rbarry, jboggs - We've got three features on our list for 3.5
13:03:08 <fabiand> Let's go through each of them and check the status.
13:04:47 * fabiand just stretches the time a bit to give rbarry the chance for heads up ..
13:06:13 <fabiand> The let#s start with us, jbiddle__
13:06:17 <fabiand> jboggs, ^^
13:06:27 <fabiand> I can start with mine:
13:06:29 <jboggs> can you link me to the list
13:06:50 <fabiand> jboggs, sorry, link oyu to what list? :)
13:07:01 <jboggs> feature list
13:07:03 <jboggs> sorry :)
13:07:33 <fabiand> ah sure, just a sec
13:08:30 <fabiand> #link 3.5. feature list: https://bugzilla.redhat.com/buglist.cgi?quicksearch=875088 1038616 1053435
13:09:02 <fabiand> That is:
13:09:25 <fabiand> 875088 [RFE] ovirt-node-registration - a generic node registration (rbarry@redhat.com)
13:09:44 <fabiand> 1038616 [RFE] Support for hosted engine (jboggs@redhat.com)
13:10:07 <fabiand> 1053435 [RFE] oVirt virtual appliance (fabiand@redhat.com)
13:10:45 <jboggs> got it now
13:11:00 <fabiand> Basically I would like to summarize: wiki page status, the design idea and implementation status
13:11:35 <fabiand> Maybe I can start
13:11:56 <fabiand> #item 1053435 [RFE] oVirt virtual appliance (fabiand@redhat.com)
13:12:09 <fabiand> #item wiki page: http://www.ovirt.org/Feature/oVirtAppliance
13:13:08 <fabiand> For the design idea. Currently my state is that I am comming up with a kickstart which can be used by lmc (or imgfac) to generate an "image"
13:13:23 <fabiand> for now it's a plain qcow2 image, but the goal is to finally have an ova image.
13:13:38 <fabiand> There are three bigger parts I am looking at.
13:14:03 <fabiand> 1. Build process: Make sure it works with lmc and imgfac (actively maintained)
13:14:36 <fabiand> 2. Get a good platform ks -- I'm looking if I can leverage some Fedora kickstarts for other appliance like images to get a good package set.
13:14:47 <fabiand> 3. Engine specific configuration / installation
13:14:58 <fabiand> I've started on 1. and 2.
13:15:08 <fabiand> I've got a kickstart which can be turned into an image.
13:15:30 <fabiand> The imgfac people where helpful and provided some deatils on how to directly created a OVA from the ks in one pass (previously two passes).
13:15:38 <fabiand> Tho I have not tested it yet.
13:15:56 <fabiand> My draft repo is here:
13:15:58 <fabiand> #link https://github.com/fabiand/ovirt-appliance/
13:15:58 <jboggs> what's installed on the appliance, engine + node?
13:16:07 <fabiand> jboggs, only engine
13:16:27 <fabiand> The idea with that appliance is, that it is the "payload" for you feature :)
13:16:55 <fabiand> So basically you can take this oVirt Appliance (actually oVirt Engine Appliance) and provide it to Node, and node set's it up as a new VM.
13:16:56 <jboggs> ah ok yeah much easier to have it prebuilt in this case
13:17:00 <fabiand> yeah ..
13:18:21 <fabiand> jboggs, the good thing is also that you - or the hosted.engine plugin - doesn't need to exactly know what is needed for a correct Engine VM
13:18:25 <fabiand> basically it's split ..
13:18:53 <fabiand> Bottom line for now:
13:19:49 <fabiand> #item Status: Platform kickstart and lmc/imgfac can be used to build an image, Engine specific work is not started
13:20:07 <fabiand> jboggs, do you want to continue?
13:20:13 <fabiand> #item 1038616 [RFE] Support for hosted engine (jboggs@redhat.com)
13:20:22 <jboggs> #item wiki page: http://www.ovirt.org/Node_Hosted_Engine
13:21:02 <jboggs> Still need to revist again, there were some netowkring/setup issues when trying to complete the install, like the node had been fenced
13:21:28 <jboggs> Also when the node restarted, storage wasn't assembling correctly, due to vdsm configuration that we need to persist
13:21:55 <jboggs> and the vm network was unable to reach anything, likely just another persistance issue we need to capture
13:22:04 <fabiand> jboggs, where did the network not come up correctly?
13:22:13 <fabiand> jboggs, on the host or guest?
13:22:52 <jboggs> it's up but it's just not routing
13:23:10 <fabiand> on the host/node side?
13:23:24 <jboggs> engine vm
13:23:40 <jboggs> can reach the console via vnc but can't get to host/outside network
13:23:54 <fabiand> ah okay ..
13:24:11 <fabiand> jboggs, to start from the beginning
13:24:16 <fabiand> It sounds like you have a working plugin?
13:24:49 <jboggs> yes pending the remaining issues
13:25:03 <jboggs> was going to pickup again for F20
13:25:22 <fabiand> okay
13:25:34 <fabiand> And the plugin - adds a page to the TUI I guess, and pulls in some packages?
13:25:41 <fabiand> How is the setup triggered?
13:26:05 <clarkee_> v2v is fun.
13:27:10 <jboggs> triggered via a setup page. Also due to the ssh disconnect, screen is pulled in so you can reconnect if you timeout
13:27:24 <jboggs> via console not an issue
13:30:12 <fabiand> jboggs, nice the solution with using screen
13:30:25 <fabiand> jboggs, does the engine-setup also create the OS inside the VM?
13:30:38 <fabiand> or does it just create the VM container (so basically just the machine, not the OS)?
13:30:53 * fabiand just tries to get the whole picture
13:31:20 <jboggs> It runs the scripts provided by ovirt-hosted-engine-setup
13:31:26 <fabiand> #item Patch for feature is in gerrit: http://gerrit.ovirt.org/26201
13:31:43 <fabiand> okay ..
13:31:47 <jboggs> which creates the vm, you install it, setup the repos, install engine, then it registers the node to engine
13:31:57 <fabiand> okay ..
13:32:04 <jboggs> then swaps it over to a HA service to monitor it
13:32:07 <fabiand> thanks, that is insightful ..
13:32:14 <fabiand> oh okay .. nifty :-P
13:32:39 <jboggs> not our scripts if you were thinking that lol
13:32:47 <fabiand> jboggs, or doron, do you know if ovirt-hosted-engine-setup also takes a link to an appliance to setup the VM?
13:32:53 <fabiand> instead of letting the user manually create it?
13:32:58 <fabiand> jboggs, ;)
13:33:27 <fabiand> jboggs, do you know who works on the hosted-engine-setup?
13:36:06 <jboggs> fabiand, http://www.ovirt.org/User:Scohen according to wiki
13:36:30 <jboggs> fabiand, also sbonazzo
13:36:37 <fabiand> jboggs, ack thanks
13:36:50 <fabiand> because we should make sure that engine-setup can consume an appliance
13:37:19 <fabiand> #item Status: Plugin is available some issue with the guest networking
13:39:54 <doron> didi: can you remind me wat hosted engine setup can use for an image?
13:40:22 <doron> iirc ovf.
13:41:36 <doron> fabiand: jboggs ^^^^^^
13:42:02 <fabiand> doron, thanks
13:42:18 <fabiand> didi, yes, in general it's the question if "hes" can use an image
13:44:39 <fabiand> jboggs, okay - seems as if didi is busy :)
13:44:54 <fabiand> jboggs, thanks for this update
13:45:10 <xevilstar> tried alot of times same problem
13:45:14 <fabiand> seems as if rbarry ain't around, I'll try to catch up with hime via email ..
13:45:35 <xevilstar> the other two virtual machines are running
13:45:36 <fabiand> #action fabiand to follow up with rbarry on 3.5 feature
13:45:41 <xevilstar> I  create the third
13:45:49 <xevilstar> I create the disk
13:45:56 <xevilstar> I try to install
13:45:58 <fabiand> jboggs, could you drop an email to didi to see if hosted-engine-setup can take an image?
13:46:02 <xevilstar> the disk disappears
13:46:05 <jboggs> sure
13:46:23 <fabiand> jboggs, and could you the update the plugin to also take the image url and pass this to the steup?
13:46:49 <jboggs> will do
13:46:52 <fabiand> Thanks
13:47:00 <xevilstar> please help
13:47:19 <fabiand> #action jboggs to sync with didi on hosted-engine-setup and consuming appliance images
13:47:27 <fabiand> #topic Other Items
13:47:29 <jboggs> xevilstar, what's the problem?
13:48:11 <xevilstar> I have installed two virtual machines whose are  running
13:48:32 <fabiand> If there are no other items then I close this lengthy meeting :)
13:48:34 <xevilstar> i install the third
13:48:43 <xevilstar> add the disk to it with no error messages
13:48:45 <fabiand> Going once
13:48:57 <xevilstar> the disc disappears
13:49:08 <JC> Anyone know how I can get around the 8TB limit in the creation of VD's via the web interface?
13:49:12 <fabiand> twice
13:49:22 <xevilstar> when I launch run once
13:49:54 <fabiand> Thanks
13:49:56 <fabiand> #endmeeting