15:03:00 <doron> #startmeeting oVirt Weekly Sync
15:03:00 <ovirtbot> Meeting started Wed Apr  2 15:03:00 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:03:00 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:03:11 <doron> #topic Agenda and roll Call
15:03:12 <doron> #info infra update
15:03:14 <doron> #info 3.3 updates
15:03:15 <doron> #info 3.4 status
15:03:17 <doron> #innfo 3.5 planning
15:03:18 <doron> #info conferences and workshops
15:03:20 <doron> #info other topics
15:03:48 <doron> before we dive in
15:04:06 <doron> let me set the time for the meeting since we havd some DST errors here
15:04:36 <doron> Info starting next week meeting will be date -d 'WEDNESDAY 1000 EDT'
15:04:49 <apuimedo> doron: can we not set it at utc?
15:04:50 <doron> which should work for all...
15:05:16 <doron> apuimedo: so how do you want to set it?
15:05:57 <apuimedo> if it was set utc, it would not be so surprising when there's dst like changes happening
15:06:16 <apuimedo> each local time zone would only need to be aware of its own dst
15:06:22 <sbonazzo> date -d 'WEDNESDAY 1400 UTC'
15:06:46 * lvernia is here.
15:07:00 <doron> apuimedo: will date -d 'WEDNESDAY 1400 UTC' work for you?
15:07:05 <doron> lvernia: hi
15:07:07 * gtemple here
15:07:11 <doron> gtemple: hi
15:07:56 <apuimedo> sbonazzo: doron yes. Now it's 15:00 utc though. but 14h utc for the meeting series sounds good
15:07:57 <apuimedo> :-)
15:08:04 <doron> #Info starting next week meeting will be date -d 'WEDNESDAY 1400 UTC'
15:08:15 <doron> #topic infra update
15:08:23 <doron> dcaro: orc_orc here
15:08:25 <doron> ?
15:08:30 <sbonazzo> doron, action item, update the wiki meeting page
15:08:57 <doron> #action update wiki meeting page for meeting time.
15:09:10 <doron> dcaro: here?
15:09:25 <dcaro> doron: yep
15:09:36 <doron> dcaro: any highlights from infra this wek?
15:09:40 <doron> (week)
15:10:12 <dcaro> finally added the os1 slaves and fully working with them, that will enable us to expand vastly the number and oses of the slaves easily
15:10:45 <doron> #info infra team added new jenkins slaves based on os1.
15:10:45 <dcaro> and also finishing upgrade job, almost done (found an issue with yum groups too, we are currently troubleshooting)
15:11:14 <doron> #info infra finalizing upgrade job.
15:11:20 <doron> dcaro: thanks.
15:11:29 <doron> moving on.
15:11:30 <dcaro> doron: welcome :)
15:11:32 <doron> #topic 3.3 updates
15:11:45 <apuimedo> dcaro: any news about the pep8/pyflakes issue on some slaves
15:11:45 <doron> sbonazzo: do we have any 3.3.x expected?
15:11:57 <apuimedo> that fails the unit tests for vdsm
15:12:04 <sbonazzo> doron: yes, just released 3.3.5 RC
15:12:21 <doron> #info oVirt 3.3.5 RC released.
15:12:22 <sbonazzo> Release notes: http://www.ovirt.org/OVirt_3.3.5_release_notes
15:12:33 <doron> sbonazzo: when is the expected ga?
15:12:44 <dcaro> apuimedo: I remember we talked about that, and we are using the recommended pep8 in the wiki, but I don't remember how it ended, the issues are still there?
15:12:50 <sbonazzo> oVirt 3.3.5 GA scheduled for next week, 2014-04-09, as in http://www.ovirt.org/OVirt_3.3.z_release-management
15:12:50 <sbonazzo> No known blockers. No bugs targeted to 3.3.5 still open.
15:12:50 <sbonazzo> This should be last 3.3.z oVirt release.
15:13:37 <apuimedo> dcaro: for some slave I think so
15:13:42 <apuimedo> I'll check jenkins later
15:13:47 <sbonazzo> doron: ^
15:13:56 <doron> #info oVirt 3.3.5 GA scheduled for next week, 2014-04-09. This will be the last 3.3.x release as 3.4 already ga'ed.
15:14:11 <doron> sbonazzo: thanks.
15:14:29 <doron> #topic 3.4 status
15:14:33 <doron> sbonazzo: ?
15:14:47 <sbonazzo> oVirt 3.4.0 has been released last week
15:14:47 <sbonazzo> oVirt 3.4.z management page has been created: http://www.ovirt.org/OVirt_3.4.z_release-management
15:14:57 <sbonazzo> oVirt 3.4.1 timeline has been proposed as:
15:14:57 <sbonazzo> oVirt 3.4.1 RC Build: 2014-04-30
15:14:57 <sbonazzo> oVirt 3.4.1 General availability: 2014-05-07
15:15:05 <sbonazzo> itamar suggested to release RC one week earlier for having more time for handling blockers
15:15:05 <sbonazzo> I suggested to postpone GA by one week if we need more time, because the week before will be after Holidays on a lot of countries
15:15:05 <sbonazzo> and people will push pending changes in that week.
15:15:53 <doron> #info oVirt 3.4.0 has been released last week. Up next: oVirt 3.4.1 RC Build: 2014-04-30, oVirt 3.4.1 General availability: 2014-05-07
15:15:54 <sbonazzo> doron: pending decisions on the above dates
15:16:13 <doron> sbonazzo: earlier than 30?
15:16:24 <sbonazzo> rc earlier than 30 or ga later than 7
15:17:34 <doron> sbonazzo: I guess later than 7 will give us more time, but may add more noise?
15:19:19 <sbonazzo> doron: not sure. I've no strong feelings against having RC earlier but I feel like we'll have a lot of changes between RC and GA in that case
15:19:48 <doron> sbonazzo: very well, so let's to rc earlier.
15:20:15 <doron> s.to/do
15:20:25 <sbonazzo> doron: ok
15:21:06 <doron> #info 3.4.1 rc  date updated to 23-4-2014, to accomodate holidates.
15:21:14 <doron> sbonazzo: anything else on 3.4?
15:21:36 <sbonazzo> no
15:21:55 <doron> thanks. monig on
15:22:20 <doron> #topic 3.5 planning
15:22:40 <doron> ok, let's do a quick review of current areas state;
15:22:41 <jeffspeff> is there a way for ovirt to auto-assign an unused vm (let's say windows 7 vm's) when a client connects?
15:22:59 <doron> sahina: here for gluster?
15:23:09 <sahina> doron, hi.
15:23:24 <doron> sahina: hi. 3.5 updates?
15:24:01 <sahina> doron, 3.5 progress has been updated in the doc..2 in progress, others still at design stage
15:24:25 <doron> sahina: do you have everything scoped for 3.5 timeline?
15:25:15 <sahina> doron, 2 of the features - gluster quota and snapshot are to be scoped out
15:25:51 <doron> sahina: very well. you can remove dev owner if you do not plan to have them.
15:26:08 <sahina> doron, ok.
15:26:24 <doron> sahina: also, would you be able to have a quick review next week of your features in a separate session?
15:26:33 <doron> I will ask the same from everyone.
15:27:13 <sahina> doron, sure. review = what we are going to deliver?
15:27:37 <doron> sahina: yes. assuming you have a design in feature pages, review them.
15:27:47 <doron> could be irc or phone.
15:27:54 <doron> or if trivial email.
15:28:12 <sahina> doron, k..can do
15:28:17 <doron> sahina: thanks.
15:28:55 <doron> #info gluster will scope out 2 features from current planning. Additionally they will have a review session for relevant features.
15:29:01 <doron> moving to infra
15:29:14 <doron> who's here for infra?
15:30:07 <doron> I'll try again later.
15:30:17 <doron> sbonazzo: 3.5 integration updates?
15:30:48 <sbonazzo> doron: published the list of features we're working on on users mailing list
15:31:05 <sbonazzo> doron: all features page have been created
15:31:32 <sbonazzo> oVirt 3.5.0 release management page has been created http://www.ovirt.org/OVirt_3.5_release-management
15:31:32 <sbonazzo> Feature freeze: 2014-05-01
15:31:32 <sbonazzo> Branching: 2014-06-01
15:31:32 <sbonazzo> All remaining date still need to be decided.
15:31:32 <doron> sbonazzo: very well. any relevant risks / other issues?
15:31:51 <lmickh> hello, I setup a two hosted-engine hypervisors and then changed the datacenter and cluster name from Default.  Now I want to add another hosted-engine hypervisor, but it is still trying to add it to the Default cluster.  Is there a way around this on 3.3.1?
15:32:11 <sbonazzo> doron: we have a lot of holidays this month, time is the only risk IMHO
15:32:24 <doron> sbonazzo: very well, we'll track it.
15:32:56 <doron> #info integration team sent all feature pages for review in the ML. Currently time may be an issue.
15:32:59 <doron> sbonazzo: thanks
15:33:06 <doron> moving on to network
15:33:10 <lvernia> doron: Hi.
15:33:16 <doron> lvernia: welcome back.
15:33:19 <doron> 3.5 status?
15:33:20 <lvernia> doron: Thank you!
15:33:34 <lvernia> doron: Yeah, all features listed with an owner are indeed scoped for 3.5.
15:33:49 <lvernia> All are missing feature pages - will try to have them all published soon next week.
15:34:02 <lvernia> That is, early next week.
15:34:06 <apuimedo> lvernia: not missing, just in progress ;-)
15:34:11 <doron> lvernia: very well. will you have a review session next week?
15:34:36 <doron> apuimedo: I'd mention in progress anyway ;)
15:34:42 <lvernia> doron: I don't see a reason why not, but we should have the feature pages up first for people to be able to have a look ahead of time.
15:34:50 <lvernia> doron: So maybe towards the end of the week?
15:35:25 <doron> lvernia: right, but we do have a timeline. if you are missing something specific it's fine. but in general we should converge as this is a very short time before feature freeze....
15:35:47 <doron> so we should try to review the important / interesting features next week.
15:35:50 <lvernia> doron: So I will schedule a review for sometime next week, either way.
15:35:57 <doron> lvernia: thanks.
15:36:01 <lvernia> doron: Sure.
15:36:32 <doron> #info network 3.5 updates: scope is clear, feature pages in progress. A review session will take place next week.
15:36:40 <doron> fabiand: here for node?
15:37:13 <doron> I'll try again later.
15:37:21 <doron> sla...
15:38:08 <doron> #info sla 3.5 updates: most features are scoped. feature pages in progress. review session will be done next week.
15:38:20 <doron> who's here for storage?
15:38:26 <doron> amureini: here?
15:38:53 <doron> sgotliv: here?
15:39:13 <doron> will try later....
15:39:18 <doron> ecohen|mtg: here?
15:39:56 <ecohen|mtg> doron, well, in meeting, obviously... :)
15:40:02 <sgotliv> doron, I am on the openstack meeting
15:40:06 <ecohen|mtg> doron, no UX updates for 3.5.
15:40:24 <doron> sgotliv: this is problematic...
15:40:44 <doron> ecohen|mtg: do you have everything in place and will you have a review session next week?
15:40:54 <sgotliv> doron, I moved there from RHEV :-)
15:41:03 <doron> sgotliv: can you make sure we have someone from storage to report here?
15:41:14 <sgotliv> doron, will do my best
15:41:19 <doron> sgotliv: 10x
15:41:52 <ecohen|mtg> doron, not sure if I will have a review session next week - probably not needed. I will look into it and decide later on.
15:42:02 <sgotliv> doron, amureini will join in a sec
15:42:13 <doron> ecohen|mtg: very well, if so please mail your pges for review next wek?
15:42:18 <amureini> doron, amureini here for storage, sorry. damn calendar +dst = fail
15:42:19 <doron> sgotliv: thanks
15:42:27 <doron> amureini: I know.
15:42:38 <doron> amureini: storage 3.5 has all features scoped? \
15:43:12 <fabiand> doron, here
15:43:44 <ecohen|mtg> doron, sure
15:43:45 <doron> #info ux 3.5 updates: update will be sent to the ML. Currently no updates.
15:43:45 <amureini> doron, yes, google doc is updated with the infos. a few bzs still missing, but it's a filing gap, not a scoping gap
15:44:09 <doron> amureini: will you do a review session next week for storage features?
15:44:26 <apuimedo> dcaro: ping
15:44:32 <amureini> doron, yeah, sure.
15:44:41 <dcaro> apuimedo: pong, sup?
15:44:42 <amureini> doron, will send details to the ML
15:44:49 <doron> amureini: thanks. please make sure your feature pages are ready for the review.
15:44:58 <amureini> doron, ack
15:45:00 <apuimedo> dcaro: can you tell me where http://gerrit.ovirt.org/#/c/26373/ is?
15:45:19 <doron> #info storage 3.5 updates: currently closing planning gaps. A review will be done next week.
15:45:30 <doron> moving next to virt
15:45:34 <doron> mskrivanek: here/.
15:45:39 <doron> ?
15:45:43 <dcaro> apuimedo: where as in where the gerrit server? the git branch? the project?
15:46:00 <apuimedo> dcaro: sorry, what is the error cause?
15:46:07 <apuimedo> the patchset has a bug url
15:46:15 <dcaro> apuimedo: Bug-Url: ERROR, At least one bug-url is required for the stable branch
15:46:27 <doron> until we hear from mskrivaneklet's check with fabiand...
15:46:35 <fabiand> hey
15:46:35 <doron> fabiand: node 3.5 status?
15:46:41 <dcaro> apuimedo: the bug urls you introduced do not match the 'required' format: "Bug-Url: blablalba"
15:46:56 <apuimedo> dcaro: ah fuck
15:46:58 <fabiand> doron, Node has thre features, registration, hosted engine and virtual appliance (for the engine)
15:47:02 <apuimedo> missing a ':'
15:47:06 <apuimedo> pffff
15:47:16 <fabiand> doron, for the registration we need to sync with the vdsm/engine people
15:47:18 <dcaro> apuimedo: yep :)
15:47:28 <fabiand> doron, for the HE and virtual appliance we are on track ..
15:47:30 <apuimedo> dcaro: thanks!
15:47:30 <doron> fabiand: very well. do you have feature pages set for all?
15:47:39 <dcaro> apuimedo: you can edit the message through the ui
15:47:47 <mskrivanek> doron: yes
15:47:52 <fabiand> doron, they are .. in planning :)
15:47:57 <fabiand> doron, we'll have something for next week
15:48:00 <apuimedo> dcaro: it still says -1
15:48:02 <apuimedo> http://gerrit.ovirt.org/#/c/26373/2
15:48:07 <apuimedo> can you retrigger the hook?
15:48:15 <apuimedo> oh
15:48:18 <dcaro> apuimedo: I see no value
15:48:20 <apuimedo> it happened automatically
15:48:22 <apuimedo> good
15:48:24 <apuimedo> it took a bit
15:48:26 <apuimedo> :P
15:48:31 <doron> fabiand: very well, please run a review session next week to present the pages.
15:48:39 <dcaro> apuimedo: yep, it taks a few seconds, depends on the bugzilla response time mostly
15:48:47 <mskrivanek> doron: the time shift confused me, sorry. 3.5 virt is accurate on the planning spreadsheet
15:48:48 <doron> or more important the features...
15:48:53 <fabiand> doron, will do!
15:48:58 <doron> fabiand: thanks
15:49:24 <doron> #info node 3.5 updates: current planning is done. A review session will take place next week with updated pages.
15:49:33 <doron> mskrivanek: back to you with virt updates.
15:49:47 <apuimedo> dcaro: that's a long time then... Darned slooooooooow bugzilla
15:50:05 <doron> mskrivanek: looks like some bugs are missing, as well as feature pages.
15:50:27 <doron> mskrivanek: ?
15:50:35 <dcaro> apuimedo: yep, it'm not as fast as I'd like it either
15:50:43 <doron> lbianc: still here?
15:50:51 <lbianc> hi doron
15:51:03 <doron> lbianc: hi! do you have ppc planning for 3.5?
15:51:59 <mskrivanek> doron: yes, some of them. Not many feature pages, they are mostly nits
15:52:00 <lbianc> No, no new features for 3.5. We will be around till the patches that block missing features for ppc64
15:52:17 <doron> lbianc: thanks.
15:52:34 <mskrivanek> doron: there are still couple of lines unassigned, but nothing major. volunteers welcome:-)
15:52:34 <doron> #info PPC for 3.5: no new features planned.
15:52:36 <lbianc> doron: thanks!
15:52:53 <doron> mskrivanek: will you have a review session next week with the updated pages?
15:54:09 <doron> mskrivanek: ?
15:54:10 <mskrivanek> once all people do what they are supposed to do we can do that
15:54:23 <mskrivanek> actually it's just ~5 bugs still not opened
15:54:35 <mskrivanek> but I suppose not all of them have proper doc text:/
15:54:41 <mskrivanek> yet
15:55:07 <doron> mskrivanek: we should target next week aswe have feature freeze soon
15:55:17 <doron> mskrivanek: at least for major features.
15:55:24 <mskrivanek> however I do not expect more feature pages, maybe for virtio-rng...but that's about it, rest are nits
15:55:58 <doron> mskrivanek: it's about feature review. so it's ok if you do not have everything there, even though it is getting late for big features.
15:56:18 <mskrivanek> the big ones have feature pages, all of them (well, it's just instance types really)
15:56:33 <doron> mskrivanek: very well. So will you have a review session next week?
15:57:22 <mskrivanek> I may have missed that....so are we doing them globally? per team? The feedback from last time was.,.it varied:)
15:57:51 <doron> mskrivanek: per team, next week. so in your case you should review virt features.
15:57:58 <mskrivanek> ok, fine
15:58:01 <doron> mskrivanek: you should set the time.
15:58:07 <doron> thaks
15:58:39 <doron> #info virt 3.5 updates: mostly scoped, minor issues still in progress. Review session will be set for next week.
15:59:18 <doron> #info infra missing a representative. Please update offline and have a review session next week.
15:59:31 <doron> sbonazzo: anything else for 3.5?
16:00:02 <sbonazzo> doron: only the pending dates, still not assigned for milestones
16:00:19 <doron> sbonazzo: let's discuss it over the ml?
16:00:24 <sbonazzo> doron: ok
16:00:29 <doron> sbonazzo: thanks.
16:00:32 <doron> movingon
16:00:39 <doron> #topic conferences and workshops
16:00:54 <doron> so I got bkp|afk 's updates offline;
16:01:05 <doron> #info oVirt will be represented at the Summit Developer Lounge at Red Hat Summit by bkp, and ovedo will be speaking at DevNation.
16:01:27 <doron> #info on FISL: In addition to two sessions at FISL, we get to do an oVirt community update session. There will also be oVirt discussions at a Red Hat dojo in Sao Paulo before FISL.
16:01:44 <doron> other events- ovedo is planning on doing a Docker integration presentation at DockerConf in London on June 6, and bkp has submitted the same presentation for the DockerCon event the next week in San Francisco.
16:01:49 <doron> gchaplik_ has submitted a talk on "SLA and Scheduling in opensourced virtualization world" for Open Source Bridge in Portland June 24-27.
16:02:14 <doron> The CfP emails seem to be working, as bkp is getting a lot more interest from individuals.
16:02:26 <doron> and this is it from bkp.
16:02:30 <doron> moving on
16:02:36 <doron> #topic other topics
16:02:46 <doron> bkp is about finished with cataloging all of the Features pages on the wiki, and will be launching a community project to do some Spring Cleaning on them this week.
16:03:02 <doron> #info Mirroring still proceeds, with dcaro's able assistance. Expecting links from three more mirror sites soon.
16:03:11 <doron> #info
16:03:14 <doron> #info The slowness of the wiki has been noted, and bkp is investigating.
16:03:21 <doron> bkp is working with another OSAS team member to derive a plan to get solid download numbers for oVirt using pattern-based analysis from the logs. Will make more progress on this after Summit.
16:03:39 <doron> this is it. anyone wants to discuss something?
16:03:52 <doron> or raise something?
16:04:10 <doron> going once?
16:04:56 <doron> going twice...
16:04:57 <ecohen|mtg> will there an ovirt weekly status meeting calendar invitation sent?
16:05:13 <doron> ecohen|mtg: sbonazzosent it, he can resend if needed.
16:05:26 <doron> ecohen|mtg: also there's a wiki page for all meetings.
16:05:42 <doron> ecohen|mtg: do you want an emaili with a calendar link?
16:06:10 <ecohen|mtg> doron, not sure.. I don't have that meeting in my calendar... does anyone else have it?
16:06:31 <doron> ecohen|mtg: you can add the google ical which is being updated
16:06:46 <ecohen|mtg> doron, ok. thanks.
16:06:48 <psebek> What about Google Summer of Code proposals?
16:07:02 <doron> sbonazzo: can you resend the calendar link?
16:07:16 <doron> psebek: good point. I'll ask bkp to mail updates.
16:07:34 <doron> #action bkp to send updates to the list on GSoC status.
16:07:49 <sbonazzo> doron: surehttps://www.google.com/calendar/ical/ppqtk46u9cglj7l987ruo2l0f8%40group.calendar.google.com/public/basic.ics
16:08:11 <doron> #info oVirt calendar link: https://www.google.com/calendar/ical/ppqtk46u9cglj7l987ruo2l0f8%40group.calendar.google.com/public/basic.ics
16:08:18 <doron> ecohen|mtg: ^^^^^^^
16:08:28 <doron> anything else?
16:08:33 <ecohen|mtg> doron, many thanks.
16:08:57 <doron> ecohen: that's all sbonazzo's hard work.
16:09:09 <ecohen> sbonazzo, many thanks :)
16:09:50 <doron> going once?
16:10:29 <doron> going twice...
16:11:11 <doron> Just reminding you all next week we'll be back to 14:00 UTC.....
16:11:27 <doron> Thanks all for joining!
16:11:30 <doron> #endmeeting