15:13:29 <fabiand> #startmeeting oVirt Node Weekly Meeting
15:13:29 <ovirtbot> Meeting started Tue Mar 18 15:13:29 2014 UTC.  The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:13:29 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:13:36 <fabiand> #chair jboggs rbarry
15:13:36 <ovirtbot> Current chairs: fabiand jboggs rbarry
15:13:40 <fabiand> #topic Agenda
15:13:41 * rbarry here
15:13:42 * jboggs here
15:13:47 <fabiand> Let's make it short today
15:13:55 <fabiand> #info Release planning
15:14:05 <fabiand> #info Fedora 20 status
15:14:07 <fabiand> #info Jenkins
15:14:12 <fabiand> #info Other items
15:14:28 <fabiand> #topic Release planning
15:14:39 <fabiand> here are a couple of changes we could use for 3.0.5 ..
15:14:46 <fabiand> and 3.0.4 seems to be quite stable ..
15:14:58 <fabiand> So I'd like to slowly start to prepare for 3.0.5
15:15:18 <fabiand> #info Slowly prepare 2.0.5 with stabilizing patches
15:15:30 <fabiand> One thing I'd like to address ith 3.0.5 is to bring our Fedora based builds back ..
15:15:34 <fabiand> People asked for them ..
15:15:52 <fabiand> #info Re-Add Fedora based Node's with 3.0.5 ..
15:16:14 <fabiand> I don't want to include any features into 3.0.5 ..
15:16:25 <fabiand> If that's fine, then I'd move on to the next item
15:17:11 <rbarry> It currently has SELinux problems
15:17:36 <fabiand> #topic Fedora 20 status
15:17:39 <rbarry> Rather, new fedora builds do. But that's an ongoing problem anyway, and I'll hopefully ahve a patch today
15:17:42 <fabiand> rbarry, you mean the f20 build?
15:18:02 <rbarry> See also, https://bugzilla.redhat.com/show_bug.cgi?id=1068740
15:18:30 <rbarry> Fedora 19 also has SELinux problems on new builds at present. Something with localed or logind. I'm just about to test another image.
15:19:07 <rbarry> There's a fix for dracut in rawhide, but no new kernels (including new F19 builds) will be able to PXEboot newly built node ISOs
15:19:07 <fabiand> yeah
15:19:21 <fabiand> The selinux problems - and upgrades to the policy - prevented me from doing the F19 builds
15:19:32 <fabiand> rbarry, oh - so it really is a dracut problem?
15:19:46 <rbarry> Yeah. Well, it's a kernel problem that dracut has to work around.
15:19:54 <fabiand> oh okay
15:20:04 <rbarry> But dracut 036 is only in rawhide. We'll probably have to ask them to backport to at least F20
15:20:31 <fabiand> rbarry, can you say which patch needs to be backported?
15:21:06 * fabiand read the bug
15:21:26 <rbarry> Comment #2 from the bug, it looks like. http://git.kernel.org/cgit/boot/dracut/dracut.git/commit/?id=ba9368fa4fedda0f72d84f910d01d7da201405a3
15:22:25 <fabiand> Okay,
15:22:46 <fabiand> rbarry, does the F20 build boot at all when you use enforcing=0?
15:23:28 <rbarry> Both F20 and F19 boot with enforcing=0. But users can't log in, and the installer hangs as soon as you click the first button and start the locale service.
15:23:47 <fabiand> rbarry, they even can't login with enforcing=0?
15:23:55 <rbarry> Yes, they can with enforcing=0.
15:24:10 <fabiand> okay
15:24:12 <fabiand> that is good news
15:24:22 <fabiand> I could take a look at the selinux problems ..
15:24:33 <fabiand> Or do you want to tackle them :)?
15:25:07 <rbarry> I'm pretty confident that I can tackle them, but I'll ping you if I run into trouble
15:25:20 <fabiand> ack great!
15:25:32 <fabiand> rbarry, could you publish them in a f20 topic branch in gerrit
15:26:31 <rbarry> Sure. Though they're also applicable to f19, so I'm not sure if a f20 branch is appropriate, though it may make them easier to track
15:26:53 <fabiand> Yes, I agree that they might be relevant for F19 as well.
15:27:09 <fabiand> But do we agree that we only want to support one Fedora version?
15:27:27 <fabiand> I mean Fedora 20 has been out for a while now - and I know that it has issues with gfx, btu maybe it's stable enough for node?
15:28:00 <fabiand> I would like to avoid bringing Node into shape for F19 and directly jump to f20. .
15:28:00 <jboggs> may be best, getting other potential backports on 19 might be much harder
15:28:03 <rbarry> If there's a working vdsm version for Fedora 20, I'm happy to move to 20
15:28:10 <fabiand> Yep
15:28:42 <fabiand> looking here http://plain.resources.ovirt.org/releases/3.4.0-rc2/rpm/Fedora/
15:28:44 <fabiand> it seems as if there are
15:28:55 <fabiand> even more detailed:
15:28:56 <fabiand> http://plain.resources.ovirt.org/releases/3.4.0-rc2/rpm/Fedora/20/x86_64/
15:30:19 <fabiand> rbarry, I'd rather like us to start working on f21 support early ..
15:30:33 <fabiand> so basically: skip f19, have f20 support, and then maybe start on playing with rawhide ..
15:30:52 <fabiand> so basically not running behind, but keeping slightly the same schedule ... which won't be possibel.
15:31:24 <fabiand> but fedora 19 was released on July 2nd 2013 which is already quite old ..
15:36:19 <rbarry> No objections
15:36:26 * jboggs neither
15:36:53 <fabiand> okay
15:38:42 <fabiand> Let's see how it goes ..
15:39:01 <fabiand> #topic Jenkins
15:42:04 <fabiand> Jenkins is two fold
15:42:09 <fabiand> Our current jobs
15:42:14 <fabiand> and support for the Fedora builds we plan...
15:42:33 <fabiand> But I'd favor to push this out now a bit - to next week
15:43:30 <fabiand> It's not critical and let's see if we have a working F20 build available before we update jenkins ..
15:43:36 <fabiand> sounds if selinux prevents us a bit
15:43:53 <fabiand> otoh I'll once again ask infra to enable selinux in permissive mode on the builders
15:44:05 <fabiand> #action fabiand to ask infra to at least enable selinux in permissive mode ..
15:44:16 <fabiand> #topic Other items
15:44:23 <fabiand> anything else rbarry jboggs ?
15:44:28 * jboggs is taking a look at hosted engine support
15:44:28 <rbarry> Nothing here
15:44:38 <rbarry> Ah, yes. Gluster working
15:44:44 <jboggs> will likely be a plugin is fs size is an issue
15:44:56 <fabiand> rbarry, gluster is working!?
15:44:57 <fabiand> :)
15:44:58 <rbarry> I'll put together a quick plugin page, but all it took was a few iptables rules
15:45:09 <fabiand> rbarry, great news!
15:45:14 <fabiand> I know that people were looking for it!
15:45:27 <fabiand> jboggs, sorry could you elaborate
15:45:30 <rbarry> I don't have a gluster ovirt domain to test with, but I was able to mount the volume on another system and place files which were replicated
15:45:31 <rbarry> On /data
15:45:40 <fabiand> #info glsuerfs will work with some iptables updates and might get even a plugin
15:45:57 <fabiand> rbarry, okay - that's nice to have the basics!
15:46:09 <fabiand> #info glusterfs basics have been tested by rbarry
15:46:25 <jboggs> looks like it's pulling in some pulseaudio dependencies, just wouldnt want to have those in the the base image, possible blackisting, just now looking so there will likely be some optimizations
15:46:40 <fabiand> okay, jboggs what pulled in pulse audio?
15:46:48 <jboggs> ovirt-hosted-engine-setup
15:46:59 <fabiand> ugh ... the gain more and more features :)
15:47:38 <fabiand> jboggs, could you see if it was a direct dependency or did it happen indirect through some other pkg=?
15:47:41 <jboggs> its about 9MB in rpm format, hopefully it can remain compressed like that and no worries
15:47:56 <jboggs> yeah will look, working on POC for now :)
15:48:18 <fabiand> nce
15:48:28 <fabiand> #info jboggs started to work on hosted engine support
15:48:53 <fabiand> jboggs, I thought about whether we should you an installer page or setup page to setup the hosted engine stuff
15:49:08 <fabiand> My final thought was to use the setup - so adding a setup page
15:49:19 <jboggs> you would need networking support so yeah setup would be best
15:49:32 <fabiand> The reasoning behind it was - a setup page can be used to initiate the hosted engine and additionally it can provide stats about the VM carrying the engine
15:49:38 <fabiand> agreed!
15:50:53 <fabiand> So - interestng other items part today!
15:51:07 <fabiand> I fthere is nothing else ...
15:51:14 * jboggs is good
15:52:07 <fabiand> I hope rbarry is good too
15:52:11 <fabiand> Going once
15:52:11 <rbarry> Also good
15:52:13 <fabiand> twice
15:52:15 <fabiand> ah
15:52:20 <fabiand> and a third time
15:52:21 <fabiand> #endmeeting