15:10:42 <knesenko> #startmeeting oVirt Infra
15:10:42 <ovirtbot> Meeting started Mon Mar 17 15:10:42 2014 UTC. The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:42 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:10:52 <knesenko> #chair bkp ewoud dcaro
15:10:52 <ovirtbot> Current chairs: bkp dcaro ewoud knesenko
15:11:20 <knesenko> #topic Hosting
15:11:32 <knesenko> ewoud: hey .... we have a good news from rackspace
15:11:48 <knesenko> ewoud: rackspace03 was moved to the same vlan as other hosts
15:12:04 <knesenko> ewoud: dcaro I think it will be a good idea to use it as hypervisor
15:12:12 <knesenko> ewoud: and create new slaves on it
15:12:23 <knesenko> #info rackspace03 was moved to another vlan
15:12:29 <knesenko> thoughts ?
15:12:34 <dcaro> knesenko: agree
15:12:51 <knesenko> ewoud: ?
15:13:21 <dcaro> knesenko: though it does not have loads of free space
15:13:43 <knesenko> dcaro: can you try to create the ovirtmgmt bridge on ti ?
15:13:43 <knesenko> it
15:13:48 <knesenko> and I will install it ...
15:13:49 <knesenko> ?
15:13:52 <dcaro> knesenko: ok
15:13:59 <knesenko> dcaro: I don't have vpn to drac
15:14:03 <knesenko> dcaro: ok thanks
15:14:17 <knesenko> #action dcaro setup ovirtmgmt bridge on rackspace03 host
15:14:26 <knesenko> ewoud: here ?
15:15:49 <knesenko> ok
15:15:55 <knesenko> lets continue
15:16:22 <knesenko> dcaro: I assume we want to install/reinstall some slaves once ewoud will setup pxe server there , gith ?
15:16:24 <knesenko> right ?
15:17:10 <dcaro> yep, we wanted to reprovision some of them
15:17:40 <knesenko> #action reprovision slaves once PXE is ready on rackspace env.
15:17:53 <knesenko> also we have some HD space there .... so we can use it as well
15:18:16 <dcaro> we have 1 TB on rackspace01 and nother on on 02
15:19:03 <knesenko> dcaro: hm ...
15:19:12 <knesenko> dcaro: and what about 3 ?
15:19:33 <dcaro> knesenko: it does not have that TB, that's only on 01 and 03
15:20:11 <knesenko> dcaro: so we can create powerful VMs on 1 and 3
15:20:21 <knesenko> dcaro: to handle builds like engine, and ovirt-node
15:20:23 <ewoud> knesenko: sorry, here now
15:20:28 <dcaro> knesenko: sorry, only on 01 and 02
15:21:36 <ewoud> knesenko: what IPs can I set up the DHCP server to use?
15:21:49 <knesenko> dcaro: same same
15:21:55 <ewoud> knesenko: or just set up the subnet and only manually pick IPs from that subnet?
15:22:07 <knesenko> ewoud: I"ll need to find that info in their ticketing system....
15:22:28 <knesenko> ewoud: we need a specific IPs .... for the translation rules
15:22:37 <ewoud> knesenko: I think I can set it up without that info so we can at least reprovision the existing VMs
15:22:51 <knesenko> ewoud: ok
15:23:01 <knesenko> ewoud: anyway I will send you email with the info
15:23:06 <ewoud> knesenko: cool
15:23:25 <knesenko> #action knesenko send email to ewoud regarding slaves IP information
15:24:32 <knesenko> ok
15:24:34 <knesenko> next
15:24:41 <knesenko> #topic Foreman and Puppet
15:24:46 <knesenko> anything new here ?
15:25:05 <ewoud> not really I think
15:25:17 <ewoud> smartproxy to set up at rackspace was just discussed
15:25:33 <knesenko> right
15:25:41 <knesenko> ok
15:25:47 <knesenko> so nothing new here
15:25:54 <knesenko> #topic Jenkins
15:26:00 <knesenko> ok we have some news here
15:26:22 <knesenko> #info fc20 builds were disabled for 3.3 snapshots
15:26:45 <knesenko> #info repoclosure jobs were added per snapshot
15:26:51 <knesenko> dcaro: anything else ?
15:28:35 <dcaro> knesenko: We added a small snippet of groovy code to a couple of jobs so when there's a build error it will go Unstable and any other error (infra) Failed, so we can block a patch when build error and warn the devel to ping us when infra error
15:28:49 <knesenko> dcaro: great
15:29:05 <dcaro> and I've started to think how to move to yaml
15:29:08 <knesenko> also we fixed all vdsm jobs
15:29:12 <knesenko> dcaro: right ? :)
15:29:16 <knesenko> dcaro: wow !!!
15:29:22 <knesenko> dcaro: that will be awesome
15:29:24 <dcaro> xd
15:29:44 <knesenko> dcaro: I would like to help
15:29:58 <knesenko> dcaro: I want to handle Packaging jobs ...
15:30:10 <knesenko> dcaro: great time to make some changes
15:30:57 <dcaro> knesenko: ok, but we don't have the infra setup yet to support it (jenkins-job-builder and such) I'll let you know when it's there
15:31:19 <knesenko> dcaro: I CAN HELP WITH THAT ONE AS WELL
15:31:25 <knesenko> sorry .... CAPS
15:31:26 <knesenko> :)
15:31:27 <knesenko> ok
15:31:29 <knesenko> great
15:31:57 <knesenko> #topic Other Issues
15:34:27 <knesenko> anything we want to discuss here ?
15:34:55 <eedri_> knesenko, did we disucsssed new people
15:34:57 <eedri_> knesenko, for infra team?
15:35:19 <eedri_> knesenko, and adding ssh access to slaves?
15:35:22 * dcaro got scared.... don't yell... xd
15:35:23 <knesenko> eedri_: fabiand is not in the meeting ... so we will do it next time
15:35:28 * eedri_ sorry for jumping in late
15:35:37 <knesenko> ssh for slaves - no
15:35:50 <knesenko> #chair eedri_
15:35:50 <ovirtbot> Current chairs: bkp dcaro eedri_ ewoud knesenko
15:36:02 <eedri_> knesenko, also someone asked me about wiki updates
15:36:05 <eedri_> bkp, ^
15:36:16 <bkp> Working on that now.
15:36:18 <eedri_> knesenko, saying lots of stuff are outdated,
15:36:43 <bkp> Going to try to have a script add the "last modified" information to the wiki pages
15:37:07 <knesenko> bkp: we need a policy on when and what should be updated
15:37:09 <eedri_> bkp, +1
15:37:10 * Rydekull is here o7
15:37:22 <eedri_> bkp, maybe jenkins jobs that checks outdates pages?
15:37:31 <knesenko> bkp: like .... we released a new version ... what should be updated .... how ? template etc...
15:37:32 <eedri_> bkp, over a month old or something on specific pages
15:37:45 <knesenko> Rydekull: hey man !what's up
15:37:47 <eedri_> bkp, can send alert to infra
15:37:50 <knesenko> welcome to the party
15:37:52 <eedri_> dcaro, possible right?
15:38:04 <eedri_> dcaro, checking with curl/wget http headers
15:38:06 <bkp> I'm good with all of that. Though I would need help on the implementation
15:38:21 <eedri_> bkp, i'm guessing its very simple to do an http query on it
15:38:26 <eedri_> bkp, and just getting last update date
15:38:42 <Rydekull> knesenko: just had a meeting with people and going through a build and finding out that during the builds life it called bash 38k times, mkdir 23k times. Which was kinda funny to me
15:39:02 <bkp> That, or pull the value from the wiki page itself.
15:39:10 <dcaro> eedri_: anything is possible! yes, it should be rather easy
15:39:24 <knesenko> Rydekull: :) heh
15:39:28 <eedri_> dcaro, that's the spirit!
15:39:29 <bkp> Want me to draft a policy?
15:39:41 <eedri_> bkp, yes please, like which pages should we monitor
15:39:55 <bkp> What? Not *.* ?
15:39:57 <bkp> :)
15:39:59 <eedri_> bkp, i'm sure anyone from infra can assist in bringing that up
15:40:08 <eedri_> bkp, should be failry easy script
15:40:13 <bkp> Acknowledged.
15:40:34 <eedri_> bkp, maybe there's even an opensource project that does that
15:40:36 <dcaro> bkp: try to restrict it to our wiki also... xd
15:40:37 <eedri_> bkp, or jenkins pluigin
15:40:42 * eedri_ looking
15:40:46 <bkp> Still implementing the user-facing last modified info, though
15:40:55 <Rydekull> why not just query the db?
15:41:24 <bkp> Well, mediawiki has a special page that pulls up ancient pages.
15:41:25 <dcaro> knesenko: ovirtmgmt interface up and running, rebooted also to make sure it works
15:41:33 <eedri_> found this https://wiki.jenkins-ci.org/display/JENKINS/SiteMonitor+Plugin
15:41:36 <bkp> So presumably we could tweak the parameters
15:41:38 <eedri_> but's more to check if site is up/down
15:42:19 <knesenko> dcaro: +!
15:42:22 <knesenko> dcaro: thanks man
15:42:30 <knesenko> dcaro: installing it is in my queue
15:42:49 <bkp> eedri_: http://www.ovirt.org/Special:AncientPages
15:43:04 <dcaro> bkp: eedri_ I'm not sure if it's worth using a plugin, the script should be as easy as curl | egrep or python requests.get + re.match... as far as I've understood
15:43:16 <dcaro> bkp: nice!
15:43:21 <eedri_> bkp, nice
15:43:28 <eedri_> bkp, so it's even simpler than i thought
15:43:33 <bkp> It's been there.
15:43:36 <eedri_> bkp, just a cron job sending this list to infra once a week
15:43:52 <dcaro> but those are all the pages
15:43:53 <bkp> But yeah, we can use this and pipe to a cron job
15:44:06 <eedri_> bkp, though it could be too much pages
15:44:17 <eedri_> bkp, might worth trimmied it down to pages that needs updating
15:44:18 <bkp> dcaro eedri_ Yes, it would be.
15:44:52 <bkp> I may be able to create a version of this page that lists by date *and* category
15:45:07 <bkp> So, list *just* old Feature pages, for example
15:45:28 * Rydekull still feels querying/modifying db would be easier
15:45:35 <dcaro> xd, rabid dogs with lasers and chainsaws....
15:45:40 * dcaro is discovering old pages
15:47:02 <Rydekull> oh well, times up, next meeting is due. See you.
15:48:05 <dcaro> depends on how many pages, querying with curl/wget is a lot more easier to implement and maintain than querying the db imo (access to the host, to the database, read-only user, database table names...)
15:48:12 <dcaro> Rydekull: cya!
15:49:22 <bkp> Quick question, somewhat on topic: what version of mediawiki are we using?
15:49:34 <knesenko> if there is nothing official here, I would like to finish the meeting ...
15:49:49 <bkp> I'm good.
15:50:58 <dcaro> I'd like to raise that we lack monitoring, and I'd like to get it automated (so we really know what fails and when, instead of going fighting fires when devels tell you something is broken)
15:51:17 <knesenko> dcaro: yes I agree
15:52:52 <knesenko> #endmeeting