15:10:44 <doron> #startmeeting oVirt Weekly Sync
15:10:44 <ovirtbot> Meeting started Wed Feb 19 15:10:44 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:10:44 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:10:47 <doron> bkp: morning
15:11:00 <doron> #topic Agenda and roll Call
15:11:01 <doron> #info infra update
15:11:03 <doron> #info 3.3 update releases
15:11:04 <doron> #info 3.4 progress
15:11:06 <doron> #info conferences and workshops
15:11:07 <doron> #info other topics
15:11:09 <doron> #topic infra update
15:11:16 <doron> let's s tart with infra, dcaro here?
15:11:30 <doron> orc_orc: ?
15:12:25 <doron> no one here from ovirt infra?
15:12:37 <dcaro> doron: I'm around
15:12:54 <doron> hi dcaro updates?
15:13:05 * orc_orc is here
15:13:30 <doron> dcaro: and orc_orc, feel fee to update on ovirt infra.
15:13:40 <orc_orc> ovirt infra update ... minutes are at: http://ovirt.org/meetings/ovirt/2014/ovirt.2014-02-17-15.11.html
15:13:41 <dcaro> Just fixed the engine_upgrade_params job, and the scheduler proxy gerrit. Added new slave
15:13:55 <dcaro> rackspace03
15:13:57 * danken is here
15:14:22 <doron> dcaro: sounds good. any specific issues?
15:14:26 * sbonazzo here
15:14:45 <dcaro> doron: it was not preparing the database properly at the initialization of the job
15:14:59 <doron> #info infra meeting summay: http://ovirt.org/meetings/ovirt/2014/ovirt.2014-02-17-15.11.html
15:15:12 <doron> dcaro: very well.
15:15:13 <dcaro> scheduler-proxy was starting some extra builds that were not needed and failed
15:15:39 <doron> very well, thanks for the updates.
15:15:45 <dcaro> welcome :)
15:15:47 <doron> if nothing critical we'll move on.
15:15:55 <doron> #topic 3.3 releases update
15:16:00 <doron> sbonazzo: 3.3 updates?
15:16:20 <sbonazzo> doron: 3.3.4 beta has been released today
15:16:37 <doron> sbonazzo: *3.3.x* updates?
15:16:51 <sbonazzo> doron: dwh and node may be respinned before RC
15:17:45 <doron> sbonazzo: rc of 3.4?
15:18:00 <sbonazzo> rc of 3.3.4
15:18:14 <doron> sbonazzo: any 3.3.x updates?
15:18:20 <doron> before we move to 3.4.
15:18:34 <sbonazzo> doron: no blockers for now, so we should respect the schedule
15:19:04 <doron> sbonazzo: your are referring to 3.4. I'm asking on 3.3.
15:19:21 <sbonazzo> doron, please wait :-) I'm talking about 3.3.4 beta 1
15:19:42 <Mossel> hi
15:19:45 <sbonazzo> doron: we'v eno blockers for 3.3.4 so it should respect the schedule
15:19:54 <doron> sbonazzo: ok. thanks
15:20:01 <sbonazzo> doron: 3.3.4 will have a node iso respin and probably a dwh respin
15:20:23 <doron> #info no blockers for 3.3.4. currently on track. 3.3.4 will have a node iso respin and probably a dwh respin
15:20:42 <doron> sbonazzo: anything else?
15:21:12 <sbonazzo> doron: not for 3.3.z
15:21:26 <doron> sbonazzo: thanks. let's move on.
15:21:35 <doron> #topic 3.4 progress
15:21:41 <sbonazzo> doron 3.4.0 beta3 announced today
15:21:54 <sbonazzo> doron: Rc postponed by one week, test day too
15:22:10 <sbonazzo> doron: we had too many blockers for a RC
15:22:10 <doron> #info 3.4.0 beta 3 announced today. RC postponed by one week, test day too.
15:22:23 <doron> sbonazzo: how many blockers do we have today?
15:22:42 <sbonazzo> doron: 10
15:22:49 <sbonazzo> doron: 1 on new and 9 on post
15:23:16 * doron checking
15:23:56 <doron> who do we have here from storage?
15:24:13 <doron> abaron: here?
15:24:18 <itamar> doron: where can one fine 3.3.x ovirt node iso?
15:24:41 <ecohen> sbonazzo, doron - where can I see 3.4 blockers? I would like to add another one.
15:24:56 <doron> ecohen: https://bugzilla.redhat.com/showdependencytree.cgi?id=1024889&hide_resolved=1
15:25:20 <ecohen> doron, ok, so it is by a tracker bug - thanks.
15:25:40 <doron> ecohen: yes and we have a new storage blocker
15:26:19 <doron> sbonazzo: since no response from storage, and we need an answer for other bugs
15:26:46 <doron> please email the list to devel list, cc bug assignee asking for ETA. OK?
15:27:04 <doron> we need these in a better shape for the RC.
15:27:22 <sbonazzo> itamar: 3.3.4 beta are here: http://resources.ovirt.org/releases/beta/iso/
15:27:50 <doron> sbonazzo: can you handle it?
15:27:50 <sbonazzo> doron: ok, please add an action item on that
15:28:00 <amureini> doron, which new storage blocker?
15:28:22 <doron> amureini: https://bugzilla.redhat.com/show_bug.cgi?id=1057761
15:28:42 <doron> #action sbonazzo to mail devel list and blocker assignees asking for ETA.
15:29:13 <itamar> doron: easier report for (open) blocker bugs: http://alturl.com/ie3wk
15:29:40 <amureini> doron, 10x for the link; under investigation
15:30:04 <doron> amureini: thanks. please update if this will not make it to RC next week.
15:30:10 <doron> itamar: thanks for the link.
15:30:29 <doron> #info open 3.4 blockers: http://alturl.com/ie3wk
15:30:47 <doron> let's do a quick run on all groups for 3.4 updates.
15:30:56 <danken> amureini: there's nothing much we can do regarding selinux - besides convincing them to release a fix asap
15:31:08 <doron> sahina: any updates from Gluster on 3.4 items?
15:31:22 <danken> amureini: otherwise, no iscsi on Fedora.
15:31:30 <sahina> doron, no.
15:31:38 <doron> sahina: thanks
15:31:52 <doron> #info Gluster have no 3.4 updates.
15:32:04 <doron> ybronhei: here?
15:32:10 <ybronhei> doron: yep
15:32:15 <danken> doron: do we have someone with good connections with selinux folks?
15:32:15 <doron> ybronhei: 3.4 updates?
15:32:24 <ybronhei> doron: snmp is in since last night
15:32:31 <danken> all we need for that selinux blocker is a backport
15:32:46 <doron> danken: we can check for the rlevant person.
15:32:53 <ybronhei> doron: will be backported to 3.4 asap
15:32:53 <doron> ybronhei: yey!
15:33:02 <doron> ybronhei: anything else?
15:33:39 <ybronhei> doron: nop. all features are done.
15:33:45 <doron> ybronhei: thanks
15:33:53 <ybronhei> doron: fyi, http://gerrit.ovirt.org/#/q/topic:snmp-notifier+status:merged,n,z
15:34:09 <doron> #info infra 3.4 updates: snmp in master. Currently being ported to 3.4.
15:34:31 <doron> sbonazzo: integration 3.4 updates?
15:34:52 <doron> ybronhei: good job.
15:35:06 <sbonazzo> doron: we're still working on closing bugs and busy with releases composition
15:35:17 <sbonazzo> doron: this week we're also understaffed due to sikness
15:35:22 <ybronhei> doron: its not me.. but thanks from the rest of the team :)
15:35:36 <doron> ybronhei: you're representing them.
15:35:52 <sbonazzo> doron: no other news from integration
15:35:59 <doron> sbonazzo: thanks
15:36:18 <doron> #info integration 3.4 updates: still working on closing bugs and busy with releases composition.
15:36:37 <doron> lvernia: network 3.4 updates?
15:37:13 <lvernia> doron: We have two blockers opened today, already fixes pending review.
15:37:33 <lvernia> doron: Other than that I don't think so, anything in particular you're looking for?
15:37:41 <doron> lvernia: can you please add them to the tracker if not already there?
15:37:47 <lvernia> doron: They're there.
15:38:00 <doron> lvernia: so that should be enough. will it be ready for the RC?
15:38:04 <doron> (next week)
15:38:11 <lvernia> doron: Yes.
15:38:15 <doron> lvernia: thanks
15:38:19 <lvernia> doron: No problem :)
15:38:34 <doron> #info network 3.4 updates:  two blockers opened today, already fixes pending review. Should make it into RC.
15:39:00 <doron> ppc next. vitorlima here?
15:39:44 <doron> lbianc: here for PPC?
15:40:46 <doron> will try again later
15:41:21 <doron> #info sla 3.4 updates: hosted engine maintenance vdsm part ready. engine being handled and should make it to RC.
15:41:34 <doron> moving nect to storage. amureini 3.4 updates?
15:41:39 <doron> (next)
15:42:50 <doron> amureini: here?
15:42:59 <amureini> doron, yup, sec.
15:43:31 <doron> ecohen: in the meantime, and 3.4 updates for UX?
15:43:38 <ecohen> doron, there are a couple of issues: one is "Bug 1066489 - Event list not updating when events happen". In POST (patches are being reviewed).
15:43:38 <ecohen> doron, the other one is somewhat related, it is not documented in BZ yet, will take care of that soon.
15:43:38 <ecohen> doron, both will hopefully be merged to 3.4 in the upcoming couple of days.
15:44:08 <doron> ecohen: is 1066489 a blocker and is it in the tracker?>
15:44:41 <amureini> doron, re: storage - ovf on any domain and remove sp md  - under review; may require some tweaks
15:44:41 <ecohen> doron, 1066489 is in the "Depends on" field of the tracker and marked with a 3.4 "Target Release" - is there anything else that needs to be done in BZ?
15:44:52 <amureini> ecohen, sorry for barging in, not intended
15:44:59 <ecohen> amureini, :)
15:45:14 <doron> ecohen: this is fine, will it make to RC?
15:45:21 <ecohen> doron, when is the RC?
15:45:28 <doron> ecohen: 3.4 RC next week.
15:45:36 <ecohen> doron, yes, there shouldn't be a problem.
15:45:41 <doron> ecohen: thanks.
15:45:44 <ecohen> doron, np
15:45:59 <doron> #info UX 3.4 updates: 2 issues currently being handled. Should be fixed for RC.
15:46:07 <doron> amureini: back to you, 3.4 updates?
15:46:34 <amureini> doron, re: storage - ovf on any domain and remove sp md  - under review; may require some tweaks - both tentative for rc
15:47:12 <doron> amureini: please update next week. If not in RC probably out of 3.4.
15:47:19 <amureini> doron, ack.
15:47:58 <doron> #info storage 3.4 updates: ovf on any domain and remove sp md at risk of missing 3.4. To be tracked.
15:48:11 <doron> anyone here for virt?
15:48:15 <doron> ofrenkel: here?
15:49:38 <doron> #info no virt representative. Please update on list on 3.4 status.
15:49:49 <doron> vitorlima: lbianc here?
15:50:24 <doron> #info no PPC representative. Please update on list on 3.4 status.
15:50:36 <doron> danken: any special VDSM updates for 3.4?
15:51:11 <doron> sbonazzo: anything else on 3.4?
15:51:36 <danken> danken: well, we have currently seen serious ssl problems on the master branch
15:51:39 <sbonazzo> doron: next week we've 3rd testday, still need to assign people to tests
15:51:52 <doron> sbonazzo: I'm on it.
15:52:01 <sbonazzo> doron: great
15:52:05 <doron> danken: is it in 3.4 as well? do we have a bz on it?
15:52:11 <danken> please everybody inform ybronhei if you see it in 3.4, too.
15:52:42 <ybronhei> danken: you mean https://bugzilla.redhat.com/show_bug.cgi?id=1065368 ?
15:52:45 <danken> doron: no bz yet, but several fragmented reports of ssl shutting off
15:52:52 <doron> danken: what kind of problems should it be?
15:53:10 <danken> ybronhei: no, not at all.
15:53:19 <ybronhei> danken: what is it ?
15:53:33 <danken> doron: what I saw is Vdsm completely unresponsive, when running with ssl=True
15:54:00 <danken> apuimedo reported unexplayed connected resets
15:54:05 <ybronhei> danken: ok.. checking that.  haven't seen all mails today
15:54:21 <danken> ybronhei: there was no email about it... just ranting on irc
15:54:33 <doron> danken: very well, please keep us updated when you have more info.
15:54:57 <danken> doron: actaully, I'm asking this esteemed forum to update ME if you see that on 3.4.
15:55:16 <vitorlima> sorry, doron
15:55:33 <doron> #info vdsm master branch demonstrating SSL issues such as unexplayed connected resets and Vdsm completely unresponsive, when running with ssl=True. Please update ASAP if you see in 3.4 as well.
15:55:38 <doron> danken: thanks
15:55:41 <gtemple> doron: sorry
15:55:46 <doron> vitorlima: ppc 3.4 updates?
15:55:55 <doron> gtemple: ^^^^^^^^
15:56:43 <vitorlima> doron: we have some pending patches that should be reviewed
15:56:57 <vitorlima> I don't know if they will make into the 3,4 release
15:57:08 <doron> vitorlima: any progress in the past week with pending patches?
15:57:48 <vitorlima> doron, some bugfixes were merged, but the patches blocking missing features in ppc64 (suspend, migration and memory snapshots) are still without enough reviews
15:58:19 <doron> vitorlima: can you please mail your patch queue to the devel list asking for more reviews?
15:58:33 <doron> We'll try to push it forward.
15:58:57 <lbianc> Hi doron, Ok we will mail that today
15:59:04 <doron> lbianc: thanks.
15:59:37 <doron> #info PPF 3.4 updates: patches blocking missing features in ppc64 (suspend, migration and memory snapshots) are still without enough reviews. Help needed to review it.
15:59:41 <lbianc> doron: thanks
15:59:47 <doron> #info PPC 3.4 updates: patches blocking missing features in ppc64 (suspend, migration and memory snapshots) are still without enough reviews. Help needed to review it.
16:00:04 <doron> lbianc: vitorlima gtemple thanks
16:00:14 <doron> ok, let's move on.
16:00:15 <gtemple> doron: thanks
16:00:23 <doron> #topic conferences and workshops
16:00:27 <doron> bkp: here?
16:00:32 <bkp> Yup
16:00:38 <doron> bkp: updates?
16:00:40 <bkp> SCALE is this week. I will be speaking at Infrastructure.Next. ecohen will also be in attendance, helping with the booth.
16:00:54 <bkp> Also, I have prepped a preliminary list of events for the second half of 2014, with dates and CFP deadlines. For now, I have it up on Google Docs at https://docs.google.com/spreadsheet/ccc?key=0Aj2sq6U9NfU6dG1CemZhcC05LU9PZHV4eEU1UXJRR3c&usp=sharing
16:01:12 <bkp> (Sorry for the giganto link)
16:01:23 <bkp> Feel free to add comments if there is an event you would like to add, or don't think someone from oVirt should attend.
16:01:28 <doron> #info SCALE is this week. bkp will be speaking at Infrastructure.Next. ecohen will also be in attendance, helping with the booth.
16:01:41 <bkp> (Done w/ conferences)
16:02:19 <doron> #info list of events for 2nd half of 2014 available here: http://goo.gl/qFHaQh
16:03:05 <doron> bkp: I was told about a conference today, will update later on when I have more details
16:03:14 <bkp> doron: Excellent.
16:03:31 <doron> #info OpenStack day was yesterday in Korea, we had and ovirt integration session there.
16:04:05 <doron> #info lots and lots of tweets around ovirt. Feel free to follow @ovirt and help responding
16:04:13 <doron> bkp: anything else?
16:04:28 <bkp> Not for conf/social media
16:04:36 <doron> bkp: thanks!
16:04:42 <doron> #topic other topics
16:04:50 <doron> Anyone wants to raise something?
16:05:05 <bkp> Yeah: working with abonas and dneary on improving the work/process flow to download and get started with oVirt. Target date: 3.4 GA.
16:05:19 <bkp> (This is on ovirt.org)
16:05:54 <bkp> Great feedback from abonas, and I think we will have things ready in time.
16:06:06 <abonas> bkp thanks, glad to help :)
16:06:15 <doron> bkp: great, much needed. abonas thanks!
16:06:23 <bkp> Also, I'm still updating the oVirt documentation.
16:06:38 <doron> #info ovirt.org being worked on by bkp dneary and abonas. Should be ready for 3.4 GA.
16:06:42 <bkp> Quick Start Guide is updated to 3.3, needs eyeballs to check.
16:07:03 <doron> #info Quick Start Guide is updated to 3.3. Please review!
16:07:14 <bkp> That's it from me.
16:07:19 <doron> bkp: thanks.
16:07:23 <doron> Anyone else?
16:07:25 <bkp> NP
16:07:41 <doron> Going once?
16:08:00 <dneary> bkp, Link?
16:08:14 <dneary> For the upstream guide (just to get it into the minutes)
16:08:15 <doron> dneary: http://goo.gl/qFHaQh ?
16:08:15 <bkp> To?
16:08:25 <doron> dneary: right, sorry!
16:08:30 <bkp> http://www.ovirt.org/Quick_Start_Guide
16:08:41 <dneary> bkp, doron: Thanks
16:08:52 <doron> #info please review the updated http://www.ovirt.org/Quick_Start_Guide
16:09:00 <doron> Anything else?
16:09:30 <doron> Going once?
16:09:58 <doron> Going twice....
16:10:42 <doron> #endmeeting