14:06:23 <fabiand> #startmeeting oVirt Node Weekly Meeting
14:06:23 <ovirtbot> Meeting started Tue Feb 11 14:06:23 2014 UTC. The chair is fabiand. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:06:23 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:06:29 <fabiand> #chair jboggs rbarry
14:06:29 <ovirtbot> Current chairs: fabiand jboggs rbarry
14:06:37 <fabiand> #topic Agenda
14:06:42 <fabiand> #info Build status
14:06:43 * jboggs here
14:06:50 <fabiand> #info oVirt 3.3.3
14:06:54 <fabiand> #info oVirt 3.4
14:07:07 <fabiand> #info Other Items
14:07:25 <fabiand> morning jbiddle__
14:07:28 <fabiand> jboggs,
14:07:30 <fabiand> too
14:07:49 <fabiand> #topic Build Status
14:08:36 <fabiand> Well, as we can see on gerrit there are a couple of pending patches. But we merged also something like ~50 two weeks ago. When we did the update to the stable branch
14:08:43 <fabiand> #info Pending patches in gerrit
14:08:57 <fabiand> #info Many patches merged two weeks ago with the stable build for ovirt-node-iso-3.0.4
14:09:35 <fabiand> That beeing said. We've currently got a stable base-image (3.0.4) which we need to push out to reesources.ovirt.org
14:09:44 <fabiand> That also brings me to the next item
14:09:51 <fabiand> #topic oVirt 3.3.3
14:10:13 <fabiand> There is a build of ovirt-node for oVirt 3.3.3
14:10:19 <fabiand> #link http://fedorapeople.org/~fabiand/node/3.0.4/ovirt-node-iso-3.0.4-1.0.201401291204.vdsm33.el6.iso
14:10:53 <fabiand> Its hould be good from a Node POV, but it hasn't been tested thoroughly when it comes to Engine.
14:11:22 <fabiand> We should probably reach out to the vdsm people and see if they can include that iso in their testing
14:12:09 <fabiand> #action fabiand to ask vdsm people about node testing
14:12:20 <fabiand> #topic oVirt 3.4
14:12:33 <fabiand> The same base image is availabel with packages for oVirt 3.4
14:12:45 <fabiand> #info ovirt-node iso also available for oVirt 3.4 testing
14:12:51 <fabiand> #link http://fedorapeople.org/~fabiand/node/3.0.4/ovirt-node-iso-3.0.4-1.0.201401291204.vdsm34.el6.iso
14:13:01 <fabiand> But that build also needs testing
14:13:29 <fabiand> So to summarize - Currently both images are based on our stable 3.0.4 release
14:13:31 <sbonazzo> fabiand: it's currently in test today :-)
14:13:57 <fabiand> Building is currently done only for CentOS but Fedora 19/20 will also get into play at some point again
14:14:01 <fabiand> sbonazzo, hey - great!
14:14:19 <sbonazzo> fabiand: tested by OaaSvc
14:14:33 <fabiand> And that means - We are in a much better shape than one month ago
14:14:51 <fabiand> sbonazzo, oh - di he finish his testign? I thought he wanted to continue tomorrow ..
14:14:58 <fabiand> #topic Other Items
14:15:01 <sbonazzo> fabiand: not sure about the result
14:15:05 <fabiand> sbonazzo, ok
14:15:12 <fabiand> #info Feature Future Work
14:15:14 <sbonazzo> fabiand: what about jenkins jobs for building node nightly?
14:15:17 <fabiand> #undo
14:15:17 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x8bc07cc>
14:15:41 <fabiand> #topic oVirt Node Nightly
14:15:52 <fabiand> Yes, surely a good idea
14:15:56 <fabiand> But it is two fold
14:16:02 <fabiand> Node part and vdsm part
14:16:16 <sbonazzo> fabiand: vdsm is already built nightly
14:16:33 <fabiand> okay, what we can do - and there might be already a job for it - is to add the nightly vdsm to our nightly Node
14:16:52 <fabiand> having a current node nightly doesn't make much sense as we are still nto up to speed on development again ..
14:17:24 <fabiand> And - having a Nightly Node based on the last stable build has the pro that it is at least usable
14:17:33 <fabiand> A Nightly Node can be painful when it's broken
14:17:33 <sbonazzo> http://jenkins.ovirt.org/view/All/job/ovirt-node-iso/
14:17:55 <sbonazzo> fabiand: ^^ is F18 based
14:18:41 <fabiand> Also - Node builds tend to be instable because we depend on so many packages and they change quite often in Fedora, it's better with CentOS tho - which is the reason why we only provide images for CentOS currently
14:18:41 <fabiand> sbonazzo, yeah - We also need to refresh our CI stuff - As in F20 and F19 builders
14:18:41 <fabiand> Up to date CentOS buidlers (but I think we've got them)
14:19:10 <sbonazzo> fabiand: having nightly will allow you to test it from master. you can alwayse keep stable build on resource.ovirt.org
14:19:35 <fabiand> sbonazzo, well - that is also something we should speak about. builds on ressource ovirt.org :)
14:19:42 <sbonazzo> :-)
14:20:51 <fabiand> sbonazzo, if you remeber the situationat the end fo 2013 - the situation was bad, not only because of bad Node commits but mainly because so many packages changes happend, and we couldn't keep up with adjusting our code ..
14:21:14 <fabiand> sbonazzo, so - even if there are no changes on master or anywhere it can still happen that Node becomes unusable - selinux is a common buzzword here :)
14:21:30 <sbonazzo> sbonazzo: I agree.
14:21:36 <fabiand> But using centos as the integration base is much better, as the packageset is more stable
14:21:49 <fabiand> Great that you agree with yourself, sbonazzo ;)
14:22:07 <sbonazzo> fabiand: :-)
14:22:27 <sbonazzo> fabiand: I agree.
14:22:28 <fabiand> #info Nightly Node builds are welcome - Several options StableNode+NightlyVdsm NightlyNode+NightlyVdsm
14:22:59 <fabiand> One step to make this happen can be to documet the way of how we use edit-node to create the images for Engine
14:23:26 <fabiand> Also we need to improve the experience there. Gathering all the repos is not easy if you do it once in a while
14:23:41 <fabiand> Well ... We put that on the pile of things to do ..
14:24:05 <spiekey> hello
14:24:51 <spiekey> i would like to use my dedicated bond0 for gluster replication. But in my volume setup i can only select my nodes which have the management nic.
14:25:15 <fabiand> #info CI needs updates
14:25:26 <fabiand> #info Jobs should use edit-node (if not already)
14:25:29 <spiekey> how can i tell my Gluster Volume to use my bond nic?
14:25:50 <fabiand> #topic Future Features
14:26:06 <fabiand> #undo
14:26:06 <ovirtbot> Removing item from minutes: <MeetBot.items.Topic object at 0x8b2012c>
14:26:26 <fabiand> #topic Review
14:26:39 <fabiand> Not uncommon - We have a couple of pending patches
14:26:45 <fabiand> I can just encourage anyone to review them ...
14:27:11 <fabiand> jboggs and rbarry_ have been active on that front at least
14:27:42 <jboggs> I'll likely work through them again within next day or so
14:28:28 <rbarry> I'm hoping to get a chance to look at some of the bigger patches...
14:29:16 <fabiand> Okay
14:29:18 <fabiand> Great
14:29:41 * fabiand appreciates that and /me also want's got get better at reviewing again ..
14:29:49 <fabiand> Other items, rbarry, jboggs ?
14:30:14 <rbarry> Nothing here
14:30:43 <jboggs> nothing here either
14:31:18 <fabiand> Okay
14:31:19 <fabiand> then
14:31:21 <fabiand> #endmeeting