15:01:26 <doron> #startmeeting oVirt Weekly Sync
15:01:26 <ovirtbot> Meeting started Wed Jan 15 15:01:26 2014 UTC.  The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:26 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:27 <doron> #topic Agenda and roll Call
15:01:29 <doron> #info 3.3 update releases
15:01:30 <doron> #info 3.4 progress
15:01:32 <doron> #info conferences and workshops
15:01:33 <doron> #info infra update
15:01:35 <doron> #info other topics
15:01:35 * sbonazzo here
15:01:36 * lvernia is here.
15:01:38 * ecohen here
15:01:51 * danken is here
15:01:58 <doron> mskrivanek: here?
15:02:06 <doron> who's here for storage?
15:02:14 * orc_orc is here
15:02:14 <doron> ybronhei: here?
15:02:34 <ybronhei> doron: here
15:02:38 * mskrivanek here
15:02:39 <doron> ybronhei: hi
15:02:49 <doron> sgordon: here for storage?
15:03:06 <doron> sgordon: sorry...
15:03:14 <doron> sgotliv: here for storage?
15:03:49 <doron> I guess not. Let's start and see who joins.
15:03:56 <doron> #topic 3.3 update releases
15:03:59 <sgordon> doron, yeah sure ;)
15:04:05 <bkp> doron here
15:04:10 <doron> sbonazzo: 3.3.3 out. any updates?
15:04:15 <doron> bkp: hi!
15:04:22 <sbonazzo> doron: 3.3.3 beta has been composed and announced
15:04:35 <doron> right.
15:04:36 <sbonazzo> doron I've sent an email about beta status today
15:04:45 <sbonazzo> we have no blockers
15:04:53 <sbonazzo> and some bugs still open
15:05:08 <sbonazzo> We should scrub them and re target non blockers
15:05:43 <doron> sbonazzo: and rc build planned for 2014-01-21?
15:06:05 <sbonazzo> doron: yes
15:06:15 <doron> very well.
15:06:34 <sgotliv> doron, I am here
15:06:45 <doron> #info 3.3.3 beta has been composed and announced. Some BZs needs scrubbing. rc build planned for 2014-01-21.
15:06:50 <doron> sgotliv: hi.
15:07:04 <doron> let's move on to 3.4
15:07:14 <doron> #topic 3.4 progress
15:07:19 <sbonazzo> 3.4.0-alpha has been composed and announced
15:07:39 <sbonazzo> we have an issue with vdsm so we're going to refresh at least vdsm packages there
15:07:40 * itamar here
15:08:23 <doron> #info 3.4.0-alpha announced. Re-spin needed due to vdsm issue.
15:08:29 <doron> thanks sbonazzo
15:08:34 <sbonazzo> stabilization branching / feature freeze was scheduled for today
15:08:41 <doron> right
15:08:46 <sbonazzo> but will be postponed at least to tomorrow morning
15:08:57 <doron> Why is that?
15:09:18 <itamar> doron: to let folks merge till EOD today (in different timezones)
15:09:42 <doron> itamar: then we should define the dates better next time.
15:10:20 <doron> #info stabilization branching / feature freeze postponed to let folks merge till EOD today (in different timezones).
15:10:23 <mskrivanek> I have to say we do have quite a few feature pending merge, final reviews...so even one day later is a lot for virt.
15:10:53 <doron> mskrivanek: are you suggesting more than one day?
15:10:53 <SvenKieske> Hi, can anyone elaborate on my proposed blockers for 3.4 ? if not now it would be cool if you could reply on the ML
15:10:57 * danken was preparing for Jan 20 as feature freeze... so I have plenty of requests for exceptions.....
15:11:12 <doron> SvenKieske: we'll get to it.
15:11:53 <sbonazzo> Jan 20 is beta build
15:12:26 <doron> itamar: what about pushing to Jan 20, and beta build a day later?
15:12:31 <doron> sbonazzo: ^^^^^^^^^^^^^^
15:13:01 <sbonazzo> doron: no time for stabilizing the branch? we need to have master stable by Jan 20 then...
15:13:28 <mskrivanek> doron: well, yes, I can always use a day or two. OTOH we can always backport missing REST API patches or some fine tuning. So I for one would not really push that hard to postpone
15:13:30 <doron> sbonazzo: then we'll re-spin beta
15:13:32 <itamar> doron: i prefer to fork to stable, allow maintainers to be more leniant till beta branch.
15:13:37 <danken> even Jan 20 is a tight schedule for us... but at least we can squeeze few important things in.
15:13:44 <itamar> s/beta branch/beta build/
15:14:05 <doron> itamar: accoording to danken he need this buffer
15:14:21 <doron> if not more.
15:14:27 <danken> doron: but I can survive with the lenience mode
15:14:39 <danken> I mean, branch tonight, but have feature freeze on Jan20
15:15:15 <danken> it would give peopl 4 more days notice that if they do not rush, the train is leaving without them.
15:15:20 <itamar> danken: this will limit backports to things that need closure, etc. which i think is good. also sends message there is a penalty (overhead) to missing the date (of backports).
15:15:38 <mskrivanek> itamar: +1
15:15:55 <danken> itamar: and that there's a penalty (to me) for thinking feature freeze is on the 20th :-(
15:16:21 <doron> so we have a concensus?
15:16:45 <danken> ybronhei is going to hate it... more work for him as stable branch maintainer.
15:16:57 <itamar> danken: I'm one as well...
15:17:01 <doron> danken: for 5 days...
15:17:11 <sbonazzo> +1 from me
15:17:13 <ybronhei> yes, i won't like it much. but dougsland will help me with that
15:17:29 <doron> very well then
15:17:33 <sgotliv> doron, we have 2 storage features "Ovf on any domain" and "Multipath" currently under review. It won't be ready tomorrow
15:17:59 <doron> sgotliv: you can backport it if some already merged,
15:18:09 <doron> sgotliv: will this so?
15:18:09 <danken> sgotliv: there's also the no-pool-md that's a must for 3.4.
15:18:13 <sbonazzo> OVF on any location is marked as blocker
15:18:28 <sgotliv> danken, that's too :-)
15:18:31 <ybronhei> all features that are still not ready will need an exception flag now
15:18:36 <doron> sbonazzo: as a blocker it may be ported.
15:18:38 <dougsland> ybronhei, sure.
15:19:16 <doron> sgotliv: at least ovf can be backported. as for multipath
15:19:27 <doron> is already started then you can close it as well.
15:19:33 <SvenKieske> mskrivanek: regarding backporting of rest-api patches: please don't do that, the past shows us that it get's forgotten and I'm really sick of having functionality missing via API !
15:19:39 <doron> you have untill Jan 20. Will you make it?
15:19:46 <doron> sgotliv: ?
15:20:06 <sgotliv> doron, I hope so, it mostly depends on reviewers right now
15:20:15 <doron> sgotliv: very well.
15:20:22 <doron> so we agreed.
15:20:29 <mskrivanek> SvenKieske: it was not forgotten, it wasn't simply done. The bug was saying that clearly
15:20:32 <dneary> Hi all
15:20:41 <danken> sgotliv: ovf upload is out of draft mode only today... it might be hard.
15:21:49 <itamar> doron, are we reviewing for status line by line?
15:22:03 <doron> #agreed ovirt 3.4 feature freeze happens on Jan 16. Stabilization branch should be created. Feature completion allowed.
15:22:09 <SvenKieske> mskrivanek: well the outcome is the same, missing functionality via API, which for me is equal to missing functionality, because I need to use the api. This tells me, that the API is not 100% supported and always is one step behind in features, which is a sad thing :(
15:22:13 <doron> itamar: yes, we'll do it now
15:22:18 <sbonazzo> doron: before checking features status one by one, bug status
15:22:34 <sbonazzo> doron: we have 3 blockers and 280 non blockers
15:22:57 <sbonazzo> and 2 proposed blockers by SvenKieske
15:23:01 <doron> sbonazzo: what are the blockers?
15:23:14 <sbonazzo> network - Bug 987813 - [RFE] report BOOTPROTO and BONDING_OPTS independent of netdevice.cfg storage - Bug 1032686 - [RFE] API to save OVF on any location gluster - Bug 1038988 - Gluster brick sync does not work when host has multiple interfaces
15:23:43 <doron> RFEs should be fine- they have 5 days ot conclude.
15:23:43 <mskrivanek> SvenKieske: I would agree with that. You can as well view it as not having the feature. Which is fine. But that doesn't block supporting patches to get in (e.g. with guest agent or vdsm this happens quite often) so you get the complete functionality only in the next release.
15:24:03 <itamar> sbonazzo: these RFEs shouldn't be blocking the release unless raised for discussion in this meeting.
15:24:05 <doron> mskrivanek: SvenKieske please wait with this discussion or move to ML.
15:24:36 <sbonazzo> and proposed are: Bug 987832 -        failed to add ovirtmgmt bridge when the host has static ip; Bug 1038121 -        ubuntu 12.04 server lts fails to boot without console=ttyS0,38400n8 kernel parameter
15:24:37 <sahina> regarding Bug 1038988 - Gluster brick sync does not work when host has multiple interfaces - we have a dependency on glusterfs introducing UUID
15:24:38 <sgotliv> danken, why?
15:25:16 <doron> sahina: and will it be resolved?
15:25:17 <itamar> sbonazzo: if i filter by 3.4.0 target release, not including features (which will either make it in, or be postponed), I see 240.
15:26:05 <doron> itamar: if you can share the query we'll all sync on the same items.
15:26:07 <sahina> doron, yes ..glusterfs 3.5 is scheduled for release this month. following up to get the required patch there
15:26:13 <itamar> doron: i'm cleaning it up...
15:26:32 <doron> sahina: so we should have it fix by Jan 20?
15:26:43 <sbonazzo> itamar: ok, well it's still a high number 240... are you cleaning up tracker?
15:26:47 <itamar> sbonazzo: out of the 240, ~120 are on ovirt-node, which should probably be pushed to 3.5.0 mostly (fdeutch)
15:26:55 <danken> the network bug (report BOOTPROTO and BONDING_OPTS) is a blocker for our iproute2 feature
15:27:08 <itamar> sbonazzo: please clean the tracker.
15:27:14 <itamar> danken: what's the ETA for it?
15:27:18 <danken> I'd like to keep it as a blocker even after beta
15:27:29 <sahina> doron, we can have the engine and vdsm side fix done..but i'm not sure if gluster 3.5 will be released by jan 20
15:27:41 <danken> otherwise, we'd have to drop that feaure from 3.4.
15:28:18 <doron> sahina: since it's beta we should be fine with a release note for the beta
15:28:25 <doron> as long as it will make it to rc
15:28:38 <sahina> doron, ok.
15:28:51 <doron> sbonazzo: so we're good with gluster
15:28:52 <danken> itamar: I'd say - end of Jan is realistic.
15:29:18 <doron> danken: for this bug?
15:29:48 <sbonazzo> doron: ok gluster is the only one still open as blocker
15:29:48 <sahina> doron, even for the gluster task management - we have a dependency on gluster 3.5. so what do you suggest? disable this feature till 3.5 is released or release note to use with gluster 3.5 beta?
15:29:57 <itamar> danken: so do we keep the iproute2 feature? what's the mitigation plan for the risk? off by default?
15:29:59 <sbonazzo> doron: what about proposed blockers?
15:30:22 <sbonazzo> Bug 987832 -        failed to add ovirtmgmt bridge when the host has static ip
15:30:26 <sbonazzo> Bug 1038121 -        ubuntu 12.04 server lts fails to boot without console=ttyS0,38400n8 kernel parameter
15:30:31 <doron> sahina: if it will be ready for 3.4 release note is fine (as long as ovirt is usable)
15:30:37 <itamar> sahina: what's the ETA for gluster 3.5? if there is beta, and GA is expected by march, i think makes sense.
15:30:54 <doron> sbonazzo: 987832 should be fixed. what are the implications?
15:30:55 <SvenKieske> sbonazzo: I could elaborate on these, as I filed them and proposed them
15:31:34 <apuimedo> itamar: it is off by default
15:31:35 <itamar> doron: ovirt 3.4 open bugs by group: http://red.ht/19utttS
15:31:56 <doron> itamar: thansl
15:31:57 <sahina> itamar, from what i hear 3.5 GA is slated for month end
15:32:12 <itamar> sahina: ok, that i think good enough for our beta.
15:32:19 <SvenKieske> doron 987832 is fixed? BZ states it's in state "new" ?
15:32:24 <doron> #info ovirt bugs by group http://red.ht/19utttS
15:32:38 <doron> SvenKieske: I said should be fixed...
15:32:43 <danken> itamar: the plan for iproute2 is to have it off by default. On only for a debian build.
15:32:53 <sbonazzo> doron: I agree in having it as blocker
15:32:57 <SvenKieske> doron: ah sorry, misread that, thank you
15:34:00 <doron> SvenKieske: as for 1038121, looks like you can boot it with the relevant parameters. so should be fixed, but not a blocker
15:34:52 <SvenKieske> doron: okay for me, I'll open a new BZ for the not-ejected cloud-init-iso
15:35:17 <doron> SvenKieske: another issue? a blocker?
15:35:39 <doron> sbonazzo: anything else?
15:35:40 <itamar> SvenKieske: doron: not a blocker. its a feature
15:35:45 <SvenKieske> doron: I don't really know: when you attach a run once cloud-init iso to the vm it sticks to it over reboots
15:35:54 <sbonazzo> doron: not on bugs status side
15:36:04 <doron> very well.
15:36:22 <doron> let summarize the blockers-
15:36:30 <SvenKieske> I think I saw a BZ for this somewhere but I can't find it anymore..
15:36:39 <mskrivanek> SvenKieske: reboot from within the VM? that's as designed then
15:36:57 <mskrivanek> SvenKieske: we had a different one that the iso was always there, which is fixed AFAIK
15:37:26 <itamar> mskrivanek: its as designed, but we want it fixed... same as for PXE
15:37:50 <doron> #info 3.4 current blockers: 987832, RFE's (which may slip if not completed). Gluster issues should have a release note until 3.5 is out.
15:37:54 <SvenKieske> okay, thanks for the information so far :)
15:37:58 <doron> ok guys,
15:38:11 <doron> quick review of 3.4 features to see what's in
15:38:18 <doron> and please respond fast.
15:38:43 <doron> starting from virt today,
15:38:49 <doron> mskrivanek: virt status?
15:39:07 <itamar> jhernand, please fix the bug from 652883 to the ovirt one. thanks
15:39:15 <mskrivanek> not really different from the spreadsheet
15:39:50 <mskrivanek> hotplug, cloud-init persistence, reboot VM, template versions still pending review&merge
15:39:51 <doron> mskrivanek: what should still be in and not ready?
15:40:13 <doron> anything else?
15:40:14 <mskrivanek> most of them are partially in, just need those couple days to get all related patches
15:40:45 <doron> mskrivanek: 15 features done?
15:40:58 <mskrivanek> since last week i don't think anything really changed, it's just more in progress. Some of them may make it today (reboot, sso)
15:41:13 <mskrivanek> doron: I see 12 green
15:41:29 <doron> mskrivanek: very well ;)
15:42:09 <doron> #info virt feature status for 3.4: 12 features made it. hotplug, cloud-init persistence, reboot VM, template versions needs to be completed by Jan 20.
15:42:13 <doron> thanks mskrivanek
15:42:19 <doron> moving to ux. ecohen?
15:42:27 <ecohen> doron, yes, hi.
15:42:27 <ecohen> doron, "low resolution support": made it in on time eventually.
15:42:27 <ecohen> doron, new (small) feature: "easily collapsible left-pane": almost done, will be merged to 'master' at the beginning of next week.
15:42:27 <ecohen> doron, requesting here to introduce it as an exception feature for ovirt-3.4 (should be low risk).
15:43:10 <doron> ecohen: not a problem as long as it will make it until Jan 20. Will it work?
15:43:25 <ecohen> doron, tight, we will try. worst case - next version. thank you.
15:43:33 <doron> ecohen: thanks
15:44:13 <itamar> doron: so we're giving "grace" till jan 20th. anything not making that one, should be raised for discussion of risk/gap/etc.
15:44:48 <doron> #info UX feature status for 3.4: 3 features made it. low-resolution should be completed by jan 20.
15:44:52 <doron> itamar: yes.
15:45:01 <doron> moving next to storage
15:45:12 <doron> sgotliv: 3.4 features status?
15:45:17 <sgotliv> Ovf an dmultipath under review
15:45:37 <sgotliv> Single disk snapshot - merged
15:46:02 <sgotliv> Vdsm tests - done for local SD started working on NFS
15:46:09 <doron> sgotliv: what are the red BZs in the spreadsheet?
15:46:24 <sgotliv> give me a link
15:46:27 <sgotliv> please
15:46:39 <doron> sgotliv: https://docs.google.com/spreadsheet/ccc?key=0AuAtmJW_VMCRdHJ6N1M3d1F1UTJTS1dSMnZwMF9XWVE&usp=drive_web#gid=0
15:47:00 <doron> sgotliv: looks like 4 features made it?
15:47:11 <sgotliv> just a sec
15:47:18 <itamar> doron: these are items with BZs which are not ovirt BZs (RHEV BZs by mistake)
15:47:29 <doron> itamar: thanks.
15:47:35 <sgotliv> I will update a spreadsheet
15:47:48 <itamar> sgotliv: thanks. please make sure to use only ovirt BZs in the googledoc
15:47:50 <doron> sgotliv: so assuming we have 4 in. what's still pengin ?
15:47:57 <doron> (pending)
15:48:31 <sgotliv> hsm async tasks won't be for 3.4
15:48:56 <doron> sgotliv: take 5, I'll come back to you in a few minutes. please check what's in and what should be ready ny Jan 20. ok?
15:49:09 <sgotliv> great, thanks
15:49:11 <doron> switching to SLA
15:49:56 <doron> #info sla feature status for 3.4: 5 features in. Hosted engine maintenance should be ready by Jan 20.
15:50:09 <doron> moving next to PPC.
15:50:13 * gtemple ppc here
15:50:20 <doron> gtemple: welcome
15:50:23 <lbianc> doron here
15:50:31 <doron> 3.4 features?
15:50:55 <vitorlima> doron, we have all the important changes merged, except for the ones that block migration and memory snapshots
15:51:03 <vitorlima> and a small fix
15:51:24 <doron> vitorlima: good job. Anything which you're working on until Jan 20?
15:51:58 <vitorlima> we will work only these unmerged changes, fixing them according to the reviews
15:52:17 <doron> vitorlima: and does it work 'out of the box' in 3.4?
15:52:41 <vitorlima> yes, but if the user tries to use these two unsupported features, it will cause some problems
15:52:59 <doron> vitorlima: thanks. please make sure we have release notes for it.
15:53:26 <vitorlima> doron, is there enough time for these pending changes to be merged?
15:53:31 <danken> vitorlima: anything bending on the vdsm front?
15:53:41 <doron> #info ppc feature status for 3.4: all important changes merged, except for the ones that block migration and memory snapshots.
15:53:54 <doron> vitorlima: you have until Jan 20.
15:54:09 <vitorlima> danken: no, all our proposed changes were merged
15:54:20 <doron> very nice
15:54:21 <itamar> vitorlima: can you please open two BZs for all these PPC items
15:54:31 <itamar> vitorlima: one for adding cross arch support for ovirt.
15:54:40 <itamar> vitorlima: one for adding PPC arch support.
15:54:55 <doron> let's move on to network.
15:54:57 <itamar> and use these two on the appropriate items
15:55:07 <vitorlima> itamar: sure, we will do it
15:55:14 <doron> lvernia: 3.4 status?
15:55:43 <lvernia> doron: Mostly done, split the Neutron integration into several smaller features as discussed last week.
15:55:57 <lvernia> doron: Labels will make it, one last GUI patch pending review before it can be colored green.
15:56:13 <lvernia> doron: Hopefully will make it even before the branch-off.
15:56:19 <doron> lvernia: you have 5 in, 2 pending until Jan 20?
15:56:38 <danken> true iproute is still in high risk
15:56:50 <lvernia> doron: 5 already in, one more definitely going in by Jan 20th.
15:56:52 <itamar> sgotliv: any item on storage list which won't make the januray 20th date of beta build and need an exception for that?
15:56:55 <doron> danken: so will it slip?
15:57:14 <itamar> mskrivanek: any item on storage list which won't make the januray 20th date of beta build and need an exception for that date?
15:57:18 <lvernia> doron: Not sure about security groups, danken might know better the breadth of the issues with migration there.
15:57:41 <sgotliv> itamar, the spreadsheet is updated now
15:57:43 <danken> doron: no news since last week regarding security groups
15:57:55 <danken> but at worst - it's a reasonable bug to fix
15:58:11 <danken> (not supporting migration/hibernation)
15:58:17 <sgotliv> multiple storage domains maybe won't be ready
15:58:21 <doron> lvernia: danken so sec groups will slip?
15:58:32 <lvernia> doron: I would say 5 already in, 1 will be in by Jan 20th, 2 to be completed later (security groups and iproute2).
15:58:34 <itamar> sgotliv: 1. i still see non ovirt bz's.
15:58:47 <doron> lvernia: thanks
15:58:49 <danken> doron: even if it does "slip" it would be only a partial slip
15:58:49 <danken> ""
15:59:01 <itamar> sgotliv: % doesn't help me to understand ETA (date) - will make jan 20th or no.
15:59:14 <danken> iprout2 is in bigger risk
15:59:25 <doron> #info network  feature status for 3.4: 5 features in. security groups and iproute2 to be completed by Jan 20.
15:59:31 <itamar> danken: please flag like line 68 as requesting exception
15:59:36 <doron> moving on to integration
15:59:36 <danken> and part of it was declared blocker for SvenKieske
15:59:40 <sgotliv> itamar, ovf and multipath probably yes
15:59:43 <lvernia> doron: And labels to make it by January 20th.
15:59:55 <itamar> sgotliv: probably yes what?
16:00:02 <doron> #info network  feature status for 3.4: 5 features in. Network labels, security groups and iproute2 to be completed by Jan 20.
16:00:14 <sgotliv> itamar, will be ready for jan 20
16:00:23 <itamar> sgotliv: anything not ready by jan 20th?
16:00:30 <doron> sbonazzo: integration status?
16:00:35 <danken> itamar: ok, when I manage to log into the page. sooooo slow.
16:00:38 <sgotliv> itamar, multiple storage domains
16:00:49 <itamar> danken: why slow?
16:00:56 <sbonazzo> dwh migration to otopi is now under verification
16:00:57 <danken> google docs is slow here.
16:01:00 <danken> no idea why
16:01:17 <itamar> sgotliv: please notate as requesting exception like line 68
16:01:27 <sbonazzo> we had progress on centos support for reports (jasper 5.5 built for centos)
16:01:41 <danken> there are two other patches that *I* consider "musts": defaultRoute API, and smart network_setup hooks. both under review, and both expected to be in by Jan 20.
16:01:46 <doron> sbonazzo: you have URI in. 3 others to be completed?
16:02:03 <sbonazzo> but I'm not sure that centos will be completed by jan 20.
16:02:15 <danken> defaultRoute is important as it would allow us to use non "ovirtmgmt" name for management network.
16:02:23 <doron> sbonazzo: what should be ready by 20?
16:02:28 <sbonazzo> reports migration to otopi is ongoing, not sure it will be ready
16:02:32 <doron> or may be ready?
16:02:53 <sbonazzo> probably DWH, (uri and hosted engine completed)
16:03:05 <doron> sbonazzo: thanks
16:03:27 <itamar> sbonazzo: please notate as requesting exception on the centos like line 68
16:03:47 <sbonazzo> itamar: reports to otopi too?
16:03:55 <itamar> danken: what defaultRoute - no such feature on the doc?
16:03:56 <doron> #info integration feature status for 3.4: uri and hosted engine completed. eports migration to otopi may be ready by Jan 20 (or slip). Same goes for centos.
16:04:11 <itamar> sbonazzo: yes.
16:04:17 <doron> moving next to infra
16:04:20 <doron> ybronhei: ?
16:04:31 <ybronhei> doron: snmp & snmp trap monitoring (will do only snmp trap as notification) - already posted, planed to be merged asap (by jan 20), probably during this week, currently they're struggling with jenkins issues
16:04:32 <ybronhei> doron: same with - "authentication refactoring" part and "allow to provide a password change url on login failure when password expires"
16:04:32 <ybronhei> doron: same for "CCP report should contain the created_by field".
16:04:32 <ybronhei> doron: the dwh part should be in by tomorrow
16:04:32 <ybronhei> doron: all the others are done and merged
16:05:13 <ybronhei> doron: all those 4 are meant to make it to Jan 20
16:05:20 <sbonazzo> itamar: done
16:05:21 <itamar> ybronhei: sbonazzo: lvernia: sgotlic: sabose: please note stable branch will be created tomorrow. so gaps would have to be backported to it.
16:05:36 <doron> ybronhei: looks like you have !9 features done.
16:05:55 <lvernia> itamar: Ack, will pass the message on as well.
16:06:03 <ybronhei> doron: yep.. seems like that
16:06:10 <doron> ybronhei: thanks
16:06:16 <sahina> itamar, got it
16:06:26 <itamar> sgotliv - why requesting exception to all? only for the one post the 20th.
16:06:28 <sbonazzo> ydary too,  please note stable branch will be created tomorrow. so gaps would have to be backported to it.
16:07:13 <doron> #info infra feature status for 3.4:  9 features in. snmp & snmp trap monitoring, authentication refactoring, CCP report should contain the created_by field should be ready for Jan 20.
16:07:50 <doron> sahina: pleaserefresh your status?
16:07:59 <sahina> doron, Gluster async tasks - requires gluster 3.5. Gluster volume capacity information - still under review. Hoping to get it in by Jan 20 and backported to stable branch
16:08:20 <itamar> mskrivanek - ping
16:09:06 <doron> sahina: thanks
16:09:27 <danken> regarding virt, I'm told that guestIF: Adding guest agent API versioning support
16:09:27 <danken> http://gerrit.ovirt.org/#/c/17004/8
16:09:27 <danken> is a must
16:09:50 <doron> #info gluster feature status for 3.4: Gluster async tasks done, but requires gluster 3.5. Gluster volume capacity information should be done for Jan 20.
16:09:58 <doron> back to storage
16:10:00 <doron> sgotliv:
16:10:06 <danken> and I'd like to finally get rid of that timeOffset bug...
16:10:08 <sgotliv> doron, yes
16:10:27 <doron_afk> sgotliv: how many features do you have completed?
16:10:28 <sgotliv> multiple storage domains looks like it has a chance of being complete in the next few days
16:10:28 <sgotliv> multipath and store ovf on any domain - code review
16:10:28 <sgotliv> get rid of storage pool md - 90% complete
16:10:28 <sgotliv> Spreadsheet is updated now
16:10:51 <itamar> sgotliv: please remove the requesting exception for those planned to make the jan 20th.
16:11:00 <sgotliv> itamar, I will
16:11:11 <doron> sgotliv: so for features completed and merged?
16:11:16 <doron> s/for/4/
16:11:52 <sgotliv> doron, according to spreadsheet 5
16:12:13 <doron> sgotliv: you have 4 greens
16:12:43 <sgotliv> doron, and single disk snapshot
16:12:57 <itamar> sgotliv: make it green then.
16:12:59 <doron> why is it not green?
16:13:13 <danken> mskrivanek_away: is that right? "guestIF: Adding guest agent API versioning support" a must have?
16:14:14 <doron> sgotliv: very well, 5 features ready. Now, what do you expect to be ready by Jan 20?
16:14:46 <sgotliv> doron, ovf and multipath
16:14:56 <doron> sgotliv: much appreciated.
16:15:27 <doron> #info storage 3.4 feature status: 5 features ready, ovf and multipath should be done by Jan 20.
16:15:33 <danken> doron: I have to leave, but I'd like to talk about the test day.
16:15:45 <doron> danken: sure
16:15:52 <danken> It would be great to have assignment of tasks to people
16:15:57 <doron> danken: start a thread when possible, cc me.
16:15:58 <danken> like was done in 3.3.
16:16:23 * danken want to use this venue to get to a decision
16:16:28 <doron> anything else for 3.4 we need to update?
16:16:47 <danken> it's time to prepare for the test day - it's only one week away, right?
16:17:06 <doron> danken: I thought you need to go?
16:17:46 <danken> I do - it's an action item I'd like you to take care of, while I'm gone ;-)
16:17:49 <doron> anyway danken, for 3.4 testday, what are you looking for?
16:18:24 <danken> I'd like to see a list of testable tasks, assigned to all devel/qe
16:18:52 <doron> danken: I think itamar had a similar concept in mind
16:19:10 <doron> but we should allow people to choose tasks first.
16:19:11 <danken> doron: yeah, he did it last time
16:20:00 <doron> so the idea is to some up with a task list, and allow others to assign themselves
16:20:12 <doron> to a task.
16:20:15 <doron> anything else?
16:20:36 <doron> tasks should be created by feature owners?
16:20:52 <doron> danken_gone: ?
16:21:38 <doron> a bit hard to discuss with danken_gone, so we'll push this one to the mailing list for completion.
16:21:46 <doron> moving on.
16:21:56 <doron> #topic conferences and workshops
16:22:04 <doron> bkp: dneary updates?
16:22:17 <bkp> We will have two oVirt talks lined up for Infrastructure.Next. Nailing them down today.
16:22:30 <bkp> FOSDEM schedule set. If you want see the schedules or help staff the booth, sign up at http://etherpad.ovirt.org/p/ovirt-fosdem-14
16:22:47 <bkp> That's it from me on conferences.
16:23:01 <doron> #info Infrastructure.Next expecting 2 ovirt talks.
16:23:29 <doron> #info FOSDEM all set. If you want see the schedules or help staff the booth, sign up at http://etherpad.ovirt.org/p/ovirt-fosdem-14
16:23:33 <doron> thanks bkp
16:23:40 <bkp> doron: NP
16:23:45 <doron> #topic infra update
16:23:54 <doron> orc_orc: how are you?
16:24:13 <orc_orc> hirata: on the LSB call now
16:24:17 <orc_orc> but fine, ty
16:24:35 <doron> so maybe dcaro can update on infra?
16:24:39 <orc_orc> as to infra, no neeting this week due to unavailability of a chair
16:24:43 <doron> (if needed)
16:25:01 <doron> orc_orc: so no special updates?
16:25:07 <orc_orc> no special updates
16:25:10 <doron> thanks
16:25:13 <orc_orc> one outage of the gerrit noted and logged
16:25:27 <doron> #info infra: no special updates
16:25:37 <doron> #topic other topics
16:26:08 <doron> anyone wants to raise something?
16:26:19 <dcaro> upgraded gerrit to 2.8!
16:26:30 <doron> dcaro: yei!
16:26:44 <bkp> Nieuwland case study done, waiting for ovirt.org admin privileges to post it.
16:26:45 <doron> #info infra: upgraded gerrit to 2.8!
16:26:54 <dcaro> some issues with the new changes view though, looking into it
16:26:59 <bkp> Writing up dneary interview with IT Novum for next case study
16:27:03 <doron> bkp: do you need help?
16:27:12 <bkp> Jodi Biddle from RHEV team in Australia has volunteered to help on release notes
16:27:25 <bkp> doron: On what, specifically?
16:27:43 <doron> bkp: anything. This is a good chance if someone wants to help.
16:28:17 <doron> #info case studies making good progress.
16:28:21 <doron> #info Jodi Biddle from RHEV team in Australia has volunteered to help on release notes
16:28:28 <bkp> I'm good. Just waiting for bureaucratic status on MediaWiki. Everyone should start expecting a lot more one-off queries from me now.
16:28:44 <doron> cool ;)
16:28:52 <doron> anting else?
16:28:56 <doron> (anything)
16:29:06 <bkp> Not from me
16:29:14 <doron> going once?
16:29:46 <doron> going twice...
16:30:15 <doron> thanks everyone. Have a good day / night and happy feature freeze!
16:30:18 <doron> #endmeeting