15:06:41 <knesenko> #startmeeting oVirt Infra
15:06:41 <ovirtbot> Meeting started Mon Jan  6 15:06:41 2014 UTC.  The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:06:41 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:06:55 <knesenko> #chair obasan
15:06:55 <ovirtbot> Current chairs: knesenko obasan
15:06:58 <knesenko> #chair eedri
15:06:58 <ovirtbot> Current chairs: eedri knesenko obasan
15:06:58 * orc_orc is here
15:07:17 <knesenko> #chair orc_orc
15:07:17 <ovirtbot> Current chairs: eedri knesenko obasan orc_orc
15:07:19 <knesenko> ewoud: here ?
15:07:24 <knesenko> Rydekull: here ?
15:07:31 <knesenko> bkp: here ?
15:08:17 <bkp> knesenko: Yes
15:08:24 <knesenko> #chair bkp
15:08:24 <ovirtbot> Current chairs: bkp eedri knesenko obasan orc_orc
15:09:08 <eedri> orc_orc, i have a conf live if you want to join a voice chat to discuss the current stats
15:09:17 <orc_orc> kkwill call in
15:09:22 <knesenko> bkp: ^^
15:11:26 <knesenko> #topic Hosting
15:11:57 <knesenko> Hi all
15:12:11 <knesenko> I hope you enjoyed your holidays
15:12:13 <orc_orc> not call ID: 842-597-391-5 ?
15:12:45 <bkp> knesenko: Monitoring, but on another call.
15:12:52 <knesenko> bkp: ok
15:12:54 <eedri> orc_orc, the bridgeid: 1959353860
15:13:10 <orc_orc> * nod *
15:13:12 <knesenko> so I installed monitoring.ovirt.org/cacti service to monitor our infra
15:13:21 <knesenko> and we have few stats for it ...
15:13:39 <knesenko> you can find the credentials in a usual place
15:13:51 <knesenko> #info knesenko monitoring.ovirt.org/cacti was installed
15:16:19 <eedri> #info http://etherpad.ovirt.org/p/Hardware_requirements_infra
15:20:07 <ewoud> knesenko: semi here, highlight if needed
15:20:22 <knesenko> ewoud: we are on the phone call
15:20:24 <knesenko> ewoud: ok
15:20:54 <ewoud> knesenko: ok, will read the minutes
15:23:05 <eedri> http://www.softlayer.com/dedicated-servers/dual-processor-servers
15:26:13 <SvenKieske> Hi infrateam, just a info from your user: the main ovirt.org repo is very slow regarding downloading packages, I never get more than 250kbps which leads to some time to get a new setup running, any chance of speeding this up?
15:30:49 <SvenKieske> Is the etherpad chat disabled?
15:33:07 <orc_orc> SvenKieske: I do not see it either
15:34:05 <SvenKieske> well, nevermind, I just did point to my message from here, regarding the downloadspeed from the main repo. does nobody else got a problem with that? I already reported that some months ago via ML but never got any replies :(
15:34:48 <orc_orc> statistics: sysstat
15:35:12 <orc_orc> adding a wrapper to a Jenkins process start to log load
15:35:27 <orc_orc> also, bail on a new jenkins when load too high
15:35:41 <orc_orc> is there a re-queue mechanism>
15:37:21 <knesenko> #action try to use sysstat for our server to get more statistics
15:37:58 <knesenko> #action look for a load management plugin for jenkins and slaves
15:38:48 <orc_orc> w | logger -p local1.info
15:39:30 <orc_orc> w | top -n 1    and check the value
15:39:38 <eedri> #action try to change vCpu allocation per slave to see if that affects the cpu load on rackspace servers
15:39:51 <orc_orc> w | head -n 1    and check the value
15:39:59 <orc_orc> 10:39:56 up 48 days,  5:29, 39 users,  load average: 1.64, 1.64, 1.42
15:40:17 <orc_orc> if one lf last 3 too bi, abail and ask for a wrequeue
15:40:20 <orc_orc> hi*
15:44:20 <knesenko> #info we found from the current statistics that our hypervisors mostly have high CPU
15:45:31 <knesenko> #info we agreed to reduce the vCPU on slaves to see how it will reduce the load
15:46:03 <knesenko> #info we will try to gather more statistics with the tools orc_orc provided
15:46:16 <knesenko> ok I think we summarized most of the issues here in hosting
15:46:25 <knesenko> I am moving to another topic
15:46:38 <knesenko> #topic
15:46:48 <knesenko> #topic Foreman and Puppet
15:46:54 <knesenko> ok what do we have here
15:47:29 <knesenko> we have few patches here waiting for merge
15:47:37 <knesenko> http://gerrit.ovirt.org/22761
15:47:42 <knesenko> http://gerrit.ovirt.org/22762
15:48:29 <knesenko> ewoud: can you review them ^^ ?
15:48:42 <knesenko> we need cacti user for reverse ssh tunnel ...
15:49:00 <knesenko> because we have few slaves behind a NAt
15:49:54 <knesenko> moving to jenkins
15:50:00 <knesenko> #topic Jenkins
15:50:05 <knesenko> eedri: helo :)
15:50:17 <knesenko> eedri: ok ok ok
15:50:26 <knesenko> so I did some work here as well
15:50:51 <knesenko> #info added missing builders for some projects http://jenkins.ovirt.org/view/Packaging/
15:51:11 <knesenko> I added new publishers to resources.ovirt.org
15:51:21 <knesenko> now we will have publisher per version
15:51:30 <knesenko> #info new publishers http://jenkins.ovirt.org/view/Publishers/
15:51:48 <knesenko> Also I am working on a new layout for repos
15:52:02 <knesenko> #info http://resources.ovirt.org/pub/
15:52:08 <knesenko> example for the new layout
15:52:15 <knesenko> each version will land in its place
15:52:32 <orc_orc> knesenko: there was concern on the ML that hits will bread 'downgrades' under yum?
15:52:47 <knesenko> orc_orc: it will work with a new layout
15:53:07 <orc_orc> can a 'flat' all in one directory view be made, using the 'hardlink; program, as well
15:53:12 <orc_orc> ok ...
15:53:18 <orc_orc> how to test that it is working?
15:53:44 <orc_orc> because the 'repodata' directories will be down a lot of levels
15:53:53 <knesenko> what do you mean ?
15:54:27 <orc_orc> the new layout has a vertical string of directory and sub directories one moves through
15:54:37 <knesenko> ok
15:54:39 <orc_orc> to reach the repodata related toa given release point
15:54:54 <orc_orc> but sometimes a person wants to 'fall back' to an earlier working version
15:55:04 <knesenko> orc_orc: got you
15:55:06 <orc_orc> which yum supports through the ...
15:55:18 <orc_orc> downgrade   command
15:55:34 <orc_orc> and for that to work, yum needs to see the eralier versions in the repodata
15:55:35 <knesenko> lets take for example - http://resources.ovirt.org/pub/ovirt-3.3-snapshot/rpm/Fedora/20/
15:55:41 <knesenko> you are running fedora
15:55:54 <knesenko> all nightly 3.3 builds will land there
15:56:21 <knesenko> and we will save for example 'n' builds
15:56:32 <knesenko> so you will be able to downgrade
15:57:01 <orc_orc> ... so will the prior versions be down in a directory under http://resources.ovirt.org/pub/ovirt-snapshot/rpm/Fedora/20/ with its own repodata?
15:57:01 <ovirtbot> orc_orc: Error: ".." is not a valid command.
15:57:04 <orc_orc> ... so will the prior versions be down in a directory under http://resources.ovirt.org/pub/ovirt-snapshot/rpm/Fedora/20/ with its own repodata?
15:57:31 <orc_orc> (actually both the latest and the prior versions, I guess)
15:57:42 <knesenko> ovirt-snapshot - is for master builds
15:57:57 <knesenko> master is the next version
15:58:18 <orc_orc> so where will the union of 3.2 and 3.3 content be under your model?
15:59:00 <knesenko> http://resources.ovirt.org/pub/ovirt-${version}-snapshot/
15:59:12 <knesenko> -snapshot - nightly builds
15:59:30 <knesenko> http://resources.ovirt.org/pub/ovirt-${version} - released builds
15:59:47 <knesenko> http://resources.ovirt.org/pub/ovirt-snapshot - master nightly builds
16:02:00 <knesenko> orc_orc: I will send an email on it
16:02:04 <knesenko> ok guys thanks
16:02:08 <orc_orc> knesenko: thank you
16:02:11 <knesenko> I think we are done here
16:02:18 <knesenko> orc_orc: thanks for help ! was nice talking to you
16:02:23 <orc_orc> indeed
16:02:26 <knesenko> #endmeeting