15:01:05 <doron> #startmeeting oVirt Weekly Sync
15:01:05 <ovirtbot> Meeting started Wed Dec 11 15:01:05 2013 UTC. The chair is doron. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:05 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:11 * orc_orc_ is here
15:01:19 <doron> #topic Agenda and roll Call
15:01:32 <doron> #info 3.3 update releases
15:01:34 <doron> #info 3.4 progress
15:01:35 <doron> #info conferences and workshops
15:01:37 <doron> #info infra update
15:01:38 <doron> #info other topics
15:01:54 * amureini here
15:01:57 * ecohen here
15:01:59 <amureini> hi everyone
15:02:03 <doron> dougsland: here?
15:02:40 <doron> hi amureini
15:02:42 <dougsland> doron, yes.
15:02:51 * dougsland here
15:02:55 <doron> dougsland: covering for infra today/
15:02:56 <doron> ?
15:03:01 <dougsland> doron, yes.
15:03:22 <doron> #topic 3.3 update releases
15:03:37 <doron> since sandro is away
15:03:47 <doron> we should look into 3.3.2 beta
15:03:58 <doron> it seems that there are 2 issues;
15:04:05 * sherold is here
15:04:23 * evilissimo here for virt
15:04:45 <doron> virt 1029885 cloud-init testcase does not work in engine 3.3.1
15:04:46 <doron> virt 1025829 sysprep floppy is not attached to Windows 2008 R2 machine
15:05:33 <doron> 1029885 is cloud-init, and not really ovirt bz.
15:05:35 * SvenKieske is here for 1029885
15:05:45 <doron> SvenKieske: any feedback?
15:06:19 <SvenKieske> well you can't use it in EL < 6.5. because there are no packages which provide cloud-init >= 0.7.2.
15:06:29 <SvenKieske> this does also effect other distros as well
15:07:12 <SvenKieske> maybe this should be noted in the documentation at least, I'm fine atm with it, I wrote a relatively huge bashscript, to handle the cloud-init meta-data
15:07:21 <doron> SvenKieske: right, but we cannot block on something we cannot fix.. we can issue some release note if it makes sense.
15:07:31 <SvenKieske> which does even more than cloud-init can do, e.g. handle ipv6
15:07:53 <SvenKieske> maybe I can release this script to the community sometime.. have to ask
15:08:00 <doron> SvenKieske: so you agree with non blocking on 1029885?
15:08:19 <SvenKieske> doron: right, but would be cool to put it in the wiki , on which version of cloud-init we depend
15:08:25 <SvenKieske> yeah, doesn't block
15:09:04 * masayag here for network
15:09:12 <doron> #agreed 1029885 is not be blocker, should be documented
15:09:33 <doron> #agreed 1029885 is not be blocker, working cloud-init version should be documented
15:09:38 <itamar> SvenKieske: what's the dependency chaing for cloud-init from el 6.5 if you install it on earliur .el6 (say, 6.4)?
15:10:34 <SvenKieske> itamar: I'm sorry, but I couldn't test it yet, we will stick with el 6.5 but there are also problems with LTS release of ubuntu and debian 7 afaik
15:11:34 <SvenKieske> itamar: from my own buildtests I remember there are mainly python-libs dependencies
15:11:42 <doron> I'd like to ask about 1025829, seems not to be a real blocker as well.
15:11:53 <evilissimo> doron: 1025829 is in post
15:11:55 <itamar> SvenKieske: ok, well, as said, not something we can block 3.3.2 on -
15:12:11 <dneary> Hi all
15:12:13 <evilissimo> it has open review for the backport to ovirt-3.3 master is merged http://gerrit.ovirt.org/#/c/22290/
15:12:16 <evilissimo> hi dneary
15:12:49 <doron> evilissimo: still, I'd like to be able to release the latest build we have as this may take time regardless of the patch.
15:12:54 <doron> hi dneary
15:13:51 <SvenKieske> Bug 1039009 isn't marked as a blocker for 3.3.2 releae also this is it targets release
15:13:55 <evilissimo> doron: at least a workaround for this seems to be simple
15:14:18 <evilissimo> at least from what I can tell about this patch
15:14:29 <doron> very well then. So it seems that 3.3.2 can be released if there are no blockers.
15:14:30 <SvenKieske> the patch for Bug 1039009 is in the tree but afaik untested, I'd like to test this pretty intensiv, so I can see if there goes anything wrong with this
15:14:51 <SvenKieske> doron: see my comment about Bug 1039009
15:14:56 <itamar> doron: 22290 should be backported to 3.3.2 branch. just merged it to 3.3 branch
15:15:16 <evilissimo> itamar: should I post it?
15:15:23 <evilissimo> for 3.3.2
15:15:32 <evilissimo> I think roy is not here anymore
15:16:28 <itamar> evilissimo: works for me
15:16:33 <evilissimo> ok
15:17:47 <doron> very well.
15:17:58 <doron> so when can we release 3.3.2?
15:18:22 <SvenKieske> doron: I'm not sure we talk about the same release, do you mean 3.3.2 beta /rc release or 3.3.2 final release? sorry for the confusion
15:18:37 <evilissimo> itamar: http://gerrit.ovirt.org/22301
15:18:45 <doron> SvenKieske: you're right. this will be 3.3.2 RC
15:19:16 <SvenKieske> doron: I'd just like to remind that the backported patches for bug 1039009 in the 3.3.2 tree got no testing which I'm aware off, so before final release I'd like to test them.
15:19:36 <doron> SvenKieske: this is why we have rc.
15:19:39 <SvenKieske> doron: alright, so I would be fine to release this as 3.3.2 RC so I can test and see if there are any bugs leftover :-)
15:19:52 <doron> should become the release unless we find something critical.
15:19:56 <itamar> evilissimo: merged to 3.3.2 branch as well.
15:20:26 <doron> OK, any objections to release 3.3.2 RC this Monday?
15:21:13 <doron> I'll take that as a no.
15:21:14 <dougsland> doron, I am working into a dep python-cpopen: http://jenkins.ovirt.org/view/vdsm/job/vdsm_3.3_install_rpm_sanity_gerrit/320/label=centos64/consoleFull
15:21:35 <dougsland> other then that, no objections from infra.
15:21:52 <dougsland> eedri_, is looking this failure job with me.
15:22:02 <evilissimo> itamar: thanks
15:22:03 <doron> dougsland: that's good, but not an RC blocker. right?
15:22:42 <eedri_> doron, vdsm fails to install if python-cpopen is already installed
15:22:46 <dougsland> doron, depending of solution (if we change in vdsm.spec) we will need to rebuild vdsm package only.
15:22:54 <eedri_> doron, but if you manually remove that, then it will work.
15:23:01 <eedri_> doron, that's at least what happens on jenkins for now
15:23:11 <doron> eedri_: so there's a sane workaround we can publish
15:23:21 <eedri_> doron, imo i think there are sections on the spec file that shouldn't be there
15:23:28 <doron> eedri_: dougsland and there's enough time until M onday to esolve it.
15:23:49 <dougsland> doron, yes.
15:24:05 <doron> Very well then.
15:24:21 <doron> #info 3.3.2 RC to be released on Monday.
15:24:26 <doron> Moving on
15:24:46 <doron> #info 3.4 progress
15:25:01 <doron> let's go over the various areas
15:25:19 <doron> Gluster... sahina here?
15:25:24 <sahina> doron, hi
15:25:41 <doron> hi sahina. how are you doing on 3.4 progress?
15:26:02 <sahina> doron, for gluster not much change from last week. Monitoring of gluster volumes feature at slight risk
15:26:28 <doron> sahina: does it look like it converges to the deadline?
15:27:02 <sahina> doron, except for the monitoring feature - yes
15:27:35 <doron> sahina: thanks. please check for monitoring to see if we should stop monitoring it...
15:27:46 <sahina> doron, :) will do
15:28:02 <doron> #info Gluster working as planned. Monitoring feature to be revisited.
15:28:30 <doron> dougsland: here for infra?
15:28:58 <doron> dougsland: one feature already done.
15:29:09 <evilissimo> doron: afaik ybronhei is supposed to be here for infra
15:29:26 <doron> evilissimo: right, but today he's away for a test.
15:29:42 <evilissimo> doron: ah ok, didn't know :) I just realized it was your mail anyway ;)
15:29:59 <doron> evilissimo: any idea on the status of 3.4 features?
15:31:08 <doron> I'll take that as a no. Will get back to infra later.
15:31:15 <doron> didi: here?
15:32:05 <doron> skipping integration for now.
15:32:07 <evilissimo> doron: honestly I am not aware of all of it
15:32:11 <alonbl> doron: how can I help?
15:32:34 <doron> alonbl: can you give a short update on infra features for 3.4?
15:32:39 <evilissimo> I know partial it's in progress, the guest agents for Ubuntu and openSuse are done
15:32:46 <alonbl> doron: infra?
15:32:53 <doron> alonbl: sorry, integration.
15:33:00 <evilissimo> but I can't really give a good status update :( on the 3.4 features :/
15:33:09 <alonbl> doron: I think that mainly to finish the packaging rewrite
15:33:14 <alonbl> doron: dwh, reports
15:33:24 <alonbl> doron: also make the websocket proxy standalone component
15:33:42 <alonbl> doron: if we finish this until 3.4 I will be very happy.
15:33:47 <nsoffer> evilissimo, any progress on the traceback?
15:33:54 <alonbl> doron: then we can consider splitting dwh and reports to different server
15:34:05 <doron> alonbl: virtual appliance?
15:34:06 <evilissimo> unfortunately not, I am unable to get the proper traceback
15:34:11 <nsoffer> evilissimo, anything in the logs that explain that load
15:34:12 <nsoffer> ?
15:34:14 <evilissimo> I made a crash dump
15:34:23 <evilissimo> err core dump
15:34:25 <alonbl> doron: ohad is working on that
15:34:29 <evilissimo> but that din't give me much info
15:34:34 <alonbl> doron: I am unsure this is a 'feature'
15:34:38 <ohadlevy> alonbl: i do not
15:34:38 <doron> alonbl: we're monitoring https://docs.google.com/spreadsheet/ccc?key=0AuAtmJW_VMCRdHJ6N1M3d1F1UTJTS1dSMnZwMF9XWVE&usp=sharing#gid=0
15:34:43 <alonbl> doron: this is yet another distribution.
15:34:44 <evilissimo> nsoffer: lets switch back to vdsm
15:34:55 <nsoffer> I think you need to install some gdb python package to get a traceback
15:35:03 <doron> this should have the list of integration features for 3.4
15:35:16 <nsoffer> evilissimo, is this related to some bug?
15:35:32 <evilissimo> nsoffer: #vdsm
15:35:32 <alonbl> doron: the appliance has nothing to do with 3.4 as far as I understand although it can be at 3.0 list
15:35:39 <nsoffer> ok
15:35:49 <alonbl> doron: but as I wrote ohad is working on this
15:36:10 <doron> alonbl: ok. we'll need to get an update for that later. Thanks.
15:36:39 <doron> #info integration making progress on 3.4 features. missing an update on virtual appliance.
15:36:47 <doron> moving next to network.
15:36:51 <masayag> hi
15:36:51 <doron> masayag: here?
15:36:54 <doron> hi
15:37:00 <masayag> 4/6 features will be on time: Multi-Host Network Configuration, Extend integration with Neutron, iproute2 and nic ordering
15:37:03 <doron> masayag: network updates on 3.4?
15:37:13 <masayag> 2/6 are at risk: network labels (at design) network QoS (on implementation stage)
15:37:13 <itamar> masayag - please add ovirt BZ numbers to the various lines... thanks.
15:37:27 <masayag> will do
15:37:53 <doron> #info network doing very well. Cuurently at risk: network labels (at design) network QoS (on implementation stage)
15:38:04 <doron> thanks masayag
15:38:14 <masayag> you welcome
15:38:15 <doron> fabiand: here?
15:39:18 <doron> I'll take it as a no.
15:39:28 <doron> #info no updates on ovirt node.
15:39:44 <doron> someone here for ppc?
15:40:22 <doron> I'll take it as a no.
15:40:32 <gtemple> yes, I and vitorlima
15:40:41 <doron> gtemple: hi
15:40:47 <doron> any updates on your progress?
15:42:08 <vitorlima> doron, a lot of patches were merged, but the spreadsheet describing each feature was not updated to reflect this
15:42:38 <doron> vitorlima: thanks. So for visibility please update it by next week's meeting?
15:42:59 <vitorlima> sure, could someone give R/W access to that spreadsheet?
15:43:28 <vitorlima> lbianc was responsible for keeping it updated, but he is away
15:43:31 <doron> vitorlima: please mail itamar your gmail account
15:43:42 <doron> you should get a RW invite.
15:43:53 <doron> vitorlima: gtemple also, will you make it to the 3.4 deadline?
15:44:08 <itamar> vitorlima: or request access via the googledoc
15:44:23 <dougsland> doron, feature update about infra: we are in progress about snmp and authentication (sorry the delay)
15:44:25 <vitorlima> sure
15:44:34 <gtemple> sure
15:44:43 <doron> dougsland: thanks. please let vitorlima to complete his report.
15:44:45 <vitorlima> we will, of course it will depend on the reviews that we are getting on gerrit
15:44:50 <itamar> vitorlima: you should be good now.
15:44:59 <eedri_> itamar, ping
15:45:00 <vitorlima> thanks, itamar
15:45:04 <itamar> vitorlima: i saw a lot of progress - vdsm bugs and engine patch merged for a lot of items?
15:45:13 <doron> vitorlima: please alert if you see a review is stuck and we'll be able to support. ok?
15:45:48 <vitorlima> itamar: yes, in the last 7 days we are progressing quickly
15:45:55 <doron> #info PPC is making progress. Should update spreadsheet for next meeting with recent updates. Deadline looks good for now.
15:45:55 <vitorlima> there are more patches coming
15:46:14 <doron> back to infra
15:46:20 <doron> dougsland: updates?
15:46:33 <danken> vitorlima: I have rebased one of your patches
15:46:44 <danken> please review/verify it...
15:46:56 <dougsland> doron, the feature are in progress (snmp and authentication)
15:47:01 <vitorlima> danken, sure I will
15:47:29 <doron> dougsland: any issues for 3.4 deadline?
15:48:03 <danken> vitorlima: please enlist fromani for the review of http://gerrit.ovirt.org/#/c/18718/7/vdsm/vm.py
15:48:28 <doron> #info infra team working as planned. WIP on SNMP and authentication.
15:48:36 * doron for sla
15:48:49 <vitorlima> danken: done
15:49:20 <doron> #info SLA team reviewed the features this week. some may not make it to the deadline, so an update will be given next week for the relevant features.
15:49:20 <danken> vitorlima: or someone else from the virt team. adding a name to gerrit may not be enough. use your nagging powers ;-)
15:49:36 <doron> amureini: how are storage doing?
15:50:34 <amureini> doron, on track, mostly. hsm async tasks is shaky, and need to nail down the scope of the functional tests - not sure how much of it will be delivered for 3.4
15:50:46 <YamakasY> wow SVN is really nice
15:51:16 <doron> amureini: you are missing BZs and feature pages. can you please update for next week?
15:51:53 <doron> amureini: what's currently as risk for 3.4 deadline?
15:52:36 <amureini> doron, only things that seem to miss info are the ones cloesd in 3.3. I am not opening a "feature page" for functional tests.
15:52:47 <amureini> doron, as noted, hsm async tasks is the main concern
15:52:55 <amureini> doron, others should be ok
15:53:15 <doron> amureini: functional tests>?
15:53:19 <SvenKieske> "read only disks" is stated as "done" in gdoc but in the feature page it's status is wip?
15:53:32 <amureini> doron, I take the following statement back, I see the missing feature pages. will get them update
15:53:51 <amureini> doron, as per your question "viable, ever-working vdsm functional tests", requested by danken
15:54:16 <doron> amureini: very well. so let's have a full update forr next week including features at risk. ok?
15:54:18 <amureini> SvenKieske, patches are merged, need to update the feature page. thank
15:54:41 <amureini> doron, I thought I just gave the list (of 1) features at risk.
15:54:51 <doron> amureini: and functional tests?
15:55:11 <SvenKieske> amureini: cool, thank you :) I always love an updated wiki :-)
15:55:26 <doron> amureini: also some others are marked as stretch.
15:55:43 <amureini> doron, will be delivered to 3.4, in some scope or another
15:56:20 <doron> #info storage is mostly on track other than hsm async tasks. Functional tests may be re-scoped.
15:56:23 <doron> thanks amureini
15:56:33 <doron> ecohen: here?
15:56:38 <ecohen> doron, yes
15:56:41 <doron> hey
15:56:43 <ecohen> hi
15:56:53 <doron> how is the ux doing for 3.4?
15:57:04 <ecohen> doron, not extremely well:
15:57:05 <ecohen> doron, "case insensitive search" - done (quite a long time ago) by Oved.
15:57:05 <ecohen> doron, "centralizing refresh logic", "broken layout in low resolutions", "ovirt new l&f" - in progress, all at risk.
15:57:05 <ecohen> doron, everything else ("grid column selector", "ui plugins support for error dialogs", "single messages file", "GUI over REST API") - won't happen, moved to the 'removed' sheet.
15:57:45 <doron> #info UX team progress:
15:57:52 <doron> #info "case insensitive search" - done
15:58:04 <doron> #info "centralizing refresh logic", "broken layout in low resolutions", "ovirt new l&f" - in progress, all at risk.
15:58:18 <doron> #info other features postponed.
15:58:22 <doron> thanks ecohen
15:58:26 <ecohen> doron, np
15:58:31 <doron> evilissimo: here for virt?
15:58:46 <evilissimo> yes I am
15:58:57 <doron> evilissimo: how is virt doing for 3.4?
15:59:45 <doron> evilissimo: also, many are missing bz numbers and feature pages. Can you please update for next week?
16:00:03 <evilissimo> As I said, some features are in progress, guest agents for Ubuntu and openSUSE are done, but I unfortunately cannot give a granular feature update
16:00:11 <evilissimo> doron: will push for that
16:00:50 <doron> evilissimo: thanks. Also if you can update on risks next week that would help.
16:01:34 <evilissimo> k
16:01:47 <doron> #info virt team on track; guest agents for Ubuntu and openSUSE are done. Risks to be updated next week.
16:02:01 <doron> that's it for 3.4. Moving on
16:02:16 <doron> #info conferences and workshops
16:02:43 <doron> #topic conferences and workshops
16:02:49 <doron> dneary: itamar updates on $TOPIC?
16:02:50 <dneary> We expect to be sending out FOSDEM notifications by the end of the week
16:03:14 <doron> dneary: including schedule?
16:03:26 <dneary> doron, I believe that's the plan.
16:03:47 <doron> #info FOSDEM notifications and schedule to be sent by the end of the week.
16:04:03 <doron> dneary: thanks. Anything else?
16:04:08 <dneary> We will also be opening the call for content for another one day event focussed on open source cloud & infrastructure projects in the next couple of weeks - keep your eye out
16:04:33 <dneary> In other unrelated community news: a new oVirt book just hit the market
16:05:05 <evilissimo> dneary: the one the author was writing about on the users list?
16:05:18 <evilissimo> recently
16:05:33 <dneary> Getting Started with oVirt 3.3 by Alexey Lesovsky: http://www.packtpub.com/getting-started-with-ovirt-3-3/book
16:05:47 <dneary> evilissimo, Yes, that's correct
16:06:24 <dneary> Also, I saw on Twitter recently the awesome story of an Austrian company migrating 1100 machines to oVirt to manage their datacenter.
16:06:45 <dneary> https://twitter.com/search?q=%23OpenSourceDataCenter&src=typd
16:07:06 <evilissimo> oh it wasn't the author, but someone related to the publisher
16:07:08 <evilissimo> anyway
16:07:22 <doron> dneary: other updates?
16:07:48 <dneary> I have also been maintaining the oVirt twitter account much more: follow it for Twitter news as I learn about it: https://twitter.com/ovirt
16:08:47 <doron> #info ovirt twitter account available. You're all invited to follow- https://twitter.com/ovirt
16:08:55 <doron> dneary: thanks.
16:09:17 <itamar> and this one "Opaque, Android client for oVirt and RHEV, is available for public beta:"
16:09:37 <amureini> dneary, isn't this the old "Open Virtualization" account?
16:09:43 <dneary> itamar, Yes - that sounds like a nice project, it would be good to get feedback from the community
16:09:48 <dneary> amureini, Yes
16:09:58 <mskrivanek> doron: in addition to above mentioned guest agent features - the only other feature ready for 3.4 is "search by description". Everything else is at risk
16:10:13 <amureini> dneary, 10x. was just trying to understand what the "news item" was here.
16:10:13 <mskrivanek> for virt I mean
16:10:14 <dneary> I only recently figure out how to get access, and have been maintaining it. bkp (Brian Proffitt) will be joining me in that
16:10:30 <doron> mskrivanek: thanks. will be noted next week.
16:10:50 <dneary> amureini, So the "news item" is "it's now worth following"
16:10:57 <amureini> dneary, `-)
16:11:10 <evilissimo> dneary: :D
16:11:15 <doron> ok, so moving to next topic;
16:11:18 <doron> #topic infra update
16:11:35 <doron> who wants to update?
16:12:09 <doron> dcaro: orc_orc updates?
16:12:15 <orc_orc_> doron: ok
16:12:19 <orc_orc_> getting minutes
16:12:41 <orc_orc_> rackspace03 issue wkraround may have been found,
16:12:59 <orc_orc_> * ACTION: dcaro request a new certificate for gerrit.ovirt.org
16:13:10 <orc_orc_> was listed -- I don't know the process on that, but it is out there
16:13:24 <doron> dcaro update?
16:13:40 <dcaro> orc_orc_: it's still there :/, I enabled the ssl, but the cert is expired
16:13:48 <orc_orc_> other matters were dicusssed, but not really relevant for here as to blockers, etc
16:14:12 <doron> dcaro: are you renewing it? issuing another?
16:14:13 <orc_orc_> minutes at: http://ovirt.org/meetings/ovirt/2013/ovirt.2013-12-09-15.11.html
16:14:17 <itamar> I created a VM for oved to create an images.ovirt.org via glance to host images.
16:14:35 <orc_orc_> that is about all from Infra
16:14:44 <doron> #info VM created for images.ovirt.org via glance to host images.
16:14:51 <dcaro> doron: Yep, I have to create a request and send it to engops to sign
16:15:18 <doron> #info dcaro handling SSL in gerrit.ovirt.org
16:15:22 <doron> thanks guys.
16:15:25 <doron> Moving on
16:15:34 <doron> #topic other topics
16:15:45 <doron> anyone want to raise something?
16:16:05 <orc_orc_> the current gerrit cert is not signed by an ahthority in the chain
16:16:16 <orc_orc_> any reasoin not to be using startssl?
16:16:21 <doron> orc_orc_: so it becomes an exception
16:16:55 <doron> ok, no additional updates.
16:17:00 <doron> Going once...
16:17:14 <doron> Going twice...
16:17:29 <doron> #endmeeting