14:00:32 <mburns> #startmeeting oVirt Weekly Meeting
14:00:32 <ovirtbot> Meeting started Wed Oct 16 14:00:32 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:32 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:47 <mburns> #topic agenda and roll call
14:00:59 <mburns> #info 3.3 updates
14:01:03 <mburns> #info 3.4 planning
14:01:18 <mburns> #info conferences and workshops
14:01:32 <mburns> #info infra update
14:01:43 <mburns> #info next week's meeting
14:01:46 <mburns> #info Other Topics
14:01:53 * sbonazzo here
14:02:07 * oschreib partially here
14:03:19 <mburns> #topic oVirt 3.3.0.1 update
14:03:35 <mburns> #info vdsm, engine, and tools all have updates pending
14:03:39 <mburns> can we push them live?
14:03:56 <dneary> hi
14:05:13 <sbonazzo> mburns: no blockers for 3.3.0.1 AFAIK
14:05:25 <sbonazzo> mburns: what's pending?
14:05:45 <mburns> sbonazzo: all i need is an ack to push them live, and i'll post the later today
14:05:58 <mburns> if there are no known issues, then i'm all set
14:07:02 <sbonazzo> mburns: 3.3.0.1 looks good to me
14:07:18 <mburns> ok
14:07:28 <mburns> #info 3.3.0.1 ready to go live
14:07:40 <mburns> #action mburns to push and send release notice to mailing lists
14:09:39 <mburns> ok, moving to 3.3.1
14:09:46 <mburns> #topic oVirt 3.3.1 update release
14:09:56 <mburns> sbonazzo: any updates here?  i saw your email earlier...
14:10:16 * oschreib has to go, moving classes.
14:10:22 <sbonazzo> mburns: it seems that also 3.3.1 is in a good shape
14:10:29 <oschreib> but I see you guys handles things pretty well
14:10:33 <sbonazzo> mburns: I think we can go with beta
14:10:45 <mburns> sbonazzo: ok, what's the plan for building the packages?
14:11:54 * danken is here
14:11:55 <mburns> danken: ping -- any update on vdsm for 3.3.1?
14:12:15 <sbonazzo> mburns: for ovirt-engine, log collector and uploaders I can take care of building them (I've to check for uploaders and log collector if a build is needed). other maintainers should take care of respective packages
14:12:15 <danken> mburns: afaik, it's fine
14:12:17 <danken> but
14:12:24 <danken> we still need selinux
14:12:37 <danken> I've added the relevant selinux-policy bug to the tracker.
14:13:14 <sbonazzo> danken: is that for having it in centos?
14:13:29 <danken> centos or any other el6
14:13:38 <sbonazzo> danken: ok
14:13:41 <dneary> Will be paying little attention here until ovirt.org is reworking
14:13:46 <mburns> danken: is there a pending build for selinux yet?
14:13:52 <danken> sbonazzo: it's one of our supported platforms!
14:13:57 <danken> mburns: yes
14:14:07 <danken> but it's still hidden within Red Hat.
14:14:07 <sbonazzo> danken: ok
14:14:15 <mburns> danken: ahh, ok
14:14:25 <mburns> so we need to get it into koji
14:15:12 <mburns> danken: i'm guessing there is no workaround except a new selinux package?
14:15:34 <danken> mburns: I think that it does not work that way... we'd need to make it free, and then it would get into centos or whereever.
14:15:47 <danken> mburns: I do not think EPEL6 has it.
14:15:50 <danken> or allows it.
14:16:22 <danken> so you should not look for it in koji.
14:16:29 <mburns> ok
14:16:45 <mburns> #info sbonazzo has tools and engine under control and will build
14:16:59 <mburns> #info vdsm is ready, but is blocked by selinux bug on el6
14:17:27 <mburns> danken: do you have builds available?
14:17:36 <mburns> (of vdsm)
14:17:37 <sbonazzo> mburns: ok. I'll build tomorrow morning.
14:17:45 <mburns> sbonazzo: thanks
14:17:47 <danken> mburns: hmmmm
14:18:01 <danken> let's ask dougsland take care of making sure they are there?
14:18:12 <danken> (a build from the tip of the ovirt-3.3 branch)
14:18:36 <mburns> #action dougsland to build vdsm from ovirt-3.3 branch and provide to mburns for posting
14:18:45 <dougsland> mburns, danken o>
14:19:00 <danken> dougsland: thanks in advance
14:19:09 <mburns> #info we can note that selinux is needs to be permissive on EL6 for the time being
14:19:35 <mburns> danken: i'm assuming permissive will minimize the problem in the short term?
14:19:42 <danken> mburns: and make Dan Walsh weep.
14:19:52 <mburns> danken: it's temporary and only in beta...
14:20:04 <mburns> danken: it makes me sad too
14:20:25 <danken> mburns: better add a release note for folks to run
14:20:25 <danken> sudo semanage fcontext -a -s system_u -t virt_var_run_t -r s0 '/var/run/vdsm(/.*)?'
14:20:27 <danken> on hosts.
14:20:46 <mburns> danken: that solves it?
14:20:52 <danken> or we could do an ovirt-3.3-only patch to vdsm that runs it on %post script.
14:21:30 <mburns> danken: i just wonder if that will break on ovirt-node
14:21:32 <danken> dougsland: and ybronhei could take care of that, too.
14:21:50 <danken> mburns: ... or done on firs vdsm startup
14:21:57 <danken> (if it breaks ovirt-node)
14:22:21 <mburns> danken: tbh, i'm not sure which is more likely to break on ovirt-node
14:22:44 <mburns> selinux stuff with node is always tricky...
14:23:06 <mburns> #action fabiand_ to work with dougsland to figure out the right way to handle this short-term
14:23:25 <danken> dunno, either wait for selinux-policy, (kick some friends in westford for this!) or set ovirt-node to permissive.
14:23:41 <mburns> danken: permissive on ovirt-node --- not going to happen...
14:24:06 <mburns> but i'm sure that dougsland and fabiand_ can find a solution
14:24:06 <danken> so we must wait for selinux-policy.
14:25:00 <mburns> #info workaround  for vdsm issue semanage fcontext -a -s system_u -t virt_var_run_t -r s0 '/var/run/vdsm(/.*)?'
14:25:10 <mburns> (just so i can find it easily later
14:25:12 <danken> plase remind me of the ovirt-3.3.1 tracker bug?
14:25:24 <mburns> sbonazzo: do you have the tracker bug handy?
14:25:31 <sbonazzo> https://bugzilla.redhat.com/show_bug.cgi?id=1019391
14:25:58 <mburns> #info once vdsm is built, a new node can be generated
14:26:12 <mburns> #info tracker:  https://bugzilla.redhat.com/show_bug.cgi?id=1019391
14:26:30 <sbonazzo> mburns: we've a brand new blocker on that tracker in assigned state
14:26:51 <danken> mburns: if you could kick https://bugzilla.redhat.com/show_bug.cgi?id=1015068 to CLOSE|NEXT_RELEASE
14:26:59 <sbonazzo> mburns: but I think we can go with the beta1 also without it
14:27:00 <danken> it would be even best.
14:27:14 <danken> for selinux-policy-3.7.19-195.el6.13
14:27:41 <mburns> danken: that's a rhel bug -- i'm not touching a rhel bug to mark it closed...
14:28:05 <mburns> the errata needs to ship it
14:28:11 <danken> mburns: exactly
14:28:30 <danken> mburns: I'm asking you to politely kick the relevant people to make it happen.
14:28:34 <mburns> ahh, ok
14:28:42 <mburns> i'll see if i can track the right people down
14:29:59 <mburns> ok, anything else for 3.3.1?
14:30:50 <mburns> sbonazzo: can you make sure things like otopi and ovirt-host-deploy aren't needed (or get built if they are?)
14:31:39 <sbonazzo> mburns: I can check package dependencies and ensure they're all satisfied
14:32:22 <mburns> ok, thanks
14:32:25 <mburns> moving on to 3.4
14:32:32 <mburns> #topic oVirt 3.4 planning
14:33:21 <mburns> #info itamar has started a thread on board@ discussing a new cadence for releases
14:34:07 <danken> I did not see a "kill vdsm-reg" task there, but we must have it.
14:34:09 <danken> it's time.
14:34:22 <mburns> #info based on this schedule we'll be targeting a release in late January/early February
14:34:26 <danken> not in board@....
14:34:47 <mburns> #info with the end goal of moving to a much quicker cadence for update releases
14:35:01 <mburns> danken: i'll copy the discussion to arch@ as well
14:37:02 <mburns> let's discuss the changes on list, rather than here, since i'm sure people not here have opinions
14:37:12 <mburns> any objections?
14:37:31 <danken> I'm happy with short cycles
14:37:47 <sbonazzo> mburns: ok for discussing on list
14:37:52 <danken> as long we keep a few weeks (4?) for stabilization)
14:38:06 <mburns> danken: yes, it will be shorter dev cycle, longer stabilization
14:38:16 <mburns> the email is vague on how long for each step
14:38:39 <mburns> but i think we said that we should freeze around start of January
14:38:52 <mburns> and do stabilization only until we release
14:40:24 <mburns> ok, moving on
14:40:30 <mburns> #topic conferences and workshops
14:40:46 <mburns> #info big conference is at KVM Forum next week
14:41:15 <mburns> #info many talks at CloudOpen/LinuxCon and at KVM Forum
14:41:36 <mburns> #info Other upcoming conferences are on the wiki home page
14:42:18 * mburns doesn't have anything else to say about this and dneary is busy trying to fix ovirt.org right now...
14:42:59 <mburns> we can re-visit this topic later if needed
14:43:06 <mburns> #topic Infra updates
14:43:14 <mburns> ewoud: eedri_ any updates this week?
14:43:30 <mburns> #info ovirt.org is currently down (as of about 1/2 hour ago)
14:43:38 <eedri_> mburns, new baremetal slave was added to jenkins.ovirt.org
14:43:44 <mburns> #info dneary is working on figuring out why right now
14:43:54 <mburns> #info bare metal slave added to jenkins
14:43:57 <dneary> Site is back up, but slow
14:43:58 <eedri_> mburns, it's currently a testing server, and if it will prove to work well, we might add more
14:44:21 <mburns> #info targeted as a host for running tests (including spawning vms)
14:44:23 <dneary> The database had an issue on restart, restarted it again and it appears to be working correctly, but no idea why
14:44:36 <mburns> dneary: ack
14:45:02 <dneary> mburns, Have we ever minuted that we're actively recruiting an oVirt community manager right now?
14:45:16 <mburns> dneary: no, not that i'm aware of
14:45:29 <mburns> dneary: i'll do so in Other Topics
14:45:39 <dneary> This is the opening: http://etherpad.corp.redhat.com/OpenShiftOSASCollaboration
14:45:46 <dneary> Gah. Wrong link, sorry
14:45:55 <dneary> This is the link: https://careers-redhat.icims.com/jobs/40181/technical-community-manager---ovirt/job
14:46:06 <mburns> ack, i'll add it to minutes
14:46:21 * sbonazzo need to go
14:46:23 <mburns> eedri_: ewoud:  anything else from infra?
14:48:04 <mburns> ok, moving on then
14:48:06 <mburns> #topic Next Week's Meeting
14:48:23 <mburns> #info Due to KVM Forum next week, it seems that most participants won't be available
14:48:41 <mburns> #info i'd propose that we skip the meeting and handle any topics/issues over email
14:48:50 <mburns> any objections?
14:49:41 <mburns> ok, then i'll cancel next week's meeting
14:49:49 <eedri_> mburns, http://resources.ovirt.org/meetings/ovirt/2013/ovirt.2013-10-14-14.02.html
14:49:54 <eedri_> mburns, infra meeting summry link
14:49:55 <mburns> #action mburns to cancel next week's meeting
14:50:09 <mburns> #topic other topics
14:50:15 <mburns> #info Additional Infra updates
14:50:17 <mburns> #link http://resources.ovirt.org/meetings/ovirt/2013/ovirt.2013-10-14-14.02.html
14:50:38 <mburns> #info Red Hat is actively recruiting a Community Manager for the oVirt Project
14:50:45 <mburns> #link https://careers-redhat.icims.com/jobs/40181/technical-community-manager---ovirt/job
14:51:27 <mburns> dneary: can people ping you if they're interested or want more details?
14:52:23 <mburns> or just follow the link on that page to apply?
14:52:36 <mburns> if anyone has other topics, please raise them now
14:54:58 <mburns> ok, thanks everyone
14:55:00 <mburns> #endmeeting