14:02:24 <knesenko> #startmeeting oVirt Infra
14:02:24 <ovirtbot> Meeting started Mon Oct 14 14:02:24 2013 UTC. The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:24 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:33 <knesenko> #chair ewoud eedri_ obasan
14:02:33 <ovirtbot> Current chairs: eedri_ ewoud knesenko obasan
14:02:41 <knesenko> Rydekull: here ?
14:02:43 * orc_orc is here
14:02:56 <knesenko> #chair orc_orc
14:02:56 <ovirtbot> Current chairs: eedri_ ewoud knesenko obasan orc_orc
14:03:13 <knesenko> orc_orc: Hello
14:03:24 <orc_orc> good day ;)
14:03:31 <knesenko> orc_orc: would you like to introduce yourself ?
14:03:31 <obasan> orc_orc, hello
14:04:02 <orc_orc> I am Russ Herrold ... was at the meeding last week, and getting a handle on the infra suport of the CI system presently, with an eye to replicating it
14:04:47 <knesenko> orc_orc: welcome aboard
14:04:51 <orc_orc> thannk you
14:05:22 <knesenko> orc_orc: on which areas do you prefer to work ? system administration ? coding ?
14:05:22 <eedri> orc_orc, are you considering joining the infra team as a formal member?
14:05:53 <orc_orc> eedri: I am happy to do so ... I run such in other contexts
14:06:43 <orc_orc> I do not quite understand the approach to reporting and solving infra bugs as it does not seem an issue tracker is systematically used, other than a mailing list
14:07:28 <knesenko> orc_orc: you are right ... we use mailing listing more than the issue tracker
14:07:37 <knesenko> we should switch to it
14:07:40 <knesenko> ok lets start
14:07:46 <knesenko> #topic Hosting
14:07:50 <knesenko> ok ...
14:07:57 <ewoud> knesenko: I saw your migration plan
14:08:00 <knesenko> so I sent the migration plan to the infra list
14:08:19 <knesenko> so you are more then welcomed to review it
14:08:23 <knesenko> ewoud: how it looks like ?
14:08:29 <ewoud> http://lists.ovirt.org/pipermail/infra/2013-October/004123.html
14:08:40 <ewoud> knesenko: I was wondering what you meant by the mac address mapping
14:08:50 <knesenko> ewoud: ah ...
14:09:10 <knesenko> ok .. so now we have static mapping between the VMs mac.
14:09:30 <knesenko> what I mean is: vm01 is running on rackspace01 and it works ok
14:09:48 <knesenko> If we will try to migrate to another host, VM will lost connectivity
14:10:07 <knesenko> because rackspace guys did some mapping on their side
14:10:29 <knesenko> So I asked them to make it dynamic, so we will be able to migrate VMs between hosts
14:10:45 <ewoud> knesenko: it would be helpful to document the network setup there because this is new to me
14:10:55 <knesenko> ewoud: yes ... right
14:11:16 <ewoud> #action knesenko document network setup for hosts at rackspace
14:11:21 <orc_orc> knesenko: it would seem an 'assignment pool' of MAC addresses is needed betwrrn a given cluster of dom0's to manage, so that they could self manage this at layer 2 ?
14:11:31 <knesenko> ewoud: that's what I wrote ... you are faster than me
14:11:32 <ewoud> knesenko: other than that I think it's good
14:11:53 <ewoud> knesenko: can we use the ovirt mac address pool feature for this?
14:12:16 <knesenko> orc_orc: maybe ... I opened a ticket. lets wait for their reply
14:12:33 <knesenko> ewoud: I am not aware of that feature :)
14:12:39 <knesenko> ewoud: what is that ?
14:12:57 <ewoud> knesenko: I changed it for alterway02 because we had a conflict because ovirt always defaults to the same
14:13:43 <ewoud> knesenko: but ovirt has a pool where it picks a mac address from when you create a new VM
14:13:52 <knesenko> ewoud: ah ... you mean the way engine generates the MAC address pool ?
14:13:55 <eedri> knesenko, ewoud is talking about MacPoolRanges field in vdc_options table
14:14:05 <ewoud> knesenko: yes
14:14:08 <knesenko> ewoud: ah ok ...its not relevant in our case
14:14:21 <ewoud> knesenko: how so?
14:14:26 <knesenko> ewoud: the problem is in their network configuration
14:15:09 <knesenko> according to their netowrk VM with mac A will be able to connect to the internet only when running on host B
14:15:16 <knesenko> that's their policy
14:15:49 <ewoud> knesenko: ah
14:16:08 <knesenko> and we want setup with migration
14:16:45 <knesenko> so ... they need to solve and define that VM with MAC A should be able to run on rackspace*
14:16:49 <knesenko> all our servers
14:16:55 <knesenko> ok anything else on hosting ?
14:17:12 <knesenko> good
14:17:21 <knesenko> #topic puppet and foreman
14:17:25 <knesenko> ewoud: news ?
14:17:30 <knesenko> dcaro is not here today
14:17:59 <ewoud> knesenko: no, had no time to work on it last week
14:18:35 <eedri> knesenko, yes
14:18:45 <knesenko> eedri: yes please
14:19:01 <eedri> knesenko, we have a few open issues for puppet, i wonder if i should add it as tickets to trac
14:19:29 <knesenko> eedri: yes ... I would like to move all tasks to track
14:19:56 <knesenko> guys, if you see email with some request - please reply to them to open a ticket .
14:20:01 <knesenko> we should start using tickets
14:20:34 <eedri> knesenko, ok, we have some issues, i will open tracs for them
14:20:44 <knesenko> eedri: good
14:21:03 <knesenko> orc_orc: are you familiar with puppet ?
14:21:36 <eedri> #action eedri to open trac tickets on open puppet tasks
14:22:18 <orc_orc> knesenko: yes -- I use it locally for some projects
14:22:32 <orc_orc> I was looking for the trac link -- the web pages seem to point to bugzilla as the issue tracker ?
14:22:54 <knesenko> orc_orc: send me the link please
14:22:55 <ewoud> we should update the trac pages
14:23:36 <orc_orc> both: http://www.ovirt.org/Community and http://www.ovirt.org/Communication seem to
14:23:59 <eedri> https://fedorahosted.org/ovirt/report
14:24:02 <eedri> orc_orc, ^
14:24:05 <orc_orc> http://www.ovirt.org/Infrastructure_team_meetings
14:24:06 <ewoud> orc_orc: ovirt uses bugzilla where ovirt infra uses trac so that may be a bit confusing
14:24:30 <orc_orc> oops -- that page needs the link -- shall I add it?
14:26:18 <ewoud> orc_orc: please
14:26:29 <knesenko> anything else ?
14:27:27 <knesenko> #topic Jenkins
14:27:28 <eedri> knesenko, yea
14:27:32 <eedri> knesenko, on jenkins i mean
14:27:35 <knesenko> eedri: :)
14:27:39 <knesenko> shoot
14:27:57 <eedri> knesenko, there were some requests by community for fedora20 slave and ubunto slave
14:28:19 <eedri> knesenko, i think we can reinstall one of the f18 slaves as f20
14:28:28 <knesenko> eedri: ok .. lets open a tciket for that also
14:28:30 <eedri> knesenko, since most focus now is on f19, right
14:28:34 <knesenko> eedri: ok ...
14:28:42 <eedri> ewoud, can foreman install both?
14:28:49 <knesenko> eedri: make no sense to me to do it before the migration
14:29:14 <ewoud> eedri: yes, but we may need to add the preseed template
14:29:26 <knesenko> orc_orc: would you like to handle puppet tasks eedri will open ?
14:29:46 <ewoud> eedri: https://github.com/theforeman/community-templates/tree/master/preseed should be a good starting point
14:31:15 <eedri> ewoud, are these ready made iso files ?
14:31:26 <eedri> ewoud, or provision temaplres
14:31:33 <ewoud> eedri: provision templates
14:31:59 <eedri> ewoud, ok,
14:32:17 <eedri> #info info on install ubunto in foreman: https://github.com/theforeman/community-templates/tree/master/preseed
14:32:43 <eedri> ewoud, what about f20?
14:33:23 <orc_orc> knesenko: I am happy to look at them and try -- my account name in FAS is: herrold
14:33:39 <eedri> orc_orc, you just need user on gerrit.ovirt.orgt
14:33:43 <knesenko> orc_orc: great !
14:33:51 <eedri> orc_orc, then you can push patches to any ovirt project
14:34:05 <ewoud> eedri: that should be a matter of adding the Operating System in foreman, link the templates and install
14:34:36 <eedri> ewoud, ok
14:34:44 <eedri> ewoud, so i guess we'll need to add it as ticket as well
14:35:07 <ewoud> eedri: yes
14:36:14 <eedri> #action open ticket on adding support for installing f20 and ubunto in foreman.ovirt.org
14:36:34 <knesenko> anything else here ?
14:37:17 <eedri> knesenko, yes
14:37:32 <eedri> knesenko, jenkins LTS has newer version with multiple bug fixed, needs to be upgraded
14:37:44 <knesenko> obasan: ^^ ? :)
14:37:46 <eedri> knesenko, also, lots of plugins versions are also outagred
14:38:01 <obasan> eedri, knesenko I will do it
14:38:43 <knesenko> obasan: good
14:38:58 <eedri> #action obasan to upgrade jenkins.ovirt.org to latest LTS and review plugins upgrades
14:39:11 <eedri> knesenko, also, i'm currently testing adding a new bare-metal slave to jenkins
14:39:26 <eedri> knesenko, you can see it as "remote_slave_jnlp_dell01"
14:39:58 <knesenko> eedri: good !
14:40:11 <eedri> knesenko, so feel free to try and run jobs on it and play with it
14:40:39 <knesenko> where is Rydekull ?
14:40:42 <eedri> #info new bare-metal minidell added as jenkins slave to testing (will be able to run VMs)
14:41:36 <knesenko> I will try to send him email
14:42:05 <knesenko> This week I"ll try to finish with rackspace migration
14:42:09 <knesenko> I hope so
14:42:19 <knesenko> seems like we are done here. right ?
14:42:50 <eedri> knesenko, maybe it's worth review tickets?
14:42:55 <ewoud> +1
14:43:02 <eedri> knesenko, cause i'm not sure anyone looks at them outside of this meeting
14:43:13 <knesenko> eedri: I need to go now ... If you can take a lead on it it will be great
14:43:15 <knesenko> eedri: can you ?
14:43:34 <eedri> knesenko, i'm not fully familiar with the bot commands
14:43:53 <knesenko> at the end of the meeting just run \#endmeeting
14:43:55 <knesenko> :)
14:44:00 <knesenko> eedri: that's all
14:44:10 <eedri> knesenko, ok
14:44:14 <knesenko> eedri: thanks
14:44:17 <knesenko> buy guys
14:44:33 <eedri> ok, last things on jenkins
14:44:42 <eedri> i saw new vdsm functional tests job
14:44:52 <ewoud> eedri:
16:02:24 <@ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:45:01 <eedri> i think apuiemo is managing them
14:45:25 * eedri doesn't remember the exact nic
14:46:15 <ewoud> there was something with the maintainer of that
14:46:19 <ewoud> wasn't it passed on?
14:46:29 <eedri> i think we should appoint an engine and vdsm owner for jenkins upstream
14:46:59 <eedri> someone who will be in charge of monitoring the jenkins status, cause right now some jobs might stay broken for some time
14:47:11 <eedri> like it was, without anyone looking into it
14:47:29 <ewoud> eedri: I do like the idea and jenkins can easily always CC someone when a build breaks
14:47:36 <eedri> and last time i proposed to add infra@ovirt.org as email recepient on failing jobs, it was rejected
14:48:03 <ewoud> eedri: I think because infra@ was getting spammed and infra may not be able to fix the jobs
14:48:16 <eedri> ewoud, yes, i agree
14:48:17 <ewoud> if it's code for example
14:48:30 <eedri> ewoud, there are a few ways to handle it, we can tell jenkins to send only 1 email per failure for e.g
14:48:47 <eedri> ewoud, so it won't email on reoccuring failures
14:49:02 <eedri> ewoud, or maybe a job that will email unstable jobs daily/weekly?
14:49:04 <eedri> to infra
14:49:18 <ewoud> eedri: I like the daily/weekly idea
14:49:38 <eedri> ewoud, or we can spend time in the meeting to review them?
14:49:55 <ewoud> eedri: I think a weekly mail before the meeting may be helpful then
14:50:07 <ewoud> eedri: so we at least have some time overview and time to prepare
14:50:11 <eedri> ewoud, +!
14:50:16 <eedri> ewoud, +1
14:50:46 <eedri> #action add jenkins job to email infra@ovirt.org list of unstable jobs before infra meeting
14:52:48 <eedri> ok
14:52:59 <eedri> we still got a few min to review tracs
14:53:07 <eedri> #topic trac tickets
14:53:15 * eedri opening link
14:53:39 <orc_orc> https://fedorahosted.org/ovirt/query?status=new&status=reopened&order=priority&col=id&col=summary&col=status&col=type&col=priority&col=milestone&col=component looks promising
14:53:57 <orc_orc> #17 implies backups are not being taken?
14:54:08 <eedri> orc_orc, they are,
14:54:19 <eedri> orc_orc, jenkins, gerrit are backed up
14:54:27 <eedri> ewoud, is foreman too ?
14:54:43 <eedri> ewoud, in $company we have a script that backups foreman db iir
14:54:44 <orc_orc> eedri and so, are they tested automatically as to usability?
14:55:01 <eedri> orc_orc, no, don't think we reached that point yet
14:55:07 <orc_orc> * nod *
14:56:43 <orc_orc> it would seem puppet or such could be asked to do this -- also fabiand mentioned igor on one of the mailing lists across the weekend
14:57:12 * fabiand lifts his head ..
14:57:19 <orc_orc> fabiand: heh
14:57:56 <orc_orc> fabiand: use case is testing https://fedorahosted.org/ovirt/ticket/17 backups
14:58:01 <fabiand> what igor can do is spawn VMs to run functional tests and not clutter some other host. it was started ot test rhev but can probably spawn VMs with other OSs too
14:58:34 <fabiand> ah no, igor is not for taking backups :)
14:58:49 <eedri> orc_orc, testing backips doesn't requires vms or spawning vms, foreman can handle it
14:59:06 <orc_orc> ... not for taking -- for doing deployments form such images to see if they are usable
14:59:06 <ovirtbot> orc_orc: Error: ".." is not a valid command.
14:59:14 <orc_orc> \... not for taking -- for doing deployments form such images to see if they are usable
14:59:27 <eedri> #action check if all critical services are backed-up (jenkins/gerrit is currently backedup)
14:59:29 <orc_orc> from*
15:00:17 <eedri> ok, we don't have much time, but i will say a few words on #73
15:00:38 <eedri> we're lacking setup/upgrade jobs automation on ci since otopi migration
15:01:13 <eedri> this is something we need to push forward, and i'm in the process of checking which is the best way to achive it
15:01:33 <eedri> we might have existing code we can use for it, i will have an answer for next meeting
15:02:02 <eedri> one last thing - obasan tested nested virt, and it seems to work w/o issues
15:02:28 <eedri> we should covert one of the existing vms on rackspace to support nested virtualiztion so we can runs tests on them
15:02:38 <eedri> i.e create vms
15:02:56 <eedri> #action obasan to add nested virt support to one of rackspace jenkins slaves
15:03:14 <orc_orc> eedri: nested virtualization does not work on RHEL 6'ish libvirt as I recall -- so it needs a Fedora host?
15:03:32 <eedri> orc_orc, yes. the bare metal running the vms is fedora 19
15:03:45 <eedri> orc_orc, only supported on fedora kernel for now
15:04:04 <eedri> orc_orc, but on top of it you can crearte centos/rhel/fedora vms
15:04:07 <orc_orc> it is a kernel capability needed, not a libvirt one?
15:04:21 <eedri> orc_orc, afaik its supported in the kernel
15:04:22 <eedri> obasan, ?
15:04:32 <orc_orc> eedri: thanks
15:04:53 <eedri> ewoud, anything to add before we close?
15:05:00 <obasan> eedri, nested virt only works on fedora
15:05:28 <eedri> going once
15:05:46 <eedri> 2
15:06:11 <eedri> ok, cya everyone, if you have issue. please email infra@ovirt.org
15:06:15 <eedri> #endmeeting
15:06:46 <eedri> ewoud, ?
15:07:29 <orc_orc> strange that a chair cannot end a meeting
15:07:31 <orc_orc> #endmeeting