14:16:06 <knesenko_> #startmeeting oVirt Infra
14:16:06 <ovirtbot> Meeting started Mon Oct 7 14:16:06 2013 UTC. The chair is knesenko_. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:16:06 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:16:15 <knesenko_> #chair obasan dcaro ewoud eedri
14:16:15 <ovirtbot> Current chairs: dcaro eedri ewoud knesenko_ obasan
14:16:58 <knesenko_> lets start
14:17:06 <ewoud> http://ovirt.org/meetings/ovirt/2013/ovirt.2013-09-30-13.58.html are the minutes from last time
14:17:26 <knesenko_> ewoud: thanks
14:17:37 <knesenko_> #topic Hosting
14:18:09 <ewoud> I think rackspace03.ovirt.org would be the most interesting point here
14:18:10 <ewoud> any news?
14:18:24 <eedri> dcaro, did you got a reply on the ticket?
14:18:28 <knesenko_> no news from my side
14:18:34 <knesenko_> was very busy last week
14:19:16 <dcaro> eedri: yep, they told me to connect through IDRAC xd, so I asked them to instlal the os until they can give me ssh session (as I was unable to make the iDRAC console work)
14:20:27 <eedri> dcaro, you can update the ticket with a link to the other ticket saying that iDRAC consle didn't work
14:20:34 <eedri> dcaro, and they need to do it
14:20:48 <eedri> dcaro, there is a ticket documenting all that for the other servers
14:21:24 <dcaro> eedri: ok, I'll link the old ticket too
14:23:23 <ewoud> anything else on hosting?
14:23:35 <knesenko> seems like not
14:24:00 <knesenko> #topic Artifactory
14:24:06 <knesenko> :\
14:24:08 <knesenko> what is that ?
14:24:14 <ewoud> #chair knesenko_
14:24:14 <ovirtbot> Current chairs: dcaro eedri ewoud knesenko_ obasan
14:24:21 <knesenko_> #topic Artifactory
14:24:23 <ewoud> it doesn't track names it seems :)
14:24:35 <knesenko_> ewoud: ok
14:24:40 <ewoud> I did write an initial patch
14:24:48 <knesenko_> eedri: can you update ?
14:24:56 <ewoud> http://gerrit.ovirt.org/19698
14:25:22 <ewoud> today I started looking into running it on tomcat, but then I wanted to use more external modules
14:25:37 <ewoud> so I'm now finishing up the r10k patch (Puppetfile)
14:25:46 <ewoud> http://gerrit.ovirt.org/19141
14:26:41 <knesenko_> ewoud: ok thanks
14:26:57 <ewoud> there are also some action items open to actually start using it on our slaves, but I haven't gotten around to looking at those
14:27:19 <eedri> knesenko_, yes
14:27:26 <eedri> knesenko_, artifactory is installed and work afaik
14:27:36 <eedri> knesenko_, we need to update 2 kinds of jobs
14:27:57 <eedri> ewoud, you mean tomcat instead of apache as frontend
14:28:26 <ewoud> eedri: yes, but I don't know if you want tomcat facing the world so it's common to place apache in front of that
14:28:41 <eedri> ewoud, no problem, as long as it will be accesible via port 80
14:28:56 <eedri> ewoud, i think we should enable it (access port 80) before migrating jobs to use it
14:29:00 <eedri> ewoud, to save duplicate work
14:29:11 <ewoud> eedri: sounds good to me
14:29:45 <eedri> ewoud, ok, so in terms of updating maven jobs (i.e jobs that run maven directly like unit test/findbugs/etc..)
14:30:49 <eedri> ewoud, jobs should use alternate xml file - artifactory-ovirt-org-settings.xml
14:30:58 <eedri> ewoud, it can be seen in http://jenkins.ovirt.org/job/ovirt_engine_find_bugs/configure
14:31:14 <eedri> ewoud, so that file needs to be copied to the workspace and then maven should use it as alternate settings file
14:31:30 <eedri> ewoud, in the advanced maven section
14:32:12 <ewoud> eedri: I think we can configure it for the jenkins user only by placing it in ~/.m2
14:32:25 <eedri> ewoud, no you can't
14:32:32 <eedri> ewoud, cause those jobs are using private maven repos
14:32:40 <eedri> ewoud, and not the user repo on the slave
14:33:11 <eedri> ewoud, unless it possible to use private repo and that file from jenkins homedir
14:34:06 <eedri> ewoud, i mean you can place it on the slaves instead on the master and save that copy on jobs
14:34:32 <eedri> ewoud, but i think we'll still need to configure alternate settings.xml file
14:34:45 <eedri> ewoud, make sense"?
14:36:00 <ewoud> eedri: maybe, but I'm not sure how maven exactly parses its config to give an answer
14:36:20 <ewoud> eedri: what's so special about the find bugs job that it needs a custom maven config?
14:39:14 <eedri> ewoud, nothing, i just used it for testing :)
14:39:25 <eedri> ewoud, all jobs should migrate to our artifactory
14:39:41 <eedri> ewoud, it will stop the failures that are caused from blocking maven repo - sometimes happens
14:39:48 <eedri> ewoud, and i'm quite sure it will fasten the jobs
14:39:52 <eedri> ewoud, at least on new runs
14:40:12 <ewoud> eedri: ok, I think it's clear we need to fix it somehow
14:40:12 <eedri> ewoud, anyway, there are another type of jobs - make jobs that use mvn internally
14:40:30 <ewoud> eedri: let's look at it later so we can continue the meeting
14:40:42 <eedri> ewoud, those jobs needs a param sent to make to make it work - sometning alonbl_ propsed - http://pastebin.com/Bk4usdJV
14:40:47 <eedri> ewoud, sure
14:40:56 <eedri> ewoud, do you want to add it as ai ? or info?
14:41:55 <ewoud> #action ewoud ensure jenkins jobs use the artifactory server
14:43:08 <ewoud> knesenko_: next item on the agenda?
14:43:36 <knesenko_> ewoud: puppet and foreman if there are any news there ?
14:44:05 <ewoud> knesenko_: yes, I'll quickly write what I wrote before in info items
14:44:20 <eedri> knesenko_, also jenkins i assume
14:44:38 <knesenko_> #topic Foreman/Puppet
14:45:18 <ewoud> #info patch to use r10k for deployment is almost ready
14:46:11 <ewoud> I haven't had time yet to look at deploying VMs using foreman at rackspace
14:46:30 <ewoud> but how do we assign IPs there?
14:46:35 <ewoud> we should document that somehow
14:48:49 <ewoud> I want to deploy a smartproxy to do DHCP and TFTP, but for that I need to know the network topology there
14:49:00 <ewoud> dcaro: eedri knesenko_ any of you can describe/document that somewhere?
14:49:44 <knesenko_> ewoud: I am not aware of alterway topology
14:49:47 <knesenko_> ewoud: maybe eedri
14:49:48 <knesenko_> ?
14:50:06 <ewoud> knesenko_: I know alterway, but not rackspace
14:50:34 <eedri> ewoud, anything we need to know - just need to open a ticket to rackspace and they will gladly provide the info
14:50:42 <dcaro> ewoud: I think we should ask them, as they must be aware that a dhcp server will be running there.
14:50:58 <ewoud> eedri: mostly, how do we pick an IP?
14:50:59 <eedri> ewoud, so you can ask either me dcaro or knesenko_ to ask them - send email with info needed and we can open a ticket
14:53:52 <ewoud> eedri: I'll send a mail then
14:53:56 <ewoud> knesenko_: next topic?
14:54:14 <knesenko_> we out of time .
14:54:27 <knesenko_> I think that we covered most of the issues.
14:54:35 <ewoud> ok
14:54:42 <knesenko_> I will have more time to work on rackspace migration this week
14:54:47 * knesenko_ hope so
14:54:51 <knesenko_> thank you guys
14:54:59 <knesenko_> #endmeeting