13:01:17 <mburns> #startmeeting oVirt Weekly Meeting
13:01:17 <ovirtbot> Meeting started Tue Sep 24 13:01:17 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:17 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:22 <mburns> #topic agenda and roll call
13:01:28 * oschreib here
13:01:33 <mburns> #chair oschreib
13:01:33 <ovirtbot> Current chairs: mburns oschreib
13:01:46 <mburns> #info 3.3 updates
13:01:52 <mburns> #info 3.4 planning
13:02:01 * danken is here
13:02:15 <mburns> #info conferences and workshops
13:02:23 <mburns> #info infra update
13:02:27 <mburns> #info Other Topics
13:02:52 * sbonazzo here
13:04:09 <mburns> #topic 3.3 updates
13:04:38 <mburns> #info there are a few important issues that should be fixed for 3.3.0.1
13:04:57 <dcaro> Rydekull: ewoud eedri the slaves are up again, not sure why but creating the symlink did not work (it said permission error, but I think they were ok), I'm now mounting the new virtual device on the images directory
13:05:27 <oschreib> mburns: I hope to have that by next week
13:05:41 <mburns> #info patch:  19217
13:05:56 <mburns> #info bugs 1007980 1008938 1009100
13:06:02 <dcaro> Rydekull: eedri ewoud: maybe I created it too big (500GB) :S, but that should last until we have gluster, then we can free it
13:06:08 <mburns> #info oschreib plans to have builds available next week
13:06:36 <mburns> oschreib: do any of those impact things other than engine?
13:06:52 <oschreib> I'll have to check tjat
13:06:59 <oschreib> and create the 3.3.0.1 tracker.
13:07:12 <oschreib> and close 3.3.0, I should have done this.
13:07:28 <mburns> #action oschreib to coordinate builds with non-engine components if needed
13:07:38 <mburns> #action oschreib to create 3.3.0.1 tracker and close 3.3.0 tracker
13:09:38 <mburns> #info plan is to post builds next week to updates-testing, then promote to stable the following week
13:10:12 <mburns> ok, now 3.3.1
13:10:22 <oschreib> 3.3 branch re-created
13:10:25 <mburns> #info plan for 3.3.1 -- rebase engine and vdsm
13:10:36 <oschreib> so rebase for engine is done
13:10:45 <oschreib> vdsm probably next week
13:10:48 <danken> we have an issue with vdsm
13:10:56 <mburns> #info engine rebase is complete
13:11:01 <mburns> #info issue with vdsm rebase
13:11:04 <mburns> danken: ?
13:11:06 <danken> current master cannot inter-migration with 3.3
13:11:23 <danken> there was a post on that by "Dead Horse"
13:11:32 <danken> fsimonce is aware of that
13:11:52 <danken> but you should know that we cannot rebase vdsm before that's settled.
13:11:55 <mburns> fsimonce: danken: solvable? or are we going to do backports to current branch?
13:12:49 * mburns tentatively looking at posting 3.3.1 beta the week of 9-Oct
13:13:12 <danken> mburns: I believe that reverting the offending patch is possible
13:13:41 <danken> and a worse-case "check dst vdsm version before migration" is also possible. but very very ugly.
13:13:55 <mburns> danken: ok
13:14:18 <oschreib> mburns: I'll create a 3.3.1 beta on Monday I hope
13:14:34 <mburns> oschreib: ok, not much use until we have vdsm, though
13:14:40 <oschreib> indeed
13:14:51 <danken> However, I do not think we can make a rebase by this weekend - we need some testing for changes in block storage.
13:15:15 <mburns> danken: if i said end of next week, would that be doable?
13:15:18 <abaron> danken: what changes?
13:15:36 <danken> abaron: oneshort teardown/prepare
13:15:39 <danken> short filters
13:15:51 <danken> sanlock everywhere
13:16:03 <danken> all affecting VM startup on block storage
13:16:20 <abaron> not just block storage :)
13:16:30 <abaron> except for short filters
13:16:51 <Rydekull> dcaro: it may have been selinux (if we're running it there)
13:16:58 <danken> I've asked my friends for a confirmation that there are no regression before we rebase
13:17:01 <Rydekull> dcaro: anyway, good job
13:17:18 <dcaro> Rydekull: true, I did not check that :S
13:17:29 <mburns> danken: if i said end of next week, would that be doable?
13:17:40 <mburns> (or early the following week)
13:18:26 <abaron> mburns: yes, it is being tested as we speak
13:18:46 <abaron> (imo at least)
13:18:51 <mburns> abaron: ok, thanks
13:19:07 <mburns> #info vdsm should be ready by end of next week, in time for posting the following week
13:20:18 <mburns> we can spin ovirt-node builds once vdsm is ready
13:20:39 <mburns> rough date for release?
13:20:51 <mburns> 28-Oct?
13:21:51 <danken> please excuse my horrible inet connectivity. have I missed something terribly important?
13:22:02 <mburns> #idea scheduled release date for 3.3.1 is 28-Oct
13:22:24 <mburns> danken: abaron just committed that you would solve all problem in the world by next week
13:23:18 <mburns> danken: actually, no, just that rebase would be complete and ready for posting to beta repos by end of next week (or early the following week)
13:23:46 <danken> that's more realistic.
13:24:15 <mburns> ;-)
13:24:41 <mburns> #agreed beta posting set for week of 8-Oct
13:25:45 <mburns> #agreed tentative release date -- week of 28-Oct
13:26:03 <oschreib> sounds good
13:26:07 <mburns> anything else for 3.3?
13:26:14 <oschreib> not here
13:26:28 <mburns> oh, one more statement
13:26:46 <mburns> #info mburns working on a solution for gluster storage domains on EL6
13:27:00 <mburns> #info no solution yet, but it's being worked on
13:27:04 <abaron> mburns: what's the issue there?
13:27:18 <mburns> abaron: el6 has old qemu-kvm packages (6.4 era)
13:27:25 <abaron> ah
13:27:31 <mburns> gluster storage domains require newer features
13:27:36 <abaron> ack
13:28:04 <mburns> ok, moving on before anyone can latch onto that...
13:28:12 <mburns> #topic 3.4 planning
13:28:28 <mburns> itamar: have you consolidated the feature list for 3.4?
13:28:41 * mburns hasn't tracked that thread closely
13:29:14 <mburns> #info feature collection and planning is underway
13:29:16 <itamar> mburns, not yet
13:29:28 <mburns> ok, then we'll postpone decisions until next week
13:29:28 <itamar> i need to review the long thread on that...
13:30:03 <mburns> #info no hard dates planned until after review of requested features is complete
13:30:49 <itamar> mburns - will take more than a week on that one. I also want to propose a change to process i'll send to arch
13:31:14 <mburns> #info itamar to propose process change for the release
13:31:16 <mburns> itamar: ack
13:31:28 * mburns will leave it here until we get that thread going.
13:31:50 <mburns> #topic Conferences and Workshops
13:31:55 <mburns> dneary: any new updates?
13:34:04 <mburns> #link http://www.ovirt.org/Upcoming_events
13:34:14 <mburns> some of the things that are coming up ^^
13:34:19 * mburns moves on
13:34:27 <mburns> #topic Infra update
13:34:27 <sbonazzo> mburns: https://fosdem.org/2014/
13:34:53 <mburns> ewoud: eedri: updates?
13:35:03 <mburns> sbonazzo: cool, do we have planned ovirt talks there?
13:35:22 <sbonazzo> mburns: I don't know yet but would be nice
13:35:33 <mburns> ok, i'll add it to the Upcoming Events page
13:35:49 <ewoud> mburns: checking minutes
13:36:17 <ewoud> from http://ovirt.org/meetings/ovirt/2013/ovirt.2013-09-23-14.02.html
13:36:31 <ewoud> we have a third host at rackspace, which we're planning to install
13:37:00 <ewoud> then migrate the existing VMs so we can create a cluster based on gluster
13:37:27 <mburns> #info added third host at rackspace
13:37:36 <mburns> #info plan to install then migrate existing vms
13:37:44 <mburns> #info plan to create a gluster-based cluster
13:37:46 <ewoud> we're trying to install an artifactory at alterway, but ran into some issues with the network; looking into it with them
13:38:46 <ewoud> if that works well, we can also look at migrating other services from linode01
13:39:02 <ewoud> some jenkins updates for which I'll refer to the minutes
13:39:13 <ewoud> and I think that's it
13:39:26 <mburns> #info working on installing artifactory, but some issues encountered, still working
13:39:49 <mburns> #info for other details, please refer to the minutes:  http://ovirt.org/meetings/ovirt/2013/ovirt.2013-09-23-14.02.html
13:39:53 <mburns> thanks ewoud
13:39:58 <mburns> #topic Other Topics
13:40:05 <mburns> anyone have other things to bring up?
13:41:30 <mburns> sbonazzo: added fosdem to the page mentioned above
13:41:35 <mburns> (and the home page)
13:41:42 <sbonazzo> mburns: great
13:41:55 <mburns> going once on other topics ...
13:42:22 <mburns> twice..
13:42:28 <sbonazzo> mburns: is it planned any 3.2.z mainteinance?
13:42:50 <mburns> sbonazzo: no, once we shipped 3.3, we stopped doing anything on 3.2
13:43:02 <sbonazzo> mburns: ok, thanks
13:43:25 <mburns> last call for other topics
13:43:46 <dneary> mburns, Apologies - I have not been here
13:43:56 <mburns> dneary: no worries
13:43:59 <dneary> mburns, I am giving a webinar in a few minutes...
13:44:11 <mburns> dneary: i just referred to the upcoming events page on the wiki
13:44:17 <mburns> #endmeeting