14:00:01 <mburns> #startmeeting oVirt Weekly Meeting
14:00:01 <ovirtbot> Meeting started Wed Sep 11 14:00:01 2013 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:01 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:05 <mburns> #chair oschreib dneary
14:00:05 <ovirtbot> Current chairs: dneary mburns oschreib
14:00:12 <mburns> #topic Agenda and Roll Call
14:00:18 <mburns> #info 3.3 Release Status
14:00:31 <mburns> #info tentative planning for 3.3.1
14:00:38 <mburns> #info 3.4.0 planning
14:00:41 <mburns> #info conferences and workshops
14:00:47 <mburns> #info infra update
14:00:50 <mburns> #info other topics
14:01:13 <mburns> also, just as an fyi -- i'm somewhat split-focused during this meeting...
14:01:33 * oschreib here
14:01:49 * sahina here
14:01:58 * yzaslavs here
14:03:53 <mburns> #topic 3.3 release status
14:04:13 <mburns> #info final RC builds posted between yesterday and today for engine, vdsm, node
14:04:35 <oschreib> I suspect the all-in-one issues are not over.
14:05:03 <mburns> oschreib: blocking issues?
14:05:05 <oschreib> I'd like to get two +1 on the .el6 build and the all-in-one before release
14:05:12 <oschreib> mburns: under invastigations
14:05:19 <mburns> oschreib: ok
14:05:19 <sgotliv> sgotliv here
14:05:30 * mburns will try to pick up el6 build today
14:05:51 <mburns> #info ovirt-node-iso rpms will be uploaded shortly
14:06:04 <mburns> #info node iso images are available in releases/3.3/iso
14:06:27 <oschreib> I wouldn't release in a short cycle without few positive installations
14:06:34 <mburns> oschreib: agreed
14:06:34 <oschreib> we normally want at least a week
14:07:18 <mburns> oschreib: yes, i normally agree, but let's see if we can get successful tests and get it out quicker
14:07:28 <mburns> dneary: plan is to get marketing stuff out on Monday, right?
14:07:36 <dneary> mburns, Yes
14:08:05 <mburns> oschreib: so we can wait until monday if we have to
14:08:54 <oschreib> I'm fine with Monday, but again, I need as many installation as we can
14:09:01 <mburns> agreed
14:09:17 <mburns> #action mburns to get things set for release today
14:09:29 <mburns> #action mburns to coordinate release for Monday
14:09:31 <dneary> oschreib, mburns: My understanding was that we would have release ready packages today
14:09:39 <dneary> An oVirt Live for 6.4 would be appreciated too
14:10:01 <oschreib> dneary: Ohad is working on ovirt-live
14:10:06 <oschreib> dneary: no ETA yet
14:10:15 <mburns> dneary: -live is hard to do when we don't have stable engine...
14:10:29 <mburns> i think that's ok to lag a bit behind the ga release...
14:10:29 <oschreib> or stable all-in-one
14:10:49 <dneary> Yes, it's OK
14:11:01 <dneary> But it would be nice to have it ASAP
14:11:26 <mburns> dneary: agreed
14:12:06 <oschreib> dneary: I thought we will have packages today to, and they we're built, BUT, they failed my tests (and I don't know if it's a local issue or not), I'd love some help from people over here with aio installations, so we could verify and release in short cycle
14:12:58 <dneary> oschreib, Can you please send regular emails to arch@ when there are problems with builds, please? It seems like we're losing a day every time a package needs to be rebuilt
14:13:31 <oschreib> dneary: what sort of emails?
14:13:40 <dneary> oschreib, Status of builds
14:13:50 <dneary> If a package needs rebuilding, it should happen ASAP
14:14:08 <oschreib> dneary: I'm the one building ovirt-engine
14:14:27 <oschreib> and since I don't have any other resource, it's me or someone from the team testing it.
14:14:36 <dneary> oschreib, Which tests did they fail?
14:14:43 <oschreib> all in one install
14:15:11 <oschreib> on f19
14:16:56 <mburns> ok, so plan is to get as many successful tests as possible in the next 2 days
14:17:04 <mburns> and get problems reported ASAP
14:17:21 <oschreib> mburns: after the meeting, can you send an status update, and request for feedback on the rpms?
14:18:02 <mburns> oschreib: i can send a current status as i know it and ask for feedback, yes
14:18:14 <mburns> #action mburns to solicit feedback on beta rpms
14:18:16 <oschreib> superb
14:19:11 <mburns> #info no open blockers at the moment, release just pending successful testing of current packages
14:19:33 <mburns> anything else we have to discuss on 3.3.0?
14:19:39 <oschreib> nope
14:19:54 <mburns> #topic 3.3.1 planning
14:20:13 <mburns> oschreib: i think the main drive is when we can get engine ready to go
14:20:25 <cultavix> \exit
14:20:33 <mburns> target mid-october (so just before ovirt dev meetings in Edinburgh)?
14:21:28 <mburns> oschreib: ?
14:21:29 <oschreib> well, it depends on the 3.3.1 branch (if we're going to rebase the engine or not)
14:21:53 <mburns> oschreib: from itamar, it seems it's primarily bug fixing in master branch
14:22:02 <oschreib> it's true
14:22:03 <mburns> with a couple small features, but things that would be valuable
14:22:16 <oschreib> mburns: I won't call them small
14:22:17 <mburns> and 3.3.1 should also include the hosted engine
14:22:26 <mburns> oschreib: what are the features?
14:23:03 <oschreib> I'm not tracking all the features that got into the engine, I heard that network profiles is in, and it's pretty heavy
14:23:09 <oschreib> again, I'm not against a rebase
14:23:22 <oschreib> but if we do so, I'd like to have some sort of test day
14:23:29 <oschreib> and a short beta cycle
14:23:47 <oschreib> so we should rebase->beta->tests->beta2->release
14:23:52 <oschreib> or something like that
14:24:02 <mburns> oschreib: ok, how long do you need to get things into a good state for a test day?
14:24:22 <mburns> #info engine exploring pulling all master changes (primarily bug fixes) into 3.3.1
14:24:46 <oschreib> mburns: I don't think it should be problematic at all
14:25:06 <oschreib> mburns: if the rebase will be smooth, it can just take a day
14:25:13 <mburns> #info target should be before developer meetings in October
14:25:35 <oschreib> but.... It's a really ugly thing to do in a small release
14:26:38 <mburns> oschreib: ok, how about planning to get packages together for 3.3.1 for 25 Oct?
14:26:49 <mburns> and plan test day for following week
14:27:20 <oschreib> mburns: so how should we decide about the rebase issue?
14:27:39 <mburns> oschreib: let's get to a decision on the email thread
14:27:57 <mburns> i haven't seen any objections to a rebase yet, but if you have concerns, let's get them there
14:28:25 <oschreib> #action oschreib to get a decision on 3.3.1 rebase
14:28:58 <mburns> oschreib: final build for issues in 3.3.1 test day on 14-Oct and release that week?
14:29:28 <sahina> will vdsm be rebased with master as well for 3.3.1 ?
14:29:43 <oschreib> mburns: I'd not decide on dates before the release of 3.3.0
14:29:46 <oschreib> but sounds ok
14:30:04 <oschreib> (I'll be OOO between 06.10 and 12.10, jut FYI)
14:30:15 <mburns> #info tentative plan: build new 3.3.1 packages by 25-Sep, test-day on 1-Oct, rebuild between 9-Oct and 14-Oct for test day issues, release prior to 20-Oct
14:30:33 <mburns> oschreib: ok, it's a tentative plan...
14:30:44 <mburns> sahina: that's a choice of the vdsm team
14:30:58 <mburns> but in general, i'm against a rebase unless it's only bug fixes
14:31:17 <sahina> mburns, cos some of the engine patches have corresponding vdsm changes as well
14:31:36 <mburns> sahina: those would need to be backported if we don't rebase
14:31:49 <sahina> mburns, k. got it
14:32:16 <mburns> but rebase choice has to be the maintainer's choice
14:33:05 <mburns> #topic 3.4.0 planning
14:33:20 <oschreib> mburns: don't even start the thread about engine maintainership
14:33:46 <mburns> i don't have much to say here other than to point to the feature request list is on the arch@ mailing list
14:33:49 <mburns> oschreib: ;-)
14:33:59 <mburns> yes, i ran into that when you were out...
14:34:01 <oschreib> same here
14:34:13 <oschreib> itamar started an email thread about it as well
14:34:26 <mburns> #info please comment/request/commit to new features on arch@ and users@ mailing lists
14:35:06 <sahina> mburns, do we have a timeline for 3.4 release or will we decide that as per features?
14:35:14 <mburns> #info we'll start talking dates and release planning in the next few weeks
14:35:25 <yzaslavs|mtg> mburns: even what we think is the obvious? bazulay and others from his group for example have plans to continue improving the async task mgmt at engine...
14:36:09 <mburns> yzaslavs|mtg: features like that should get feature pages and attached to the new 3.4 release management page that i'm hoping oschreib will be creating shortly...
14:36:30 <yzaslavs|mtg> mburns: i thought so, wanted to be sure, thanks
14:37:50 <mburns> yzaslavs|mtg: might make comment on the thread if there are net new features rather than just improvements
14:38:30 <mburns> something like "we're working on improving async task management, see the feature page here: "
14:38:52 <mburns> but i'll leave that to your best judgement
14:39:19 <mburns> i'm looking to get info on big features that we will want to track for the release
14:39:28 <mburns> and highlight in release marketing
14:39:57 <mburns> #topic workshops and conferences
14:40:03 <mburns> dneary: any news here?
14:40:22 <mburns> #info oVirt Developers Meeting during KVM Forum in Edinburgh, UK 21-23 October
14:40:59 <mburns> #info to attend, please register for KVM Forum
14:41:06 <mburns> #info first 200 people to register get free admission
14:41:15 <itamar1> mburns - on vdsm - need to review more carefully. I think worth doing the extra testing for a rebase (even if we need to change the version). we can stabilize that version in a short cycle, revert problematic issues, etc.
14:41:35 <itamar1> mburns, but we'll confer with danken on what's best for vdsm
14:41:57 <mburns> itamar1: agreed, we can discuss on the existing email thread
14:42:39 <mburns> dneary: any other details we should be sharing here?
14:42:48 <dneary> mburns, Is the plan for 3.3.1 (apologies, was AFK) to rebase straight after the 3.3 release?
14:43:06 <dneary> mburns, If so, I'd like to get packages off the rebased branch straight after that
14:43:18 <dneary> I have details on the talks
14:43:20 <mburns> dneary: depends on the final decision made, but i'd like to see them ASAP
14:43:24 <dneary> Let me fetch them up...
14:43:51 <mburns> we can rebase anytime, iiuc
14:44:22 <dneary> * LinuxCon Europe - CloudOpen
14:44:22 <dneary> * 6 oVirt related talks:
14:44:22 <dneary> RAM Snapshots in oVirt - Arik Hadas
14:44:22 <dneary> oVirt and Cloud-Init integration - Omer Frenkel
14:44:22 <dneary> Empowering Data Center Virtualization Using KVM - Livnat Peer
14:44:24 <dneary> Converged Infrastrucure with Open Source - Theron Conrey
14:44:25 <dneary> GlusterFS Architecture & Roadmap - Vijay Bellur
14:44:27 <dneary> Cloud Computing with KVM - Tony Gargya
14:44:29 <dneary> * 2 hours training session
14:44:31 <dneary> Scripting And Integration with the oVirt Engine - Oved Ourfali
14:44:33 <dneary> * LinuxCon Europe - KVM Forum
14:44:35 <dneary> * 5 oVirt talks in KVM Forum:
14:44:37 <dneary> Empowering Data Center Virtualization using KVM (Livnat Peer)
14:44:39 <dneary> Kimchi: Simplified KVM Management (Adam Litke)
14:44:43 <dneary> Providing quality of service for VMs in oVirt (Martin Sivak)
14:44:45 <dneary> Linux storage stack for the cloud (Yeela Kaplan)
14:44:47 <dneary> Trusted Compute Pools Feature in oVirt (Gang Wei)
14:44:49 <dneary> * 3 oVirt talks in oVirt developer meeting:
14:44:51 <dneary> The State of oVirt (Itamar Heim)
14:44:53 <dneary> oVirt hosted engine: the egg that hosts its parent chicken (Doron
14:44:55 <dneary> Fediuck)
14:44:57 <dneary> oVirt for PowerPC (Otavio Luiz Ferrant)
14:44:59 <dneary> Oops - that's quite a flood
14:45:01 <dneary> We also need to define a rough agenda for the developers summit still - needs to get done over the next week or so
14:45:21 <dneary> It's been fortunate that 3.3 has been delayed so much in one way - we'll be much closer to the start of the release cycle for 3.4 now
14:46:18 <mburns> dneary: is that posted on the wiki anywhere?
14:46:30 * mburns doesn't want to info all of that
14:47:14 <mburns> #info 6 talks in CloudOpen track of LinuxCon (requires separate registration to LinuxCon)
14:47:14 <dneary> mburns, Not yet
14:47:33 <mburns> #info 5 talks at KVM Forum on oVirt
14:47:48 <dneary> By the way, the el6 release RPM http://resources.ovirt.org/releases/ovirt-release-el6-7-1.noarch.rpm gives a 404 (link from the 3.3 test day page)
14:48:01 <mburns> #info 3 talks currently planned for developer meetings
14:48:12 <mburns> dneary: oh, we revved it
14:48:32 <mburns> http://resources.ovirt.org/releases/ovirt-release-el6.noarch.rpm
14:48:37 <mburns> dneary: i'll fix the page shortly
14:48:43 <mburns> $info
14:49:03 <mburns> #info schedule still being worked for oVirt Dev Meetings
14:50:02 <mburns> #info see full meeting transcript for details of what the presentations are
14:50:12 <mburns> dneary: anything else?
14:50:38 <dneary> mburns, We also have 2 oVirt related presentations in LinuxCon NA
14:50:56 <mburns> #info 2 presentations at LinuxCon NA
14:50:59 <dneary> I still do not have dates for a Raleigh workshop, but making some progress
14:51:11 <mburns> dneary: oh, didn't realize we had anyone going to LCNA
14:51:18 * mburns tried, but his talk was not accepted
14:51:29 <dneary> Private Cloud SLA - Greg Padgett
14:51:41 <mburns> #info progress has been made on RTP workshop, but details not defined yet
14:51:43 <dneary> And Theron Conrey had a talk accepted too (don't know if he plans to attend)
14:51:58 <mburns> ah, cool
14:52:45 <mburns> dneary: anything else?
14:53:14 <dneary> We have a nice new user case study up on the site!
14:53:29 <mburns> #info Case study added to the wiki
14:53:36 <dneary> http://www.ovirt.org/Alter_Way_case_study
14:53:46 <mburns> awesome
14:54:13 <dneary> I am eager to have other volunteers - I'd love to showcase people using oVirt in small businesses, universities and research centers, hosting companies, or services companies deploying it for clients
14:54:30 <dneary> Will pitch it on the users list after the release
14:54:32 <mburns> dneary: karim might be someone to talk to
14:55:04 <dneary> We're also working on the 3.3 promotion push. You can see our key talking points here: http://www.ovirt.org/OVirt_3.3_talking_points
14:55:25 <mburns> #info 3.3 promotional push being worked on
14:56:27 <dneary> mburns, karim? As a user, or a source of potential users?
14:56:41 <mburns> dneary: as a user success story
14:57:25 * mburns moves on
14:57:27 <mburns> #topic infra update
14:57:34 <mburns> eedri: ewoud: updates?
14:57:40 <mburns> #chair ewoud eedri
14:57:40 <ovirtbot> Current chairs: dneary eedri ewoud mburns oschreib
14:58:23 <eedri> mburns, we have now enabled unit tests per patch for ovirt-engine patches
14:58:48 <mburns> #info unit tests running per-patch for engine patches
14:59:02 <eedri> mburns, new disks were installed on rackspace to allow new gluster storage (planned for backups & new jenkins slaves)
14:59:55 <mburns> #info new storage added to rackspace servers
15:00:07 <mburns> #info planned for backups and jenkins slaves
15:00:25 <eedri> maybe ewoud can elaborate on puppet efforts done as well
15:00:49 <ewoud> not sure, there's much to report right now, but let's see
15:01:28 <eedri> mburns, there are also plans to add new ovirt tools jobs soon
15:01:40 <ewoud> we have a puppet server with foreman and all hosts report. we've started to set up most of our base install now I think
15:01:47 <mburns> #info plans for new ovirt tools jobs soon (image/iso uploader)
15:02:03 <ewoud> currently we're working on the deployment procedure to get changes in through gerrit to production
15:02:31 <mburns> #info puppet/foreman running with all hosts reporting, base install mostly up and done
15:02:39 <ewoud> future steps would be to add more hosts (resources, lists, gerrit) and their configuration as well as monitoring
15:03:10 <mburns> #info working on deployment procedure to get changes through gerrit to production
15:03:30 <mburns> #info next steps: move more hosts to foreman (resources/lists/gerrit)
15:03:44 <ewoud> and documentation …
15:03:53 <mburns> #info and documentation of the setup
15:04:08 <mburns> eedri: ewoud: excellent
15:04:11 <mburns> anything else?
15:04:30 <ewoud> mburns: not that I can think of now
15:04:39 <mburns> ok, thanks for the update
15:04:43 <mburns> #topic Other Topics
15:04:49 <mburns> anyone have anything else to bring up?
15:05:22 <mburns> going once...
15:06:23 <mburns> twice..
15:06:25 <damnski> Hi: are you guys done meeting?
15:06:40 <mburns> gone.
15:06:43 <mburns> #info no other topics
15:06:47 <mburns> #endmeeting