14:01:24 <oschreib> #startmeeting oVirt Weekly Meeting
14:01:24 <ovirtbot> Meeting started Wed Aug 21 14:01:24 2013 UTC.  The chair is oschreib. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:24 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:34 <oschreib> #topic agenda and roll call
14:01:42 <oschreib> #info 3.3 status update
14:01:53 <oschreib> (Afterwards, if we will have some spare time)
14:02:04 <oschreib> #info infra team update
14:02:11 <oschreib> #info Conference and Workshop
14:02:19 <oschreib> #info Other Topics
14:02:30 <oschreib> (waiting a minute for people to come)
14:02:35 <oschreib> #chair mburns
14:02:35 <ovirtbot> Current chairs: mburns oschreib
14:02:45 * sahina here
14:04:13 * sbonazzo here
14:04:29 <oschreib> anyone else here?
14:05:10 <oschreib> (I don't see virt/storage/sla/network etc reps here, not sure if there's a point to this meeting)
14:05:21 <oschreib> only gluster integration and node reps
14:05:28 <sgotliv> I am from storage
14:05:30 <oschreib> mburns: thoughts^^ ?
14:05:57 <emesika> emesika here
14:09:15 <oschreib> sgotliv: emesika: are you representing your team regarding 3.3 release? have you reviewed blocker?
14:10:05 <sgotliv> oschreib:yes
14:10:47 * lvernia here
14:10:51 <emesika> oschreib,  no . but I'll do my best
14:10:54 <sgotliv> oschreib:yes for represent
14:11:26 * jbrooks lurks
14:11:33 <oschreib> ok
14:11:38 <oschreib> lets do our best
14:11:44 <oschreib> #topic 3.3 Release update
14:11:57 <oschreib> #info ovirt 3.3 releae page and tracker:
14:12:04 <oschreib> #link http://www.ovirt.org/OVirt_3.3_release-management
14:12:12 <oschreib> #link https://bugzilla.redhat.com/show_bug.cgi?id=918494
14:12:21 <oschreib> #info GA is one week from niow
14:12:24 <oschreib> #undo
14:12:24 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9b148cc>
14:12:35 <oschreib> #info GA is one week from now
14:12:40 <mburns> oschreib: i agree, let's do our best
14:13:00 <oschreib> #info RC build has been uploaded to ovirt.org, thanks mburns
14:13:15 <mburns> node builds with latest vdsm hopefully coming today
14:13:24 <oschreib> cool!
14:13:35 <oschreib> lets do quick blocker review for what we can
14:13:43 <oschreib> #info Blocker review
14:14:02 <oschreib> #info Bug 988299 - Impossible to start VM from Gluster Storage Domain (engine, MODIFIED)
14:14:34 <oschreib> sahina: did we pushed this fix into 3.3 branch?
14:15:34 <sahina> oschreib, i believe deepakcs has done this (was a vdsm fix)
14:15:56 <sahina> oschreib, will confirm in a min
14:16:01 <oschreib> thanks
14:16:02 <sahina> oschreib, please go ahead
14:16:19 <oschreib> #info probably fixed
14:16:37 <oschreib> #action sahina to verify 988299 is pushed
14:16:43 <oschreib> next
14:17:08 <oschreib> #info Bug 994523 - [vdsm][multiple gateways] Keep ovirt management as default in the main routing table always (engine, MODIFIED)
14:17:23 <oschreib> amuller: fsimonce: update on the bug above?
14:18:30 <amuller> oschreib: Well, it's modified
14:18:40 <amuller> oschreib: can be closed
14:19:06 <oschreib> amuller: in which vdsm build is this fix? we need to make sure it's uploaded to ovirt.org
14:19:46 <sahina> oschreib, sorry to interrupt. but for bug 988299, patch http://gerrit.ovirt.org/#/c/17994/ submitted with vdsm spec file changes
14:19:56 <amuller> oschreib: It was merged on the 7th of August
14:19:58 <sahina> oschreib, this has not been merged yet.
14:20:11 <amuller> oschreib: to ovirt-3.3 branch
14:20:47 <mburns> oschreib: if it was merged that long ago, then it's in the latest vdsm build on ovirt.org
14:21:05 <oschreib> we're confusing two patches here
14:21:17 <oschreib> apperantly the patch sahina is talking about is not in yet
14:21:24 <oschreib> amuller's is in apperantly
14:22:14 <mburns> oschreib: yes, right
14:22:56 <oschreib> sahina: can you please push it forward? it is marked as a blocker to the version, and I wouldn't like to delay the version for it
14:23:34 <mburns> #info patch for 988299 is not merged yet ( http://gerrit.ovirt.org/#/c/17994/ )
14:23:36 <sahina> oschreib, sure. if we could get someone from vdsm to merge this, i can ask deepakcs to post to 3.3 branch as well
14:23:43 <mburns> #info need new vdsm build with this patch
14:24:17 <oschreib> next
14:24:52 <oschreib> #info Bug 994604 - Users cannot log into UserPortal (engine, MODIFIED)
14:25:11 <oschreib> ecohen: are you here?
14:25:18 <ecohen> oschreib, here - sorry for arriving late.
14:25:19 <oschreib> ecohen: any updates on the bug above?
14:25:45 <ecohen> oschreib, this one has been merged to master, would probably be a good idea to backport it to ovirt-engine-3.3 (it hasn't been done yet AFAIK)
14:26:04 <oschreib> ecohen: can you please make sure it happens?
14:26:10 <ecohen> oschreib, sure, no problem.
14:26:18 <oschreib> #action ecohen to push into 3.3 branch
14:26:31 <oschreib> #action oschreib to rebuild engine afterwards
14:27:16 <oschreib> if this will happen tomorrow, I think we will still be able to ship GA on time, not sure though
14:27:18 <oschreib> next
14:27:46 <oschreib> #info Bug 997362 - [engine-config] /var/log/ovirt-engine/engine-config.log doesn't exist (engine, MODIFIED)
14:28:03 <mburns> oschreib: given there will be a new vdsm version, i'm going to delay the node build
14:28:05 <oschreib> anyone from infra here?
14:28:25 <emesika> emesika
14:28:27 <oschreib> mburns: well, I have no idea when will it happen
14:28:39 <oschreib> mburns: so it might be a good idea to build node anyway
14:28:55 <oschreib> emesika: any updates on the bug above? did we pushed it into 3.3 branch?
14:28:59 <mburns> oschreib: i'd rather spend our time fixing other bugs than have to build twice
14:29:20 <emesika> oschreib,  checking ....
14:29:50 <oschreib> mburns: ok
14:30:27 <dneary> Hi all
14:30:38 <oschreib> hey dneary
14:31:03 <oschreib> emesika: I going on with the meeting, can you please just make sure it's pushed into that branch?
14:31:50 <mskrivanek> sorry, I'm 30 minutes late, but I'm here for virt. And good news is I'm not aware of any blockers...:-)
14:31:55 <emesika> oschreib, no problem
14:32:10 <oschreib> #action emesika to check with 997362
14:32:18 <oschreib> #info Blocker review done
14:32:43 <oschreib> mburns: what about communications/announce/etc for next week? who's responsible for those?
14:35:21 <ecohen> oschreib, sorry for interrupting: regarding "Bug 994604 - Users cannot log into UserPortal": this one is actually an infra/AD-related issue, so I am not sure about its status (maybe emesika can check on its status as well) - I was referring to the GUI issue fixed in http://gerrit.ovirt.org/#/c/18228/ (isn't documented in any oVirt BZ afaik, but still worth backporting to ovirt-engine-3.3)
14:35:59 <jbrooks> oschreib, I'm helping w/  communications/announce/etc
14:36:24 <oschreib> ecohen: ok, thnaks for the info
14:36:33 <ecohen> oschreib, np - sorry for the confusion earlier.
14:36:43 <oschreib> emesika: can you please make sure also 994604 gets into the branch?
14:36:56 <emesika> oschreib, sure
14:37:09 <oschreib> jbrooks: cool, we will need them for next week I hope, or a bit later if we will delay
14:37:53 <jbrooks> oschreib, is/will the feature page be accurate about which features made it in?
14:38:36 <oschreib> jbrooks: the 3.3 release page should be pretty accurate
14:38:44 <jbrooks> cool
14:38:56 <oschreib> I suggest having a release go/no-go next week, a day before the weekly meeting
14:39:00 <oschreib> mburns: ^^
14:39:24 <mburns> oschreib: we can try that on tuesday
14:39:38 <mburns> it will have to be 1hr earlier than this meeting, though
14:39:47 <mburns> (otherwise we conflict with the ovirt-node meeting)
14:40:09 <oschreib> mburns: ok, Tuesday, one hour earlier than ovirt meeting, that's 4PM Israel time
14:40:29 <oschreib> #action oschreib to send mail on release go/no-go meeting
14:40:40 <oschreib> mburns: finished with 3.3 stuff
14:40:47 <oschreib> mburns: the meeting is all yours :)
14:41:31 <mburns> ok, thanks oschreib
14:42:03 <mburns> #topic workshops and conferences
14:42:09 <mburns> dneary: any info here?
14:42:30 <dneary> mburns, Literally just back from vacation...
14:42:34 <dneary> But here's the skinny
14:42:36 <mburns> #info ovirt developer meetings and planning to happen at KVM Forum (21-23 October in Edinburgh)
14:42:51 <dneary> There will be oVirt content in the KVM Forum in Edinburgh in October.
14:42:52 <sbonazzo> oschreib: mburns: we're still in development but today ovirt-hosted-engine-ha and ovirt-hosted-engine-setup have reached nightly repo
14:43:25 <dneary> On Wednesday 23rd, we will also be planning the oVirt developer meeting, where we'll have a series of BOFs to plan the development of oVirt for the next year or so
14:43:27 <mburns> #info there will be additional oVirt content during KVM Forum as well
14:43:38 <mburns> sbonazzo: excellent
14:43:51 <mburns> sbonazzo: oschreib:  do we plan a respin/backport to get these into 3.3?
14:43:55 <dneary> People wishing to attend should register for the KVM Forum
14:44:09 <oschreib> mburns: it's an independent project, so no need
14:44:26 * mburns notes that registration is free for the first 200 kvm forum registrants
14:44:37 <mburns> oschreib: ahh, so just new rpms to post
14:44:44 <knesenko> i
14:44:56 <dneary> I need to do the rounds of everyone we want in attendance - I have a list of about 30 people to contact. I will also be looking to seed discussion topics and appoint session leaders in preparation for the meetings.
14:45:17 <dneary> mburns, Do you have any updates on what's been done to prepare for the 3.3 release in the last few weeks?
14:45:18 <awels> oschreib: #info Bug 994604 - Users cannot log into UserPortal (engine, MODIFIED) has been backported to 3.3 branch
14:45:25 <dneary> Release notes, announcements, that kind of thing?
14:45:43 <oschreib> awels: and pushed? if so, please close the bug
14:45:45 <mburns> #info dneary to make sure everyone that should be there is in attendance for ovirt dev meetings
14:45:58 <dneary> Also, is there an install document/quick start, work on the all in one bootable ISO?
14:46:02 <awels> oschreib: its pushed up, but not merged
14:46:16 <oschreib> awels: I'm counting on you :)
14:46:19 <jbrooks> dneary, I've started on release notes, prepared to work on announce
14:46:27 <jbrooks> and promotion
14:46:38 <mburns> dneary: i'm just back from vacation last week, so still catching up myself
14:46:42 <ecohen> awels, note that there has been a confusion earlier - 994604 is actually an infra bug, and emesika is taking care of backporting it.
14:46:49 <ecohen> oschreib, ^^^
14:46:58 <awels> oschreib: /me has no powers to do that. Hopefully someone that does will merge it soon.
14:47:21 <ecohen> awels, oschreib - we are talking about the user portal login issue in the GUI that has no oVirt BZ associated with it.
14:48:01 <awels> ecohen: 994604 is not the bug I backported
14:48:14 <dneary> jbrooks, Great! Thanks
14:48:17 <mburns> #info jbrooks has been working on release notes, announcement, etc
14:48:22 <dneary> jbrooks, Are they in the wiki?
14:48:32 <ecohen> awels, see the sentence that you wrote earlier: "oschreib: #info Bug 994604 - Users cannot log into UserPortal (engine, MODIFIED) has been backported to 3.3 branch"
14:48:37 <awels> oschreib: oops wrong one, I back ported another user portal login issue.
14:48:48 <jbrooks> dneary, yes, copied from 3.2, with features from the 33 planning page
14:48:56 <dneary> Great
14:49:14 <jbrooks> They need filling out, I'm going to work on that this week
14:49:21 <awels> ecohen: I see, I was confused, I did backport the right one, just not 994604
14:49:27 <mburns> dneary: anything else we are forgetting?
14:49:27 <ecohen> awels, indeed.
14:49:59 <dneary> mburns, I guess oschreib might have info on the all in one and live distro?
14:50:21 <mburns> dneary: all-in-one should be the same, i think
14:50:42 <dneary> Last I heard there were some issues with the live distro on CentOS 6.4
14:50:44 <mburns> a live distro -- normally, i'd say mgoldboi or ohadlevy, but neither online, so i'd defer to oschreib
14:51:00 <oschreib> all in one - should work, it's a sub rpm of engine
14:51:10 <oschreib> #action oschreib to check about 3.3 live distro
14:51:52 <mburns> dneary: anything else?
14:52:04 <dneary> I think I'm good for now :-)
14:52:04 <mburns> dneary: btw, i'm confirmed for KVM Forum
14:52:09 <dneary> Great!
14:52:10 <mburns> though i have no talks scheduled
14:52:24 <mburns> (no travel plans quite yet, but, i'm registered and have travel approval
14:52:40 <mburns> #topic infra update
14:52:57 <mburns> ewoud: do you have any updates?
14:53:04 * mburns saw knesenko disappear...
14:54:22 <eedri> mburns, if ewoud isn't here i can chime in
14:54:37 <mburns> eedri: ok, go ahead
14:55:06 <eedri> mburns, basically we have some extra storage on rackspace severs (2TB) which will allow us to migrate all backups to there and add more jenkins slaves
14:55:17 <eedri> mburns, new centos64 slaves are online for jenkins
14:55:34 <eedri> mburns, new puppet classes were added to better manage jenkins slaves
14:55:39 <mburns> #info extra storage in rackspace servers, so backups will be migrated there
14:55:47 <mburns> #info new centos 6.4 slaves are only
14:55:57 <mburns> #info new puppet classes added to manage jenkins slaves
14:56:04 <mburns> #info more room for additional jenkins slaves
14:56:15 <eedri> mburns, jenkins server was updated to latets LTS
14:56:40 <mburns> #info jenkins updates to latest LTS (long term stable)
14:56:44 <eedri> mburns, new nightly builds for host-engine-setup & ha were added
14:57:10 <mburns> host-engine-setup and ha builds are now built nightly and pushed to nightly repos
14:57:51 <eedri> mburns, hosted-engine i meant of corse
14:58:01 <sbonazzo> mburns: ovirt-hosted-engine-setup, missing info command
14:58:03 <mburns> #info hosted-engine-setup and ha builds are now built nightly and pushed to nightly repos
14:58:16 <mburns> sbonazzo: yep, just noticed i missed #info
14:58:28 <sbonazzo> mburns: ok :-)
14:58:35 <eedri> mburns, network functional tests are in progress on jenkins
14:58:56 <mburns> #info in process of adding network functional testing to jenkins
14:59:35 <eedri> mburns, that's it, thanks
14:59:45 <mburns> thanks eedri
14:59:49 <mburns> #topic Other Topics
14:59:54 <mburns> anyone have other topics to bring up?
15:01:23 <mburns> going once...
15:01:50 <mburns> twice..
15:01:59 <mburns> gone.
15:02:04 <mburns> #info no other topics
15:02:06 <mburns> thanks all
15:02:09 <mburns> #endmeeting