14:00:50 <mburns> #startmeeting oVirt Node Weekly Meeting
14:00:50 <ovirtbot> Meeting started Tue Aug 20 14:00:50 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:50 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:56 <mburns> #topic agenda and roll call
14:01:02 <mburns> #chair jboggs fabiand rbarry
14:01:02 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
14:01:08 * jboggs here
14:01:19 * fabiand here too
14:01:30 * rbarry here also
14:01:44 <mburns> #info 3.0.1
14:01:47 <mburns> #info 3.1.0
14:01:53 <mburns> #info other topics
14:01:57 <mburns> #topic 3.0.1
14:02:04 <mburns> fabiand: where are we with a 3.0.1 update?
14:02:16 <mburns> oVirt is looking for new node builds with the latest vdsm
14:02:20 <mburns> (f19 and el6)
14:02:24 <fabiand> mburns, okay
14:02:29 <fabiand> well, we prepared an iso last week
14:02:34 <fabiand> And waited for some feedback
14:02:48 <fabiand> There are a couple of patches that need to go into 3.0.1
14:02:50 <fabiand> mainly network related
14:03:02 <fabiand> We need to merge them into the 3.0 branch
14:03:14 * fabiand actually planned to do this but didn't get round doing it ..
14:03:30 <mburns> fabiand: any chance of getting to it today/tomorrow?
14:03:39 <mburns> #info test iso posted last week
14:03:51 <fabiand> yes
14:03:53 <mburns> some patches pending for 3.0.1 that need porting to node-3.0 branch
14:03:55 <eedri_> ewoud, knesenko we need to add git to puppet class for all jenkins slaves
14:03:56 <mburns> #info some patches pending for 3.0.1 that need porting to node-3.0 branch
14:04:03 <fabiand> at latest tomorrow afternoon (CEST)
14:04:27 <mburns> #info fabiand will have things ready to be posted by tomorrow (afternoon CEST)
14:04:44 <mburns> fabiand: what help do you need to make that happen?
14:05:13 <fabiand> mburns, maybe we can diskuss later on what patches we want to pull into 3.0.1
14:05:33 <fabiand> and I'd appreciate if someone volunteers to do the el6 builds.
14:06:02 <rbarry> I can do EL6 again
14:06:08 <fabiand> rbarry, cool - thanks!
14:06:15 <mburns> fabiand: sure, we can talk about what to pull back
14:06:20 <mburns> rbarry: thanks
14:06:31 <mburns> #info fabiand and mburns to discuss patch inclusion in 3.0.1
14:06:37 <mburns> #info rbarry to assist with el6 builds
14:06:49 <mburns> anything else for 3.0.1?
14:07:29 <fabiand> nope
14:07:31 <fabiand> not from me ..
14:07:56 <rbarry> Nothing...
14:08:14 <mburns> ok, moving on then
14:08:18 <mburns> #topic 3.1.0
14:08:38 <mburns> Mostly just a brainstorming/feature idea topic
14:09:01 <mburns> #info Some things i'd like to tackle in 3.1.0
14:09:52 <rbarry> I know we don't really need more network changes, but I'd love to see openvswitch in Node.
14:09:52 <jboggs> storage / install module rewrite :)
14:10:08 <fabiand> rbarry, :)
14:10:11 <mburns> #info break up ovirt-node into more sub-packages like -virt -tui etc for use cases that don't need those pieces of functionality
14:10:12 <fabiand> I also thought about that ..
14:10:16 <mburns> #info storage/install module re-write
14:10:19 <fabiand> jboggs, +1 on this one too! make it testable!
14:10:21 <mburns> #info openvswitch
14:10:38 <mburns> #info live plugins
14:10:54 <fabiand> live plugins=plugins installed at runtime? mburns
14:11:06 <mburns> fabiand: yes
14:11:14 <jboggs> can pair that with puppet config likely
14:11:40 <mburns> jboggs: possibly, or with some sort of push model from a management server like ovirt-engine
14:12:36 <mburns> #info some sort of "here i am, here is what i can do" publishing model
14:12:53 <mburns> to make registration easier for things like engine
14:12:56 <mburns> #info to make registration easier for things like engine
14:13:06 <mburns> #info kimchi plugin
14:13:41 <mburns> if you're not aware of kimchi:  http://github.com/kimchi-project/kimchi
14:14:27 <mburns> i think these are good ideas
14:14:53 <mburns> let's think about new features and we can discuss at next week's meeting
14:15:05 <mburns> and figure out what we'll target and what we'll defer
14:15:08 <fabiand> ack
14:15:29 <mburns> #info think about new features and we can discuss at a later meeting
14:15:55 <mburns> #action mburns to email node-devel to solicit new feature requests
14:16:29 <mburns> #topic other topics
14:16:41 * mburns doesn't really have other topics other than:
14:17:16 <mburns> #info there is interest in an ovirt-node based system discovery and provisioning image for use with foreman
14:17:28 <mburns> #info they're doing initial investigation
14:18:16 <mburns> #info some actions that will be needed:  further kickstart work, splitting to more subpackages for specific functionality (tui, virt, etc)
14:18:22 <mburns> any other topics?
14:18:29 <knesenko> eedri_: git rpms ?
14:18:48 * fabiand will be doing a presentation on test automation - with a focus on node ;) next weekend at froscon
14:18:59 <fabiand> nothing else from me ..
14:19:09 <jboggs> im good
14:19:28 <mburns> #info fabiand doing a presentation on test automation with a focus on node at froscon next week
14:19:33 <mburns> good luck fabiand
14:19:36 <fabiand> thanks, mbetak
14:19:38 <fabiand> mburns,
14:19:57 <mburns> ok, if nothing else, then we can end the meeting
14:20:22 <mburns> #endmeeting