13:59:57 <knesenko> #startmeeting oVirt Infra meeting
13:59:57 <ovirtbot> Meeting started Mon Jul  8 13:59:57 2013 UTC.  The chair is knesenko. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:59:57 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:10 <knesenko> #chair obasan dcaro
14:00:10 <ovirtbot> Current chairs: dcaro knesenko obasan
14:00:14 <knesenko> ewoud: here ?
14:00:59 <knesenko> dcaro: here ?
14:01:24 <knesenko> #chair eedri
14:01:24 <ovirtbot> Current chairs: dcaro eedri knesenko obasan
14:01:32 <ewoud> knesenko: pong
14:01:47 <knesenko> ewoud: hello, have time for a meeting ?
14:02:08 <ewoud> knesenko: yes
14:02:21 <knesenko> ewoud: ok ... want to lead ?
14:02:44 <ewoud> knesenko: feel free to lead
14:02:47 <knesenko> ewoud: ok
14:02:56 * ewoud is a bit tired from getting up at 5:30 am today
14:03:20 <knesenko> ewoud: ok :)
14:03:41 <knesenko> #topic Hosting
14:03:48 <knesenko> ok lets start then
14:04:05 <knesenko> I have news regarding the racksapce intallation
14:04:21 <knesenko> finished the installation ...
14:04:28 <dcaro> \o/
14:04:30 <knesenko> now we have there two LOCAL DCs
14:04:31 <ewoud> yay
14:04:53 <knesenko> I ask to open all ports that we need for spice ssh etc ...
14:05:11 <knesenko> now I have to configure IPs on the slave
14:05:12 <ewoud> and it would be cool if foreman could talk to the ovirt API
14:05:27 <ewoud> so you can provision using foreman
14:05:34 * knesenko have some issues with that - opened a ticket to rackspace
14:05:39 <dcaro> ewoud: it sould be able (the computer resource is added and can list the domains at least)
14:05:47 * eedri here
14:05:51 <knesenko> mmmm .... what  else
14:06:18 <ewoud> dcaro: ah cool
14:06:28 <eedri> knesenko, so using gluster storage?
14:06:36 <knesenko> we have a public IPs for those slaves .... I opened a ticket for Red Hat guys to create DNs entries for the slaves
14:06:43 <knesenko> eedri: nope ... local
14:07:02 <knesenko> eedri: we don';t have enough space for gluster
14:07:11 <knesenko> thats the main reason
14:07:15 <eedri> knesenko, how much space does it need?
14:07:34 <knesenko> with gluster we will have 100GB
14:07:39 <knesenko> 130GB max
14:07:52 <knesenko> with the local storage we have 250GB +-
14:08:27 <knesenko> there are some differences between the HD size of racksapce servers
14:08:43 <knesenko> that's all from my side ... so this week I hope I will finish with the slaves .
14:08:55 <knesenko> news on your side guys ?
14:09:06 <knesenko> thanks dcaro for adding the servers to foreman !
14:09:08 <knesenko> and puppet
14:09:32 <eedri> knesenko, we need to make sure we add the vms as well when they are ready :)
14:09:32 <obasan> yes. I wanted to start monitor the oepnshift instance with icinga but I only got an ssh access today :( so I will do that soon
14:09:50 <knesenko> eedri: yes
14:10:13 <ewoud> I've been quite busy, but I did notice that when I tried to log in to foreman I sometimes had connection issues
14:10:20 <knesenko> obasan: and ... any progress ?
14:10:40 <ewoud> do you guys notice something similar?
14:10:53 <knesenko> obasan: ok ... didn;t noticed
14:11:01 <knesenko> ewoud: nope ...
14:11:04 <knesenko> maybe dcaro
14:11:23 <dcaro> ewoud: I did not notice anything strange
14:12:01 <dcaro> ewoud: http or ssh?
14:12:02 <ewoud> hmm ok
14:12:08 <ewoud> dcaro: ssh and puppet
14:12:18 <ewoud> also had issues when I tried to sync a rackspace node
14:12:42 <eedri> obasan, you also added some monitoring for ovirt.org, right?
14:12:44 <ewoud> let's monitor it then
14:13:02 <obasan> eedri, indeed. yes
14:13:07 <obasan> I added http monitoring
14:13:15 <knesenko> obasan: +1
14:13:38 <knesenko> anything else on hosting ?
14:13:58 <knesenko> eedri: is there any news regarding the external storage ? :)
14:13:59 <ewoud> my jenkins slave could possibly be discussed under jenkins
14:14:01 <dcaro> we have a new stats machine, with fedora18, I'm still working on it
14:14:15 <ewoud> there are too many jobs running for the amount of memory in it
14:14:19 <knesenko> dcaro: what is stats machine ? :)
14:14:32 <ewoud> top - 16:14:29 up 216 days, 20:19,  1 user,  load average: 18.41, 18.66, 17.78
14:14:35 <knesenko> ewoud: yes I know ... rackspace slaves should solve it
14:14:40 * ewoud doesn't like a load of 18
14:14:43 <dcaro> to keep some statistics and performance monitoring
14:14:51 <knesenko> dcaro: ok
14:14:53 <obasan> dcaro, graphite?
14:15:21 <dcaro> Right now it has awstats, because I'm trying to get some info for the robots.txt files
14:15:30 <obasan> dcaro, +1
14:15:40 <dcaro> but yes, I was planning on installing graphite
14:16:12 <knesenko> ok lets move to the jenkins
14:16:17 <knesenko> #topic Jenkins
14:16:40 <knesenko> we update pep8 on some slaves
14:16:43 <knesenko> updated
14:17:12 <knesenko> status is quite good on jenkins . only one job fails
14:17:31 <knesenko> ewoud: you wanted to say something about your slave ?
14:18:32 <ewoud> as I said, bit heavy load
14:18:53 <knesenko> aha .... will solve it soon I hope
14:19:06 <knesenko> eedri: any news ? dcaro ?
14:19:53 <dcaro> nop, we had a couple of jobs that were stuck and blocking new runs, but retarting jenkins fixed it
14:20:18 <knesenko> ok good .... so nothing special on jenkins ...
14:20:34 <knesenko> lets move on
14:20:47 <knesenko> #topic puppet
14:21:01 <knesenko> I have no news in this area
14:21:19 * ewoud neither
14:21:37 <ewoud> we should do more with it, but at least we're adding user accounts for everyone
14:21:47 <dcaro> yep
14:22:08 <knesenko> i hope we will do more when rackspace slaves will be ready
14:22:32 <ewoud> yes, maybe we can try adding slaves using puppet, including installation?
14:23:04 <knesenko> ewoud: it will be great !
14:23:16 <ewoud> maybe install 1 or 2 manually to reduce the load, then figure out how to do it properly?
14:23:31 <knesenko> ewoud: for now I am going to install 1 VMs on rackspace .... create a template from it . and then create a VMs from that template
14:23:34 <ewoud> not sure how many manual packages are installed
14:23:55 <ewoud> I heard something about pep8, but do we have a list?
14:24:36 <knesenko> ewoud: I am sorry .... list ?
14:24:44 <knesenko> I am not aware ...
14:25:12 <eedri> ewoud, can foreman add vms using the ovirt api? (i mean that already have dns+dhcp)
14:25:30 <ewoud> eedri: yes, it can create them
14:25:43 <ewoud> eedri: or do you mean add existing ones?
14:25:47 <eedri> ewoud, so even if we don't have smart proxy ?
14:25:52 <eedri> ewoud, to manage thier dns/dhcp
14:26:04 <obasan> eedri, it works quiet well.I've done it with the monitoring vm
14:26:04 <eedri> ewoud, yea, like reprovision
14:26:11 <ewoud> eedri: I think you do need a smart proxy, but maybe you can (ab)use templates
14:26:21 <knesenko> eedri: there is no dhcp in rackspace .... only static IPs
14:26:59 <ewoud> you could use tftp over the internet and use static IPs
14:27:08 <eedri> knesenko, ok, my point is if someone tried using the "compute resources" in foreman to resintall vms on ovirt-engine
14:27:23 <eedri> rather than installing new ones
14:28:37 <knesenko> eedri: ok
14:29:23 <knesenko> anything else here ?
14:30:00 <ewoud> eedri: I don't think you can reprovision without tftp/pxe
14:30:19 <eedri> ewoud, any reason why not to install it on our foreman?
14:30:21 <knesenko> ewoud: right .... you need to boot from somewhere
14:30:42 <eedri> ewoud, i meant, no using the smart proxy for dns/dhcp. just using existing records
14:31:09 <ewoud> eedri: I think there's some manual code to link hosts in foreman to actual VMs if that's what you mean
14:31:28 <eedri> ewoud, ok, i guess we'll find out soon
14:31:32 <ewoud> I'd have to look up the issue where they compare mac adresses
14:31:34 <eedri> ewoud, once we start having vms running
14:31:43 <dcaro> foreman can use vm templates to provision machines
14:31:52 <eedri> dcaro, that's good..
14:31:58 <eedri> dcaro, so not need for immediate pxe/tftp
14:32:07 <eedri> dcaro, might be even faster provisioning
14:32:08 <dcaro> with a minimum os installed so no tftp/dhcp is needed, but we need the templates )
14:32:27 <eedri> knesenko, i suggest creating f19/f18 and centos 64 templates
14:32:35 <eedri> quaid, ping
14:32:57 <knesenko> eedri: yes ... I have some issues with configuring the IPs on the slaves . But I will create those templates
14:33:22 <eedri> not sure about rhel instance, (we have rhel now on amazon), i think we can start without it
14:35:12 <knesenko> #topic Other Business
14:36:01 <knesenko> Opened a profile for the oVirt project on linkedin - http://www.linkedin.com/company/ovirt?trk=top_nav_home
14:36:42 <ewoud> knesenko: how do you determine who's added?
14:37:01 <knesenko> ewoud: who's added where ?
14:37:32 <knesenko> its a company profile ... you can follow it ... or you can add it as your current job
14:37:54 <ewoud> knesenko: ah ok
14:38:15 <eedri> knesenko, do we have anyone adding info to it?
14:38:21 <eedri> knesenko, like events/news
14:38:42 <knesenko> eedri: I've added Itamar and Dave to the admins .
14:38:59 <eedri> knesenko, ok
14:39:07 <eedri> knesenko, might worth adding a link to it on ovirt.org
14:39:18 <knesenko> eedri: there is a link
14:39:39 <knesenko> under the : Website
14:40:20 <knesenko> we have 61 followers ! :)
14:40:41 <knesenko> and only 2 employees :) me and obasan
14:40:46 <eedri> knesenko, i mean from ovirt.org -> linkedin
14:40:57 <knesenko> eedri: ah ... ok ... there is no link
14:41:01 <eedri> knesenko, like a linkedin logo
14:41:19 <knesenko> eedri: where do you want to add it ?
14:41:24 <knesenko> eedri: to the main page ?
14:41:35 <eedri> knesenko, best to ask on infra, but i think yes
14:42:27 <eedri> knesenko, http://www.rackspace.com/
14:42:35 <eedri> knesenko, like rackspace has on the bottom
14:43:11 <knesenko> #action knesenko add linkedin profile link to the main page ovirt.org
14:43:16 <knesenko> eedri: aha .. ok
14:43:49 <knesenko> what else guys ?
14:44:08 <knesenko> any progress on tickets -  https://fedorahosted.org/ovirt/report/1 ?
14:45:34 <knesenko> ok ... seems like no progress here
14:46:02 <dcaro> I close one ticket... adding the rackspace hosts to puppet
14:46:05 <eedri> knesenko, jenkins was upgraded
14:46:12 <eedri> knesenko, to latest centos 6.4
14:46:21 <knesenko> seems like the highest priority is installing slaves ....
14:46:27 <knesenko> eedri: dcaro thanks guys
14:46:29 <knesenko> good job
14:47:33 <knesenko> ok guys . have a nice week !!!
14:47:38 <dcaro> you too :)
14:48:10 <knesenko> thank you all !
14:48:17 <knesenko> #endmeeting