14:00:21 <mburns> #startmeeting oVirt Weekly Meeting
14:00:21 <ovirtbot> Meeting started Wed Jul 3 14:00:21 2013 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:26 <mburns> #topic agenda and roll call
14:00:28 <dneary> hi. Here
14:00:38 <mburns> #info 3.3 status update
14:00:39 * ofri__ here
14:00:47 * ecohen here
14:00:50 * lvernia here
14:00:53 <jbiddle__> Oh. Good timing.
14:00:54 <jbiddle__> Here
14:00:58 <mburns> #info Conferences and workshops
14:01:03 <mburns> #info infra team update
14:01:07 <mburns> #info Other Topics
14:04:16 <mburns> #topic oVirt 3.3 status Update
14:04:33 <mburns> #link http://www.ovirt.org/OVirt_3.3_release-management
14:04:48 <mburns> let's start with Virt today
14:04:56 * mgoldboi here - finally...
14:05:02 <mburns> hi mgoldboi
14:05:20 <mburns> Any update on RAM Snapshots and spice html5 integration?
14:05:25 <mburns> both are orange
14:05:42 <mburns> and cloud-init integration (red)
14:05:45 <mgoldboi> mskrivanek: update?
14:07:01 <mburns> ok
14:07:04 <mburns> on to Infra
14:07:09 <mburns> update on External Tasks?
14:08:18 <mburns> Networking: Quantum (orange) or NetworkReloaded(orange) ?
14:09:05 <mburns> ok, what groups are here to update status?
14:09:08 <lvernia> mburns: OpenStack Network integration UI patches will be pushed in the next couple of days.
14:09:18 <lvernia> mburns: backend already merged.
14:09:32 <ofri> SLA
14:09:35 <lvernia> mburns: Not sure about Network Reloaded, but it
14:09:41 <mburns> #info Networking: Openstack Network integration should be merged in next couple days
14:09:43 <lvernia> it's marked as not-necessary?
14:10:06 <mburns> lvernia: yes, but if it's not getting in, we should drop it from the release page
14:10:23 <shubhendu> shubhendu here from RHSC team redhat bangalore
14:10:30 <lvernia> mburns: I don't have any info on it, sorry, specifically I don't know that it's not getting in :)
14:10:32 <danken> mburns: agreed. It is only partially in
14:10:43 <danken> mburns: and should not worry us any longer
14:10:51 <mburns> danken: ok, i'll drop it from the table
14:10:59 * yzaslavs in representing infra features
14:10:59 <mburns> danken: thanks
14:11:12 <danken> the bulk of the code is there, but we are more worried about the multigw+selinux+dhcp combination
14:11:22 <danken> so we put our resources there.
14:11:28 <jbiddle__> mburns: since I'm awake, I have an update about community docs
14:11:42 <mburns> #info networking: networkreloaded being dropped from release tracking, but may still get in
14:11:48 <mburns> jbiddle__: sure, go ahead
14:12:08 <mburns> yzaslavs: any update on External Tasks?
14:12:14 <shubhendu> mburns: Sahina would have already update in last meet that gluster swift and gluster hook rest api we are targetting for next week-end
14:12:22 <yzaslavs> mburns: still in progress, API issues
14:12:35 <jbiddle__> mburns: the rhev docs team is going to start a sprint on tuesday morning AEST time to start the tidy up process for the wiki.
14:12:36 <mburns> yzaslavs: on track for 15-July?
14:12:42 <jbiddle__> mburns: all welcome to join.
14:12:58 <danken> shubhendu: is there anything pending on the gluster/vdsm front?
14:13:00 <mburns> shubhendu: still on track for next weekend?
14:13:05 <yzaslavs> mburns: yes
14:13:21 <shubhendu> vsdm service patch is not yet merged
14:13:22 <mburns> #info infra: external tasks making progress, still on track
14:13:47 <mburns> #info Docs: rhev docs team will start a spring on Tuesday to tidy up the wiki
14:13:54 <mburns> #info Docs: all are welcome to join in
14:14:14 <shubhendu> mburns: rest apis we are targetting for next week end (12th July)
14:14:36 <mburns> #info gluster: on target for end of next week (12-July)
14:14:52 <danken> shubhendu: is it a blocker for you guys?
14:15:14 <mburns> ofri: SLA updates?
14:15:20 <ofri> yes
14:15:25 <mburns> scheduler, Qos, watchdog...
14:15:28 <ofri> I am happy to announce "trusted compute pools" is finaly in
14:15:32 <shubhendu> mburns: rest apis we are still in initial stage
14:15:41 <danken> shubhendu: only now do I notice that Aravinda has answers on http://gerrit.ovirt.org/#/c/11094/
14:15:49 <mskrivanek> mgoldboi: sorry
14:15:57 <mburns> #info SLA: trusted compute pools merged
14:15:59 <ofri> watch dog - same as last week. still waiting for the REST API part
14:16:08 <mburns> ofri: still on track for 15-July?
14:16:15 <shubhendu> danken: yes aravinda has updated status but patch is still pending
14:16:20 <ofri> yep
14:16:23 <ofri> QoS - the feature was practically broken into two - "Network QoS" and "VNIC Profiles"
14:16:29 <ofri> QoS will be tight but (i hope) on time
14:16:35 <mburns> #info SLA: watchdog missing REST API piece, but should be good for feature freeze
14:16:35 <ofri> as for VNIC profiles - maybe somone fron network team could update
14:16:40 <mskrivanek> mburns: virt - ram snapshots, cloud-init, spice html5 still orange. But should make it during next week
14:16:49 <ofri> Scheduling API and oVirt scheduler - like last week. still tight but on schedule for the 15th
14:17:02 <mburns> #info Infra: all features should make it by next week
14:17:26 <doron_> mburns: did you mean SLA
14:17:44 <mburns> doron_: no, that was based on mskrivanek 's comment
14:17:45 <danken> shubhendu: please tell him that I really dislike the notion of the failOnError semantics
14:17:55 <mburns> #info SLA: tight timeframes on scheduler and QoS, but should be good for feature freeze
14:18:02 <mburns> doron_: that's for SLA^^
14:18:06 <shubhendu> danken: sure
14:18:08 <doron_> mburns: thanks
14:18:18 <shubhendu> danken: i think he is already taking care
14:18:26 <mburns> danken: lvernia: VNIC profiles?
14:18:26 <yzaslavs> mburns: mskrivanek was for virt, not infra.
14:18:44 <mburns> yzaslavs: bah
14:18:46 <lvernia> danken: ?
14:18:49 <mburns> #undo
14:18:49 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9a75c2c>
14:18:51 <mburns> #undo
14:18:51 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9b10d0c>
14:18:56 <mburns> #info VIRT: all features should make it by next week
14:19:01 <mburns> #info SLA: tight timeframes on scheduler and QoS, but should be good for feature freeze
14:19:27 <mburns> lvernia: ofri said to check with network team for vnic profile status
14:19:45 <mburns> #info Node: all features green
14:20:02 <danken> lvernia: I hoped that you know more..
14:20:13 <yzaslavs> mburns: no prob :) there is one issue at external tasks we need to close besides tests, besides that - only API tests. i hope we can converge by next week.
14:20:25 <mburns> yzaslavs: excellent
14:20:29 <lvernia> mburns, danken: I'm being told that it should be tight but on time.
14:20:51 <mburns> #info SLA/Network: vnic profiles tight but should be on time
14:20:58 <ofri> lvernia: as far as i know ovedo is currently working on it. but im not sure about the scheduale
14:21:15 <mburns> Integration?
14:21:30 <mburns> both self-hosted engine and optoi infra migration are orange
14:21:37 <lvernia> ofri: just talked to Moti and Alona, who'll also be working on it.
14:21:55 <ofri> lvernia: ok. thanks
14:22:03 <mburns> UX team: frontend Refactor and GWT(P) upgrade -- those look like they're going to miss FF
14:22:19 <mburns> are they really essential?
14:22:27 <mburns> or should we defer to the next release?
14:22:47 <ecohen> mburns, they are both pretty big changes... I wouldn't want them to miss the FF, especially the GWT upgrade.
14:23:20 <mburns> ecohen: they're marked as should, but not must
14:23:25 <mburns> are they required for this release?
14:23:43 <ecohen> mburns, define "required" :) I will have to get back to you on that.
14:24:11 <mburns> ecohen: i'd rather not delay feature freeze beyond 15-July
14:24:22 <mburns> but if you can get back to me about it, i'd appreciate it
14:24:32 <ecohen> mburns, I will. thanks.
14:24:46 <mburns> #action ecohen to see if UX features are required for 3.3 release or if they can be deferred
14:25:38 <mgoldboi> mburns: integration - otopi based installer - on track
14:26:14 <mburns> Storage team: updates on R/O disks (orange) manage storage connections(red) backup api(red) disk block alignment(orange) resign/force resign SPM(no status)
14:26:15 <mgoldboi> mburns: integration - hosted engine setup - at risk, but i believe it would make it
14:26:29 <mburns> #info integration: otopi based installer on track
14:26:57 <mburns> #info integration: hosted engine at risk, but should make it
14:27:22 <mburns> any other groups that i missed?
14:27:47 <danken> in network, we need to pay more attention for the vdsm side of the quantum integration
14:27:47 <danken> http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:master+topic:OpenstackNetProvider,n,z
14:28:22 <mburns> danken: any risk there?
14:28:27 <danken> I hate to push it in the last minute
14:28:43 <mburns> or will it be in before feature freeze?
14:28:44 <danken> well, it's not in yet. and beta is in 10 days...
14:28:56 <danken> it has to.
14:29:06 <danken> so it would
14:29:16 <mburns> danken: is it close?
14:29:20 <danken> yes
14:29:23 <mburns> ok
14:29:35 <mburns> we can fix bugs after feature freeze
14:29:42 <mburns> but having it feature complete is important
14:29:52 <mburns> anyone from the storage team here?
14:30:36 <mburns> abaron_: anyone who can give updates on storage features for 3.3?
14:32:03 <mburns> #info Summary:
14:32:34 <mburns> #info UX features won't make it for 15-July, ecohen checking on need for the features and other options
14:32:52 <mburns> #info Integration and SLA are pretty tight on a couple features
14:32:59 <mburns> #info but should make feature freeze for all of them
14:33:49 <mburns> #info please plan to have builds done for Beta on or before 16-July
14:33:57 <mburns> #info plan to post beta either 16 or 17-july
14:35:00 <mburns> #info no feedback from storage team given in this meeting, so unclear on the status of storage features
14:35:14 <mburns> anything else for 3.3?
14:36:36 <mburns> ok, moving on...
14:36:45 <mburns> #topic Workshops and Conferences
14:36:52 <mburns> dneary: any updates
14:37:58 <mburns> #info LinuxCon /CloudOpen EU (21-23 October, Edinburgh, UK) CFP closes 21-July
14:38:35 <mburns> #info oVirt Developer Meetings to happen concurrently with LC/CloudOpen EU
14:38:53 <mburns> KVM Forum CFP also closes soon (also co-located with LC/CloudOpen EU)
14:38:55 <mburns> #info KVM Forum CFP also closes soon (also co-located with LC/CloudOpen EU)
14:39:58 <mburns> #info planning underway for next workshop, but no details yet
14:40:28 <mburns> moving on, now...
14:40:34 <mburns> #topic Infra updates
14:40:38 <mburns> ewoud: any updates?
14:40:44 <mburns> #chair ewoud mgoldboi dneary
14:40:44 <ovirtbot> Current chairs: dneary ewoud mburns mgoldboi
14:41:38 <dneary> mburns, Hi there
14:41:46 <dneary> Sorry - distracted
14:41:59 <dneary> No updates re events
14:42:04 <mburns> dneary: seems everyone is today...
14:42:06 <dneary> Theron is currently on PTO
14:42:21 <dneary> re infra, we've made some progress on organising things
14:42:42 <mburns> excellent
14:42:49 <mburns> any specifics that make good #infos?
14:42:59 <dneary> The website is more stable
14:43:14 <dneary> We've identified bots as the probably cause of the performance issues with the website and Gerrit
14:43:29 <dneary> Now we need to fix them. dcaro is on it
14:43:45 <mburns> #info identified bots that likely caused many of the perf issues with gerrit and ovirt.org
14:43:51 <mburns> #info dcaro is working on fixing them
14:44:54 <dneary> More work to be done to organise things, but it's slowly coming together
14:45:07 <mburns> dneary: ok, thanks
14:45:22 <mburns> #info infra working on getting organized and starting to pull things together
14:46:45 <mburns> #topic Other Topics?
14:46:54 <mburns> anyone have other stuff to discuss?
14:48:33 <mburns> going once...
14:49:08 <mburns> twice..
14:50:42 <mburns> gone.
14:50:46 <mburns> thanks all
14:50:47 <mburns> #endmeeting