14:03:04 <mburns> #startmeeting oVirt Weekly Meeting
14:03:04 <ovirtbot> Meeting started Wed Jun 26 14:03:04 2013 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:04 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:12 <mburns> #chair oschreib
14:03:12 <ovirtbot> Current chairs: mburns oschreib
14:03:17 <mburns> #topic agenda and roll call
14:03:24 <mburns> #info 3.2 Status Update
14:03:29 <mburns> #undo
14:03:29 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9a8d84c>
14:03:38 <mburns> #info 3.2 Update Stream
14:03:43 <mburns> #info 3.3 Status Update
14:03:43 * ofri here
14:03:47 * ecohen here
14:03:48 * lvernia here
14:03:53 <mburns> #info Infra report
14:03:59 <mburns> #info Conferences and Workshops
14:04:04 <mburns> #info Other Topics
14:04:14 * danken here
14:05:11 * mgoldboi here
14:05:24 <mburns> #chair mgoldboi
14:05:24 <ovirtbot> Current chairs: mburns mgoldboi oschreib
14:06:04 * dustins_ntap here
14:06:21 <mburns> #topic 3.2 Update Stream
14:06:51 <mburns> #info mburns didn't finish vdsm -17 push, will finish now
14:07:06 <danken> mburns: thanks
14:07:07 <mburns> #action mburns still needs to follow up on node build
14:07:45 <mburns> mgoldboi: we said last week there was some concern around 3.1->3.2 upgrade
14:07:51 <mburns> is that resolved?
14:07:58 <mburns> i think alourie was working on it
14:08:13 <mgoldboi> mburns: in progress - being worked out with the user by KB
14:09:23 <mburns> #info upgrade 3.1->3.2 documentation being worked out
14:09:25 <mburns> #info no code fix
14:09:39 <mburns> anything else come up for 3.2?
14:10:21 <mburns> danken: you requested python-ethtool for 3.2 repos
14:10:24 <mburns> is that needed?
14:10:36 <mburns> or can we live with what's in fedora for 3.2?
14:10:37 <danken> mburns: for 3.3
14:10:44 <danken> sure
14:10:48 <mburns> ok
14:10:59 <dneary> Hi
14:11:01 <danken> only 3.3 would need newer ethtool and libvirt
14:11:06 <mburns> danken: ok
14:11:17 <mburns> anything else for 3.2 updates?
14:12:36 * ykaplan here
14:14:10 <mburns> #topic 3.3 Status Update
14:14:21 <mburns> #link http://www.ovirt.org/OVirt_3.3_release-management
14:15:11 <mburns> can i get an overall status from each group?
14:15:27 <mburns> and whether each group is on track for Mid-July freeze?
14:16:03 <danken> (/me curses while the page loads. soooo slowly)
14:16:13 <mskrivanek> just to add to danken, 3.3 will need 2 new packages for virts' console features novnc and html5_spice. And a new websocket proxy rpm as part of our build
14:16:31 <mburns> danken: yep, that's a topic for the infra section
14:16:37 <mburns> mskrivanek: are those in core fedora?
14:17:10 <mburns> #info 3.2 quick async update -- vdsm -17 pushed to stable...
14:17:10 <mskrivanek> mburns: novnc is in F18(i believe), spice_html5 only in F20
14:17:48 <danken> mburns: just like you love it ;-)
14:18:28 <mburns> ok, can someone take ownership from an oVirt point of view of spice_html5?
14:18:43 <mburns> and produce builds for EL6, F18, F19?
14:19:07 <mburns> we can host those since they're not in fedora already
14:19:36 <mburns> danken: for the libvirt issue, i think i'd rather document that we need virt-preview rpms
14:19:48 <mburns> rather than host the libvirt rpms on ovirt.org
14:20:03 <mskrivanek> 3.3 virt: instance types will be in partially - new VM dialog. Should it remain red? Cloud-init not sure, the rest of features should make it by the end of month
14:20:06 <danken> mburns: doesn't createrepo has a feature of linking to an external repo?
14:20:24 <mburns> danken: not sure
14:20:45 <mburns> danken: maybe we can update the ovirt-release package to include virt-preview?
14:20:46 <danken> mskrivanek: I'm scrambling to get the vdsm side of cloud-init in.
14:21:09 <mburns> #info need owner for html5_spice package
14:21:10 <danken> ah, the yum.repo. good idea.
14:21:12 <mskrivanek> mburns: for spice_html5 ok. I nominate Vinzenz Feenstra for producing those.
14:21:15 <danken> mburns: ^^
14:21:38 <mburns> #info need to get F18, F19, EL6 builds for hosting on ovirt.org
14:22:07 <mburns> #info Vinzenz Feenstra nominated for ownership
14:22:58 <mburns> #info vdsm requires libvirt from virt-preview for 3.3
14:23:20 <mburns> #action mburns to update ovirt-release rpm to include virt-preview repo
14:23:20 <danken> mburns: isnt that an #action due to evilissimo?
14:23:53 <mburns> danken: yes, if i had known that evilissimo was Vinzenz...
14:24:02 <mskrivanek> sorry:)
14:24:24 <mburns> #action evilissimo to produce EL6 F18 F19 rpms for html5_spice and deliver to mburns for hosting on ovirt.org
14:24:50 <mburns> danken: what about libvirt in EL6 -- i'm guessing that doesn't have the feature set you need?
14:26:20 <danken> mburns: oh it does. it was backported
14:26:27 <mburns> danken: excellent
14:26:37 <mburns> so it was just f18 that is missing the feature set
14:26:49 <mburns> #info EL6 libvirt already has the feature enabled
14:27:14 <mburns> #info ovirt-node will enable virt-preview repo for fedora based builds going forward (patch submitted this morning)
14:27:57 <danken> (when base Fedora has everything we need we can revert that)
14:28:07 <mburns> #info virt features should be done by end of month
14:28:09 <mburns> danken: ack
14:28:24 <abaron> on the storage side:
14:28:39 <abaron> Read on disks - looks like it will make it
14:29:03 <abaron> Manage storage connections: risky, but should make it (everything except being able to edit iSCSI connection from GUI)
14:29:21 <abaron> Backup API: Doesn't look like it will make it
14:29:41 <abaron> Allow reelect SPM: looks like it will make it
14:30:07 <abaron> The features which are green are already in.
14:30:46 <mburns> #info storage features: one optional feature is unlikely, one Must is risky, but should make it, all others are looking good
14:31:26 <mburns> #info node features -- all green and merged
14:31:37 <ecohen> UX: Frontend Refactor + GWT(P) Upgrade are risky (currently set for end of July), other than that - green (branding is in)
14:31:37 <danken> on network, we've got the bult of multigateway code in
14:31:53 <danken> go ahead, ecohen
14:32:07 <mburns> updates from SLA, Integration, Infra?
14:32:15 <ecohen> danken, sorry - we are probably going according to the order in the wiki - I apologize.
14:32:20 <mburns> danken: i can read both and summarize
14:32:23 <mburns> so you can both go
14:32:37 <ecohen> I'm done :)
14:32:46 <mgoldboi> mburns: integration - updating hosted-engine to orange - on track for mid july
14:33:27 <sahina> on the gluster features,
14:33:38 <evilissimo> Note: For the guest agent we've prepared Ubuntu packaging
14:33:40 <mburns> #info UX: frontend refactor is risky, target for end of july
14:33:48 <evilissimo> but that still needs review
14:34:02 <abaron> mgoldboi: that would only be bootstrapping, no?
14:34:05 <mburns> #info integration: self-hosted engine is on track
14:34:27 <mgoldboi> abaron: that's right - according to the feature page
14:34:34 <abaron> mgoldboi: got it
14:34:52 <mburns> ecohen: end of july for Frontend?
14:34:57 <mburns> freeze is mid-july
14:35:09 <mburns> #info guest-agent is preparing Ubuntu packaging
14:35:14 <mskrivanek> evilissimo: still it should make it and let's declare it's on track...
14:35:19 <ecohen> mburns, I know - and we will try to aim that, but I cannot guarantee it.
14:35:31 <mburns> ecohen: ok, thanks
14:35:49 <ecohen> mburns, can you please put a similar #info item on the GWT(P) Upgrade?
14:35:53 <evilissimo> mskrivanek: well that's what I hope to say by that. The feature per se is complete
14:36:19 <mburns> #info UX -- GWT(P) upgrade also at risk (target end of July)
14:36:27 <ecohen> mburns, thanks.
14:36:41 <mburns> sahina: gluster?
14:36:46 <danken> mskrivanek: I might have missed it - have you mentioned ram snapshots?
14:36:46 <sahina> gluster hooks management in. REST Api for gluster hooks management needs to be done, targeting mid-jul
14:37:07 <sahina> gluster swift services management - vdsm patch yet to be merged
14:37:20 <sahina> rest api for this not yet in either.
14:37:24 <danken> mskrivanek: I worry about side effects with faulty nfs there.
14:38:08 <evilissimo> danken: won't you have bad sideeffects also with disks and a faulty NFS?
14:38:16 <mburns> #info gluster -- hooks mgmt in, rest api for hooks not done but on target, swift service mgmt posted, api for swift is not done
14:38:18 <mskrivanek> danken: ram snapshots are generally ready. I'm also worried about many flows in fact, but I think it's good enough as a start. for 3.3
14:39:04 <mburns> doron: any updates on SLA?
14:39:09 <ofri> on SLA:
14:39:10 <dneary> mburns, Let's whip everyone into shape to ensure that everyone is here next week for 3.3
14:39:16 <mburns> mgoldboi: infra?
14:39:29 <mburns> dneary: we have pretty good representation today
14:39:49 <ofri> oVirt scheduler [must] and Scheduling API [must] - it's going to be tight but it looks
14:39:50 <danken> mskrivanek: but we still need to merge the vdsm patch....
14:40:00 <mgoldboi> emesika: don't see yair here - any updates on infra features?
14:40:00 <dneary> mburns, Ah, sorry - had the impression that we couldn't do an "in/out" meeting
14:40:29 <mburns> dneary: this is a status update, not an in/out meeting
14:40:36 <dneary> mburns, OK
14:40:49 <dneary> Don't we need to do one of those? I thought that was today
14:40:49 <iranzo> ofri: is there any url for information on scheduler?
14:40:50 <mburns> so far everything looks like it's on track, except possibly some UX features
14:40:56 <dneary> Ah, great
14:41:15 <mburns> #info SLA -- scheduler is tight, but ok
14:41:23 <ofri> iranzo: like feature page?
14:41:31 * mgoldboi have to go - will catch up later on
14:41:34 <evilissimo> mburns: F18 EL6 and probably soon also F19 packages of spice-html5 already exist
14:41:41 <danken> sahina: would you remind me which gluster patch is blocking for 3.3?
14:41:42 <evilissimo> mskrivanek: ^^
14:41:43 <ybronhei> Hey all, I represent the infra team
14:42:12 <mburns> ybronhei: hi, any updates on status?
14:42:12 <evilissimo> https://admin.fedoraproject.org/updates/FEDORA-2013-3792/spice-html5-0.1.2-2.fc18?_csrf_token=b63ad0b0ce0bbfc5133e389bef6899aa015d7e38
14:42:17 <ofri> more from SLA:....
14:42:21 <ofri> Network Qos [must] - we are still waiting for the pm decision on this one.
14:42:25 <ofri> it was changed dramatically in the past week.
14:42:29 <ofri> Watchdog engine support [must] - on time
14:42:32 <evilissimo> https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-0644/spice-html5-0.1.2-2.el6?_csrf_token=b63ad0b0ce0bbfc5133e389bef6899aa015d7e38
14:42:45 <ybronhei> mburns: not something specific
14:43:11 <mburns> ybronhei: everything is on track for 17-July feature freeze?
14:43:13 <ybronhei> mburns: most of our 3.3 features are about to be done
14:43:15 <mskrivanek> evilissimo: great!
14:43:26 <ybronhei> mburns: it looks like it.
14:43:33 <mburns> #info SLA -- QoS is questionable for design, all others in
14:43:40 <mburns> #info infra status -- everything on track
14:43:47 <mburns> evilissimo: excellent
14:44:11 <mburns> evilissimo: are they going into Fedora directly?
14:44:15 <mburns> and EPEL?
14:44:38 <danken> network: multigw is in (with one known new bug), netreloaded is partial - but not a must anyway. neutron integration would be on time, but mkolesni can tell more.
14:44:38 <mburns> #info Summary: Everything looking on track
14:44:46 <mburns> #undo
14:44:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x9a8026c>
14:44:57 <evilissimo> mburns: I just checked on my fedora 18 and I can see them via yum
14:45:05 <mburns> evilissimo: excellent
14:45:08 * mskrivanek has to run, but hopes danken will accept the crappy RAM snapshot vdsm patch:-)
14:45:16 <mburns> #info html5_spice in Fedora already
14:45:30 <danken> mskrivanek: couldn't you get someone from storage to help you with nfs domains?
14:45:36 <mskrivanek> danken: the nfs issue was already there, that was our understanding from eduardo...but let's talk tomorrow about it perhaps
14:45:44 <mburns> danken: neutron?
14:45:50 <mburns> is that the new name for Quantum?
14:46:01 <danken> mburns: yep. trying to get used to it
14:46:07 * danken loves trademark wars
14:46:30 <danken> mskrivanek: now we're making worse with this 512 zeros padding
14:46:31 * evilissimo too see Metro :p
14:46:38 <mburns> danken: so networking -- everything is on track?
14:46:55 <danken> yes, thouh not all patches are in
14:47:08 <mburns> danken: right, i'm tracking high-level
14:47:20 <mburns> don't need it all committed, but on track for dev freeze
14:47:31 <mburns> #info network -- all on track for freeze
14:47:42 <mburns> #info Summary: almost everything is on track
14:47:46 <danken> hi ahadas_, I've just mentioned your 0-padding on nfs :-(
14:48:24 <mburns> #info At Risk: UX features -- Refactor and GWT(P) upgrade
14:49:27 <mburns> #info tight, but ok for now: SLA -- scheduler, Storage -- manage storage connections
14:49:36 <mburns> #info All others are on track
14:49:42 <mburns> ok, anything else around 3.3?
14:49:59 <mburns> or things mentioned that i didn't get into #info's?
14:50:48 <mburns> ok, moving on
14:50:56 <mburns> #topic Infra update
14:51:04 <mburns> ewoud: anything new here?
14:51:10 <mburns> #chair ewoud
14:51:10 <ovirtbot> Current chairs: ewoud mburns mgoldboi oschreib
14:51:15 <danken> mburns: not deeply related, but do you know if MLNX drivers are going to be part of ovirt-node?
14:51:24 <ewoud> mburns: work is still ongoing with the slaves @ rackspace
14:51:38 <mburns> eedri: you wanted to discuss F17/F18/F19 jenkins slaves, right?
14:51:39 <ewoud> mburns: we're going to update the f17 slave to f19
14:51:58 <mburns> danken: what's the driver name?
14:52:28 * danken does not recall :-( some folks asked me about it today
14:52:42 <ewoud> mburns: and quaid sent a mail that he thinks we need a project coordinator for the infra team because he's lacking time to do it
14:52:49 <ahadas_> danken: hi, yes I saw - you're right, but I thought we concluded that those kind of things should be handled separately as they appear in different places in the code as well
14:53:00 <ewoud> http://lists.ovirt.org/pipermail/infra/2013-June/003424.html
14:53:20 <eedri> question is should we keep supporting/releasing f17 rpms
14:53:42 <mburns> danken: ok, let me do some research after the meeting
14:53:54 <mburns> #info work ongoing with slaves @ rackspace
14:54:05 <mburns> #info will be updating f17 slave to f19
14:54:24 <mburns> #info quaid looking for someone to step as infra project coordinator
14:54:28 <ahadas_> danken: even though in the padding case it's a little different as I'm not using pickle
14:54:38 <mburns> eedri: imo, we can drop f17
14:54:40 <danken> ahadas_: the padding is completely new, thanks to abaron and kwolf not agreeing on a sane solution.
14:54:48 <mburns> we required 18 for 3.2, iirc
14:54:51 <eedri> mburns, ok.
14:55:01 <mburns> and we'll need to support f19 for 3.3
14:55:12 <ahadas_> danken: yeah..
14:56:11 <mburns> eedri: so i'd go ahead and drop f17 and move it to f19
14:56:25 <eedri> mburns, sounds good.
14:56:46 <eedri> mburns, we can already add another f17 later if needed
14:56:51 <eedri> s/already/always
14:56:53 <mburns> eedri: and, perhaps when we get the new rackspace stuff up, we can add additional f18 and 19 slaves
14:57:04 <eedri> mburns, thats the plan
14:57:04 <mburns> eedri: right
14:57:34 <mburns> #agreed drop f17 slave in favor of f19 slave, add new slaves for f18/f19 soon, can add f17 if needed later
14:57:44 <mburns> eedri: the only case for f17 i can think of is guest-agent
14:57:56 <mburns> which should be buildable in mock on f18
14:57:57 <ewoud> but I can image we can use mock for that
14:58:04 <mburns> exactly
14:58:10 <mburns> or just build in koji
14:58:21 <mburns> or somewhere outside jenkins, if needed
14:58:31 <mburns> ok, anything else for infra?
14:58:39 <ewoud> not at the moment I think
14:58:45 <mburns> ok, thanks
14:58:51 <mburns> #topic Conferences and Workshops
14:59:00 <mburns> dneary: do you know anything for this topic?
14:59:32 <dneary> mburns, I do
14:59:36 * mburns doesn't see theron
14:59:41 <mburns> dneary: excellent!
15:00:01 <dneary> mburns, Theron has started planning on the next oVirt workshop. I'm not sure if we're ready to announce a venue yet
15:00:20 <dneary> We've also started planning for an oVirt developer meeting in Edinburgh as part of the KVM Forum
15:00:54 <dneary> I would like to get as many oVirt developers there as possible to have a "planning the future" set of meetings for Node, Engine and VDSM, as well as KVM of course
15:00:56 <mburns> #info planning underway for next Workshop (no location announced yet)
15:01:25 <mburns> #info planning underway for oVirt developer meeting in Edinburgh as part of KVM Forum (late October)
15:01:43 <mburns> #info would like to get as many devs as possible there for planning the future
15:01:52 <dneary> Aside from that, Theron recently presented oVirt and Gluster integration at the Red Hat Summit, and participated in a workshop on that also
15:02:39 <mburns> #info Theron presented oVirt and Gluster integration at Red Hat Summit recently
15:02:47 <mburns> #info including a live demo in the oVirt booth
15:03:04 <mburns> #info mburns has a talk submitted for CloudOpen NA
15:04:34 <mburns> #info submission deadline for LinuxCon/CloudOpen EU (in Edinburgh) is 21-July
15:04:55 <mburns> #info CFP also open for KVM Forum
15:05:28 <mburns> #info no closing date listed, so get submissions in ASAP
15:05:45 <mburns> dneary: anything else?
15:06:29 <mburns> #topic Other Topics
15:06:35 <mburns> anything else from anyone else?
15:07:05 <mburns> going once...
15:08:48 <mburns> twice..
15:09:27 <mburns> gone.
15:09:29 <mburns> Thanks all
15:09:32 <mburns> #endmeeting