14:00:48 <mburns> #startmeeting oVirt Node Weekly Meeting
14:00:48 <ovirtbot> Meeting started Tue Jun 25 14:00:48 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:48 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:54 <mburns> #chair jboggs rbarry
14:00:54 <ovirtbot> Current chairs: jboggs mburns rbarry
14:01:00 <mburns> #topic Agenda
14:01:01 * jboggs here
14:01:04 * rbarry here
14:01:08 <mburns> #info 3.0 status review
14:01:24 <mburns> #info next steps
14:01:26 <mburns> #info other topics
14:01:38 <mburns> #topic 3.0 status review
14:01:48 <mburns> #info pre-beta images posted last night
14:02:03 <mburns> #info some issues already found
14:02:11 <sgocken> Real quick before I interupt on your meeting.  Just tried to install node 3.0 el6 and install failed at 80% with can't find file or directory
14:02:39 <mburns> jboggs: ^^
14:02:49 <mburns> #info some install issues on el6 (late breaking)
14:03:05 <mburns> #info services don't start correctly on el6
14:03:14 <mburns> #info security screen broken on el6
14:03:22 * fabiand is here
14:03:23 <mburns> #chair fabiand
14:03:23 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
14:03:23 <jboggs> ack looking into
14:04:30 <mburns> #info security page fix is posted and merged
14:05:22 <mburns> #info patch pending for service startup issues
14:05:26 <mburns> #info http://gerrit.ovirt.org/16080
14:06:39 <mburns> #info images are available for F18, F19, EL6
14:06:53 <fabiand> mburns, awesome!
14:07:18 <mburns> #info also posted test packages for ovirt-node-plugin-vdsm
14:08:47 <mburns> #info likely to be another build available either in the next day or so
14:09:18 <mburns> any other known issues with 3.0?
14:09:52 <mburns> jboggs: there are a couple of edit-node patches that need review/comments
14:09:57 <mburns> oh...
14:10:11 <jboggs> gonna finish those up this morning
14:10:21 <mburns> ovirt-node-recipe and possibly ovirt-node-tools need to adjust their dependencies
14:10:33 <mburns> they require livecd-tools that is newer than el6 provides
14:10:50 <mburns> either that, or we need to update epel livecd-tools
14:11:23 <mburns> #info couple edit-node patches pending -- jboggs to review this morning
14:11:50 <mburns> #info need to review dependencies for -recipe and -tools rpms for el6 compatibility
14:12:55 <mburns> jboggs: i'd like to see the upgrade lockfile patch get finished as well
14:13:20 <jboggs> ok will try to get that in by tomorrow
14:13:25 <mburns> thanks
14:13:39 <mburns> #topic next steps
14:13:51 <mburns> #info next steps are to get these issues ironed out and merged
14:14:06 <mburns> #info then get an official set of beta images posted
14:14:26 <fabiand> ack
14:14:48 <mburns> #info then test with the ovirt-node-vdsm-plugin packages for oVirt compatibility
14:15:46 <mburns> any other thoughts/comments on 3.0?
14:16:20 <fabiand> once I get my access to the wiki back
14:16:30 <fabiand> I#ll add a list of tests we should do to cover the networking changes
14:16:39 <mburns> excellent
14:16:47 <mburns> rbarry: can you do the same for the puppet changes?
14:16:52 <fabiand> They cover quite many use cases and I'd love to see some participation to run them..
14:16:57 <mburns> those are the big ticket things, i think
14:17:06 <fabiand> maybe we can even have a node test day!?
14:17:19 <mburns> sure, but lets get a beta build done first
14:17:19 <rbarry> mburns: Definitely
14:17:31 <fabiand> mburns, sure
14:17:46 <mburns> #topic Other Topics
14:18:08 <fabiand> we are getting in a good shape, when union mounts land and we are using a new build tool will be even more shiny :)
14:18:08 <mburns> #info was pinged earlier about including some newer versions of packages in ovirt.org repos
14:18:25 <mburns> #info specifically things like libvirt
14:18:25 <fabiand> mburns, e.g. for el6?
14:18:35 <mburns> actually, this was f18 centric
14:18:45 <fabiand> okay, what was the reason for requestoing this?
14:19:21 <mburns> some features in f19 libvirt are needed for 3.3 features
14:20:06 <mburns> #info we can handle this in ovirt-node by simply adding the virt-preview repo
14:20:15 <fabiand> mh ack ..
14:20:21 <mburns> #link http://fedoraproject.org/wiki/Virtualization_Preview_Repository
14:20:28 <fabiand> but I'd rather like to use only oficial packages in the final release
14:21:06 <mburns> fabiand: i agree, but the impact is that a base image that includes the vdsm plugin will update libvirt
14:21:24 <mburns> and i'm not sure that's something i'm comfortable with...
14:21:31 <fabiand> I see ..
14:21:39 <mburns> vdsm wants these packages for GA on both F18 and F19
14:22:18 <fabiand> mburns, why don't you want vdsm to pull in the change and let us stay with the fedora version?
14:22:19 <mburns> the proposal would be to include virt-preview packages on the node permanently
14:22:38 <mburns> fabiand: i don't like plugins changing core packages...
14:22:49 <fabiand> yeah, that's what I thought ..
14:22:53 <mburns> and i consider libvirt core
14:23:01 <fabiand> yes
14:23:07 <fabiand> but on the other side ..
14:23:31 <mburns> the other issue is EL6, which doesn't have the virt-preview repo
14:23:31 <fabiand> once openstack becomes a consumer we won't be able to statisfy both needs .. if they conflict
14:24:20 <mburns> fabiand: yes, though i'd say we can force all images to use virt-preview rpms
14:24:27 <fabiand> hehe
14:24:31 <fabiand> I see, master
14:24:40 <fabiand> :)
14:24:46 <mburns> in the old days (3-4 years ago), we had virt-preview enabled by default
14:25:13 <fabiand> "früher war's immer besser" (it was always better in the past) :)
14:25:26 <mburns> there is a decent chance that openstack would *like* virt-preview as well
14:25:35 <fabiand> but honestly, I'm .. a bit skeptic, but I wouldn't object
14:25:53 <mburns> and fwiw, the virt-preview rpms are the f19 rpms, iiuc
14:26:13 <mburns> just rebuilt for f18
14:26:26 <mburns> i'll check with some openstack folks to see what they think
14:26:48 <mburns> if they are indifferent or would prefer that we use virt-preview, then i'd vote to go with virt-preview
14:27:06 <fabiand> ack
14:27:08 <fabiand> sounds good
14:28:04 <mburns> jboggs: did we add the mechanism to edit-node to run the regular minimizer scripts?
14:28:28 <jboggs> not sure honestly, would have to look
14:28:50 <mburns> ok, that's another consideration
14:28:52 <jboggs> it runs the plugin's own minimizer
14:29:09 <mburns> a libvirt change brings in a *lot* of dependencies, iiuc
14:29:19 <mburns> which we end up minimizing out
14:29:37 <mburns> so it might even push us over the 256MB limit...
14:30:34 <mburns> #action mburns to check with openstack folks on virt-preview repo
14:30:50 <mburns> #info decision on whether to enable by default to come base on that discussion
14:31:33 <mburns> fabiand: and yes, union mounts and livemedia-creator/oz will be very nice when they're ready
14:31:37 <mburns> any other topics?
14:31:45 <fabiand> nope
14:32:40 <mburns> ok, then we can close this meeting i think
14:32:42 <mburns> thanks all
14:32:43 <mburns> #endmeeting