14:02:17 <mburns> #startmeeting oVirt Node Weekly Meeting
14:02:17 <ovirtbot> Meeting started Tue Jun 18 14:02:17 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:17 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:22 <mburns> #topic agenda
14:02:29 <mburns> #info patch review
14:02:36 <mburns> #info 3.0 status and planning
14:02:38 <mburns> #info other topics
14:02:46 <mburns> #chair fabiand rbarry
14:02:46 <ovirtbot> Current chairs: fabiand mburns rbarry
14:03:50 <Yamaksi> mburns: did we talk about the pxe ISO some time ago ?
14:04:18 <mburns> Yamaksi: i don't know
14:04:20 * fabiand is around ..
14:04:53 <Yamaksi> mburns: I did with someone and the docs were going to be updated how to make a CentOS or RHEL ISO... there is only a FC now
14:05:12 <mburns> Yamaksi: for ovirt-node?
14:05:22 <eedri> ewoud, can you reset my sudo pass on the f17 slave?
14:06:02 <mburns> #topic patch review
14:06:02 * rbarry is here
14:06:46 <mburns> #info patch queue has grown since last week
14:07:28 <mburns> #info many are related to bridgeless networking or bond configuration
14:07:44 <mburns> #info bridgeless and bonding should be merged in the next day or two
14:07:48 <Yamaksi> mburns: fixes or not putted int ?
14:07:50 <Yamaksi> *in
14:07:59 <fabiand> mburns, update on bridgeless and bonding ... it works, but there are known rough edges ..
14:08:11 <mburns> fabiand: ack
14:08:29 <fabiand> e.g. the validation in th eui is not completely sane (e.g. a missing bond name is only detected when the user saves, not before)
14:08:40 <fabiand> unit tests are available for bonds and bridgeless stuff
14:08:46 <mburns> Yamaksi: mostly enhancements, some fixes
14:08:54 <Yamaksi> mburns: good work!
14:09:10 <fabiand> I tested a couple of common scenarios (direct-nic configuratio w/dhcp, bond with two nics and dhcp, bond as slave of bridge w dhcp)
14:09:12 <fabiand> the ywork
14:09:12 <mburns> #info some validations are missing in the networking and bonding, but mostly functional
14:09:28 <mburns> fabiand: excellent
14:09:36 <fabiand> the mode configuration of bonding can be made nicer in the ui ... e.g. we can offer a seleciton of modes
14:09:51 <fabiand> and stuff like that, but the backend should be fine ..
14:09:55 <mburns> fabiand: excellent
14:10:02 <mburns> ui enhancements are easy in the future
14:10:10 <mburns> backend working is the important thing
14:10:13 <fabiand> yep
14:10:16 <fabiand> that was also my focus
14:10:40 <mburns> #info backend appears solid, frontend has some rough edges, but works
14:11:17 <mburns> #info independent push caused patches to not rebase cleanly
14:11:29 <mburns> #action mburns and fabiand to clean this up and get things merged
14:13:04 <mburns> #action all need to work on patch reviews this week
14:13:33 <fabiand> well
14:13:42 <fabiand> the patch queue should go down if we merge the topology and bond patches
14:13:51 <fabiand> and we should merge them in one go ..
14:13:54 <mburns> fabiand: yes, that will cut it about in half
14:14:01 <mburns> fabiand: yes
14:14:42 <mburns> fabiand: but we still need to get other things reviewed and merged
14:14:47 <fabiand> ack
14:14:53 <fabiand> ack ack ack
14:14:54 <fabiand> :)
14:15:17 <mburns> but lets get topology and bonding merged today
14:15:29 <mburns> then we won't have to fight the massive rebasing anymore
14:15:58 <fabiand> yep
14:16:14 <fabiand> maybe we can also write some functional tests for the bonding stuff
14:16:20 <fabiand> they are good candidates for igor ..
14:16:32 <fabiand> bonding+bridgeless
14:16:37 <mburns> fabiand: yes, but those can go in after we get beta images built
14:16:41 <fabiand> ack .
14:18:50 <mburns> #topic 3.0 status and planning
14:19:07 <mburns> #info actions to review patches and get them merged this week (by Thursday)
14:19:18 <mburns> #info build and post a beta image on Friday
14:19:45 <fabiand> mburns, do you know if there is an vdsm update?
14:19:48 <mburns> target RC next week, GA the following week
14:19:55 <mburns> fabiand: for 3.0 or 2.6?
14:20:13 <fabiand> mburns, I don't know, you just mentioned that we might need a new image due to a vdsm update ..
14:20:28 <fabiand> But this only makes sense for 2.6 if I think about it ..
14:21:12 <mburns> fabiand: yes, there is a pending vdsm update (in updates-testing)
14:21:23 <mburns> we should build a 2.6.1 at some point
14:21:27 <fabiand> ack
14:23:52 <mburns> actually 2.6.2
14:23:59 <mburns> or whatever the next version is
14:24:30 <mburns> any objections to those dates for 3.0 builds?
14:27:07 <mburns> ok, then lets work from that schedule
14:27:13 <mburns> #topic 2.6.x updates
14:27:26 <mburns> #info new vdsm is pending, need to include it in a new 2.6.x build
14:27:39 <mburns> #action fabiand to build and post the new image
14:27:49 <mburns> #topic other topics
14:27:54 <mburns> rbarry: fabiand anything else?
14:28:07 <fabiand> no
14:28:17 <rbarry> Nothing
14:28:59 <mburns> ok, then...
14:29:03 <mburns> #endmeeting