14:01:07 <mburns> #startmeeting oVirt Node Weekly Meeting
14:01:07 <ovirtbot> Meeting started Tue Jun  4 14:01:07 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:07 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:14 <mburns> #chair jboggs rbarry fabiand
14:01:14 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
14:01:17 * fabiand is here
14:01:20 <mburns> #topic agenda
14:01:27 * rbarry is here
14:01:32 <mburns> #info patch review
14:01:35 <mburns> #info feature status
14:02:10 <mburns> BlairQ: try disabling ovirt-beta and enabling just ovirt-stable
14:03:18 <mburns> #topic outstanding patches
14:04:17 <mburns> #info 25 patches outstanding, some with acks that just need dependencies merged or rebasing
14:04:58 * fabiand posted a set of patches to do some package cleanups
14:05:00 <mburns> #info many patches around cleaning up old code
14:05:06 <fabiand> thanks to mburns and jboggs we could remove some unused files
14:05:22 <mburns> #info some draft and RFC patches that need updates
14:06:05 <mburns> #info 6 patches have code review nacks that need action
14:06:48 <mburns> #action ALL -- review patches, update patches that need updates, nag people for reviews if your patches aren't being reviewed
14:07:01 * jboggs here
14:07:15 * mburns makes a note to start doing nag emails...
14:07:46 <mburns> anyone have other comments on patch status?
14:08:52 <fabiand> nope
14:08:53 <fabiand> well
14:09:06 <fabiand> I plan to push some patches wrt to the brodgeless mode during the next two days ..
14:09:14 <fabiand> I suppose we'll need to do some testing on them ..
14:09:16 <mburns> fabiand: yep, that's next topic
14:09:37 <mburns> #topic Feature review
14:09:52 <mburns> #info bridgeless network -- patches to be posted in next couple days
14:11:09 <mburns> fabiand: agreed, we need a *lot* of testing with this feature
14:11:19 <mburns> as in full end-to-end testing
14:11:24 <fabiand> yes
14:11:38 <fabiand> maybe we can take the opportunity to write some tests like you did with the vdsm plugin ..
14:12:46 <mburns> fabiand: yes
14:13:04 <mburns> rbarry: any updates on the password widget?
14:13:19 <fabiand> I'll open a feature page for the bridgeless stuff and prepare a table,
14:13:44 <rbarry> mburns: Patches posted today
14:13:56 <mburns> fabiand: excellent!
14:14:08 <mburns> #action fabiand to create bridgeless network feature page and test matrix
14:14:53 <mburns> fabiand: you should link it to the oVirt 3.3 release page, node 3.0 release page, and engine feature page that it's related to
14:15:04 <fabiand> yep
14:15:13 <mburns> rbarry: awesome
14:15:22 <fabiand> #info fabiand to link it to the oVirt 3.3 release page, node 3.0 release page, and engine feature page that it's related to
14:15:36 <mburns> #info patches for password/confirmation widget are coming today
14:17:17 <mburns> #info tuned stuff is close, updated patches should be available in next couple days
14:17:30 <fabiand> nice
14:17:33 <mburns> #info log sync should also be updated in that timeframe
14:17:46 <mburns> #undo
14:17:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0xa3bc7ec>
14:18:07 <mburns> #info log directory sync from iso to filesystem  should also be updated in that timeframe
14:18:31 <Yamaksi_> jvandewege: ok, need to check that...
14:18:40 <mburns> #info EL6 is close to working
14:18:56 <Yamaksi_> jvandewege: have you ever switched nics on IP base ? I did it (and before) changed mac-address but no network anymore... weird ?
14:19:03 <mburns> #info EL6 needs a couple outstanding patches merged (dracut, urwid workarounds)
14:19:22 <mburns> fabiand: how is F19?
14:19:38 <fabiand> mburns, fine the last time I looked!
14:19:49 <fabiand> mburns, I had a couple of patches ... one bigger issue with selinux
14:19:52 <fabiand> but now it looks okay ..
14:19:58 <mburns> fabiand: excellent
14:19:59 <fabiand> but we need to fix collectd ..
14:20:02 <fabiand> also on F18 ..
14:20:08 <mburns> fabiand: yes
14:20:12 <fabiand> it really messes up the logs
14:20:15 <mburns> fabiand: is there a bug?
14:20:20 <fabiand> yep
14:20:43 <fabiand> .bug 908270
14:20:43 <ovirtbot> fabiand: Error: "bug" is not a valid command.
14:20:45 <jvandewege> Yamaksi_: switching nics also changes mac and that means no network when using linux. /etc/udev/xx-network-abc controls that
14:21:24 <fabiand> mburns, and - I didn't test it but biosdevname is also a topic ..
14:21:50 <fabiand> I didn't have time to look at the ... i guess problem ... in it's completeness, but our udev rules wouldn't have any affect anymore
14:22:27 <mburns> oh, wonderful
14:22:52 <mburns> fabiand: maybe take that into consideration with your bridgeless network effort?
14:22:56 <Yamaksi_> jvandewege: mhh, ubuntu is better on it
14:23:04 <fabiand> mburns, yes ...
14:23:17 <Yamaksi_> jvandewege: I changed the mac's also
14:23:26 <Yamaksi_> jvandewege: and removed that file and rebooted
14:23:36 <fabiand> mburns, it's mainly investigation for now, and el6 dependent ... iiuic the nic names will be predicatble in f19+ ... without any need for a configuration file ..
14:23:57 <fabiand> Just wanted to give heads up
14:24:07 <mburns> fabiand: ok
14:24:18 <mburns> we'll have to watch it in f19 and el6
14:24:26 <fabiand> yep
14:24:41 * mburns commented on the collectd bug
14:24:55 <mburns> ok, any other features that we need to discuss?
14:25:05 <mburns> oh, puppet
14:25:34 * fabiand reviewd rbarry s patch. it looks quite good now, found just a couple of small .. glitches
14:25:42 <fabiand> But I haven't tested it yet
14:25:55 <mburns> ok
14:26:13 <Yamaksi_> jvandewege: okay, something weird in that file, two times eth0
14:26:51 <mburns> #info puppet patch is close, some comments and small tweaks needed
14:27:05 <rbarry> The patch is much trimmer, specfiles/makefiles merged. fabiand's comments should be addressed today or tomorrow at the latest, depending on how long finishing the password entry stuff takes me
14:28:47 <mburns> ok, anything else that i'm forgetting?
14:29:29 <fabiand> not from me
14:30:07 <fabiand> ah well
14:30:07 <fabiand> jenkins problems?
14:30:35 <mburns> fabiand: tbh, i'm just about ready to say forget jenkins.ovirt.org
14:30:45 <fabiand> mburns, why?
14:30:55 <fabiand> and - what alternative to use?
14:31:29 <mburns> fabiand: we don't have an alternative, but it's just painful that we can only get about 5 runs before the slave breaks...
14:31:47 <fabiand> is there a way that we can use the jenkins virt plugin
14:31:49 <mburns> and it's not always our fault...
14:31:51 <fabiand> or jeknkins libvirt ..
14:31:55 <fabiand> mburns, yes ...
14:32:11 <mburns> not familiar with the jenkins virt plugin
14:32:13 <fabiand> with the jenkins libvirt (or virt?) plugin we could launch a vm on each build ..
14:32:20 <fabiand> the same vm ..
14:32:28 <fabiand> at least we don't need to reboot the host ..
14:32:46 <mburns> fabiand: problem is that we're running on a vm already
14:32:59 <fabiand> argh ...
14:33:07 * fabiand is not happy about the situation
14:33:16 <fabiand> and I'd like to keep the continous builds ..
14:33:27 <mburns> fabiand: only alternative i see is to run it on the internal systems and publish to ovirt.org somehow
14:33:30 <mburns> but that's not ideal
14:33:34 <fabiand> no
14:33:37 <fabiand> what about nesting?
14:33:58 <fabiand> didn't someone from infra, was it ewoud?, look at if we could use nesting?
14:34:14 <mburns> fabiand: oh, wait...
14:34:24 * fabiand freezes ..
14:34:29 <mburns> fabiand: maybe, if the virt plugin supports it
14:34:35 <mburns> we could have it launch our own vm
14:34:42 <mburns> dedicated to our use for building
14:34:46 <mburns> that could work
14:34:55 <mburns> but it needs to be able to work with ovirt
14:35:04 <fabiand> mburns, sounds good!
14:35:05 <mburns> and i'm guessing that's not something it can do
14:35:09 <fabiand> mh ..
14:35:21 <fabiand> cant we use ovirt's api to trigger a vm boot from the job ..
14:35:49 <fabiand> mh
14:35:53 <mburns> fabiand: it gets ugly, doing that
14:35:58 <fabiand> yep
14:36:08 <mburns> then we have to do all that setup, ssh to the vm once it's up
14:36:10 <fabiand> but it is already ugly at a different node in the graph
14:36:11 <mburns> then run everything
14:36:49 <fabiand> mburns, I imagine that we prepare one vm builder and jenkins slave, which is down, then brought up to do the build, then brought down again ..
14:36:50 <ewoud> fabiand: for nested virt: the rackspace servers are installed with fedora, I think kiril, eedri or dcaro was planning on installing ovirt on them
14:37:11 <fabiand> ewoud, awesome! that means nesting can work ... iiuic
14:38:36 <mburns> fabiand: we also have a pending switch to live-media/oz
14:38:48 <mburns> that might help this longterm as well...
14:39:14 <mburns> in the meantime, i think we just have to continue with the occasional reboot of the jenkins host
14:39:36 <mburns> although maybe we can try to trace what's doing the other stuff that's leaving loop devices around
14:40:06 <fabiand> I once requested a temporary access to the builders to trace it down -..
14:40:16 <fabiand> but folks were sceptical about this ..
14:40:44 <fabiand> I can understand that, I'd still offer to try to track it down  .. if noone else volunteers ..
14:40:57 <mburns> fabiand: i'll ack access for you
14:42:02 <fabiand> mburns, I'd request the access on the infra ml again ..
14:42:08 <mburns> fabiand: ok
14:42:18 <mburns> do so, and i'll ack and argue if needed
14:42:23 <mburns> ok, anything else?
14:43:46 <mburns> ok, let's close the meeting then, and try to get these patches reviewed/acked/merged
14:43:49 <mburns> #endmeeting