14:00:21 <mburns> #startmeeting oVirt Weekly Meeting
14:00:21 <ovirtbot> Meeting started Wed May 29 14:00:21 2013 UTC. The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:21 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:24 <sbonazzo> mburns: working on self hosted engine feature
14:00:31 <mburns> #topic agenda and roll call
14:00:34 <mburns> sbonazzo: ok
14:00:34 <sbonazzo> mburns: I don't have engine yet
14:00:58 * ofri_ here
14:01:10 <mburns> #info 3.2.x update
14:01:14 * lvernia here
14:01:21 * dustins_ntap is here
14:01:29 <mburns> #info 3.3 status
14:01:34 * jb_netapp here
14:01:50 <mburns> #info other topics
14:02:11 * danken here
14:02:14 * mburns notes that he *will* be somewhat distracted today...
14:03:24 <mburns> #topic 3.2 updates
14:03:44 * yzaslavs here
14:03:57 <mburns> #info all pending builds are updated on ovirt.org/releases
14:04:49 <mburns> #info expected updates coming shortly: sdk/cli and vdsm
14:05:49 * mgoldboi here
14:05:53 <mburns> mgoldboi: hi
14:05:58 <mgoldboi> mburns: hello
14:06:12 <mburns> mgoldboi: any news on sdk and cli updates?
14:06:30 <mgoldboi> mburns: i thought it was closed last week
14:06:50 <mburns> mgoldboi: sdk/cli weren't included in the update because i didn't have the packages
14:07:02 <mburns> they were posted somewhere internally that i didn't have access to
14:09:02 <mburns> mgoldboi: if you can get them to me, i'll get them uploaded
14:10:18 <mburns> #info no other updates planned at this time
14:10:43 <mburns> #topic oVirt 3.3 status update
14:10:55 <danken> (besides the pending vdsm async build with http://gerrit.ovirt.org/#/q/status:open+project:vdsm+branch:ovirt-3.2,n,z )
14:11:11 <danken> fsimonce is going to build it soon, I'm told.
14:11:15 <mburns> danken: right, that's captured above
14:11:21 <mburns> #link http://www.ovirt.org/OVirt_3.3_release-management
14:11:45 * oschreib here
14:12:53 <mburns> looking at the feature table, we cannot possibly go into code freeze this week
14:13:48 <mgoldboi> mburns: i would say postpone schedule at at least 2-3 weeks
14:14:08 <mburns> #idea delay schedule 2-3 weeks
14:14:15 <doron> mgoldboi: I say month from what I see.
14:14:54 <mgoldboi> doron: we'll need to see if we can push it and re-estimate in 2 weeks from now based on the progress
14:15:21 <mburns> let's delay and re-visit in next couple weeks
14:15:25 <doron> mgoldboi: agree, but having a few people missing in the coming weeks I can say
14:15:30 <doron> much is missing.
14:15:58 <mgoldboi> doron: all of the features are must
14:16:26 <mgoldboi> anything we can focus on and maybe drop one or two in order to make schedule ?
14:16:50 <mburns> yes, i think we need to prioritize the features
14:17:08 <doron> agreed.
14:17:20 <mburns> doron: mgoldboi: who can prioritize?
14:17:46 <mgoldboi> doron: it's your realm - should be done by you
14:17:49 <doron> mburns: I'd say we need a representative for each area
14:18:34 <mburns> ok
14:18:39 <danken> is there anyone from storage?
14:19:20 <doron> mburns: I suggest we discuss the prio's next week and then make an educated decision.
14:19:30 <mburns> agreed
14:19:31 <danken> they have a Must feature http://www.ovirt.org/Features/Edit_Connection_Properties
14:19:31 <danken> slated to be ready on 2013-06-30
14:20:00 <doron> we need to make sure we have a rep' from each area for next week's mtg.
14:20:09 <mburns> #agreed maintainers/reps from each area will prioritize and we'll reschedule at next week's meeting
14:20:21 <mgoldboi> mburns: action on me
14:20:40 <danken> just a sec - I missed the agreement: we postponing the beta date without setting a new one?
14:20:41 <mburns> #action mgoldboi to ensure rep from each area will be present next week
14:21:51 <mburns> not much else we can discuss on 3.3 until we have the right people
14:21:53 <danken> mgoldboi, mburns: we have network, sla, infra, node - only storage is missing. why should we wait for another week?
14:22:26 <mburns> danken: we really need to get the details filled out on the chart
14:22:39 <mburns> and get features prioritized correctly
14:23:10 <mgoldboi> mburns: but if only storage is missing we can start to do the work this week
14:23:19 <mburns> sure
14:23:21 <danken> mgoldboi: exactly.
14:23:36 <mburns> i saw it more as an offline thing, but we can do it on here
14:23:58 <mburns> #chair mgoldboi
14:23:58 <ovirtbot> Current chairs: mburns mgoldboi
14:24:16 <mgoldboi> mburns: danken: table should include must and should though, so it should be straight forward
14:24:23 <danken> mburns: I prefer to decide on a new beta date. if storage is unhappy, let then apply for postponing it.
14:24:46 <danken> mburns: mgoldboi: the table has Must/Should/Optional
14:25:14 <mburns> danken: hard to decide a beta date if we don't have info on must/should/optional on a lot of features
14:25:18 <danken> features are way too red. so clearly we need to postpone the beta date.
14:25:20 <mburns> danken: and no target dates
14:25:25 <mburns> danken: yes
14:25:59 <danken> Few features request June 16
14:26:13 <danken> one Must feature of storage request June 30
14:26:37 <mgoldboi> mburns: danken: so june 26?
14:26:38 <mburns> sla features are requesting 1-july for some features
14:26:45 <mburns> and they're listed as must
14:27:01 <danken> doron is here to state if this is indeed the case
14:27:26 <doron> danken: indeed this is the case. we need enough time to complete the new oCirt scheduler.
14:27:42 * mburns notes that one UX feature requests 31-June which doesn't actually exist
14:27:45 <doron> (oVirt)
14:28:03 <danken> doron: and are you comfortable with July 1?
14:28:19 <mabsKenpachi> hi evryone
14:28:27 <danken> mburns: that a polite way to say that the ux feature would never finish ;-)
14:28:29 <doron> danken: hopefully yes.
14:28:40 <mburns> so latest date filled out is 1-july
14:28:47 <mburns> so it sounds like a 1 month slip
14:28:51 <mabsKenpachi> i face some problems with a new installation of ovirt on a Fedora 18
14:29:05 <mabsKenpachi> after a reboot of the systems
14:29:13 <mabsKenpachi> ovirt is on
14:29:15 <mabsKenpachi> start
14:29:28 <mabsKenpachi> but i got nothing on my browser
14:29:40 <danken> mburns: I would like to set this date in stone.
14:29:42 <mabsKenpachi> seems like it not responding
14:29:58 <doron> mabsKenpachi: as topic suggests we're in a meeting now. can you retry later please?
14:29:58 <danken> if someone is uncomfortable about it, they should at least show up.
14:30:06 <mburns> danken: doron: mgoldboi: let's set dates to current plan +1 month
14:30:14 <doron> agreed.
14:30:25 <mburns> so ga Aug 1
14:30:25 <mburns> freeze on july 1
14:30:30 <mgoldboi> danken: mburns: i would say 2-3 weeks and re-evaluate
14:30:42 <danken> mgoldboi: evaluate what?
14:30:56 <mburns> mgoldboi: next statement was going to be that we have a checkpoint in 2 weeks to make sure we're still on track
14:31:01 <mabsKenpachi> does anyone have see like a problems
14:31:01 <mgoldboi> danken: status, what can we pass on and what is in
14:31:16 <mabsKenpachi> ok
14:31:18 <mabsKenpachi> sorry
14:31:20 <mburns> mgoldboi: i'd rather slip once than slip multiple times
14:31:23 <danken> mgoldboi: sure.
14:31:43 <doron> mburns: +1
14:31:48 <oschreib> +1
14:31:59 <mgoldboi> danken: i'm afraid that putting a one month delay can put people into sleep
14:32:03 <danken> mburns: but another month's slip won't be so nice!
14:32:26 <mgoldboi> mburns: but i guess time will tell...
14:32:48 <doron> mgoldboi: we can set re-prio 3 weeks from now
14:33:02 <doron> so everything not ready for now+1m will be removed.
14:33:19 <mburns> doron: i'd say in 2 weeks
14:33:25 <mburns> that's about the halfway point
14:33:38 <doron> no objections.
14:33:39 <mburns> and doesn't give people the chance to fall asleep as much
14:34:00 <mgoldboi> mburns: ok, sounds reasonable
14:34:08 <mburns> #info delay release and all other dates 1 month
14:34:41 <mburns> #info checkpoint on features still at risk in 2 weeks (12-May)
14:35:01 <mburns> #action mburns to send schedule update announcement
14:35:47 <mburns> #idea all features listed on the chart that do *not* have ETA or must/should/optional are dropped
14:35:51 <mburns> thoughts on that ^^
14:36:15 <mgoldboi> mburns: time to be tough...
14:36:40 <mgoldboi> mburns: +1
14:37:16 <mburns> i think it is
14:37:19 <oschreib> ++1
14:37:43 <mburns> #agreed features missing priority or ETA are dropped on 12-May
14:37:56 <mburns> ok, anything else on 3.3?
14:38:01 <mgoldboi> mburns: we need to put a date on it though
14:38:12 <mburns> date on...?
14:38:26 <mgoldboi> mburns: my bad
14:38:47 <mburns> oh, date on when we drop features missing information
14:38:56 <mburns> yes, at the re-sync in 2 weeks
14:39:35 <mburns> ok, moving on
14:39:40 <mburns> #topic Conferences and workshops
14:39:54 <mburns> dneary: anything new this week?
14:40:38 <mburns> #info there will be a booth at Red Hat Summit (June 11-14)
14:41:01 <dneary> Sorry - giving a webinar
14:41:11 <doron> mburns: we have guys in LinuxCon Japan now
14:41:21 <mburns> #info presentations going on at LC Japan as well
14:41:35 <doron> IIRC we have heron there, and Lsazlo giving a session on oVirt intro+SLA
14:41:38 <dneary> how's feature freeze looking?
14:41:48 <dneary> Theron is in Japan this week
14:42:24 <dneary> For Summit plans: is there a list of everyone from oVirt who is at the Summit?
14:42:34 <dneary> That would be helpful to us
14:42:41 <mburns> dneary: we have features that are 1 month away from freezing, so we're delaying 1 month with a checkpoint in 2 weeks
14:43:15 <dneary> Also, perhaps we could have next week be a "feature triage" meeting, where we bump anything red to 3.4 unless we get better visibility on when it'll be release-ready
14:43:29 <mburns> dneary: that's the plan for 2 weeks from now
14:43:35 <dneary> Sounds good
14:43:46 <mburns> dneary: i'll work on a list of people who are attending summit
14:43:59 <dneary> mburns, Thanks
14:44:28 <mburns> #topic infra report
14:44:33 <mburns> ewoud: anything to update this week
14:45:14 <ewoud> mburns: actually yes
14:45:25 <mburns> #chair ewoud
14:45:25 <ovirtbot> Current chairs: ewoud mburns mgoldboi
14:45:40 <ewoud> #info with the help of rackspace dcaro managed to install the rackspace server
14:46:10 <ewoud> #info installing ovirt on it so we get more jenkins slaves helping us run more tests
14:46:35 <ewoud> #info our foreman/puppet environment is starting to take shape
14:47:07 <ewoud> #info work in progress on installing monitoring software (icinga) so we can spot out of disk space ahead of time
14:47:41 <ewoud> mburns: that should be the important highlights
14:47:53 <mburns> ewoud: ok, thanks!
14:48:11 <mburns> #topic other topics
14:48:15 <mburns> anyone have anything else?
14:48:56 <dneary> Can I just say: it's awesome to have the feature matrix
14:49:38 <mburns> +1
14:49:42 <dneary> It really makes it clear how realistic/unrealistic the release dates are
14:49:55 <dneary> Next challenge is keeping it updated
14:50:01 <mburns> yep
14:50:19 <mburns> ok starting the countdown...
14:50:21 <dneary> And getting a decision meeting on which of those red "Musts" we can bump
14:50:23 <mburns> going once...
14:51:04 <mburns> twice..
14:51:32 <mburns> gone.
14:51:35 <mburns> thanks everyone
14:51:38 <mburns> #endmeeting