18:03:55 <ewoud> #startmeeting installing foreman.ovirt.org
18:03:55 <ovirtbot> Meeting started Mon May  6 18:03:55 2013 UTC.  The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
18:03:55 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
18:03:58 <ewoud> #chair knesenko
18:03:58 <ovirtbot> Current chairs: ewoud knesenko
18:04:16 <ewoud> ok, the goal is to install foreman.ovirt.org
18:04:33 <knesenko> ok
18:04:43 <ewoud> it will run on alterway02.ovirt.org as a centos 6 VM
18:04:52 <knesenko> ewoud: I heard from eedri that u have already installed it . we need just to configure it ?
18:05:12 <ewoud> knesenko: no, last time I wanted to install the VM there were no IPs to install with
18:05:19 <knesenko> ewoud: ok
18:05:28 <knesenko> can you ssh to this machine ?
18:05:29 <ewoud> eedri already installed the all-in-one ovirt install on the host though
18:06:03 <ewoud> knesenko: yes
18:06:59 <knesenko> ewoud: so lets do it via 'screen' ?
18:07:24 <knesenko> ewoud: can u create an account for me there ? or send me the root credentials in procate message
18:07:31 <ewoud> knesenko: not sure I can share the base centos install, but I think that's nothing new for you
18:07:49 <ewoud> I do notice there is a base centos_64_base VM, but I don't know who created that
18:08:26 <ewoud> now I only have to figure out how to get a spice console
18:09:38 <knesenko> ewoud: alterway02.ovirt.org - is a VM or physical host ?
18:10:08 <ewoud> knesenko: physical
18:10:47 <knesenko> ewoud: ok
18:12:22 <knesenko> ewoud: u told me that u have an ssh access to this machine ///
18:12:34 <knesenko> ewoud: so why do we need spice there ?
18:12:44 <ewoud> knesenko: for the VM
18:13:24 <knesenko> ewoud: .... I am confused a little bit .
18:14:00 <knesenko> alterway02.ovirt.org - is a physical server that runs what on it ?
18:14:06 <knesenko> ovirt-engine ?
18:14:08 <ewoud> knesenko: alterway02 is the physical host running ovirt all-in-one
18:14:13 <knesenko> ah ok
18:14:27 <knesenko> so you can open webadmin there ...
18:14:35 <knesenko> and create a vm from there ...
18:14:37 <ewoud> knesenko: on that machine we now want a VM running CentOS 6.4 where we can then install foreman
18:14:42 <ewoud> knesenko: yes, but no spice-xpi
18:15:02 <knesenko> ewoud: spice-xpi should be installed on your browser
18:15:10 <knesenko> I think
18:15:36 <knesenko> yes ... and u should use firefox
18:16:00 <ewoud> but as a gentoo user I don't have any spice-xpi package available
18:16:39 <knesenko> ewoud: I have spice .
18:16:57 <knesenko> ewoud: send me the cred. to the webadmin ...
18:20:21 <knesenko> ewoud: ?
18:22:05 <dneary> eedri, Ping?
18:22:35 <ewoud> knesenko: sec, almost got ovirt-shell working
18:23:11 <knesenko> ewoud: k
18:23:39 <ewoud> bah, unknown error: [Errno 25] Inappropriate ioctl for device
18:23:49 <ewoud> not sure what ovirt-shell does there
18:24:14 <knesenko> ewoud: :\
18:26:26 <knesenko> I am in
18:34:42 <knesenko> so we want to install centos on that vm ?
18:34:47 <knesenko> ewoud: ^^
18:35:20 <ewoud> knesenko: yes
18:35:47 <ewoud> that's what I have experience with and then we don't have to bother getting RHEL subscriptions
18:36:17 <ewoud> also, our community is more likely to use CentOS than RHEL so that was another reason for us to prefer CentOS
18:36:48 <knesenko> ewoud: have no idea how to install it ...
18:37:02 <knesenko> ewoud: also VM can;t get ip
18:37:12 <ewoud> knesenko: you have to use static IPs
18:37:12 <knesenko> ewoud: http://www.if-not-true-then-false.com/2011/centos-6-netinstall-network-installation/ ?
18:38:11 <ewoud> http://ekohl.nl/kickstart is the kickstart I tend to use
18:41:00 <ewoud> knesenko: kernel line would then be: linux text ks=http://ekohl.nl/kickstart ip=31.15.26.1 gateway=31.15.26.253 netmask=255.255.255.0 dns=8.8.8.8
18:41:48 <ewoud> not sure if I need to fill in a crypted password for it to work
18:48:08 <ewoud> knesenko: any luck?
18:48:18 <knesenko> ewoud: editing the kernle line ....
18:48:29 <knesenko> ewoud: but seems like it deprecated
18:49:29 <knesenko> ewoud: on the menu clicking on tab to edit the command line
18:49:51 <knesenko> ewoud: editing the line with your parameters
18:50:19 <knesenko> ewoud: what nextr ?
18:50:22 <ramonn> ewoud, i dont know the infrastructure team, but i want to report a bug: the name ovirt.org ( without www) isn't resolving. Just the www.ovirt.org
18:51:36 <ewoud> ramonn: that's odd, that used to work
18:52:20 <ewoud> knesenko: I usually do a netinstall and with the kickstart there should be no user interaction
18:52:22 <ramonn> ewoud, here in brazil i notice that since saturday, i will check with another server in eua
18:52:24 <ramonn> *usa
18:53:32 <ramonn> i was wrong, the name ovirt.org resolves, but to a different address than www.ovirt.org
18:54:23 <ewoud> someone commented the rewrite rule, not sure who and why
18:54:28 <ewoud> ramonn: should work again
18:55:24 <ewoud> ramonn: yes, it does resolve because you can't CNAME a domain, only a subdomain
18:55:39 <ewoud> ramonn: but on that other IP there was a redirect, which I restored now
18:56:33 <ramonn> ewoud, nice, its working
18:56:35 <ramonn> ewoud, thanks
18:57:48 <ewoud> ramonn: thanks for the report
19:00:25 <knesenko> ewoud: stuck on retrieving image
19:03:01 <ewoud> knesenko: anything in the second console using alt+f2?
19:03:44 <knesenko> ewoud: nothing
19:04:18 <knesenko> ewoud: seems like a connection problem
19:04:29 <knesenko> ewoud: Maybe Ips we are using ?
19:04:56 <ewoud> victory, updating ovirt-shell to 3.3.0.2 works
19:05:04 <ewoud> knesenko: seems dns isn't correct
19:05:57 <knesenko> ewoud: :)
19:06:29 <knesenko> ewoud: shall I continue '
19:06:30 <knesenko> ?
19:07:35 <ewoud> knesenko: you can only attach one console?
19:07:58 <ewoud> I was hoping we could use a shared console
19:08:11 <knesenko> ewoud: it dropped u oit ?
19:08:25 <ewoud> knesenko: yes
19:08:42 <knesenko> ewoud: oh
19:08:44 <knesenko> :(
19:08:55 <knesenko> ewoud: continue then ...ill wait
19:09:40 <knesenko> ewoud: which dns will u use ?
19:10:08 <ewoud> knesenko: 8.8.8.8 should be google dns and it's what's set up in /etc/resolv.conf
19:10:14 <ewoud> so I think that should work
19:10:26 <knesenko> ewoud: so why its stuck in my case ?
19:10:32 <knesenko> ewoud: works for u ?
19:12:08 <ewoud> knesenko: not sure, retrying now
19:12:24 <knesenko> ewoud: ok. crossing the fingers
19:12:27 <knesenko> :)
19:12:36 <ewoud> knesenko: oh, I think I know
19:12:47 <ewoud> knesenko: in the kickstart there's instructions to use DHCP
19:13:04 <knesenko> ewoud: oh oh oh ... I noticed that !
19:13:25 <knesenko> ewoud: I am too tired ... had a lot of issues today ...
19:13:34 <knesenko> in the office
19:14:15 <ewoud> knesenko: after DHCP timed out I entered it manually and that seems to work now
19:14:33 <knesenko> ewoud: good
19:15:17 <knesenko> ewoud: as u said , need to setup sudo there
19:16:05 <ewoud> knesenko: yes, maybe install some LDAP server to get separate accounts on our ovirt instance
19:16:30 <ewoud> knesenko: installed 57 of 243 packages now
19:17:31 <knesenko> ewoud: ok
19:23:44 <ewoud> knesenko: right, it's installed so let's see if SSH works :)
19:24:11 <knesenko> ewoud: should work !
19:24:48 <ewoud> knesenko: I'm afraid the DHCP in the kickstart screwed us, and a weird "hash" as root pw doesn't help :S
19:25:12 <knesenko> ewoud: want me to connect from spice ?
19:25:18 <knesenko> ewoud: or you will do it ?
19:25:40 <ewoud> knesenko: think you can boot to single user mode and set it static and force a root pw?
19:25:47 <knesenko> ewoud: ok
19:25:49 <knesenko> will do
19:28:21 <knesenko> ewoud: hehehe .... it takes too much time to open a spice console
19:28:31 <knesenko> ewoud: So I can't get the single user mode
19:28:41 <ewoud> knesenko: I'll try
19:28:43 <knesenko> ewoud: rebooted
19:28:45 <knesenko> no no
19:28:53 <knesenko> ewoud: don't disconnect
19:28:54 <knesenko> me
19:29:00 <ewoud> knesenko: ok :)
19:35:25 <knesenko> ewoud: try now
19:35:36 <ewoud> knesenko: victory :)
19:36:41 <knesenko> ewoud: I am back
19:36:49 <ewoud> knesenko: I installed screen and started in one
19:38:44 <knesenko> ewoud: I am tehre
19:39:45 <ewoud> going to follow http://theforeman.org/manuals/1.1/quickstart_guide.html
19:40:56 <ewoud> knesenko: we also need to have RH IT create foreman.ovirt.org so maybe you can make a ticket for that?
19:41:10 <ewoud> on the VM I added it to the hosts file, but that's not ... ideal
19:41:35 <knesenko> ewoud: I can do that
19:44:56 <knesenko> #action knesenko file a RH IT ticket to create foreman.ovirt.org
19:45:08 <knesenko> ewoud: only u can do that
19:45:11 <knesenko> :
19:45:16 <ewoud> #chair knesenko
19:45:16 <ovirtbot> Current chairs: ewoud knesenko
19:45:27 <knesenko> #action knesenko file a RH IT ticket to create foreman.ovirt.org
19:45:30 <ewoud> knesenko: I thought I already made you chair, but maybe with the DC?
19:45:39 <ewoud> also, there is no confirmation for #action
19:45:53 <knesenko> ewoud: I was disconnected
19:45:54 <ewoud> #info foreman.ovirt.org installed as a basic centos 6.4
19:46:17 <ewoud> #info added foreman.ovirt.org to its hosts file
19:46:34 <ewoud> #info running foreman installer using default options now
19:47:17 <ewoud> oh bah, I noticed it's installing sqlite instead of postgres
19:47:48 <knesenko> ewoud: can we reintall it ?
19:48:15 <ewoud> knesenko: yes, but not sure if postgres support is already in the released installer
19:48:41 <ewoud> doens't look that way
19:49:33 <ewoud> #info installing foreman from the foreman installer develop version
19:49:39 <knesenko> ewoud: I can ask Ohad tomorrow when it will be ready
19:49:57 <knesenko> ewoud: maybe it worse to wait ?
19:50:12 <ewoud> knesenko: I've contributed sufficient patches to the installer to know how to use the git version
19:50:25 <knesenko> ewoud: ok
19:52:53 <ewoud> I am wondering why I'm getting HTTP 403 responses because I haven't seen those before
19:53:12 <knesenko> ewoud: so Red Hat IT is responsible to create foreman.ovirt.org DNS records ?
19:53:39 * quaid can file a ticket for that right now
19:53:40 <ewoud> knesenko: that's what quaid told me
19:53:47 * ewoud waves at quaid
19:54:00 <knesenko> quaid: can you CC me ?
19:54:07 <quaid> yeah, I can open up the @redhat.com people who can make such requests to a wider group - I should make sure that eedri & dcaro & iheim can for instance
19:54:21 <quaid> but I like the idea of us potentially taking it over when things settle down a bit
19:54:58 <quaid> knesenko: sure
19:55:04 <quaid> which IP?
19:55:14 <quaid> is this is an A or CNAME record?
19:55:30 <knesenko> quaid: 31.15.26.1
19:55:42 * quaid thinks A but isn't sure
19:55:51 <ewoud> yes, A
19:55:54 <knesenko> quaid: its a VM - so should A
19:56:07 <quaid> good just checking :)
19:56:08 <knesenko> quaid: a new VM we installed
19:56:11 <knesenko> ok
19:56:15 <knesenko> quaid: 10x
19:57:16 <quaid> 10x?
19:57:30 <ewoud> thanks
19:57:39 * ewoud assumes
19:57:51 <knesenko> quaid: thanks
19:57:54 <knesenko> :)
19:57:58 <quaid> heh, that's a new one on me
19:58:34 <quaid> should we have them setup the other IPs at the same time?
19:59:45 <quaid> oic, they aren't live yet
19:59:54 <quaid> (the rest are replacements, so we don't want to move them yet)
20:01:02 <ewoud> quaid: we already know the IPs so that would be best
20:01:24 <ewoud> quaid: oh wait, those VMs have existing services, so should not be changed
20:01:57 <quaid> right! just noticed that :)
20:01:59 * ewoud quickly updates his foreman-howto
20:06:28 <ewoud> knesenko: try https://31.15.26.1/ using admin and the root pw you set
20:07:22 <knesenko> ewoud: cudos
20:07:58 <ewoud> knesenko: https://github.com/ekohl/foreman-howto/blob/master/README.rst is pretty much what I used
20:08:07 <knesenko> ewoud: kudos
20:08:09 <ewoud> #info installed foreman
20:09:23 <Guest4493> have you guys seen this bug yet: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=703113 ?
20:09:49 <ewoud> knesenko: now trying to add the foreman host to itself
20:09:58 <Guest4493> i'm encountering it w/ engine-manage-domains
20:11:47 <knesenko> ewoud: ok
20:13:16 * quaid also requested that the other @redhat.com Infra team folk be added to the "may request DNS changes" list to remove YASPoF
20:14:33 <knesenko> ewoud: puppet -t --server ....  ?
20:15:07 <ewoud> knesenko: no, I needed to add the smart proxy to foreman before the puppet server was allowed access
20:17:30 <ewoud> knesenko: I lost connection it seems
20:17:36 <knesenko> ewoud: me too
20:17:51 <knesenko> ewoud: it just works slow
20:17:53 <knesenko> too slow
20:18:17 <ewoud> knesenko: odd
20:21:55 <ewoud> knesenko: I added the subnet, set up the OS
20:24:09 <ewoud> knesenko: shall we call it enough now and start populating the actual puppet repository later?
20:24:37 <knesenko> ewoud: yes
20:24:44 <knesenko> ewoud: I am tired like shit
20:25:34 <ewoud> knesenko: ok, thanks for your help :)
20:25:42 <ewoud> #endmeeting