13:01:35 <mburns> #startmeeting oVirt Node Weekly Meeting
13:01:35 <ovirtbot> Meeting started Tue Apr 16 13:01:35 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:35 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:42 <mburns> #chair fabiand jboggs rbarry
13:01:42 <ovirtbot> Current chairs: fabiand jboggs mburns rbarry
13:02:31 <mburns> #topic agenda
13:02:38 <mburns> #info feature review
13:02:44 <mburns> #info release status
13:02:48 <mburns> #info other topics
13:03:05 * fabiand is here
13:03:39 * jboggs here
13:03:44 * rbarry here
13:03:47 <mburns> #topic feature review
13:03:51 <mburns> #link http://www.ovirt.org/Node_3.0_release-management
13:04:59 <mburns> #topic Universal Image:
13:05:05 <mburns> #link
13:05:11 <mburns> #link http://www.ovirt.org/Features/Universal_Image
13:05:20 <mburns> #info owner:  mburns
13:05:27 <mburns> #info status:  devel complete and merged
13:05:59 <mburns> #topic Node Upgrade tool
13:06:03 <mburns> #link http://www.ovirt.org/Features/Node_upgrade_tool
13:06:10 <mburns> #info owner:  jboggs
13:06:29 <mburns> jboggs: status?
13:06:44 <jboggs> almost complete pending some review
13:08:17 <mburns> #info status:  in review, nearly complete
13:09:13 <mburns> #topic Software iSCSI root
13:09:19 <mburns> #link http://www.ovirt.org/Features/Node_software_iscsi_root
13:09:24 <mburns> #info owner:  jboggs
13:09:36 <mburns> #info status:  devel complete and merged, pending testing
13:10:04 <fabiand> jboggs, could you add a couple of lines to indicate how to do the testing?
13:10:09 <fabiand> i mean how to setup an iscsi tgt ...
13:10:09 <jboggs> sure can
13:10:18 <fabiand> would be nice ... then i'd give it a try ..
13:10:32 <fabiand> just a couple of hints - nothing fancy :)
13:10:32 <mburns> #action jboggs to update page with testing steps
13:11:50 <mburns> #topic Puppet Configuration Management
13:11:56 <mburns> #info no feature page yet
13:12:19 <mburns> #action rbarry to create puppet configuration feature page and link to release management page
13:12:25 <ovirtbot> 14[[07Features/Urwid TUI14]]4 !10 02http://www.ovirt.org/index.php?diff=8342&oldid=8341&rcid=8551 5* 03Fabiand 5* (-55) 10Minor fixes
13:12:32 <mburns> #info owner:  rbarry
13:12:40 <mburns> rbarry: status?
13:13:03 <rbarry> 95% code complete.  Currently testing.
13:13:11 <rbarry> Also: http://www.ovirt.org/Features/Node_Puppet_Plugin
13:13:24 <rbarry> I forgot to link it to release management, though :/
13:13:38 <mburns> #info action complete:  http://www.ovirt.org/Features/Node_Puppet_Plugin
13:14:29 <ovirtbot> 14[[07Node 3.0 release-management14]]4 10 02http://www.ovirt.org/index.php?diff=8343&oldid=8340&rcid=8552 5* 03Mburns 5* (+35) 10/* Features */ 
13:14:34 <mburns> ok, linked
13:14:56 <mburns> fabiand: what's the "open" and "partially" for on features?
13:15:22 <mburns> #info status:  95% code complete, in testing
13:15:33 <fabiand> mburns, I didn't know who took it .. therefor I added open ..
13:15:39 <mburns> ahh
13:16:03 <fabiand> I just added partially to swap, because you said that there was soe code, but there is also some code to come .. :)
13:16:13 <ovirtbot> 14[[07Node 3.0 release-management14]]4 !10 02http://www.ovirt.org/index.php?diff=8344&oldid=8343&rcid=8553 5* 03Rbarry 5* (+36) 10/* Features */ 
13:16:17 <fabiand> btw. targeted means that we target to suport f19 .. :)
13:16:34 <mburns> yep
13:16:44 <mburns> ok
13:16:54 <mburns> #topic Swap enhancements
13:17:00 <mburns> #info no feature page yet
13:17:18 <mburns> #action mburns to create feature page for swap and link to release management page
13:17:27 <mburns> #info owner: mburns
13:17:31 <mburns> #info status: not started
13:17:46 <mburns> #undo
13:17:46 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0xa3c418c>
13:17:53 <mburns> #info status: not started, partially designed
13:18:05 <mburns> #topic TUI Installer
13:18:13 <mburns> #link http://www.ovirt.org/Features/Urwid_TUI
13:18:15 <fabiand> merged and complete
13:18:20 <mburns> #owner fabiand
13:18:26 <mburns> #status:  complete and merged
13:18:26 <fabiand> fixing smaller upcoming bugs
13:18:42 <mburns> #info just bug fixing now
13:19:01 <mburns> #topic IPv6 support
13:19:04 <mburns> #link http://www.ovirt.org/Features/Node_ipv6_support
13:19:09 <mburns> #info owner jboggs
13:19:19 <mburns> jboggs: any work done here?
13:19:24 * mburns suspects not yet...
13:19:25 <jboggs> not started yet
13:19:38 <mburns> #info status:  not started yet
13:19:39 <jboggs> backend should still be there just need to link the front
13:20:08 <mburns> #info likely that backend functionality is mostly intact, just need UI work
13:20:20 <mburns> #topic Diagnostics Page
13:20:27 <mburns> #link http://www.ovirt.org/Features/Node_Diagnostic_Page
13:20:31 <mburns> #owner: rbarry
13:20:41 <mburns> #status:  patches posted, in review
13:20:47 <mburns> rbarry: anything else on this?
13:21:04 <rbarry> Nothing to add.  Just waiting on review to merge.
13:21:18 <mburns> ok
13:21:35 * fabiand will pick up the word "review" in a second again ..
13:21:45 <mburns> #topic Compatibility
13:21:59 <mburns> #info owner: fabiand
13:22:00 <fabiand> mburns, would be nice if we could setup a couple of f19 builders ..
13:22:04 <fabiand> two or so ..
13:22:26 <fabiand> then we can add jenkins  jobs etc
13:22:28 <mburns> fabiand: agreed, you should ping the infra team about setting them up ;-)
13:22:38 <fabiand> right ...
13:22:50 <fabiand> I'm somewhat tending to always poke the same member of the infra team ;)
13:22:57 <mburns> #action fabiand to ping infra about F19 builders
13:23:04 <mburns> fabiand: file a ticket
13:23:11 <mburns> rather than ping directly
13:23:20 <fabiand> is there an infra bz/track?
13:24:00 <mburns> fabiand: they use fedorahosted.org/ovirt
13:24:04 <fabiand> ah ack
13:24:06 <fabiand> thanks
13:24:20 <mburns> though the frontpage doesn't really indicate that...
13:25:01 <mburns> frontpage on fedorahost.org/ovirt that is
13:26:00 <fabiand> ok
13:26:02 <mburns> fabiand: is there a feature/wiki page for support?
13:26:10 <fabiand> mburns, nope not yet ..
13:26:17 <fabiand> I'll use a tracker bug for it ..
13:26:24 <mburns> fabiand: ok
13:26:31 <fabiand> as I suppose that quite some bugs will arise from the migration to f19 .. selinux etc
13:26:51 <mburns> #info fabiand to use tracker bug to note issues with compatibility
13:27:02 <fabiand> mburns, is there a formal process of becoming  an infra member for a subproject?
13:27:05 <mburns> #info targeting F18, F19, CentOS/EL6
13:27:29 <mburns> fabiand: no idea, i've not been participating in infra team much
13:27:33 <mburns> except as needed
13:27:34 <fabiand> I'm fine to cope with F18 and F19 but maybe someone else could look at CentOS/EL6?
13:27:52 <fabiand> mburns, right, i'll ask publicly
13:28:14 <ewoud> fabiand: infra needs to work on a formal process, but lack of time isn't helping
13:28:45 <mburns> rbarry: jboggs:  one of you want to take on EL6/CentOS compatibility?
13:28:55 * jboggs doesnt mind
13:29:09 <rbarry> I don't mind either.
13:29:18 <mburns> excellent
13:29:36 <mburns> jboggs: how about you take RHEL
13:29:40 <mburns> rbarry: you take CentOS
13:29:43 <fabiand> ewoud, yeah - somewhat comprehensible
13:29:45 <jboggs> ack
13:30:20 <mburns> #info jboggs will take lead on making sure new changes work on RHEL
13:30:31 <mburns> #info rbarry will take lead on making sure they work on CentOS
13:31:27 <mburns> #topic Release status
13:31:54 <mburns> #info on target for freeze 02-May
13:32:06 <mburns> #info and release 31-May
13:32:50 <mburns> feature discussions cover most of this topic, i think
13:33:11 <mburns> #topic Patch Reviews
13:33:20 <mburns> #info need people to start reviewing patches
13:33:28 <fabiand> ah nice thing, mburns :)
13:33:42 <mburns> #info more than 25 patches currently outstanding in gerrit
13:35:02 <mburns> #idea everyone reviews at least 2 patches per day (except when immediate critical work comes up)
13:35:09 <mburns> thoughts?
13:35:32 <fabiand> mburns, sounds good
13:35:40 <fabiand> I'd even say one patch per day ..
13:35:58 <fabiand> I remeber having reviewd a couple of patchs ... but the weren't merged ..
13:36:12 <jboggs> agreed, will start a few per day
13:36:16 <mburns> let's say 2 for now, and once we get down to a more manageable number, we can change it to 1 per day
13:36:17 <fabiand> Because reviews get lost when a new patchset arrives (due to a rebase e.g.)
13:36:23 <fabiand> ack
13:36:24 <mburns> yep
13:36:43 <fabiand> Can we also have a daily merge deadline?
13:37:19 <mburns> #agreed each person to review 2 patches per day to start, then 1 per day when we get to a more manageable number
13:37:30 <mburns> #info review means both code review and verification
13:37:42 <mburns> fabiand: what do you mean by daily merge deadline?
13:37:57 <fabiand> Some point where reviewed and verified patches get merged
13:38:42 <mburns> fabiand: i think we all have merge ability
13:38:47 <fabiand> b/c when reviewed/verified patches hang around in gerrit for some time, and someone rebases them, then all the review/verify flags are dropped ..
13:39:10 <fabiand> right, so every reviewer can merge if there is at least one other reviewer who reviewed/verified the patch?
13:39:18 <mburns> fabiand: but sure, let's say all patches for the day reviewed by 4PM EDT
13:39:30 <mburns> and i'll merge then if you want
13:40:10 <fabiand> well, I didn't know that we can all merge patches - I don't think that the deadline isn't that important in that case ..
13:40:13 <mburns> fabiand: yes, as long as they are not the patch creator
13:40:25 <mburns> so 2 sets of eyes other than the patch creator
13:40:33 <mburns> fabiand: i think we all have merge
13:40:34 <fabiand> ack
13:40:49 <mburns> if not, let me know
13:40:53 <fabiand> yup
13:40:54 <jboggs> i have merge
13:41:06 <mburns> rbarry: you might not...
13:42:00 <mburns> not sure if we added you to the right group
13:42:57 * fabiand needs to go .. but will read the bac
13:43:00 <fabiand> k log
13:43:12 <mburns> that's all i really have for today anyway
13:43:25 <rbarry> mburns: I don't seem to be part of maintainers, so I'm guessing I can't merge
13:43:40 <mburns> so let's close the meeting, and we can follow up on irc/email if there is more to discuss
13:43:44 <mburns> #endmeeting