#ovirt: oVirt Node weekly meeting

Meeting started by mburns at 13:00:40 UTC (full logs).

Meeting summary

  1. next release (mburns, 13:01:07)
    1. http://www.ovirt.org/Node_2.7_release-management (fabiand, 13:02:08)
    2. additional features added to the release planning page (mburns, 13:03:10)
    3. in discussing the release yesterday, fabiand and i thought that it might make sense to re-number the release as 3.0 (mburns, 13:05:06)
    4. since we're removing vdsm and making the image generic, changing the TUI, etc. (mburns, 13:05:30)
    5. ACTION: fabiand to update the release management page to reflect 3.0.0 release number (mburns, 13:06:42)
    6. ACTION: mburns to post patches to move version numbers in spec files to 3.0.0 instead of 2.7.0 (mburns, 13:07:08)
    7. AGREED: next version will be 3.0.0 (mburns, 13:07:34)
    8. ACTION: mburns to re-target bugs for 3.0.0 instead of 2.7.0 (mburns, 13:08:21)
    9. IDEA: Feature freeze and beta preparation -- 01-May (mburns, 13:08:57)
    10. IDEA: RC Build -- 15-May (mburns, 13:09:30)
    11. IDEA: GA -- 31-May (mburns, 13:09:48)
    12. the reasoning behind these dates: Need to be ready prior to oVirt 3.3 builds are being posted live (mburns, 13:10:23)
    13. also need them out prior to F19 (mburns, 13:10:33)
    14. AGREED: on the proposed dates (mburns, 13:12:52)

  2. Universal Image (mburns, 13:13:15)
    1. owner: mburns (mburns, 13:13:19)
    2. status: code complete and merged (mburns, 13:13:32)
    3. no objections to inclusion in 3.0.0 (mburns, 13:14:19)
    4. ACTION: mburns to add feature page -- due 10-Apr (mburns, 13:14:56)
    5. this feature is making the node generic so it can be used by multiple projects (oVirt, OpenStack, Gluster, etc) (mburns, 13:15:28)
    6. ACTION: mburns to link new feature page to release management page (mburns, 13:15:59)

  3. new upgrade tool (mburns, 13:19:20)
    1. owner: jboggs (mburns, 13:19:25)
    2. status: patches posted, in review (mburns, 13:19:36)
    3. no objections for inclusion in 3.0.0 (mburns, 13:19:54)
    4. ACTION: jboggs to create feature page and link to release management page -- due 12-April (mburns, 13:20:15)
    5. this feature is to improve support for upgrades to minimize the various upgrade issues we've found in the past (mburns, 13:21:08)
    6. jboggs will be posting updated patches later today (mburns, 13:21:55)

  4. Software iSCSI support (mburns, 13:22:29)
    1. owner: jboggs (mburns, 13:22:36)
    2. status: code complete and merged, needs testing (mburns, 13:22:47)
    3. this feature adds the ability to install to and boot from a software iscsi target (mburns, 13:23:12)
    4. no objections to inclusion in 3.0.0 (mburns, 13:23:34)
    5. ACTION: jboggs to put up feature page and link to release management page -- due 12-April (mburns, 13:24:20)

  5. puppet configuration (mburns, 13:25:38)
    1. owner: rbarry (mburns, 13:25:45)
    2. status: in development (mburns, 13:25:51)
    3. this feature will allow ovirt-node to be configured from a puppet instance (mburns, 13:26:05)
    4. there are 2 parts to this feature, the puppet provider and the parts in ovirt-node to allow the configuration (mburns, 13:26:26)
    5. ACTION: rbarry to add a feature page and link to the release management page -- due 12-April (mburns, 13:27:43)
    6. at risk until we see the code and feature page (mburns, 13:28:08)
    7. puppet provider code is located here: https://github.com/evol262/puppet-ovirt-node-plugin?ref=commandbarr (mburns, 13:29:48)

  6. swap enhancements (mburns, 13:30:26)
    1. owner: mburns (mburns, 13:30:30)
    2. status: not started (mburns, 13:30:37)
    3. this feature is to improve allocation of swap with a couple of related sub-features (mburns, 13:31:30)
    4. details will be included in the feature page (mburns, 13:31:57)
    5. ACTION: mburns to post feature page and link to release management page -- due 12-April (mburns, 13:32:13)
    6. no objection to inclusion in 3.0.0, but at risk until patches are posted (mburns, 13:32:43)

  7. TUI -- installer (mburns, 13:34:06)
    1. owner: fabiand (mburns, 13:34:12)
    2. status: complete and merged (mburns, 13:34:19)
    3. ACTION: fabiand to create feature page and link to release page -- due 12-April (mburns, 13:34:44)
    4. this feature is a re-write of the TUI installer using the urwid backend (mburns, 13:35:09)
    5. already merged, so no objections to 3.0.0 (mburns, 13:36:42)

  8. TUI -- ipv6 support (mburns, 13:36:52)
    1. owner: jboggs (mburns, 13:36:59)
    2. status: in development (mburns, 13:37:10)
    3. risk for 3.0.0 until patches are posted (mburns, 13:37:21)
    4. in the past, we had IPv6 code in the TUI, but it was disabled, this will port that code to the new TUI infrastructure and enable it by default (mburns, 13:38:00)
    5. ACTION: jboggs to create and link feature page -- due 12-April (mburns, 13:38:23)

  9. TUI -- diagnostics (mburns, 13:39:51)
    1. owner: rbarry (mburns, 13:39:57)
    2. status: patches posted and in review (mburns, 13:40:08)
    3. no objections to 3.0.0 (mburns, 13:40:17)
    4. this page enables some additional diagnostic information in the TUI and adds a scrollable table widget for future use (mburns, 13:40:46)
    5. ACTION: rbarry to create a feature page and link to release status page --due April 12 (mburns, 13:41:15)

  10. Compatibility (mburns, 13:43:12)
    1. this feature is to ensure that all work is compatible on F18, F19 (pending late F19 changes), and EL6 (RHEL/CentOS) (mburns, 13:43:57)
    2. owner: fabiand (mburns, 13:44:31)
    3. status: current master should be compatible on F18, no testing yet on F19/EL6 (mburns, 13:44:59)
    4. ACTION: fabiand to work out plan for this feature (mburns, 13:45:53)

  11. other topics (mburns, 13:47:29)


Meeting ended at 13:49:27 UTC (full logs).

Action items

  1. fabiand to update the release management page to reflect 3.0.0 release number
  2. mburns to post patches to move version numbers in spec files to 3.0.0 instead of 2.7.0
  3. mburns to re-target bugs for 3.0.0 instead of 2.7.0
  4. mburns to add feature page -- due 10-Apr
  5. mburns to link new feature page to release management page
  6. jboggs to create feature page and link to release management page -- due 12-April
  7. jboggs to put up feature page and link to release management page -- due 12-April
  8. rbarry to add a feature page and link to the release management page -- due 12-April
  9. mburns to post feature page and link to release management page -- due 12-April
  10. fabiand to create feature page and link to release page -- due 12-April
  11. jboggs to create and link feature page -- due 12-April
  12. rbarry to create a feature page and link to release status page --due April 12
  13. fabiand to work out plan for this feature


Action items, by person

  1. fabiand
    1. fabiand to update the release management page to reflect 3.0.0 release number
    2. fabiand to create feature page and link to release page -- due 12-April
    3. fabiand to work out plan for this feature
  2. jboggs
    1. jboggs to create feature page and link to release management page -- due 12-April
    2. jboggs to put up feature page and link to release management page -- due 12-April
    3. jboggs to create and link feature page -- due 12-April
  3. mburns
    1. mburns to post patches to move version numbers in spec files to 3.0.0 instead of 2.7.0
    2. mburns to re-target bugs for 3.0.0 instead of 2.7.0
    3. mburns to add feature page -- due 10-Apr
    4. mburns to link new feature page to release management page
    5. mburns to post feature page and link to release management page -- due 12-April
  4. rbarry
    1. rbarry to add a feature page and link to the release management page -- due 12-April
    2. rbarry to create a feature page and link to release status page --due April 12


People present (lines said)

  1. mburns (119)
  2. fabiand (32)
  3. ovirtbot (5)
  4. jboggs (4)
  5. MACscr (2)
  6. Rydekull (2)
  7. rbarry (1)


Generated by MeetBot 0.1.4.