14:04:58 <ewoud> #startmeeting infra weekly
14:04:58 <ovirtbot> Meeting started Mon Apr 8 14:04:58 2013 UTC. The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:04:58 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:05:20 <ewoud> the agenda
14:05:23 <ewoud> Introductions
14:05:23 <ewoud> Review of action items
14:05:23 <ewoud> Rydekull add the jenkins slaves to a list ont he wiki
14:05:23 <ewoud> quaid to setup docs sprint
14:05:23 <ewoud> Hosting
14:05:26 <ewoud> rackspace01 installed?
14:05:28 <ewoud> Puppet
14:05:31 <ewoud> Summarize the ML thread
14:05:33 <ewoud> Jenkins
14:05:36 <ewoud> Other business?
14:05:38 <ewoud> Trac review
14:05:53 <ewoud> missing anything?
14:06:35 <ewoud> #topic Introductions
14:06:56 <ewoud> anyone who would like to introduce themselves here?
14:07:40 <ewoud> #topic Review of action items
14:08:01 <ewoud> I added this to the agenda because it felt like we were forgetting to review them and sort of died
14:08:11 <ewoud> Rydekull: any progress on adding the jenkins slaves to the list?
14:08:37 <ewoud> quaid: anything on the docs sprint?
14:08:39 <dneary> Hey hey
14:08:52 <dneary> #admin theron_
14:09:05 <ewoud> #chair dneary
14:09:05 <ovirtbot> Current chairs: dneary ewoud
14:09:16 <dneary> #chair theron_
14:09:16 <ovirtbot> Current chairs: dneary ewoud theron_
14:09:20 <dneary> Thanks ewoud :-)
14:09:22 <ewoud> #chair dcaro eedri|mtg quaid
14:09:22 <ovirtbot> Current chairs: dcaro dneary eedri|mtg ewoud quaid theron_
14:09:50 * ewoud makes a list to highlight when the meeting start
14:10:19 <ewoud> since Rydekull and quaid aren't here, let's move on
14:10:22 <ewoud> #topic Hosting
14:10:38 <ewoud> haven't heard quaid about any progress on rackspace01
14:11:00 <ewoud> we should make a decission about alterway02 and the network
14:11:22 <ewoud> #chair eedri
14:11:22 <ovirtbot> Current chairs: dcaro dneary eedri eedri|mtg ewoud quaid theron_
14:11:23 * eedri here
14:11:36 <ewoud>
16:10:58 < ewoud> we should make a decission about alterway02 and the network
14:12:02 <eedri> ewoud, did you got an answer from alterway?
14:12:03 <ewoud> do we go for NAT or wait for additional IPs?
14:12:14 <ewoud> eedri: nothing that's not on the ML
14:12:25 <eedri> ewoud, how would we use nat?
14:12:33 <ewoud> but he said on April 17 he could have something
14:12:33 <eedri> ewoud, don't we need public ips to access it?
14:12:52 <ewoud> eedri: alterway02 has one public IP and we could NAT it there, but I'd rather not
14:13:11 <eedri> ewoud, doesn't sound right to me too
14:14:18 <ewoud> maybe I'm a bit spoiled since my employer has 4096 IPs (and a /32 IPv6 block), but not having to resort to NAT would make our lives easier
14:14:43 <eedri> ewoud, does the ip space have to come from alterway? or we can use other resources?
14:15:06 <ewoud> eedri: not sure how else you'd do it
14:15:08 <eedri> dneary, is rackspace providing us with ip space for the hosts?
14:15:26 <eedri> dneary, vms actually
14:15:27 <ewoud> eedri: then what? use a VPN?
14:15:51 <eedri> ewoud, yea.. it will complicate things
14:16:34 <ewoud> what we could do is use a reverse proxy on the host
14:17:02 <eedri> ewoud, so each vm will have a private ip
14:17:17 <eedri> ewoud, and the host will have a revesve proxy directing it to a dns name
14:17:43 <ewoud> eedri: yes, but then we still need NAT or a HTTP proxy for yum updates
14:17:59 <ewoud> eedri: and something like a VPN to SSH into the hosts
14:18:16 <eedri> ewoud, i say let's wait till april 17 (which is a good date, since it's my bd..)
14:18:19 <ewoud> +1
14:18:23 <eedri> ewoud, so good things might happen
14:18:27 <ewoud> eedri: no kidding, mine too
14:18:28 <dcaro> ewoud, eedri, are you talking about http reverse proxy?
14:18:33 <eedri> ewoud, really?
14:18:37 <ewoud> eedri: yes :)
14:18:41 <eedri> ewoud, cool :)
14:18:52 <ewoud> dcaro: +1 was on the waiting
14:19:07 <eedri> dcaro, we can use revese proxy, but it will complicate things
14:19:35 <eedri> ok, can we get an update on rax servers?
14:19:55 <dcaro> it will only proxy http then :S, we need more services right?
14:19:56 <ewoud> worst case you'd turn alterway02 into a host without virtualisation and make it a new kitchen sink like linode01, but I'd prefer not to
14:20:09 <ewoud> dcaro: yes, mail for mailman etc
14:20:23 <ewoud> eedri: no updates afaik
14:21:39 <eedri> quaid, ?
14:21:40 <ewoud> so we wait for April 17?
14:21:47 <eedri> ewoud, for alterway i vote +1
14:21:58 <dcaro> +1
14:22:11 <eedri> ewoud, i would like to get progress on rax, since it's blocking us from running pre-patch jenkins jobs
14:22:26 <ewoud> #agreed we wait for April 17 for more IPs from Alterway
14:22:27 <eedri> ewoud, i can run some jobs on jenkins master, but i rather not
14:22:41 <ewoud> eedri: +1
14:22:45 * Rydekull is here
14:23:04 <ewoud> maybe we should share the login credentials for rackspace so quaid isn't a SPOF
14:23:07 <Rydekull> Oh, rats, I'll be here in a minute or so
14:23:10 * Rydekull goes again
14:23:19 <eedri> quaid, dneary ping
14:23:32 <eedri> quaid, can we help in pushing forward rackspace installation?
14:23:42 <dneary> eedri, Hi there
14:23:49 <eedri> dneary, ^^
14:23:52 <dneary> eedri, I don't know if quaid is around this morning
14:24:00 <eedri> dneary, just wondering how we can push forward raxs
14:24:34 <dneary> eedri, My suggestion is to ensure that you, dcaro, ewoud & theron_ have access to anything which is blocking with quaid
14:24:50 <eedri> dneary, sounds good. how can we make it happen?
14:24:57 <dneary> eedri, Email to infra@ highlighting the problem, and I'll make sure quaid sees it & takes action
14:25:20 <ewoud> I'm sure quaid will agree
14:25:38 <ewoud> I'll send the mail
14:25:46 <eedri> ewoud, +1, thanks
14:26:10 <ewoud> #action ewoud mail to infra@ to make sure we don't have a SPOF on people with access
14:26:18 <ewoud> anything else about hosting?
14:26:30 <eedri> ewoud, maybe asking racs space
14:26:34 <eedri> ewoud, about ip space
14:26:44 <eedri> ewoud, so we won't have issue when the host is installed
14:27:04 <ewoud> eedri: mind picking that up?
14:27:57 <eedri> ewoud, sure
14:28:11 <eedri> #action eedri to send email about ip space on rackspace servers
14:28:26 <eedri> ewoud, btw, we've managed to install some nested vms running rhel on fedora18
14:28:36 <ewoud> eedri: nice
14:28:46 <eedri> ewoud, so it seems we'll be able to do that on rax as planned
14:29:23 <ewoud> ok, that's enough about hosting I think
14:30:03 <ewoud> #topic puppet
14:30:40 <ewoud> I haven't had time to build a proof of concept so I wanted to install on alterway02, but ran into the IP space problem
14:31:28 <eedri> ewoud, are you planning to run foreman + puppet master on same vm?
14:31:39 <ewoud> eedri: yes
14:31:50 <eedri> ok
14:31:51 <eedri> +1
14:32:00 <eedri> and the puppet classes cloned from git repo?
14:32:26 <ewoud> I plan on using the foreman installer to install it
14:32:41 <eedri> ewoud, sounds good. we're using 1.1 stable here
14:32:46 <ewoud> I've provided quite a few patches to it and I know it well
14:32:57 <ewoud> same, 1.1 works well
14:33:22 <ewoud> btw, went to puppetcamp amsterdam last weekend and it was great fun :)
14:33:29 <ewoud> last friday*
14:33:40 <eedri> ewoud, did you meet dcaro ?
14:33:45 <eedri> dcaro, you were also there, no?
14:33:45 <ewoud> eedri: was he there too?
14:33:58 <dcaro> nop, I was a few weeks before
14:34:25 <dcaro> but they were talking a lot about the puppetcamp
14:34:41 <fabiand> eedri, hey - you were looking a bit after jenkins, right?
14:35:06 <ewoud> anyway, at $employer we imported the foreman installer modules into our regular environment and I'm wondering if we want to do the same
14:35:33 <ewoud> do you guys also use the git hook to build the environments?
14:35:35 <dcaro> btw, ewoud, i'd like to get a little more involved in puppet/foreman, if you need help just ask
14:35:53 <dcaro> ewoud: yes, the git hook updates and creates the envs if needed
14:36:01 <eedri> fabiand, we're in the middle of infra weekly meeting
14:36:07 <eedri> fabiand, is it related? or it can wait?
14:36:20 <ewoud> dcaro: I will, but I find it hard to work on it without an actual foreman server
14:36:27 <fabiand> eedri, oops - It can wait!
14:38:37 <ewoud> dcaro: I also prefer to start working on git repo with modules
14:38:46 <dcaro> ewoud: ok, maybe we can add features to the puppet modules meanwhile
14:38:46 <ewoud> should we start on github or straight to gerrit?
14:40:05 <ewoud> dcaro: what features?
14:40:41 * quaid daylight savings confused, thinking he is early
14:41:35 <ewoud> quaid: oh, maybe that's true
14:42:17 <ewoud> recently here we switched to summer time, though it's not really that much summer
14:42:44 <eedri> israel also switched last week afair
14:42:50 <dcaro> ewoud: for example the user creation and privilege separation
14:43:20 <dcaro> (one user per admin, sudo profiles, etc..)
14:44:26 <ewoud> dcaro: long ago I started on https://github.com/ekohl/ovirt-infra-puppet so maybe we can expand that
14:45:54 <dcaro> ewoud: ok, let's talk the details on the list, maybe start a new thread on puppet modules/features that we need
14:46:32 <ewoud> argh, been playing with my PC this weekend and now I have some instabilities
14:46:54 <ewoud> anyway, long live a spare laptop
14:46:57 <ewoud> dcaro: +1 on that
14:47:38 <ewoud> #action ewoud restart the puppet ML thread
14:47:49 <Rydekull> back!
14:47:52 <ewoud> let's go back to hosting
14:47:58 <ewoud> #topic hosting
14:48:07 <ewoud> quaid: any news on rackspace?
14:49:18 <quaid> ok, so
14:49:46 <quaid> I'm still as stuck as I was a few weeks ago, it's caused me to be totally shy of the project
14:50:42 <quaid> the problem is that I don't know that I can easily add anyone to the system to get console access
14:50:54 <quaid> once hosts are installed, that's different - we should be able to get ssh access more easily
14:51:04 <quaid> but to get to the iDRAC is a bit more
14:51:24 <quaid> if there is anyone who knows they can get the iDRAC console to work on their host - I seem to be having a Java and browser problem ...
14:52:41 <Rydekull> Yeah, fix java and use the correct browser :-P
14:52:52 <quaid> clever!
14:52:54 <Rydekull> You usually dont have much more options then that :-)
14:53:29 <quaid> I may try from a local VM
14:53:42 <quaid> anyway, I get that it's important, I'll keep at it this week
14:53:46 <Rydekull> So your actual issue is that you dont get your console to start?
14:53:54 <Rydekull> from DRAC?
14:54:10 <quaid> I get it to start, and I can go through to what is really the first screen of Anaconda
14:54:27 <Rydekull> And it doesnt work in text-mode?
14:54:28 <ewoud> quaid: anything from rackspace support?
14:54:29 <quaid> in text mode, I get a blank console, and only when I hit reboot the server from the console menu do I see that I'm in Anaconda
14:54:33 <Rydekull> hrm
14:54:42 <quaid> ewoud: plenty, but not entirely useful in the end
14:54:48 <ewoud> quaid: can you do a kickstart?
14:55:08 <Rydekull> No way me or ewoud could take a peek at it? Perhaps a teamviewer session with you in it
14:55:11 <Rydekull> or something
14:55:16 <Rydekull> solve it together
14:55:21 <quaid> I think so, if it will use a local .ks file of if I get rackspace support burn it all to a CD and hang a drive locally
14:55:37 <ewoud> or over network
14:55:42 <eedri> quaid, have you tried with internet explorer on a win vm
14:55:45 <ewoud> can you select a kernel image?
14:55:45 * eedri ducks
14:56:02 <eedri> quaid, usually that works when i have an issue with java plugin for ff
14:56:03 <quaid> eedri: I don't have a win VM, so no I haven't tried taht
14:56:14 <quaid> ewoud: I think so, yes
14:56:29 <Rydekull> with OOB-solutions, IE is sometimes what is needed to be honest
14:56:55 <quaid> does anyone have an F18 kickstart file I can use? maybe one of our Jenkins installs?
14:57:19 <eedri> quaid, i should have one in our foreman instance
14:57:27 <mmornati> hello, here again..
14:57:48 <quaid> eedri: can you email that to me?
14:57:53 <mmornati> is there any reason why I can't see all ActiveDirectory users after connecting the domain to ovirt?
14:57:56 <Rydekull> quaid: actually, just thinking here a bit
14:58:20 <Rydekull> quaid: could it be, when you start textmode that your console gets changed to another com-port or even a VGA-card in that machine?
14:58:25 <ewoud> mmornati: we're in an infra meeting, after that people are more likely to be able to help you
14:58:38 <mmornati> thanks ewoud.. I can wait...
14:58:45 <eedri> quaid, http://pastebin.com/bbx29wEM
14:58:47 <Rydekull> quaid: I dont know how that machine is equipped, but you could perhaps make sure in BIOS(UEFI) that it is just using the internal VGA
14:58:58 <eedri> quaid, it might have some foreman variables in it
14:59:08 <quaid> Rydekull: I'll check, thx
14:59:24 <eedri> quaid, anything with <% ...%>
14:59:31 <ewoud> quaid: http://ekohl.nl/kickstart is what I use for my centos 6 kickstarts
14:59:35 <eedri> quaid, should be replaced with strings
14:59:50 <quaid> well, still trying to do F18
15:00:01 <quaid> I was able to get CentOS 6.4 to work (didn't complete the install)
15:00:10 <Rydekull> quaid: anyway, both me and ewoud can probably try and work with you remotely to try and solve it through teamviewer or something. if not
15:00:13 <ewoud> quaid: I know, but it's my experience with kickstarts
15:00:17 <Rydekull> quaid: provide you with a windows vm where you can try and do the same :-)
15:00:39 <eedri> quaid, sent you link to f18 kickstart file
15:01:09 <quaid> Rydekull: I'll take the help, thanks, but will skip the win vm
15:01:11 <Rydekull> quaid: if you have SSH-access, using DRAC that is, you might be able to switch the console output to a console also, and then connect there
15:01:25 <eedri> quaid, maybe it's possible to use crossover/wine?
15:01:30 <Rydekull> quaid: err, com-port I mean
15:01:31 <eedri> quaid, to run ie.. but i never tried
15:01:54 <quaid> eedri: I have in the past but don't know if it works now, presuming I can get a distribution of IE
15:02:16 <ewoud> quaid: sufficient suggestions on how to continue?
15:02:33 <ewoud> then I'd like to return to the review of action items
15:03:00 <quaid> yes, thanks, sufficient :)
15:03:44 <ewoud> #topic Review of action items
15:03:47 <ewoud> Rydekull add the jenkins slaves to a list ont he wiki
15:03:49 <ewoud> quaid to setup docs sprint
15:04:02 <ewoud> I added this to the agenda because it felt like we were forgetting to review them
15:04:03 <Rydekull> No update, but you will see an update this week. For sure.
15:04:13 <Rydekull> I've gotten my life sorted, so I should be more active :-)
15:04:43 <ewoud> Rydekull: anything we should be concerned about or just busy with other things?
15:05:02 <Rydekull> Other stuff, my life :-)
15:05:28 <ewoud> I think that's all too familiar for all of us
15:07:57 <ewoud> quaid: any news on the docs sprint?
15:09:15 <ewoud> I'm assuming not
15:09:18 <ewoud> #topic jenkins
15:09:28 <ewoud> let's round up quickly
15:09:41 <ewoud> eedri: I think most improvements are now blocked on rackspace?
15:10:15 <eedri> ewoud, yes
15:10:26 <eedri> ewoud, we would very much like to start running jobs per patch
15:10:33 <eedri> ewoud, but we can't on current infra
15:10:39 <ewoud> eedri: ok
15:10:42 <eedri> ewoud, so we need stronger vms runnign on rackspace
15:11:07 <ewoud> eedri: don't we run jobs for vdsm? or do you want to expand that to engine?
15:11:46 <eedri> ewoud, yes. like findbugs
15:11:54 <eedri> ewoud, it something we see from time to time
15:12:02 <ewoud> eedri: ah yes
15:12:04 <eedri> ewoud, engine commits are on much higer volume
15:12:07 <eedri> ewoud, than vdsm
15:12:07 <ewoud> that's rather CPU intensive
15:12:45 <ewoud> #info would like to run per patch jenkins jobs, blocked on rackspace
15:12:50 <ewoud> #topic other business
15:12:59 <ewoud> anything we missed?
15:13:37 <ewoud> quaid: is the meeting time still OK for you or is it very early for you now?
15:16:38 <ewoud> given the time I'd like to close the meeting and skip the trac review
15:16:52 <ewoud> going once
15:17:00 <ewoud> going twice
15:17:08 <ewoud> gone
15:17:10 <ewoud> #endmeeting