15:04:30 <ewoud> #startmeeting ovirt infra weekly
15:04:30 <ovirtbot> Meeting started Mon Feb 18 15:04:30 2013 UTC.  The chair is ewoud. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:30 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:41 <ewoud> #chair Rydekull quaid dneary
15:04:41 <ovirtbot> Current chairs: Rydekull dneary ewoud quaid
15:04:53 <ewoud> #info eedri unable to attend
15:04:56 <quaid> ewoud: I'll see if I can
15:04:57 <ewoud> #chair dcaro
15:04:57 <ovirtbot> Current chairs: Rydekull dcaro dneary ewoud quaid
15:05:29 <dcaro> sorry I'm late
15:05:45 <ewoud> no problem, we started 30 seconds before you came online
15:05:56 <ewoud> copying the agenda from http://www.ovirt.org/Infrastructure_team_meetings#2013-02-18
15:06:00 <ewoud> Hosting
15:06:01 <ewoud> Puppet
15:06:01 <ewoud> Jenkins
15:06:01 <ewoud> Gerrit
15:06:01 <ewoud> ovirtbot
15:06:03 <ewoud> Other business?
15:06:05 <ewoud> Trac review
15:06:30 <ewoud> #topic hosting
15:06:47 <ewoud> #info alterway01 was reinstalled with centos 6.3
15:07:02 <ewoud> #action quaid to install the teams SSH keys again
15:07:59 <ewoud> #info in the libvirt or ovirt discussion we had a good discussion and concluded we want ovirt
15:08:04 <Rydekull> \o/
15:08:24 <ewoud> http://lists.ovirt.org/pipermail/infra/2013-February/002028.html opening post
15:08:26 <ewoud> http://lists.ovirt.org/pipermail/infra/2013-February/002066.html conclusion
15:08:49 <ewoud> I did notice that oVirt isn't packaged officially for EL6
15:09:26 <ewoud> so do we go for unofficial packages or fedora?
15:09:37 <ewoud> brb
15:10:04 <Rydekull> I'd still say we go for CentOS 6.3, and either use unofficial packages, source or create our own.
15:11:44 <Rydekull> Let's stop the OS discussion, stick with what we said and go on and just do it.
15:12:05 <quaid> +1
15:13:21 <Rydekull> Just time being wasted, imho
15:16:49 <dcaro> I think that the same principle applies here, we should use our supported packages, meaning, that we use fedora, or package it for centos officially...
15:17:03 <dcaro> but I don't care too much
15:18:26 <Rydekull> Then package it, I believe we have quite a large userbase on centos that will applaud it
15:19:42 <dcaro> Ok. I have no previous knowledge of ovirt packaging, who's doing it now?
15:20:26 <Rydekull> I believe there are automated jobs, aswell as some manual parts by mburns and others, but mburns surely knows
15:20:52 <dneary> Hi all
15:20:57 <dneary> Sorry - was in a meeting
15:21:23 <dneary> ewoud, eedri_: Probably means it's reinstalled, but I don't have email about it yet
15:21:44 <ewoud> back
15:22:04 <dcaro> Rydekull: ok, we can ask mburns about how to do it
15:22:12 <mburns> packages are built by the maintainers and then sent to oschreib or mburns to be posted
15:22:49 <ewoud> any ETA? anything we can do to help?
15:23:00 <mburns> oschreib: is working on engine packages
15:23:15 * ewoud tried last weekend but too many unpackaged dependencies
15:27:12 <ewoud> so we want to wait for ovirt 3.2 on EL6 before we start with foreman & puppet, migrations
15:27:41 <Rydekull> Why Wait?
15:27:43 <Rydekull> Just do it?
15:27:54 <ewoud> without packages?
15:28:04 <Rydekull> We have source? We can build packages? What's the issue?
15:28:12 <Rydekull> its still the same oVirt
15:28:41 <ewoud> I tried building, but too little experience with it
15:28:51 <quaid> well, generally the idea of sysadmin work on our type of Linux is as preference to package
15:29:21 <quaid> so it could be ok to proceed with a package we build, not having to wait for it to be in an official repo
15:29:39 <ewoud> if you have more experience I'd like to work together to build packages
15:30:48 <Rydekull> If we are dead set on using packages, which seems quite ridiculous in my mind. We still have the maintainers that we can ask
15:31:08 <Rydekull> "Hey, you're building this for Fedora, are you willing to build it for CentOS too? Or provide me with instructions on how to do it?"
15:31:20 <Rydekull> I dont see why we should wait for that though
15:31:35 <Rydekull> It'll be the same ovirt base regardless
15:31:42 <dneary> quaid, You could try with the original password (it wasn't "password" or "ChangeMe" but it was something like that)
15:31:46 <ewoud> still, upgrading may be harder
15:32:02 <Rydekull> Why?
15:32:06 <dcaro> The idea behind is the same as the idea behind using ovirt, we should know the issues our uses are going through so we can improve all the process
15:32:21 <quaid> dneary: I'm sorting email looking for that, I may have thrown it away
15:32:26 <ewoud> and personally I have a policy of just using packages unless there's a very good reason
15:33:52 * dcaro agrees
15:34:11 <ewoud> especially since the maintainers are working on packages
15:34:14 <Rydekull> So
15:34:22 <Rydekull> How does that differ from anything I've said?
15:34:36 <quaid> Rydekull: I'll pull up the Infra team mission that I think is relevant, but be aware that the idea of running production systems in a packagized Linux but putting in non-packaged code ... that doesn't sit well with a certain type of sysadmin goal
15:34:53 <quaid> http://www.ovirt.org/Infrastructure#Mission_Statement
15:35:22 <quaid> Rydekull: when it comes to a Fedora/EL-type distro, packaging is the accepted professional standard of a sysadmin, at this point
15:35:42 <Rydekull> Yes, up until the point that there are no packages
15:35:45 <quaid> in the future I can see other methods becoming standard, the way we're now using e.g. cartridges on OpenShift
15:35:55 <Rydekull> Which is when you 1. Use source 2. Create Packages
15:36:00 <Rydekull> Its still the same source, regardless
15:36:13 <Rydekull> We're in above situation, since we seem reluctant of "third-party" packages
15:36:14 <quaid> Rydekull: right, and we either use source and have machines that are out spec & arguably harder to run, or we package the code, then proceed
15:36:29 <quaid> I'd vote for using third-party packages, if we can trust them
15:36:30 <Rydekull> And which is why im asying, why dont we just get on with it and ask the maintainers if they can provide packages
15:36:38 <Rydekull> or just create our own?
15:37:06 <quaid> +1 to create our own
15:37:14 <quaid> +1 to pushing maintainers to supply :)
15:37:28 <Rydekull> I'd say, ask maintainers for each required package first
15:37:36 <dcaro> +1 ask mantainers first
15:37:39 <Rydekull> then if we get a negative response, find another solution
15:37:51 <Rydekull> Just stop debating it endlessly :-)
15:38:07 <ewoud> mburns said they're working on it, question is the timeframe
15:40:35 <Rydekull> So we all agree, let's create a list of each package, ask each maintainer if they can provide CentOS packages, ok?
15:40:46 <Rydekull> Who wants ^ assignment?
15:41:30 * quaid a
15:41:47 * quaid dropped off network, is back
15:42:33 <ewoud> quaid: is that a yes?
15:43:15 * quaid is busy on the last assignment of getting sshkeys back on the alterway01 host, sorry
15:43:35 <Rydekull> Ok, fine, i'll contact them
15:43:40 <quaid> oh, I don't know the list of packages to start - if we just make that list on arch@ and ask at the same time?
15:44:29 * ewoud wouldn't know where to start either
15:45:39 <Rydekull> http://resources.ovirt.org/releases/3.2/rpm/Fedora/17/SRPMS/ <-- i'd start there
15:45:41 <ewoud> #action Rydekull to ask for EL6 packages
15:46:47 <ewoud> anything else to discuss?
15:47:08 <ewoud> Rydekull: do you have logins for openstack now?
15:47:14 <Rydekull> Nope
15:47:35 <ewoud> euh, openshift
15:47:35 <Rydekull> quaid is the only one with 'master' access (rhc and webpage) cause he is the 'owner'
15:48:01 * ewoud is having a bad day today
15:48:05 <Rydekull> and my key wont work
15:48:36 <quaid> Rydekull: I added it last week, still not working?
15:48:45 <dneary> Rydekull, I made some space on our instance, which should have solved the issues short-term
15:48:47 <Rydekull> quaid: no, that's why I sent a mail saying "it doesnt work" :-P
15:48:48 <quaid> I don't know of a way to share web UI because it's a single account
15:48:53 <dneary> Just before running out to my plane yesterday
15:48:54 <quaid> ah, haven't seen that email, sorry
15:49:14 <Rydekull> dneary: yeah, but my issue is getting in and trying to sort out the ovirtbot ticket :-)
15:49:25 <dneary> Rydekull, Ah, right
15:49:41 <Rydekull> dneary: and to help out in future issues, naturally
15:50:16 <quaid> Rydekull: btw, do you know that we're not supposed to work directly on the host instance via ssh?
15:50:55 <Rydekull> quaid: well, considering I need to reach its files, I dont see many other ways :-)
15:51:01 <Rydekull> quaid: and test its connections
15:52:01 <quaid> Rydekull: I think most stuff is available via git, although I forget about logs
15:52:18 <Rydekull> same issue there, no pubkey
15:52:19 <Rydekull> :-)
15:52:21 <quaid> Rydekull: it's that the content in ssh is not canonical, so a new push to git can and will overwrite
15:52:34 <quaid> can you try again? I just repasted your key in to the web UI this time
15:53:08 <Rydekull> im using, 847edb45aea84198838f915be6faa066@wiki-ovirt.rhcloud.com
15:53:17 <Rydekull> Permission denied (publickey,gssapi-keyex,gssapi-with-mic).
15:54:45 <goacid> dneary, server delivered, check your mailbox. Sorry for the delay
15:55:08 <quaid> Rydekull: can you do a git checkout?
15:55:23 <quaid> ssh://847edb45aea84198838f915be6faa066@wiki-ovirt.rhcloud.com/~/git/wiki.git/
15:55:28 <ewoud> quaid: can you also ask RH admins for alterway0{0,1}.ovirt.org?
15:55:53 <quaid> ewoud: oh dear, is that just in my /etc/hosts? sorry about that, will file ticket right away
15:56:07 <Rydekull> quaid: well, considering ssh wont work, that wont work either
15:56:10 <ewoud> quaid: it's in my ~/.ssh/config for now, but DNS would be nice :)
15:56:10 <Rydekull> quaid: but, yeah, tried, no
15:56:55 <quaid> Rydekull: ok, I was having a long wait for straight ssh, but I have it working now
15:58:15 * Rydekull also did assume that quaid meant "clone" with "checkout"
15:58:25 <quaid> Rydekull: I just emailed you back with the key I think I'm pasting in, to confirm it isn't missing any characters
15:58:49 <quaid> Rydekull: oh, yes, blame the braing that grew up on cvs and svn :)
15:59:05 <Rydekull> ;-)
15:59:29 <Rydekull> quaid: well, you can also copy it from resources.ovirt.org ~rydekull/.ssh/authorized_keys
15:59:38 <Rydekull> quaid: cause, that works just fine
16:00:15 <quaid> good thx
16:00:56 <quaid> ah -ha, I think I have extra char returns possibly
16:01:20 <dneary> quaid, Did you get in already?
16:01:25 <dneary> goacid, Dosn't work for me
16:01:38 <dneary> It doesn't prompt for a password, I get too many auth failures
16:01:41 <quaid> I haven't been able to yet
16:02:01 <Rydekull> quaid: [wiki-ovirt.rhcloud.com ~]\>
16:02:04 <Rydekull> quaid: \o/
16:02:13 <quaid> dneary: try PreferredAuthentications="password"
16:02:51 <quaid> that is, -o first
16:03:13 <dneary> quaid, Works! Yay!
16:03:31 <dneary> I was trying "PreferredAuthentications=keyboard-interactive"
16:06:17 <Rydekull> Well guys, I'll send that email about the packages, and now I can finally try and fix ovirtbot
16:06:24 <Rydekull> So, I need to head out to a bus, see you
16:06:29 <ewoud> ok, then I think we can close the meeting
16:06:52 <ewoud> any other business?
16:07:41 <ewoud> closing in 3
16:07:44 <ewoud> 2
16:07:46 <ewoud> 1
16:07:49 <ewoud> thanks all
16:07:51 <ewoud> #endmeeting