16:03:59 <mburns> #startmeeting ovirt 3.2 bug review
16:03:59 <ovirtbot> Meeting started Tue Feb  5 16:03:59 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:03:59 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:04:06 <mburns> #topic review
16:04:12 <mburns> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=881006&hide_resolved=1
16:05:04 <mburns> i'd propose that we skip anything in ON_QA
16:05:48 <mgoldboi1> verified as well...
16:05:49 <mgoldboi1> ok
16:05:56 <mgoldboi1> 879180       [NEW
16:06:49 <mburns> yes
16:07:09 <mburns> #info https://bugzilla.redhat.com/show_bug.cgi?id=879180
16:07:17 <mgoldboi1> doesn't seems to be a blocker to me, oschreib
16:07:18 <mgoldboi1> ?
16:07:59 <mburns> #info blocks 869963, but 869963 in ON_QA
16:08:02 <oschreib> sec
16:08:10 <mburns> so i think this is not really a blocker
16:08:34 <oschreib> Looks problematic but not a blokcer
16:09:04 <mburns> it's in networkmanager so we can't really control it anyway
16:09:26 <mburns> i'll remove it from the tracker
16:09:53 <mburns> #info removed from the tracker
16:10:01 <mburns> #topic bug 880768
16:10:15 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=880768
16:10:23 <mburns> oschreib: it's on modified
16:10:29 <mburns> and assigned to you
16:10:38 <mburns> #info assigned to oschreib
16:10:43 <mburns> #info Status:  Modified
16:11:03 <mburns> oschreib: in a build? or need a new build for it?
16:11:14 <oschreib> its in the build
16:11:22 <mburns> so we can move to ON_QA?
16:11:25 <oschreib> fixed already, long time ago AFAIK
16:11:25 <mgoldboi1> oschreib: please move to on_qa
16:11:30 <oschreib> already did
16:11:33 <mgoldboi1> 10x
16:11:39 <mburns> #info moved to ON_QA
16:12:03 <mburns> #topic bug 880996
16:12:06 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=880996
16:12:15 <mburns> #info assigned to ydary
16:12:23 <mburns> #info Status:  Post
16:13:04 <mburns> afaik, we don't actually ship dwh packages...
16:13:13 <mburns> so this shouldn't block 3.2 release...
16:13:18 <mburns> but correct me if i'm wrong
16:14:06 <oschreib> No idea
16:14:18 <mgoldboi1> actually - we should , i suggest mailing the bug to ydary
16:14:19 <oschreib> I didn't knew they had working f18 build
16:15:00 <mburns> it's not posted as part of beta, afaik
16:15:08 <mgoldboi1> http://gerrit.ovirt.org/#/admin/projects/ovirt-dwh
16:15:55 <mgoldboi1> should be something like tech preview in this ver
16:16:08 <mburns> yes, it's there, but not shipped on resources.ovirt.org
16:16:13 <mgoldboi1> anyhow let's clarify it with yaniv
16:16:14 <mburns> i'll ping ydary
16:16:21 <mburns> err...email ydary
16:16:38 <mburns> #info ovirt-dwh not shipped currently, mburns will ping ydary for an update
16:16:40 <ydary> mburns: I'm busy with the build at the moment
16:16:48 <mburns> ydary: ahh, excellent
16:17:05 <mburns> #info ydary working on a build now
16:17:10 <mburns> ok, then we can move on
16:17:17 <oschreib> ydary: so when will you have f18 build?
16:17:37 <mgoldboi1> ydary: is https://bugzilla.redhat.com/show_bug.cgi?id=880996 suppose to be in?
16:19:42 <mburns> #topic Bug 884990
16:19:50 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=884990
16:19:57 <mburns> #info Status New
16:20:05 <mburns> #info Component:  biosdevname
16:20:16 <mburns> #info Fedora doesn't believe this is an issue
16:20:21 <mburns> not a blocker for us IMO
16:20:53 <mgoldboi1> +1
16:21:06 <oschreib> I'm not sure what is the bottom line effect on us
16:21:21 <mburns> it strikes me as a nice to have, but not something we can control
16:21:38 <mburns> we can push them for this, but can't control if or when it gets done
16:22:06 <mburns> oschreib: just means that nics in guests aren't guaranteed to always be in the same order
16:22:15 <mburns> or they could change names
16:22:19 <mburns> eth0-> eth1
16:22:20 <oschreib> so it's not a blokcer
16:22:24 <mgoldboi1> biosdevname can be removed as well
16:22:29 <mgoldboi1> as a workaround
16:22:42 <mburns> don't even need to remove it
16:22:47 <mburns> it ignores what it can't handle
16:22:52 <oschreib> (well, I don't remember nothing like that in the release MUSTs
16:22:56 <mburns> #info removed from tracker, not a blocker)
16:23:24 <mburns> #topic Bug 886087
16:23:25 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=886087
16:23:39 <mburns> #info Status:  Modified
16:24:14 <mburns> merged in ovirt-3.2 branch in gerrit
16:24:24 <mburns> #info merged in ovirt-3.2 branch in gerrit
16:24:57 <oschreib> are we sure?
16:25:16 <mburns> yes, it's merged, i checked gerrit directly
16:25:21 <mburns> checking to see what build it was in
16:26:48 <mburns> included in the latest beta build (4.10.3-6)
16:26:56 <ydary> mburns: oschreib: mgoldboi1: please send me a email and I'll answer you as soon as I can.
16:26:56 <mburns> #info included in the latest beta build (4.10.3-6)
16:27:04 <mburns> ydary: ack, will send email
16:27:12 <mburns> #info moving bug to ON_QA
16:28:23 <mburns> skipping ovirt-node bugs for right now, we'll come back to them at the end
16:28:37 <mburns> #topic Bug 896465
16:28:56 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=896465
16:29:10 <mburns> #info Status:  Modified
16:29:59 <mburns> #info merged in master, but not in engine_3.2
16:30:13 <vfeenstr> Once more:  https://bugzilla.redhat.com/show_bug.cgi?id=907916
16:30:28 <vfeenstr> Blocks migrations F17 <=> F18
16:30:44 <oschreib> mgoldboi1: can you ask sandro to merge it to 3.2 upstream branch?
16:30:51 <mgoldboi1> oschreib: yes
16:31:03 <mgoldboi1> let's just make sure this what has been done
16:31:04 <mburns> mgoldboi1: oschreib:  vfeenstr: ack, and something we should be aware of
16:31:19 <oschreib> mburns: ok, still a blokcer.
16:31:29 <mburns> oops...
16:31:34 <mburns> meant that just for vfeenstr
16:31:45 <mburns> since he was asking about the qemu bug
16:32:15 <mburns> for 896465 -- http://gerrit.ovirt.org/#/c/11701/
16:32:19 <mburns> is already posted
16:32:25 <mgoldboi1> anyhow 907916 is a nice to have
16:32:29 <mgoldboi1> not a blocker
16:32:30 <mburns> but abandoned
16:32:42 <mburns> and not something we can control anyway
16:32:54 <mburns> and we don't do f17->f18 migration anyway, iirc
16:33:08 <mgoldboi1> meant 896465
16:33:26 <mburns> ok, so we should drop 896465 from the tracker?
16:33:39 <mgoldboi1> yes
16:33:53 <mburns> ok, dropped
16:34:06 <mburns> #info dropped from tracker, not a blocker (though it might make it in anyway)
16:34:32 <mburns> #topic Bug 896694
16:34:34 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=896694
16:34:42 <mburns> #info Status:  Modified
16:35:16 <mburns> #info in review, but not yet merged in engine_3.2
16:35:27 <mburns> #info has acks already
16:35:43 <mgoldboi1> oschreib: can you push it
16:36:00 <oschreib> I need to review it first
16:36:27 <mburns> #info oschreib to review and (hopefully) push it
16:36:28 <mgoldboi1> oschreib: sure - take into account it is already in master
16:37:06 <mburns> #topic Bug 901443
16:37:08 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=901443
16:37:20 <mburns> #info engine-setup should prompt for application mode
16:37:28 <mburns> #info Status:  Modified
16:37:34 <oschreib> merged
16:37:39 <oschreib> (preview's bug)
16:37:48 <mburns> #info it's merged
16:37:55 <mburns> oschreib: so just needs to bemoved to ON_QA?
16:38:19 <mburns> and in a build already?
16:38:30 <oschreib> mburns: done
16:38:34 <oschreib> mburns: we should rebuild engine
16:38:40 <mburns> oschreib: ack
16:38:47 <mburns> oschreib: we can discuss that at the end as well
16:38:52 <oschreib> wait
16:39:03 <oschreib> mburns: I;m talking about the preview's bug
16:39:09 <oschreib> not application mode one
16:39:10 <mburns> oh, sorry...
16:40:10 <oschreib> undo?
16:40:26 <mburns> #undo
16:40:26 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x88f93ec>
16:40:36 <mburns> #chair mgoldboi1 oschreib
16:40:36 <ovirtbot> Current chairs: mburns mgoldboi1 oschreib
16:40:58 <oschreib> no idea about this bug
16:41:02 <oschreib> why it's a blocker? mgoldboi1?
16:41:12 <mgoldboi1> somehow missed you here
16:41:16 <mgoldboi1> bz
16:41:20 <mgoldboi1> ?
16:41:55 <oschreib> https://bugzilla.redhat.com/show_bug.cgi?id=901443
16:41:56 <mburns> mgoldboi1: 901443
16:42:22 <mgoldboi1> should be in
16:42:53 <mburns> it's merged in master 24-Jan
16:42:58 <mgoldboi1> oschreib: for gluster..., oschreib can you merge it to 3.2 branch?
16:43:03 <mburns> and i don't see a 3.2 branch clone...
16:43:14 <oschreib> where's the gerrit change?
16:43:23 <mburns> http://gerrit.ovirt.org/#/c/9991/
16:43:28 <mburns> for master
16:43:42 <mburns> #info merged in master, not in 3.2 branch
16:43:49 <oschreib> mgoldboi1: I need time to review it.
16:44:06 <mburns> #info oschreib to review and backport
16:44:07 <mgoldboi1> oschreib: was reviewed and verified numeros times
16:44:11 <mburns> is it a blocker?
16:44:16 <mgoldboi1> yes
16:44:17 <oschreib> the same guy pushed it to master should push it to 3.2
16:44:24 <oschreib> wait
16:44:53 <oschreib> I thought it's for engine_3.2 , Now I see it's already merged in master
16:45:00 <oschreib> I'll be able to do it tomorrow
16:45:07 <oschreib> I'm a bit short in time today
16:45:12 <mgoldboi1> ok
16:45:12 <mburns> ok
16:45:23 <mburns> #info oschreib to merge into 3.2 tomorrow
16:45:47 <mburns> #topic Bug 901531
16:45:51 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=901531
16:46:00 <mburns> #info Deleting one gluster volume from gluster cli triggers deletion of all volumes in engine
16:46:35 <mburns> #info status:  Modified
16:46:43 <mburns> #info merged in master, not sure if it's in 3.2 branch
16:46:52 <mburns> looks like a blocker to me...
16:47:23 <mgoldboi1> +1
16:47:45 <oschreib> we need to ask Sheereish to push it into engine_3.2
16:48:01 <mburns> can one of you follow up?
16:48:15 <mgoldboi1> mburns: i'll
16:48:26 <mgoldboi1> mburns: please add it to action items
16:48:36 <mburns> #action mgoldboi1 to follow up and get it pushed to engine_3.2
16:49:03 <mburns> #topic Bug 906289
16:49:06 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=906289
16:49:18 <mburns> #info [oVirt-webadmin] [network] Non-VM networks shown as VM networks on cluster attachment dialog
16:49:31 <mburns> Status:  Post
16:50:18 <mburns> seems like it *could* go in an async update, but we don't do that very often
16:50:35 <mburns> so i think we should probably try to get it in
16:50:38 <mburns> #info Status:  Post
16:50:42 <mgoldboi1> +1
16:50:52 <mburns> #info under review for master
16:51:11 <mburns> #info no gerrit posting for engine_3.2 yet
16:51:32 <oschreib> I put a note in the bug
16:52:11 <mburns> #agreed it's a blocker, need to get posted and reviewed for 3.2 release
16:52:40 <mburns> #topic Bug 906291
16:52:47 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=906291
16:52:54 <mburns> #info  [oVirt-webadmin] [network] Non-VM networks not being detached from cluster
16:53:03 <mburns> sounds like it's related to the previous one
16:53:38 <mgoldboi1> mburns: around the same are - we need a status update from network team reg their bugs
16:53:49 <mgoldboi1> action item on me
16:53:51 <mburns> #info need update from network team
16:53:56 <mburns> #info mgoldboi1 to track down update
16:54:19 <mburns> #topic Bug 906383
16:54:25 <mburns> #link https://bugzilla.redhat.com/show_bug.cgi?id=906383
16:55:06 <mgoldboi1> mburns: add it to the pack
16:55:24 <mburns> mgoldboi1: even though this is vdsm?
16:55:40 <mburns> patch is in review (and looks ready to be merged)
16:56:20 <mgoldboi1> mburns: networking team, i'll send a mail checking on blockers status for 3.2 to relevant teams
16:56:31 <mgoldboi1> let's just make sure that the list is updated
16:57:00 <mburns> #action mgoldboi1 to follow up on this as well.
16:57:08 <mburns> #topic ovirt-node bugs
16:57:35 <mburns> #link https://bugzilla.redhat.com/showdependencytree.cgi?id=894059&hide_resolved=1
16:58:11 <mburns> #info bugs in post -- are all in various stages of review or posting, will be done hopefully by EOD today
16:58:51 <mgoldboi1> mburns: any reason those are not on the ovirt version tracker?
16:58:56 <mburns> #info bug 843734 -- Assigned -- patch expected shortly, could possibly defer to next release
16:58:59 <mburns> mgoldboi1: they are
16:59:03 <mburns> indirectly
16:59:11 <mgoldboi1> mburns: missed it
16:59:15 <mburns> node bugs were all tied to 894059
16:59:22 <mburns> which is on the 3.2 tracker
16:59:37 <mgoldboi1> ok
17:00:05 <mburns> #info bug 894061 -- patch is mostly ready, just going through last dev testing now, should be posted by EOD for review
17:00:56 <mburns> #info all others are in POST
17:01:07 <mburns> #action mburns to followup on the status of these bugs
17:01:12 <mgoldboi1> mburns: all are blockers?
17:01:18 <mburns> yes
17:01:38 <mgoldboi1> mburns: schedule-wise where do we stand?
17:02:05 <mburns> anything not a blocker is already deferred
17:02:15 <mburns> #topic schedule
17:02:38 <mburns> I think we can have node ready tomorrow (thursday at the latest)
17:02:51 <mburns> we're supposed to be shipping tomorrow
17:03:10 <mburns> what about engine?  vdsm?
17:03:24 <mgoldboi1> let's differ release in a week, to make sure all that we want in is actually in?
17:03:37 <oschreib> +!
17:03:39 <oschreib> +1
17:04:22 <mgoldboi1> i don't see the point of putting the system in stress for the release, we can say that all packages should be built till EOW
17:04:46 <mgoldboi1> and give additional quite period for the beta refresh before releasing on wendesday
17:05:29 <mgoldboi1> mburns: thoughts?
17:05:30 <mburns> mgoldboi1: i agree, based on the bug status
17:05:45 <mburns> need to bring it up on the meeting tomorrow though
17:05:57 <mgoldboi1> looks like in the current status we wont release tomorrow anyhow
17:06:26 <mburns> agreed, but we should target having all the new packages built and ready for EOW
17:06:35 <mgoldboi1> and a delay of less than a week isn't that effective from my experience - it's just puts stress on the system
17:06:43 <mgoldboi1> but let's bring it up tomorroow
17:06:51 <mburns> ack
17:07:45 <mgoldboi1> great - let's continue tomorrow - i'll issue mails till the meeting
17:08:11 <oschreib> cool
17:08:12 <mburns> mgoldboi1: thanks
17:08:33 <mburns> #info Summary:  recommend delaying the release 1 week and get all packages built by EOW
17:09:08 <mburns> anything else?
17:09:44 <oschreib> nope
17:09:59 <mburns> ok, thanks guys
17:10:02 <mburns> #endmeeting