#ovirt: oVirt Infra Team Weekly

Meeting started by quaid at 15:01:19 UTC (full logs).

Meeting summary

  1. Agenda & roll call (quaid, 15:01:30)
    1. http://www.ovirt.org/Infrastructure_team_meetings#2012-01-14 (quaid, 15:01:45)

  2. Hosting (quaid, 15:06:10)
    1. I had a kickoff meeting last Friday with RackSpace for the new hosting there; eedri & dcaro were included (either in the meeting or the materials) (quaid, 15:06:53)
    2. 10 to 15 business days from Friday 11 Jan for the new hosts to arrive (quaid, 15:07:11)
    3. http://etherpad.ovirt.org/p/new_hosting_design_Jan_2013 (quaid, 15:08:45)
    4. ACTION: Need to follow up with Kevin from Alter Way for status (quaid, 15:09:13)
    5. AlterWay servers are being installed and will be delivered on Wednesday (quaid, 15:11:52)
    6. ACTION: quaid to work on final migration plan for list review (quaid, 15:17:38)
    7. http://www.ovirt.org/Adding_a_new_system_administrator_to_a_host (quaid, 15:22:10)

  3. Puppet (quaid, 15:24:25)
    1. dcaro has sent initial Puppet manifests to the list (quaid, 15:24:41)
    2. http://lists.ovirt.org/pipermail/infra/2013-January/001799.html (quaid, 15:25:08)
    3. https://github.com/david-caro/puppet-jenkins (quaid, 15:25:15)
    4. ACTION: Infra team especially ewoud need to review initial Jenkins Puppet manifests (quaid, 15:28:23)
    5. AGREED: We'll install Jenkins manually, then have puppet master enforce the puppet classes and make sure it stays aligned to the configuration (quaid, 15:32:15)
    6. http://docs.puppetlabs.com/guides/best_practices.html (quaid, 15:38:21)
    7. https://github.com/david-caro/puppet-jenkins/tree/master/files (dneary, 15:38:33)
    8. ACTION: dcaro to request Puppet module on Gerrit (quaid, 15:44:46)
    9. AGREED: Puppet repo on Gerrit generally a good idea, will finish detail discussions on list (quaid, 15:45:32)

  4. Jenkins (quaid, 15:45:48)
    1. ACTION: All reply to the on-list request to grant admin access to dcaro (quaid, 15:46:07)
    2. Jenkins migration plan embedded in the overall new hosting design (quaid, 15:46:51)
    3. http://etherpad.ovirt.org/p/new_hosting_design_Jan_2013 (quaid, 15:46:53)
    4. recent job failure on Jenkins are likely due to infrastructure - slow VM response and out of space issues (quaid, 15:48:49)

  5. Gerrit (quaid, 15:50:03)
    1. Gerrit is generally stable currently (quaid, 15:50:23)
    2. AGREED: Still planning to move Gerrit to new hosting after things settle down from the Jenkins and Mailman moves (quaid, 15:51:15)
    3. IDEA: Should do the Gerrit install using the new Foreman/Puppet system (quaid, 15:51:40)
    4. ACTION: quaid to get an SSL Cert for one or more ovirt.org domains (quaid, 15:54:11)

  6. OpenShift - space & admin redundancy (quaid, 15:55:34)
    1. we ran out of space on our OpenShift gear over the weekend, which causes an unhelpful error that dneary fixed by cleaning up things (quaid, 15:56:00)
    2. ACTION: quaid is asking #openshift for a much bigger quota (quaid, 15:56:12)
    3. Bigger quota is now here, thanks dneary (quaid, 15:58:20)
    4. 'rhc log-clean' helps keep things clean (quaid, 15:58:31)
    5. IDEA: can we automate openshift cleanup using cron? (quaid, 15:58:42)
    6. ACTION: quaid needs to figure out how to add other admins to OpenShift, then add folks from Infra (quaid, 15:59:13)
    7. IDEA: can we use OpenShift log rotation automagic? (quaid, 15:59:43)
    8. IDEA: could use cron cartridge for our own log rotation (quaid, 16:01:42)


Meeting ended at 16:08:53 UTC (full logs).

Action items

  1. Need to follow up with Kevin from Alter Way for status
  2. quaid to work on final migration plan for list review
  3. Infra team especially ewoud need to review initial Jenkins Puppet manifests
  4. dcaro to request Puppet module on Gerrit
  5. All reply to the on-list request to grant admin access to dcaro
  6. quaid to get an SSL Cert for one or more ovirt.org domains
  7. quaid is asking #openshift for a much bigger quota
  8. quaid needs to figure out how to add other admins to OpenShift, then add folks from Infra


Action items, by person

  1. dcaro
    1. dcaro to request Puppet module on Gerrit
    2. All reply to the on-list request to grant admin access to dcaro
  2. ewoud
    1. Infra team especially ewoud need to review initial Jenkins Puppet manifests
  3. quaid
    1. quaid to work on final migration plan for list review
    2. quaid to get an SSL Cert for one or more ovirt.org domains
    3. quaid is asking #openshift for a much bigger quota
    4. quaid needs to figure out how to add other admins to OpenShift, then add folks from Infra


People present (lines said)

  1. quaid (127)
  2. eedri (25)
  3. dneary (22)
  4. dcaro (10)
  5. goacid (6)
  6. ale (4)
  7. ovirtbot (3)
  8. vfeenstr (2)
  9. ewoud (2)
  10. itamar (2)
  11. myoung34 (2)
  12. mburns (1)


Generated by MeetBot 0.1.4.