15:01:57 <mburns> #startmeeting oVirt Weekly Sync
15:01:57 <ovirtbot> Meeting started Wed Jan  9 15:01:57 2013 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:57 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:02 <mburns> #topic agenda and roll call
15:02:12 <mburns> * Release Status
15:02:17 <mburns> * Sub project reports
15:02:22 <mburns> * workshops
15:02:58 * dneary here
15:03:17 * lh is here
15:03:18 * garrett is here
15:03:36 <mburns> #chair mgoldboi quaid
15:03:37 <ovirtbot> Current chairs: mburns mgoldboi quaid
15:03:41 <lh> mburns, i have a pretty horrible cold and would like to return to bed. can we discuss workshops first please?
15:03:50 <mburns> lh sure
15:03:53 * dustins here
15:03:58 * mgoldboi here
15:04:24 * aglitke1 here
15:04:25 <lh> mburns, awesome, thanks
15:04:29 <quaid> meeting?
15:04:33 <mburns> #topic workshops
15:04:36 * quaid is here now
15:04:42 <mburns> lh: go ahead
15:05:14 <dneary> mburns, I can take this
15:05:15 <lh> Great
15:05:20 <dneary> lh is on another call
15:05:25 <lh> dneary, if you can that's great.
15:05:32 <dneary> (although she may be keeping an eye on this too)
15:05:44 <dneary> Ah - there you are :)
15:05:54 <dneary> OK - statatus on Sunnyvale workshop:
15:06:01 <lh> dneary, please do take it away. i will stick around until you're done and then head back to bed.
15:06:54 <dneary> #info NetApp workshop (Jan 22-24) is mostly ready to go. USB keys ordered, facilities arranged, schedule online
15:07:22 <mburns> #chair dneary
15:07:22 <ovirtbot> Current chairs: dneary mburns mgoldboi quaid
15:07:23 <dneary> #info Current activities are mostly around organising of board meeting, and co-ordinating burn-in of USB keys with latest pre-release version of 3.2
15:07:28 <dneary> #undo
15:07:28 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x93e288c>
15:07:28 <mburns> #info NetApp workshop (Jan 22-24) is mostly ready to go. USB keys ordered, facilities arranged, schedule online
15:07:30 <dneary> #info Current activities are mostly around organising of board meeting, and co-ordinating burn-in of USB keys with latest pre-release version of 3.2
15:07:31 <dneary> #undo
15:07:31 <ovirtbot> Removing item from minutes: <MeetBot.items.Info object at 0x93f56cc>
15:07:34 <dneary> #info NetApp workshop (Jan 22-24) is mostly ready to go. USB keys ordered, facilities arranged, schedule online
15:07:36 <dneary> #info Current activities are mostly around organising of board meeting, and co-ordinating burn-in of USB keys with latest pre-release version of 3.2
15:07:38 <mburns> heh...
15:07:40 <dneary> There we go...
15:08:22 <dneary> #info Accommodation block has expired - if you need a room for the dates of the conference, you should call up ASAP to ensure availability, and we cannot guarantee the rate any more
15:09:08 <dneary> #info Registration status: 63 registered, capacity is 100. ~20-25 Red Hatters, ~40 non-Red Hatters
15:09:57 <dneary> #info Registration will close on January 15th, due to our requirement to finalise numbers for catering, and get visitor badges made
15:10:05 <dneary> That's COB, PST
15:10:39 <dneary> Off the record, we can accept registrations for a couple of days after that, but the catering order has a hard limit on the 15th
15:10:52 <quaid> what happens for the inevitable drop-ins?
15:11:10 <quaid> we'll have some blank badges and tell them to stay hungry? ;-D
15:11:14 <mburns> maybe take # reg and add 5 or 10?
15:11:50 <dneary> #info Currently promoting the workshop to the Bay Area clouderati, and getting some decent traction this week (some Citrix/CloudStack sign-ups, one Inktank sign-up, and promising feedback from Cloudfoundry)
15:11:59 <lh> They need to be pre-registered with NetApp security, so no dice for walk ins
15:12:07 * lh will see what we can do about late adds, though
15:12:27 <dneary> quaid, What lh said for walk-ins. We can add a small number of late regs, but not a lot
15:12:28 <lh> I make no guarantees, they sound firm on no one after the 15th
15:12:52 <dneary> I am aware of 2-3 sign-ups who will not be attending already, and have let us know, so we will have some margin on the reg numbers anyway
15:13:31 <mgoldboi> dneary: just a small update on the ovirt live (usb)
15:13:38 <dneary> Regardless, anyone who wants to get past security (and that includes speakers, board members, etc) needs to sign up before the 15th.
15:13:42 <dneary> Hi jb_netapp!
15:13:50 <dneary> Yes mgoldboi?
15:13:52 <jb_netapp> Hi!
15:13:54 <mgoldboi> dneary: it has been uploaded to http://resources.ovirt.org/releases/3.2/tools/ovirt-live-1.0.iso
15:14:16 * sgordon is fashionably late
15:14:19 <dneary> mgoldboi, Is this an F18 prerelease?
15:14:23 <jb_netapp> yes, please listen to dneary in this regard
15:14:24 <mgoldboi> dneary: RN and wiki update will be done later today- but if anyone wants to start using it...
15:14:28 <mgoldboi> dneary: yes
15:14:32 <dneary> jb_netapp, we were just talking about you
15:14:43 <sgordon> mgoldboi, is there content in git/gerrit for ovirt-live now?
15:15:15 <mgoldboi> sgordon: this version is being in it's late review faze
15:15:27 <mgoldboi> sgordon: but it's there on gerrit
15:15:37 <sgordon> mgoldboi, hmm is it?
15:15:44 <sgordon> because i pulled it and it looks empty
15:15:46 * sgordon pokes
15:16:03 <mgoldboi> sgordon: http://gerrit.ovirt.org/#/c/9733/
15:16:17 <dneary> mburns, End of update, I think
15:16:20 <dneary> Any Qs?
15:16:29 * mburns pauses for questions
15:16:44 * mgoldboi blocks
15:16:47 <sgordon> mgoldboi, right so it hasn't been merged yet
15:16:49 <sgordon> bummer
15:16:54 <dneary> I would appreciate the help of all here on promoting the workshop within your personal networks this week as a last push for registrations - I'd like to see us go over 80.
15:17:02 <mburns> sgordon: http://gerrit.ovirt.org/#/c/9733/
15:17:14 <mgoldboi> sgordon: you can pull it and test it - this is the recipe
15:17:34 <mgoldboi> sgordon: a "compiled" version has been uploaded which is using this patch
15:17:35 <sgordon> mburns, yeah i know - but it's been in review for over a month
15:17:51 <sgordon> any interested party who checks out the repo gets no files
15:17:56 <sgordon> unless they know to go digging
15:18:02 <mburns> oops.../me didn't read back...
15:18:09 <mburns> ok, any other questions on the workshop?
15:18:39 <mgoldboi> sgordon: patches are welcome
15:18:44 * jb_netapp echos dneary request to sign up for security access and help to promote
15:19:04 <mburns> ok, moving on to the release status
15:19:10 <mburns> #topic release status
15:19:17 <dneary> The meat in the meeting
15:19:31 <lh> dneary, thanks
15:19:36 <mgoldboi> mburns: where do we start?
15:19:41 <dneary> lh, No problem
15:19:45 <mburns> so, today is supposed to be the release date, but that's obviously not happening
15:19:59 <dneary> lh, I will come back to Intel China workshop afterwards
15:20:12 <lh> dneary, perfect, will read logs
15:20:12 <mburns> mgoldboi: depends, do you want good stuff first? or bad stuff first?
15:20:31 <mgoldboi> mburns: we are waiting to fedora 18 GA anyhow
15:20:36 <mburns> mgoldboi: right
15:20:48 <mburns> mgoldboi: lets do the bad news first...
15:21:02 <mburns> #info not making 2013-01-09 release date
15:21:11 <mburns> #info status update for ovirt-node
15:21:37 <mburns> #info found some late breaking blocking issues with ovirt-node and move to F18
15:21:53 <mburns> #info some around selinux changes, some around various other component changes
15:22:15 <mgoldboi> mburns: we can't release ovirt 3.2 before F18, release date should be at least after F18 GA (current - 2013-01-15)
15:22:56 <mgoldboi> mburns: dropped - a week after...
15:23:01 <itamar> did we release a beta version? test day? these can happen before GA date of fedora...
15:23:03 <mburns> #info patches are in review now that should fix them
15:23:29 <mburns> we hope to have a build ready today
15:23:54 <mburns> itamar: not yet, hope to have it posted today/tomorrow
15:24:00 <mgoldboi> itamar: we were waiting with ovirt-node for the beta, but i think we need a deadline here.
15:24:04 <mburns> mgoldboi: do we have beta builds for engine, vdsm, etc...?
15:24:24 <mgoldboi> mburns: nighties till we branch
15:24:35 <mgoldboi> mburns: branch should happen in beta
15:24:41 <mburns> mgoldboi: you're ready to branch, now, right?
15:24:59 <mgoldboi> mburns: basically yes
15:25:34 <karimb> hi gus, is it expected that ovirt or rhev web interface is really-realy slow with iexplorer?
15:25:47 <mburns> mgoldboi: ok, can you start that process of branching and getting builds ready for beta?
15:26:05 <dneary> We definitely need to ship a beta version
15:26:12 <dneary> It was due to ship 28/12
15:26:18 <mburns> i need beta builds for vdsm and ovirt-host-deploy to include in the build of ovirt-node
15:26:30 <mburns> dneary: yes, ovirt-node hit issues between the shutdown and f18 move
15:26:48 <aglitke1> Is there any separation between Alpha and Beta other than time?
15:27:03 <aglitke1> Any requirements in order to call it Beta
15:27:10 <mburns> aglitke1: should be formal builds to be *beta*
15:27:21 <aglitke1> mburns: ok, thanks
15:27:33 <mburns> aglitke1: and in theory, more stable
15:28:28 <mgoldboi> aglitke1: i dont' think we have a release criteria for beta - beside features complition
15:28:44 <mgoldboi> aglitke1: but this is where stabilization starts...
15:28:50 <itamar> and any feature which isn't it, missed the boat i think...
15:28:53 <aglitke1> ok.  Just wanted to check if that was established yet.  Thanks for the details.
15:29:07 <aglitke1> itamar: Yeah, I would say so.
15:29:10 <itamar> only question is do we branch on beta build, and backport only critical bug fixes
15:29:40 <mgoldboi> itamar: if we want to ship it soon, that's the way
15:30:01 <mburns> itamar: yes, branch now, build beta from the branches, and only backport critical fixes
15:30:52 <itamar> then i suggest we send an email beta will be on say, monday, branches for relevant projects branches should be taken
15:32:15 <mburns> itamar: ok, makes sense
15:32:29 <mgoldboi> mburns: test day?
15:33:03 <mburns> mgoldboi: either wednesday next week, or monday the week after?
15:33:19 <mgoldboi> mburns: i think we had a volunteer for organizing it right?
15:33:41 <mburns> mgoldboi: i don't think...
15:34:12 * mgoldboi wonders if anyone can pick this glove
15:35:24 <itamar> monday week after some of us are traveling to ovirt workshop in sunneyvale, but wednesday may be too soon if we build on monday beta, need to pass sanity before inviting all for test day
15:36:14 <mburns> itamar: right, i'm travelling that day too...
15:36:57 <mburns> itamar: maybe make it thursday the following week when we have the breakout day for the workshop
15:37:17 <mburns> (24th)
15:38:12 <mburns> #info beta branch for all packages due by Monday January 14
15:38:26 <mburns> #info beta posted by Tuesday Jan 15?
15:39:37 <mburns> any objections to doing test day on the 24th?
15:40:41 <mgoldboi> mburns: looks good
15:40:56 <mburns> #info test day 2013-01-24
15:41:10 <mburns> any volunteers for coordinating it?
15:42:00 <sgordon> karimb, what version of IE?
15:42:17 <karimb> IE7
15:42:34 <sgordon> karimb, then yes - the JavaScript engine in IE7 is very slow
15:43:02 <karimb> sgordon, and there s no known workaround around it?
15:43:17 <mburns> ok, community organized test day
15:43:45 <mburns> mgoldboi: any other updates from the engine side?
15:43:57 <sgordon> karimb, not really - the webadmin portal makes extensive use of GWT and therefore JavaScript - i think we recommend at *least* IE8 preferably higher
15:44:07 <mgoldboi> mgoldboi: nothing in particular
15:44:14 <karimb> sgordon, ok...
15:44:16 <mburns> ok
15:44:38 <mburns> anything else from the release standpoint?
15:44:53 <karimb> sgordon, thank you
15:45:08 <aglitke1> mburns: yes.
15:45:16 <aglitke1> Do we want to set a new target release date?
15:45:27 <mburns> aglitke1: ahh, thanks
15:45:30 <mgoldboi> aglitke1: importent...
15:45:32 <mburns> forgot that part
15:45:35 <aglitke1> :)
15:45:36 <sgordon> >:D
15:46:14 <mburns> i'm thinking either 30-Jan or 6-Feb
15:46:31 <mburns> 30-jan is close if there are issues from the test day
15:46:46 <mburns> both should be fine even if f18 slips further...
15:47:34 <mburns> any thoughts on either date?
15:47:36 <aglitke1> I want to avoid another slip but Feb 6 is a pretty big slip.
15:48:04 <aglitke1> No particular preference.
15:48:05 <dneary> Jan 30 is just before FOSDEM, which would be nice
15:48:26 <aglitke1> Any holidays to worry about?
15:48:35 <mburns> nothing in the US
15:48:58 <aglitke1> itamar1: Any upcoming holidays in IL that could interfere with a release?
15:49:09 <mgoldboi> aglitke1: election day in israel, nothing other than it
15:49:10 <aglitke1> Thinking either Jan 30 or Feb 6
15:49:34 <mgoldboi> mburns: let's push to jan 30
15:49:56 <mburns> works for me
15:50:00 <mburns> any objections?
15:50:00 <aglitke1> +1
15:50:22 <itamar1> +1
15:50:41 <mburns> #agreed release date target set for 30-Jan
15:51:18 <mburns> anything else around the release status?
15:51:49 <itamar1> moran, will beta include .elt6, or only later and prior to GA?
15:52:09 <mgoldboi> itamar1: we are working on it, we need to package jboss....
15:52:24 <mburns> #action mburns to update release page and send communication to lists
15:52:33 <mgoldboi> itamar1: as said in the mailing list - target is GA, hopefully can make it for beta
15:55:18 <mburns> imo, i don't think that blocks beta
15:55:36 <mburns> ok, moving on
15:55:40 <mburns> #topic infra report
15:55:50 <mburns> quaid: anything to report?
15:56:06 <quaid> hmm
15:56:17 <quaid> #info working on details of new hosting design
15:56:50 * quaid getting link
15:57:47 <quaid> http://etherpad.ovirt.org/p/new_hosting_design_Jan_2013
15:58:31 <quaid> #info we'll talk on arch@ about service cutover dates & such
15:59:54 <quaid> all for now, sorry, wasn't fully prepared
16:00:27 <mburns> #topic workshop - China
16:00:42 <mburns> dneary: you said you wanted to circle back around and discuss this, right?
16:01:00 <oschreib_> mburns: I'm sorry, I thought the meeting is now.
16:01:00 <dneary> yup
16:01:05 <mburns> oschreib_: ;-)
16:01:11 <oschreib_> (TZ diff sucks)
16:01:17 <mburns> oschreib_: no worries
16:01:21 <dneary> OK
16:01:27 <oschreib_> any decision about beta?
16:01:38 <dneary> We have dates for a workshop in China, but the planning is in a very early stage at this point
16:02:16 <dneary> We need to put out a call for content, and I would like to discuss with the board during the board meeting whether the workshops are the best way to promote the product.
16:02:34 <mburns> dneary: what are the dates?
16:02:35 <dneary> Expect more movement on this by next week
16:02:53 <mburns> oschreib_: branching and builds to be done by monday (14-jan)
16:02:54 <dneary> 20-21 March
16:02:59 <mburns> beta posting on tuesday
16:03:07 <mburns> test day 24-jan
16:03:10 <mburns> ga 30-jan
16:03:19 <oschreib_> k. when will node be ready?
16:03:29 <mburns> #info dates are set for workshop in China, but very early in the process (20-21 March)
16:03:30 <dneary> 7 weeks lead time for a workshop is very short - we're getting close to the time when we would need to push back dates, if we don't get started organising now.
16:03:48 <mburns> #info need call for content, discussion on whether workshops are the right way to go about this
16:04:00 <mburns> dneary: i agree, 7 weeks is short
16:04:07 <mburns> do we know where the workshop is going to be?
16:04:18 <dneary> Shanghai
16:04:34 <mburns> oschreib_: we're working on a couple patches now that should let us work on f18, then we have some verification and smoke testing to do
16:04:50 <mburns> #info workshop will be in Shanghai
16:05:02 <mburns> dneary: ok, anything else?
16:05:23 <dneary> That's about it
16:06:04 <mburns> ok, thanks
16:06:13 <mburns> #topic other topics
16:06:16 <mburns> anything else to discuss?
16:08:00 <mburns> going once...
16:09:20 <mburns> twice..
16:09:36 <mburns> gone.
16:09:38 <mburns> thanks all
16:09:41 <mburns> #endmeeting