15:00:55 <mburns> #startmeeting oVirt Weekly sync
15:00:55 <ovirtbot> Meeting started Wed Dec 12 15:00:55 2012 UTC.  The chair is mburns. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <ovirtbot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:03 <mburns> #chair oschreib_ quaid dneary
15:01:03 <ovirtbot> Current chairs: dneary mburns oschreib_ quaid
15:01:04 <oschreib_> dneary: I don't think so
15:01:08 <oschreib_> :)
15:01:14 <mburns> #topic agenda and roll call
15:01:19 <oschreib_> last time I did it no one came....
15:01:21 * oschreib_ here
15:01:22 <dneary> oschreib_, mburns is doing the honours, I guess...
15:01:36 * dneary is here
15:01:46 <mburns> * Release Status
15:01:52 <mburns> * sub project Reports
15:01:54 <dneary> Schroedinger might be here.
15:01:58 <mburns> * Workshop updates
15:02:03 * dustins here
15:02:06 <vfeenstr> What about his cat? :D
15:02:13 <vfeenstr> SCNR
15:02:19 <oschreib_> vfeenstr: well, you can check
15:02:26 <vfeenstr> VDSM 3.2 was tagged FYI
15:03:51 * mgoldboi here
15:03:59 <vfeenstr> http://gerrit.ovirt.org/gitweb?p=vdsm.git;a=shortlog;h=refs/heads/ovirt-3.2
15:04:17 <mburns> #topic Release Status
15:04:27 <mburns> #info Code Freeze is scheduled for today
15:04:47 <dneary> mburns, Great weather for it (it's -2°C here)
15:05:02 * dneary keeps quiet
15:05:15 <mburns> #info projects need to branch so that we're working from a stable place
15:05:24 * lh here
15:05:26 <mburns> dneary: heh...it's 31 F here
15:05:36 <mburns> which is ~ -1 or -2 C
15:05:37 <dneary> mburns, That's cold, right?
15:05:42 <oschreib_> are we sure we're ready for code freeze?
15:05:52 <mburns> oschreib_: that's what we're here to discuss
15:05:54 <dneary> Closer to -1.
15:06:13 <mburns> #info vdsm has already branched
15:06:16 <oschreib_> well, it's 20 C here, and I consider it cold.
15:06:21 <vfeenstr> 19C here in Tel Aviv :-)
15:06:31 <mburns> #info node will likely be ready by EOD
15:06:43 <mburns> mgoldboi: oschreib_: what about engine?
15:06:46 <mburns> ready? not ready?
15:06:47 <vfeenstr> but tomorrow I go back to the cold Brno (-6C)
15:07:26 <vfeenstr> who's going create the 3.2 branch for the guest agent?
15:07:29 <oschreib_> mgoldboi isn't here I afraid
15:07:35 <mgoldboi> oschreib_: her
15:07:40 <oschreib_> ooops
15:07:41 <oschreib_> :)
15:07:50 <mburns> ;-)
15:08:11 <vfeenstr> oschreib_: it's warm
15:08:14 <mburns> vfeenstr: package maintainers generally need to create the branch
15:08:21 <mgoldboi> mburns: hard to answer, feature wise - iguess we are
15:08:27 <vfeenstr> Well that's the issue with ga at the moment
15:08:50 <vfeenstr> we need an active maintainer
15:08:57 <vfeenstr> for the guest agent
15:09:27 <mburns> vfeenstr: i can create the branch, i think, if we need it
15:09:43 <vfeenstr> well there have been commits, and currently there's no 3.1 branch
15:09:46 <vfeenstr> there's only master
15:09:47 <mburns> but we should work through either arch@ or engine-devel@ to get a maintainer chosen
15:09:53 <vfeenstr> I think it would be a good idea to get started on it
15:10:08 <mgoldboi> oschreib_: can you branch ovirt-engine?
15:10:19 <oschreib_> sure I can
15:10:23 <oschreib_> if we decide to do it
15:10:40 <mburns> sounds like the major projects are ready
15:10:50 <mburns> what about sdk/cli?
15:11:02 <mburns> and mom
15:13:36 <mburns> ok...
15:13:47 <fsimonce> mburns, vdsm was tagged yesterday (4.10.3) and there's a fedora (18) build... if nothing else pops up, this is our rc
15:13:57 <mburns> fsimonce: good to know
15:14:06 <mburns> thanks
15:14:52 <mburns> i'm going to assume that sdk/cli are ready (or close enough) that we can freeze
15:15:04 <mburns> same with mom
15:15:20 <mburns> any objections to declaring this our code freeze?
15:15:44 <mburns> oschreib_: mgoldboi:  you both seemed a bit hesitant...
15:16:43 <mburns> any concerns?
15:16:51 <mgoldboi> mburns: well, we are a bit unstable because of fedora pending release
15:17:04 <mgoldboi> mburns: do we now the current ga date for it?
15:17:32 <mgoldboi> mburns: we need to make sure we are going according to it, if we are planned to be based on it
15:17:34 <mburns> mgoldboi: fedora is scheduled to ship 08-Jan
15:17:49 <mburns> we're current scheduled for 09-Jan
15:18:10 <mgoldboi> mburns: ok
15:18:46 <mgoldboi> mburns: i think we are ready to branch, but i feel people haven't played enough with this version
15:19:07 <mgoldboi> mburns: and we don't know current quality status
15:19:09 <mburns> mgoldboi: right, because we don't have any alpha or beta out there, just nightly
15:19:40 <mgoldboi> mburns: so first step is to go with alpha and maybe branch a bit later?
15:20:03 <mburns> mgoldboi: we tried that a couple weeks ago, and never got builds for anything together to get them posted
15:20:40 <mburns> mgoldboi: if we decide to do alpha, then ga *will* slip
15:21:22 * mburns would really like to have 3.2 ready to go for the workshop at NetApp in January
15:21:49 <mgoldboi> mburns: why not take a nightly and give it as alpha?
15:22:07 <mburns> mgoldboi: we could, but 2 weeks ago, we didn't have nightlies on F18
15:22:36 <mburns> and currently, we don't have ovirt-node f18 builds in the nightly either (though i'm trying to fix that now)
15:23:35 <mgoldboi> mburns: all that i'm saying is that branching will create an overhead of double committing and if quality isn't there, that could be a hussle
15:23:57 <mburns> would people feel better about saying alpha this week, then freeze and beta next week?
15:24:32 <oschreib_> +1
15:24:42 <mgoldboi> mburns: we need to communicate this version to community, which we didn't do so far
15:25:22 <mgoldboi> mburns: we were all very busy - but i think we need to focus on people getting it and start giving feedback if needed
15:25:26 <mburns> any objections to doing alpha this week, then beta next week?
15:25:51 <mburns> #info discussion between alpha this week and beta/freeze next week
15:26:06 <mburns> #info impact, would delay GA by at least 1 week
15:26:54 <oschreib_> so no branching yet?
15:27:21 <mburns> no dissenting opinions, so delay freeze and beta
15:27:37 <mburns> #agreed no beta or code freeze this week, will try for next week
15:27:51 <mburns> #info and ship and alpha version this week instead
15:28:15 <mburns> oschreib_: can you pull together the packages for the alpha and post them?
15:28:28 <mburns> other than ovirt-node, which i'll handle later today
15:28:47 <oschreib_> basically, what do we want people to do
15:28:48 <oschreib_> ?
15:28:52 <mgoldboi> mburns: don't we have all relevant packages on the nightly? what are we missing?
15:28:55 <oschreib_> build their packages to fedora 18?
15:29:10 <mburns> mgoldboi: ovirt-node isn't there...
15:29:15 <mburns> not sure if we're missing any others
15:29:29 <mburns> but we should have them in another location than nightly
15:29:52 <mburns> oschreib_: we want people to start playing around with the new version on Fedora 18
15:31:08 <oschreib_> so, why can't we just cp -r nightly alpha ?
15:31:27 <mgoldboi> mburns: ok, looking at http://resources.ovirt.org/releases/nightly/rpm/Fedora/18/ i think we are missing only ovirt-node there
15:31:30 <mburns> oschreib_: you can
15:31:45 <mburns> oschreib_: and i'll get ovirt-node uploaded there, once it's built
15:31:48 <mgoldboi> mburns: and guest-agent
15:31:56 <oschreib_> cool
15:32:00 <mburns> ok, so we need to get a guest-agent build up too
15:32:13 <mgoldboi> mburns: great so we have our alpha content, we need just to make the repo for it
15:32:25 <mburns> mgoldboi: yep
15:32:27 <mburns> and announce it
15:32:33 <mburns> i'll handle the announcement tomorrow
15:32:40 <vfeenstr> it would be nice to have guest agent nightlies
15:32:51 <mgoldboi> vfeenstr: on your hands
15:33:03 <mgoldboi> ?
15:33:07 <vfeenstr> I am just mentioning it
15:33:18 <mburns> #action oschreib_ to setup repo for nightly
15:33:25 <vfeenstr> I know there's a lot I can do, however I need also community backing for that
15:33:41 <mburns> #action mburns to get ovirt-node and ovirt-node-iso builds uploaded to that repo
15:33:58 <mburns> who is going to get the guest agent builds together?
15:34:00 <vfeenstr> right now I am quite new to the project, I am not expecting everything to happen at once :-)
15:34:10 <mburns> oschreib_: i think we only want f18 builds in the alpha...
15:34:21 <mgoldboi> vfeenstr: i think all in favor to put it in as well - any objections to add guest-agent to nightly builds?
15:34:44 * mburns thinks it's a no-brainer to add a nightly build for guest-agent
15:35:08 <mburns> it's just a matter of getting someone the access and time to create it
15:35:23 <mgoldboi> vfeenstr: can you take it eedri and have a look?
15:35:38 <mburns> access is easy, just send mail to infra to get access
15:36:13 <mburns> ok, so to summarize:
15:36:24 <mburns> 1.  delay beta, freeze, and branch until next week
15:36:41 <mburns> 2.  create alpha release and post tomorrow
15:36:49 <mburns> 3.  delay GA by 1 week
15:37:01 <mburns> anything else to discuss w.r.t. the release status?
15:37:45 <mgoldboi> mburns: are you taking care of announcing?
15:37:47 <polfilm> there is a windows bug with the console related to mouse. any chance to get new build?
15:38:04 <mburns> #action mburns to announce the alpha availability and update dates on the wiki
15:38:09 <mburns> mgoldboi: yes
15:38:13 <mgoldboi> mburns: 10x
15:38:26 <mgoldboi> oschreib_: are you good with creating the repo?
15:38:35 <mburns> polfilm: is there a bug filed?
15:38:36 <oschreib_> I'll be ok
15:39:07 <polfilm> Spice got it fixed Dec 5th. just a matter of compiling new windows binaries
15:39:14 <mburns> ok, anything else for release status?
15:39:38 <mgoldboi> mburns: what is the timeframe for ovirt-node,  any reason to delay announcement for tomorrow?
15:40:01 <mburns> mgoldboi: we have one patch set still being reviewed (>100 patches)
15:40:09 <mburns> once that gets in, i'll start the build process
15:40:24 <mburns> but it's likely that the build won't get done today
15:40:30 <mburns> if it does, i'll send the announcement early
15:40:39 <mgoldboi> mburns: ok, thanks
15:40:58 <mgoldboi> oschreib_: can you make the repo ready for today?
15:41:12 <oschreib_> mgoldboi: if it's just copy yes
15:41:16 <mburns> polfilm: can you send me the bug number, and i'll try to follow up with the spice guys
15:41:26 <mburns> who's building guest-agent?
15:41:32 <oschreib_> mburns: /releases is in the same host?
15:41:51 <mburns> oschreib_: think you need to go to resources.ovirt.org
15:41:59 <mburns> that's the linode instance
15:43:13 <mburns> ok, moving on to the workshops
15:43:17 <mburns> #topic Workshops
15:43:26 <mburns> dneary: lh:  updates?
15:44:13 <lh> mburns, All systems are go for NetApp on 22-24 January
15:44:21 <lh> We are working on ordering attendee gifts
15:44:28 <lh> Folks need to get registered no later than 13 January
15:44:37 <mburns> #info all systems go for NetApp
15:44:50 <mburns> #info registration is open -- closes 13 January
15:45:01 <lh> Full details on the CFP, registration, venue, etc. are at http://wiki.ovirt.org/NetApp_Workshop_January_2013
15:45:15 <mburns> #info workshop runs 2013-01-22 -> 2013-01-24
15:45:21 <lh> dneary, any comments you want to make on the CFP?
15:45:40 <lh> Board Meeting will be held on 24 January and invitations have been sent out to all of the individual board members
15:45:43 <dneary> I was just this second sending out a mail merge
15:45:52 <dneary> to attendees at the first workshop in 2011
15:45:56 <lh> promotion proceeds apace via NetApp PR, the OVA and IBM's channels
15:46:02 <lh> dneary, ++
15:46:03 <mburns> #info board meeting to be held on 24 January
15:46:22 <dneary> Call for Papers: I would live to see some proposals from people related to oVirt use cases, and integrating with oVirt through both RESTful APIs and plug-ins
15:46:24 <lh> We will have an evening reception at the nearby Country Inn and Suites on Wednesday, 23 January
15:46:33 <lh> I am working on that - I want to make sure they can cater kosher
15:46:44 <mburns> dneary: when does cfp close?
15:46:45 <lh> But reception time is firm
15:46:46 <dneary> Anyone working with the oVirt project who can give insight into working with the project would be great, for example
15:46:56 <dneary> mburns, CfP closes on Friday
15:47:12 <dneary> But the goal is simply to allow us to have a provisional schedule by the end of next week
15:47:22 <mburns> #info CFP closes this Friday
15:47:28 <dneary> If I get a proposal on Saturday, Sunday or Monday it will be considered
15:47:31 <mburns> ok, so i need to get talk proposals in...
15:47:47 <mburns> #info evening event planned for Wednesday 23, January
15:47:51 <lh> That's all I have on upcoming workshops unless folks have questions re: netapp
15:47:51 <dneary> mburns, Yes, please
15:48:34 <mburns> dneary: maybe i'll just wait, and see what we need to have talks on and can fill in those areas...
15:48:55 <dneary> lh, I'd like to add that registration closes one week before the event - I am encouraging people to register early.
15:49:17 <dneary> mburns, If everyone just waits, there isn't much opportunity for crafting a schedule
15:50:00 <dneary> I would prefer to have too many proposals and have to adjudicate
15:50:22 <dneary> mgoldboi, For example, I would really appreciate it if you could put in a proposal for the 2h hands-on workshop
15:51:13 <mburns> dneary: do we have an MC for the workshop?
15:51:32 <mgoldboi> dneary: what do you mean by proposal?
15:52:10 <lh> mburns, carl trieloff will be attending from RH so he will MC
15:52:30 <mburns> ok, works for me
15:52:44 <mburns> #info people are encouraged to register early
15:53:32 <dneary> mgoldboi, An email to workshop-pc with "Title: Hands-on workshop", and "Description: "Try out the latest version of oVirt All-in-One booting live from a USB key! Laptop required for attendees if they wish to participate, this is an opportunity to see some of the basic features of oVirt in action"
15:53:33 <mburns> #info we will attempt to tailor the schedule to what attendees want to get out of it, so the earlier you register, the more likely we are to have relevant talks for you
15:53:48 <dneary> mburns, I don't know if we have an MC yet. If needs be, I can do it
15:53:49 <mgoldboi> dneary::)
15:54:05 <mburns> dneary: ok, so we have you, me, cctreiloff who can do it
15:54:20 <mburns> wasn't sure if NetApp was going to have someone play host...
15:54:43 <dneary> mburns, Something I need to look into
15:54:52 <mburns> ok
15:55:22 <mburns> dneary: whoever is playing host should probably have a 5 min intro keynote the first day, i would think...
15:55:38 <dneary> mburns, I am planning for opening keynotes
15:55:46 <mburns> ok
15:55:59 <mburns> ok, anything else about the workshop?
15:56:02 <mburns> from anyone?
15:57:08 <mburns> ok
15:57:12 <mburns> #topic Infra update
15:57:13 <dneary> re content, I'd like to take the opportunity
15:57:17 <dneary> late
15:57:20 <dneary> Slow typer
15:57:27 <mburns> #topic Workshops revisited
15:57:31 <mburns> dneary: go ahead
15:57:54 <dneary> I'd like to take the opportunity to encourage project maintainers to invite participants to contribute content - especially first time proposers
15:57:57 <oschreib_> mburns: mgoldboi: 3.2-alpha repo ready (nightly dir without EL6 and F17 rpms)
15:58:09 <dneary> It's a great way to encourage diversity in the project.
15:58:20 <mburns> oschreib_: f17? or F18?
15:58:25 * mburns thinks it should be f18
15:58:47 <oschreib_> mburns: I removed all f17
15:58:59 <mburns> #info maintainers, please encourage new participants to contribute content for the workshop
15:59:02 <mburns> oschreib_: oh, misread...
15:59:12 <mburns> thought you said with el6 and f17
15:59:15 <mburns> not without...
15:59:20 <jbrooks> oschreib_, will 3.2 have pkgs for EL?
15:59:43 <mburns> jbrooks: not official ones, i don't think
15:59:59 <oschreib_> jbrooks: well, iirc, only vdsm have .el6 packages published
16:00:04 <mburns> we're targeting that for the *next* release
16:00:15 <jbrooks> mburns, OK, good
16:00:26 <mgoldboi> oschreib_: thanks
16:00:49 <mburns> #topic Infra update
16:00:50 <mburns> quaid: any updates?
16:01:14 <eedri> we have a jenkins migration plan ready
16:02:00 <eedri> we can start testing some of it before the actual move, and most of the work can be done without downtime to existing server
16:02:27 <eedri> btw, any reason why i can't login to ovirt.org?
16:03:05 <mburns> eedri: try resources.ovirt.org
16:03:12 <mburns> that's the linode server now
16:03:16 * lh wanders to her next meeting
16:03:17 <mburns> ovirt.org is the openshift instance
16:03:22 <mburns> thanks lh
16:03:30 <mburns> #info jenkins migration plan ready
16:03:50 <mburns> #info some aspects can be tested before the move and most work can be done without downtime
16:04:01 <mburns> eedri: is there a timeframe for the migration?
16:04:05 <eedri> mburns, i'm talking about the web
16:04:09 <eedri> mburns, not ssh
16:04:16 <eedri> mburns, it's missing the login button
16:04:38 <mburns> ahh,  login is at the bottom right
16:04:48 <eedri> mburns, not yet, i didn't got any feedback on the infra list yet
16:04:58 <eedri> mburns, it's not :)
16:05:01 <eedri> mburns, not any more..
16:05:02 <mburns> ok
16:05:11 <mburns> eedri: hmm, i see it
16:05:30 <mburns> #info no eta for jenkins migration yet, awaiting feedback on infra list
16:05:34 <mburns> ok, anything else?
16:06:08 <eedri> mburns, i see it on firefox, not chrome
16:06:09 <eedri> mburns, ok
16:06:25 <mburns> eedri: i'm on chrome
16:06:29 <mburns> and just logged in
16:06:37 <mburns> ok, if nothing else for the meeting, i'll close
16:06:41 * mburns waits a minute
16:08:09 <mburns> ok, thanks all
16:08:12 <mburns> #endmeeting